Add postgis-jdbc 0.8.2, postGIS spatial data structures for JDBC.

PR:		ports/68322
Submitted by:	Sam Lawrance <boris@brooknet.com.au>
This commit is contained in:
Vanilla I. Shu 2004-06-30 03:51:48 +00:00
parent 745512aa4c
commit 7699b25330
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=112576
6 changed files with 90 additions and 0 deletions

View File

@ -208,6 +208,7 @@
SUBDIR += phpmyadmin
SUBDIR += phppgadmin
SUBDIR += postgis
SUBDIR += postgis-jdbc
SUBDIR += postgresql-contrib
SUBDIR += postgresql-devel
SUBDIR += postgresql-docs

View File

@ -0,0 +1,28 @@
# New ports collection makefile for: postgis-jdbc
# Date created: June 25 2004
# Whom: Sam Lawrance <boris@brooknet.com.au>
#
# $FreeBSD$
#
PORTNAME= postgis-jdbc
PORTVERSION= 0.8.2
CATEGORIES= databases java
MASTER_SITES= http://postgis.refractions.net/
DISTNAME= postgis-${PORTVERSION}
MAINTAINER= boris@brooknet.com.au
COMMENT= PostGIS spatial data structures for JDBC
BUILD_DEPENDS= ${JAVAJARDIR}/postgresql.jar:${PORTSDIR}/databases/postgresql-jdbc
USE_JAVA= 1.4+
EXAMPLESDIR= ${PREFIX}/share/examples/${PKGBASE}
MAKE_ARGS= EXAMPLESDIR="${EXAMPLESDIR}" \
DESTDIR="${PREFIX}" \
INSTALL_DATA="${INSTALL_DATA}" \
JAVAJARDIR="${JAVAJARDIR}"
WRKSRC= ${WRKDIR}/postgis-${PORTVERSION}/jdbc
.include <bsd.port.mk>

View File

@ -0,0 +1,2 @@
MD5 (postgis-0.8.2.tar.gz) = 0a2ed054e7a1ad74153eb844d1b56046
SIZE (postgis-0.8.2.tar.gz) = 1875280

View File

@ -0,0 +1,51 @@
diff -urN ../jdbc.orig/Makefile ./Makefile
--- ../jdbc.orig/Makefile Fri Jun 25 18:11:45 2004
+++ ./Makefile Fri Jun 25 18:12:52 2004
@@ -1,15 +1,21 @@
JAVAC = javac
JAVA = java
JAR = jar
-CLASSPATH = ../../../src/interfaces/jdbc/jars/postgresql.jar:.
+CLASSPATH = $(JAVAJARDIR)/postgresql.jar:.
all: ogis \
pgobjs \
- test
+ test \
+ jar
jar:
$(JAR) -cf postgis.jar org/postgis/*.java org/postgis/*.class README
+install:
+ $(INSTALL_DATA) postgis.jar $(JAVAJARDIR)
+ [ -d $(EXAMPLESDIR) ] || mkdir $(EXAMPLESDIR) || exit -1
+ $(INSTALL_DATA) examples/Test.java examples/TestServer.java $(EXAMPLESDIR)
+
ogis:
$(JAVAC) -classpath $(CLASSPATH) \
org/postgis/Geometry.java \
@@ -20,19 +26,21 @@
org/postgis/LinearRing.java \
org/postgis/Polygon.java \
org/postgis/MultiPolygon.java
+ touch ogis
pgobjs:
$(JAVAC) -classpath $(CLASSPATH) \
org/postgis/PGgeometry.java \
org/postgis/PGbox3d.java
+ touch pgobjs
test:
$(JAVAC) -classpath $(CLASSPATH) examples/Test.java
$(JAVA) -classpath $(CLASSPATH) examples/Test
-
+ touch test
jtest:
$(JAVAC) -classpath $(CLASSPATH) examples/TestServer.java
$(JAVA) -classpath $(CLASSPATH) examples/TestServer
-
+ touch jtest

View File

@ -0,0 +1,4 @@
PostGIS-JDBC provides the spatial data structures needed to use
PostgreSQL-JDBC with spatial tables.
WWW: http://postgis.refractions.net

View File

@ -0,0 +1,4 @@
share/java/classes/postgis.jar
%%EXAMPLESDIR%%/Test.java
%%EXAMPLESDIR%%/TestServer.java
@dirrm %%EXAMPLESDIR%%