Restore deleted port: net/ntopng

ntopng is a new generation flexible and feature-rich tool for monitoring and
troubleshooting local area networks. It provides command line and web
interfaces, the latter via an embedded web server. ntop is based on libpcap.

WWW: http://www.ntop.org/products/ntop/
This commit is contained in:
Guido Falsi 2016-05-28 22:09:55 +00:00
parent 7b875db64c
commit 768d7d5380
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=416074
14 changed files with 790 additions and 1 deletions

1
GIDs
View File

@ -164,6 +164,7 @@ devmon:*:283:
vnstat:*:284:
exaddos:*:285:exaddos
rancid:*:286:
ntopng:*:288:
backuppc:*:300:
_sphinx:*:312:
dkfilter:*:325:

1
MOVED
View File

@ -8200,7 +8200,6 @@ mail/pronto||2016-02-18|No release since 2002 http://www.muhri.net/pronto/page.p
russian/muttprint||2016-02-25|The Russian translation is included in print/muttprint
security/openssh-portable-devel|security/openssh-portable|2016-02-29|Outdated and insecure, use the main port
audio/audacious-dumb||2016-02-29|Has expired: Broken for more than 6 months
net/ntopng||2016-02-29|Has expired: Broken for more than 6 months
audio/rezound||2016-02-29|Has expired: Broken for more than 6 months
net/rubygem-amqp067|net/rubygem-bunny|2016-02-29|Has expired: Upstream prefers net/rubygem-bunny
devel/py-unittestplus||2016-02-29|Has expired: Tarballs and upstream website disappeared

1
UIDs
View File

@ -168,6 +168,7 @@ devmon:*:283:283::0:0:devmon monitor:/nonexistent:/usr/sbin/nologin
vnstat:*:284:284::0:0:vnStat Network Monitor:/nonexistent:/usr/sbin/nologin
exaddos:*:285:285::0:0:exaddos daemon user:/nonexistent:/usr/sbin/nologin
rancid:*:286:286::0:0:RANCID daemon user:/usr/local/var/rancid:/bin/sh
ntopng:*:288:288::0:0:ntopng daemon user:/nonexistent:/usr/sbin/nologin
backuppc:*:300:300::0:0:BackupPC pseudo-user:/nonexistent:/usr/sbin/nologin
_sphinx:*:312:312::0:0:Sphinxsearch Owner:/nonexistent:/usr/sbin/nologin
dkfilter:*:325:325::0:0:DK Filter Owner:/nonexistent:/usr/sbin/nologin

View File

@ -459,6 +459,7 @@
SUBDIR += ntimed
SUBDIR += ntlmaps
SUBDIR += ntop
SUBDIR += ntopng
SUBDIR += ntp
SUBDIR += ntp-devel
SUBDIR += ntpa

50
net/ntopng/Makefile Normal file
View File

@ -0,0 +1,50 @@
# Created by: Muhammad Moinur Rahman <5u623l20@gmail.com>
# $FreeBSD$
PORTNAME= ntopng
PORTVERSION= 2.2.2016.05.28
CATEGORIES= net
MAINTAINER= madpilot@FreeBSD.org
COMMENT= Network monitoring tool with command line and web interfaces
LICENSE= GPLv3
LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= librrd.so:databases/rrdtool \
libluajit-5.1.so:lang/luajit \
libzmq.so:net/libzmq4 \
libcurl.so:ftp/curl \
libndpi.so:net/ndpi \
libjson-c.so:devel/json-c
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
USES= autoreconf cpe gmake libtool localbase mysql pathfix pkgconfig sqlite
SUB_FILES= ntopng-geoipupdate.sh
USERS= ntopng
GROUPS= ntopng
USE_GITHUB= yes
GH_ACCOUNT= ntop
GH_TAGNAME= a92a08d
CPE_VENDOR= ntop
OPTIONS_DEFINE= GEOIP NLS
OPTIONS_DEFAULT= GEOIP
GEOIP_BUILD_DEPENDS= geoiplookup:net/GeoIP
NLS_USES= gettext
USE_RC_SUBR= ntopng
post-patch:
cd ${WRKSRC} && ${SH} autogen.sh
post-install:
${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/ntopng
${INSTALL_SCRIPT} ${WRKDIR}/ntopng-geoipupdate.sh ${STAGEDIR}${PREFIX}/bin
.include <bsd.port.mk>

3
net/ntopng/distinfo Normal file
View File

@ -0,0 +1,3 @@
TIMESTAMP = 1464442133
SHA256 (ntop-ntopng-2.2.2016.05.28-a92a08d_GH0.tar.gz) = c96850770d9685deca8f2e8acdb4791346f29daca66b70262b104d83e0df7921
SIZE (ntop-ntopng-2.2.2016.05.28-a92a08d_GH0.tar.gz) = 27654966

View File

@ -0,0 +1,39 @@
#!/bin/sh
set -eu
mkdir -p %%DATADIR%%/httpdocs/geoip
# arguments:
# $1 URL
# $2 output file name
_fetch() {
url="$1"
out="$2"
TEMPFILE="$(mktemp "%%DATADIR%%"/httpdocs/geoip/GeoIP.dat-XXXXXX)"
trap 'rc=$? ; set +e ; rm -f "'"$TEMPFILE"'" ; exit $rc' 0
if fetch -o - "$url" | gunzip >> "$TEMPFILE" ; then
chmod 444 "$TEMPFILE"
if ! mv -f "$TEMPFILE" "%%DATADIR%%"/"$2" ; then
echo "Unable to replace %%DATADIR%%/$2"
return 2
fi
else
echo "$2 download failed"
return 1
fi
rm -f "$TEMPFILE"
trap - 0
return 0
}
echo Fetching GeoLiteCity.dat...
_fetch "http://geolite.maxmind.com/download/geoip/database/GeoLiteCity.dat.gz" GeoLiteCity.dat
echo Fetching GeoLiteCityv6.dat...
_fetch "http://geolite.maxmind.com/download/geoip/database/GeoLiteCityv6-beta/GeoLiteCityv6.dat.gz" GeoLiteCityv6.dat
echo Fetching GeoIPASNum.dat...
_fetch "http://download.maxmind.com/download/geoip/database/asnum/GeoIPASNum.dat.gz" GeoIPASNum.dat.gz
echo Fetching GeoIPASNumv6.dat...
_fetch "http://download.maxmind.com/download/geoip/database/asnum/GeoIPASNumv6.dat.gz" GeoIPASNumv6.dat.gz

View File

@ -0,0 +1,47 @@
#!/bin/sh
#
# $FreeBSD$
#
# PROVIDE: ntopng
# REQUIRE: DAEMON
# KEYWORD: shutdown
#
# Add the following lines to /etc/rc.conf to enable ntopng:
#
# ntopng_enable (bool): Set it to "YES" to enable ntopng
# Default is "NO".
# ntopng_flags (flags): Set extra flags to ntopng
# Empty by default.
# ntopng_pidfile (path): Path to the pidfile
# Default /var/run/ntopng/ntopng.pid
#
. /etc/rc.subr
name=ntopng
desc="Monitors network traffic in realtime"
rcvar=ntopng_enable
load_rc_config $name
: ${ntopng_enable:=NO}
: ${ntopng_pidfile:=/var/run/ntopng/ntopng.pid}
httpdocs_path=%%DATADIR%%/httpdocs
scripts_path=%%DATADIR%%/scripts
callbacks_path=%%DATADIR%%/scripts/callbacks
user_path=%%PREFIX%%/etc/ntopng-users.conf
start_precmd=ntopng_precmd
command=%%PREFIX%%/bin/ntopng
command_args="-e -U ntopng -G ${ntopng_pidfile} -1 ${httpdocs_path} -2 ${scripts_path} -3 ${callbacks_path}"
ntopng_precmd()
{
local rundir=${ntopng_pidfile%/*}
if [ ! -d $rundir ] ; then
install -d -m 0755 -o ntopng -g ntopng $rundir
fi
}
run_rc_command "$1"

View File

@ -0,0 +1,160 @@
--- Makefile.in.orig 2016-05-05 13:23:53 UTC
+++ Makefile.in
@@ -9,72 +9,28 @@ INSTALL_DIR=$(DESTDIR)$(prefix)
MAN_DIR=$(DESTDIR)@MAN_DIR@
######
-HAS_NDPI=$(shell pkg-config --exists libndpi; echo $$?)
-ifeq ($(HAS_NDPI), 0)
- NDPI_INC = $(shell pkg-config --cflags libndpi | sed -e 's/\(-I[^ \t]*\)/\1\/libndpi/g')
- NDPI_LIB = $(shell pkg-config --libs libndpi)
- NDPI_LIB_DEP =
-else
- NDPI_INC=-I@NDPI_HOME@/src/include
- NDPI_LIB=@NDPI_HOME@/src/lib/.libs/libndpi.a
- NDPI_LIB_DEP=$(NDPI_LIB)
-endif
+NDPI_INC = $(shell pkg-config --cflags libndpi | sed -e 's/\(-I[^ \t]*\)/\1\/libndpi/g')
+NDPI_LIB = $(shell pkg-config --libs libndpi)
+NDPI_LIB_DEP =
######
LIBPCAP=-lpcap
######
MONGOOSE_HOME=${PWD}/third-party/mongoose
MONGOOSE_INC=-I$(MONGOOSE_HOME)
######
-HAS_LUAJIT=$(shell pkg-config --exists luajit; echo $$?)
-ifeq ($(HAS_LUAJIT), 0)
- LUAJIT_INC = $(shell pkg-config --cflags luajit)
- LUAJIT_LIB = $(shell pkg-config --libs luajit)
-else
- LUAJIT_HOME=${PWD}/third-party/LuaJIT-2.0.3
- LUAJIT_INC=-I$(LUAJIT_HOME)/src
- LUAJIT_LIB=$(LUAJIT_HOME)/src/libluajit.a
-endif
+LUAJIT_INC = $(shell pkg-config --cflags luajit)
+LUAJIT_LIB = $(shell pkg-config --libs luajit)
######
-LIBRRDTOOL_HOME=${PWD}/third-party/rrdtool-1.4.8
-HAS_LIBRRDTOOL=$(shell pkg-config --exists librrd; echo $$?)
-ifeq ($(HAS_LIBRRDTOOL), 0)
- LIBRRDTOOL_INC = $(shell pkg-config --cflags librrd)
- LIBRRDTOOL_LIB = $(shell pkg-config --libs librrd)
-else
- LIBRRDTOOL_INC=-I$(LIBRRDTOOL_HOME)/src/
- ifeq ($(OS), OpenBSD)
- LIBRRDTOOL_LIB=$(LIBRRDTOOL_HOME)/src/.libs/librrd_th.a -lm -lgobject-2.0 -lgmodule-2.0 -lglib-2.0
- else
- LIBRRDTOOL_LIB=$(LIBRRDTOOL_HOME)/src/.libs/librrd_th.a -lm -lgobject-2.0 -lgmodule-2.0 -ldl -lglib-2.0
- endif
-endif
+LIBRRDTOOL_INC = $(shell pkg-config --cflags librrd)
+LIBRRDTOOL_LIB = $(shell pkg-config --libs librrd)
######
HTTPCLIENT_INC=${PWD}/third-party/http-client-c/src/
######
-HAS_JSON=$(shell pkg-config --exists json-c; echo $$?)
-ifeq ($(HAS_JSON), 0)
- JSON_INC = $(shell pkg-config --cflags json-c)
- JSON_LIB = $(shell pkg-config --libs json-c)
-else
- JSON_HOME=${PWD}/third-party/json-c
- JSON_INC=-I$(JSON_HOME)
- JSON_LIB=$(JSON_HOME)/.libs/libjson-c.a
-endif
+JSON_INC = $(shell pkg-config --cflags json-c)
+JSON_LIB = $(shell pkg-config --libs json-c)
######
-HAS_ZEROMQ=$(shell pkg-config --exists libzmq; echo $$?)
-ifeq ($(HAS_ZEROMQ), 0)
- ZEROMQ_INC = $(shell pkg-config --cflags libzmq)
- ZMQ_STATIC=/usr/local/lib/libzmq.a
- ifeq ($(wildcard $(ZMQ_STATIC)),)
- ZEROMQ_LIB = $(shell pkg-config --libs libzmq)
- else
- ZEROMQ_LIB = $(ZMQ_STATIC)
- endif
-else
- ZEROMQ_HOME=${PWD}/third-party/zeromq-4.1.3
- ZEROMQ_INC=-I$(ZEROMQ_HOME)/include
- ZEROMQ_LIB=$(ZEROMQ_HOME)/.libs/libzmq.a
-endif
+ZEROMQ_INC = $(shell pkg-config --cflags libzmq)
+ZEROMQ_LIB = $(shell pkg-config --libs libzmq)
######
TARGET = ntopng
LIBS = $(NDPI_LIB) $(LIBPCAP) $(LUAJIT_LIB) $(LIBRRDTOOL_LIB) $(ZEROMQ_LIB) $(JSON_LIB) @HIREDIS_LIB@ @SQLITE_LIB@ @MYSQL_LIB@ @LINK_OPTS@ @GEOIP_LIB@ @LDFLAGS@ @PRO_LIBS@ -lm -lpthread
@@ -93,29 +49,11 @@ ifeq ($(OS),Darwin)
LIBS += -lstdc++.6
endif
-LIB_TARGETS =
-
-ifneq ($(HAS_LUAJIT), 0)
-LIB_TARGETS += $(LUAJIT_LIB)
- endif
-
-ifneq ($(HAS_ZEROMQ), 0)
-LIB_TARGETS += $(ZEROMQ_LIB)
-endif
-
-ifneq ($(HAS_LIBRRDTOOL), 0)
-LIB_TARGETS += $(LIBRRDTOOL_LIB)
-endif
-
-ifneq ($(HAS_JSON), 0)
-LIB_TARGETS += $(JSON_LIB)
-endif
-
.PHONY: default all clean docs test
.NOTPARALLEL: default all
-default: $(NDPI_LIB_DEP) $(LIB_TARGETS) $(TARGET)
+default: $(TARGET)
all: default
@@ -133,19 +71,6 @@ HEADERS = $(wildcard include/*.h) @PRO_H
$(TARGET): $(OBJECTS) $(LIBRRDTOOL) Makefile
$(GPP) $(OBJECTS) -Wall $(LIBS) -o $@
-$(LUAJIT_LIB):
- cd $(LUAJIT_HOME); @GMAKE@
-
-$(ZEROMQ_LIB):
- cd $(ZEROMQ_HOME); ./configure --without-documentation --without-libsodium; @GMAKE@
-
-# --disable-rrd_graph
-$(LIBRRDTOOL_LIB):
- cd $(LIBRRDTOOL_HOME); ./configure --disable-libdbi --disable-libwrap --disable-rrdcgi --disable-libtool-lock --disable-nls --disable-rpath --disable-perl --disable-ruby --disable-lua --disable-tcl --disable-python --disable-dependency-tracking --disable-rrd_graph ; cd src; @GMAKE@ librrd_th.la
-
-$(JSON_LIB):
- cd $(JSON_HOME); ./autogen.sh; ./configure; @GMAKE@
-
clean:
-rm -f src/*.o src/*~ include/*~ *~ #config.h
-rm -f $(TARGET)
@@ -155,18 +80,15 @@ cert:
cat privkey.pem cert.pem > httpdocs/ssl/ntopng-cert.pem
/bin/rm -f privkey.pem cert.pem
-veryclean: clean
- -rm -rf nDPI
-
geoip:
@if test -d ~/dat_files ; then \
cp ~/dat_files/* httpdocs/geoip; gunzip -f httpdocs/geoip/*.dat.gz ; \
else \
cd httpdocs/geoip; \
- wget -nc http://geolite.maxmind.com/download/geoip/database/GeoLiteCity.dat.gz; \
- wget -nc http://geolite.maxmind.com/download/geoip/database/GeoLiteCityv6-beta/GeoLiteCityv6.dat.gz; \
- wget -nc http://download.maxmind.com/download/geoip/database/asnum/GeoIPASNum.dat.gz; \
- wget -nc http://download.maxmind.com/download/geoip/database/asnum/GeoIPASNumv6.dat.gz; \
+ fetch http://geolite.maxmind.com/download/geoip/database/GeoLiteCity.dat.gz; \
+ fetch http://geolite.maxmind.com/download/geoip/database/GeoLiteCityv6-beta/GeoLiteCityv6.dat.gz; \
+ fetch http://download.maxmind.com/download/geoip/database/asnum/GeoIPASNum.dat.gz; \
+ fetch http://download.maxmind.com/download/geoip/database/asnum/GeoIPASNumv6.dat.gz; \
gunzip -f *.dat.gz ; \
fi

View File

@ -0,0 +1,11 @@
--- autogen.sh.orig 2016-05-05 13:23:53 UTC
+++ autogen.sh
@@ -30,8 +30,3 @@ fi
cat configure.seed | sed "s/@VERSION@/$VERSION/g" | sed "s/@SHORT_VERSION@/$SHORT_VERSION/g" | sed "s/@GIT_TAG@/$GIT_TAG/g" | sed "s/@GIT_DATE@/$GIT_DATE/g" | sed "s/@GIT_RELEASE@/$GIT_RELEASE/g" | sed "s/@GIT_BRANCH@/$GIT_BRANCH/g" | sed "s/@PRO_GIT_RELEASE@/$PRO_GIT_RELEASE/g" | sed "s/@PRO_GIT_DATE@/$PRO_GIT_DATE/g" > configure.ac
/bin/rm -f config.h config.h.in *~ #*
-
-echo "Wait please..."
-autoreconf -if
-echo ""
-echo "Now run ./configure"

View File

@ -0,0 +1,78 @@
--- configure.seed.orig 2016-05-05 13:23:53 UTC
+++ configure.seed
@@ -14,22 +14,7 @@ NTOPNG_SHORT_VERSION="@SHORT_VERSION@"
# On CentOS 6 `git rev-list HEAD --count` does not work
#
#
-REVISION=`git log --pretty=oneline | wc -l`
-
-if test -d "/usr/local/include"; then
-CFLAGS="${CFLAGS} -I/usr/local/include"
-CPPFLAGS="${CPPFLAGS} -I/usr/local/include"
-LDFLAGS="${LDFLAGS} -L/usr/local/lib"
-fi
-
-if test -d /opt/local/include; then :
- CFLAGS="${CFLAGS} -I/opt/local/include"
- CPPFLAGS="${CPPFLAGS} -I/opt/local/include"
-fi
-
-if test -d /opt/local/lib; then :
- LDFLAGS="${LDFLAGS} -L/opt/local/lib"
-fi
+#REVISION=`git log --pretty=oneline | wc -l`
if [ test -f /usr/bin/lsb_release ]; then
CODENAME=`/usr/bin/lsb_release -c|cut -f 2`
@@ -46,28 +31,9 @@ GIT_BRANCH="@GIT_BRANCH@"
PRO_GIT_RELEASE="@PRO_GIT_RELEASE@"
PRO_GIT_DATE="@PRO_GIT_DATE@"
-AC_MSG_CHECKING(for nDPI)
-NDPI_HOME=./nDPI
-if test -d "$NDPI_HOME" ; then :
- AC_MSG_RESULT(found in $NDPI_HOME)
-else
- NDPI_HOME=../nDPI
- if test -d "$NDPI_HOME"; then :
- AC_MSG_RESULT(found in $NDPI_HOME)
- else
- NDPI_HOME=$HOME/nDPI
- if test -d "$NDPI_HOME"; then :
- AC_MSG_RESULT(found in $NDPI_HOME)
- else
- AC_MSG_RESULT(not found)
- echo "Please do cd ..; git clone https://github.com/ntop/nDPI.git; cd nDPI; ./autogen.sh; make; cd ../ntopng"
- echo " and try again"
- exit
- fi
- fi
-fi
+NDPI_HOME=/usr/local
-NDPI_LIB=$NDPI_HOME/src/lib/.libs/libndpi.a
+NDPI_LIB=$NDPI_HOME/lib/libndpi.so
AC_MSG_CHECKING(for $NDPI_LIB)
if test -f "$NDPI_LIB" ; then :
AC_MSG_RESULT(found $NDPI_LIB)
@@ -359,19 +325,7 @@ if test x$GPP = x
then
GPP="g++"
else
- GPP="$GPP -O0"
-fi
-
-GIT=`which git`
-if test x$GIT = x
-then
- AC_MSG_RESULT(FATAL ERROR: git is not installed on your host)
-fi
-
-WGET=`which wget`
-if test x$WGET = x
-then
- AC_MSG_RESULT(ERROR. wget is not installed on your host: you cannot download GeoIP data)
+ GPP="$GPP ${CFLAGS}"
fi
umask 002

5
net/ntopng/pkg-descr Normal file
View File

@ -0,0 +1,5 @@
ntopng is a new generation flexible and feature-rich tool for monitoring and
troubleshooting local area networks. It provides command line and web
interfaces, the latter via an embedded web server. ntop is based on libpcap.
WWW: http://www.ntop.org/products/ntop/

14
net/ntopng/pkg-message Normal file
View File

@ -0,0 +1,14 @@
----------------------------------------------------------------------------
WARNING:
In the past, ntop has been the subject of repeated security vulner-
abilities, particularly relating to its web interface. It is strongly
suggested that you protect your ntop web interface via packet filters
or TCP wrappers.
Please install redis server from databases/redis or use -r to specify
a remote one.
Please use ntopng-geoipupdate.sh to update GeoIP database to the
latest.
----------------------------------------------------------------------------

380
net/ntopng/pkg-plist Normal file
View File

@ -0,0 +1,380 @@
bin/ntopng
bin/ntopng-geoipupdate.sh
man/man8/ntopng.8.gz
%%DATADIR%%/httpdocs/bootstrap/css/bootstrap-theme.css
%%DATADIR%%/httpdocs/bootstrap/css/bootstrap-theme.css.map
%%DATADIR%%/httpdocs/bootstrap/css/bootstrap.css
%%DATADIR%%/httpdocs/bootstrap/css/bootstrap.css.map
%%DATADIR%%/httpdocs/bootstrap/fonts/glyphicons-halflings-regular.eot
%%DATADIR%%/httpdocs/bootstrap/fonts/glyphicons-halflings-regular.svg
%%DATADIR%%/httpdocs/bootstrap/fonts/glyphicons-halflings-regular.ttf
%%DATADIR%%/httpdocs/bootstrap/fonts/glyphicons-halflings-regular.woff
%%DATADIR%%/httpdocs/bootstrap/img/glyphicons-halflings-white.png
%%DATADIR%%/httpdocs/bootstrap/img/glyphicons-halflings.png
%%DATADIR%%/httpdocs/bootstrap/js/bootstrap.js
%%DATADIR%%/httpdocs/css/Rickshaw/detail.css
%%DATADIR%%/httpdocs/css/Rickshaw/graph.css
%%DATADIR%%/httpdocs/css/Rickshaw/legend.css
%%DATADIR%%/httpdocs/css/bootstrap-datetimepicker.css
%%DATADIR%%/httpdocs/css/bootstrap-duallistbox.css
%%DATADIR%%/httpdocs/css/bootstrap-slider.css
%%DATADIR%%/httpdocs/css/bubble-chart.css
%%DATADIR%%/httpdocs/css/c3.css
%%DATADIR%%/httpdocs/css/cal-heatmap.css
%%DATADIR%%/httpdocs/css/cubism.css
%%DATADIR%%/httpdocs/css/datepicker.css
%%DATADIR%%/httpdocs/css/dc.css
%%DATADIR%%/httpdocs/css/flags.css
%%DATADIR%%/httpdocs/css/images/ui-bg_diagonals-thick_18_b81900_40x40.png
%%DATADIR%%/httpdocs/css/images/ui-bg_diagonals-thick_20_666666_40x40.png
%%DATADIR%%/httpdocs/css/images/ui-bg_flat_10_000000_40x100.png
%%DATADIR%%/httpdocs/css/images/ui-bg_glass_100_f6f6f6_1x400.png
%%DATADIR%%/httpdocs/css/images/ui-bg_glass_100_fdf5ce_1x400.png
%%DATADIR%%/httpdocs/css/images/ui-bg_glass_65_ffffff_1x400.png
%%DATADIR%%/httpdocs/css/images/ui-bg_gloss-wave_35_f6a828_500x100.png
%%DATADIR%%/httpdocs/css/images/ui-bg_highlight-soft_100_eeeeee_1x100.png
%%DATADIR%%/httpdocs/css/images/ui-bg_highlight-soft_75_ffe45c_1x100.png
%%DATADIR%%/httpdocs/css/images/ui-icons_222222_256x240.png
%%DATADIR%%/httpdocs/css/images/ui-icons_228ef1_256x240.png
%%DATADIR%%/httpdocs/css/images/ui-icons_ef8c08_256x240.png
%%DATADIR%%/httpdocs/css/images/ui-icons_ffd27a_256x240.png
%%DATADIR%%/httpdocs/css/images/ui-icons_ffffff_256x240.png
%%DATADIR%%/httpdocs/css/jquery-ui.css
%%DATADIR%%/httpdocs/css/ntopng.css
%%DATADIR%%/httpdocs/css/nv.d3.css
%%DATADIR%%/httpdocs/css/pagingbar.css
%%DATADIR%%/httpdocs/css/pie-chart.css
%%DATADIR%%/httpdocs/css/prettify.css
%%DATADIR%%/httpdocs/css/rickshaw.css
%%DATADIR%%/httpdocs/css/sequence_sunburst.css
%%DATADIR%%/httpdocs/css/tablesorted.css
%%DATADIR%%/httpdocs/css/timeline.css
%%DATADIR%%/httpdocs/css/timepicker.css
%%DATADIR%%/httpdocs/favicon.ico
%%DATADIR%%/httpdocs/font-awesome/HELP-US-OUT.txt
%%DATADIR%%/httpdocs/font-awesome/css/font-awesome.css
%%DATADIR%%/httpdocs/font-awesome/css/font-awesome.min.css
%%DATADIR%%/httpdocs/font-awesome/fonts/FontAwesome.otf
%%DATADIR%%/httpdocs/font-awesome/fonts/fontawesome-webfont.eot
%%DATADIR%%/httpdocs/font-awesome/fonts/fontawesome-webfont.svg
%%DATADIR%%/httpdocs/font-awesome/fonts/fontawesome-webfont.ttf
%%DATADIR%%/httpdocs/font-awesome/fonts/fontawesome-webfont.woff
%%DATADIR%%/httpdocs/font-awesome/fonts/fontawesome-webfont.woff2
%%DATADIR%%/httpdocs/font-awesome/less/animated.less
%%DATADIR%%/httpdocs/font-awesome/less/bordered-pulled.less
%%DATADIR%%/httpdocs/font-awesome/less/core.less
%%DATADIR%%/httpdocs/font-awesome/less/fixed-width.less
%%DATADIR%%/httpdocs/font-awesome/less/font-awesome.less
%%DATADIR%%/httpdocs/font-awesome/less/icons.less
%%DATADIR%%/httpdocs/font-awesome/less/larger.less
%%DATADIR%%/httpdocs/font-awesome/less/list.less
%%DATADIR%%/httpdocs/font-awesome/less/mixins.less
%%DATADIR%%/httpdocs/font-awesome/less/path.less
%%DATADIR%%/httpdocs/font-awesome/less/rotated-flipped.less
%%DATADIR%%/httpdocs/font-awesome/less/stacked.less
%%DATADIR%%/httpdocs/font-awesome/less/variables.less
%%DATADIR%%/httpdocs/font-awesome/scss/_animated.scss
%%DATADIR%%/httpdocs/font-awesome/scss/_bordered-pulled.scss
%%DATADIR%%/httpdocs/font-awesome/scss/_core.scss
%%DATADIR%%/httpdocs/font-awesome/scss/_fixed-width.scss
%%DATADIR%%/httpdocs/font-awesome/scss/_icons.scss
%%DATADIR%%/httpdocs/font-awesome/scss/_larger.scss
%%DATADIR%%/httpdocs/font-awesome/scss/_list.scss
%%DATADIR%%/httpdocs/font-awesome/scss/_mixins.scss
%%DATADIR%%/httpdocs/font-awesome/scss/_path.scss
%%DATADIR%%/httpdocs/font-awesome/scss/_rotated-flipped.scss
%%DATADIR%%/httpdocs/font-awesome/scss/_stacked.scss
%%DATADIR%%/httpdocs/font-awesome/scss/_variables.scss
%%DATADIR%%/httpdocs/font-awesome/scss/font-awesome.scss
%%DATADIR%%/httpdocs/geoip/README
%%DATADIR%%/httpdocs/img/asc.gif
%%DATADIR%%/httpdocs/img/blank.gif
%%DATADIR%%/httpdocs/img/block-end.png
%%DATADIR%%/httpdocs/img/block-start.png
%%DATADIR%%/httpdocs/img/cpu_icon.png
%%DATADIR%%/httpdocs/img/desc.gif
%%DATADIR%%/httpdocs/img/flags.png
%%DATADIR%%/httpdocs/img/glyphicons-halflings-white.png
%%DATADIR%%/httpdocs/img/glyphicons-halflings.png
%%DATADIR%%/httpdocs/img/graph.gif
%%DATADIR%%/httpdocs/img/info.png
%%DATADIR%%/httpdocs/img/info_icon.png
%%DATADIR%%/httpdocs/img/interaction-graph-icons/apache2.png
%%DATADIR%%/httpdocs/img/interaction-graph-icons/firefox.png
%%DATADIR%%/httpdocs/img/interaction-graph-icons/java.png
%%DATADIR%%/httpdocs/img/interaction-graph-icons/nprobe.png
%%DATADIR%%/httpdocs/img/interaction-graph-icons/ntopng.png
%%DATADIR%%/httpdocs/img/interaction-graph-icons/redis-server.png
%%DATADIR%%/httpdocs/img/interaction-graph-icons/remote_hosts.png
%%DATADIR%%/httpdocs/img/interaction-graph-icons/sprobe.png
%%DATADIR%%/httpdocs/img/loading.gif
%%DATADIR%%/httpdocs/img/logo.png
%%DATADIR%%/httpdocs/img/logo.svg
%%DATADIR%%/httpdocs/img/maps/conv30.png
%%DATADIR%%/httpdocs/img/maps/conv40.png
%%DATADIR%%/httpdocs/img/maps/conv50.png
%%DATADIR%%/httpdocs/img/maps/heart30.png
%%DATADIR%%/httpdocs/img/maps/heart40.png
%%DATADIR%%/httpdocs/img/maps/heart50.png
%%DATADIR%%/httpdocs/img/maps/m1.png
%%DATADIR%%/httpdocs/img/maps/m2.png
%%DATADIR%%/httpdocs/img/maps/m3.png
%%DATADIR%%/httpdocs/img/maps/m4.png
%%DATADIR%%/httpdocs/img/maps/m5.png
%%DATADIR%%/httpdocs/img/maps/people35.png
%%DATADIR%%/httpdocs/img/maps/people45.png
%%DATADIR%%/httpdocs/img/maps/people55.png
%%DATADIR%%/httpdocs/img/network_icon.png
%%DATADIR%%/httpdocs/img/os_icon.png
%%DATADIR%%/httpdocs/img/throbber.gif
%%DATADIR%%/httpdocs/img/warning.png
%%DATADIR%%/httpdocs/inc/aggregated_hosts_stats_bottom.inc
%%DATADIR%%/httpdocs/inc/aggregated_hosts_stats_id.inc
%%DATADIR%%/httpdocs/inc/aggregated_hosts_stats_top.inc
%%DATADIR%%/httpdocs/inc/as_stats_id.inc
%%DATADIR%%/httpdocs/inc/as_stats_top.inc
%%DATADIR%%/httpdocs/inc/community_stats_bottom.inc
%%DATADIR%%/httpdocs/inc/community_stats_id.inc
%%DATADIR%%/httpdocs/inc/community_stats_top.inc
%%DATADIR%%/httpdocs/inc/country_stats_id.inc
%%DATADIR%%/httpdocs/inc/country_stats_top.inc
%%DATADIR%%/httpdocs/inc/flows_stats_bottom.inc
%%DATADIR%%/httpdocs/inc/flows_stats_id.inc
%%DATADIR%%/httpdocs/inc/flows_stats_middle.inc
%%DATADIR%%/httpdocs/inc/flows_stats_top.inc
%%DATADIR%%/httpdocs/inc/geolocation_disclaimer.inc
%%DATADIR%%/httpdocs/inc/header.inc
%%DATADIR%%/httpdocs/inc/host_to_server_id.inc
%%DATADIR%%/httpdocs/inc/host_to_server_top.inc
%%DATADIR%%/httpdocs/inc/hosts_stats_bottom.inc
%%DATADIR%%/httpdocs/inc/hosts_stats_id.inc
%%DATADIR%%/httpdocs/inc/hosts_stats_top.inc
%%DATADIR%%/httpdocs/inc/http_servers_stats_id.inc
%%DATADIR%%/httpdocs/inc/http_servers_stats_top.inc
%%DATADIR%%/httpdocs/inc/index_TopASNs.inc
%%DATADIR%%/httpdocs/inc/index_TopApplications.inc
%%DATADIR%%/httpdocs/inc/index_TopFlowSenders.inc
%%DATADIR%%/httpdocs/inc/index_TopHosts.inc
%%DATADIR%%/httpdocs/inc/index_TopPorts.inc
%%DATADIR%%/httpdocs/inc/mac_stats_bottom.inc
%%DATADIR%%/httpdocs/inc/mac_stats_id.inc
%%DATADIR%%/httpdocs/inc/mac_stats_top.inc
%%DATADIR%%/httpdocs/inc/network_stats_bottom.inc
%%DATADIR%%/httpdocs/inc/network_stats_id.inc
%%DATADIR%%/httpdocs/inc/network_stats_top.inc
%%DATADIR%%/httpdocs/inc/os_stats_id.inc
%%DATADIR%%/httpdocs/inc/os_stats_top.inc
%%DATADIR%%/httpdocs/inc/processes_stats_bottom.inc
%%DATADIR%%/httpdocs/inc/processes_stats_id.inc
%%DATADIR%%/httpdocs/inc/processes_stats_top.inc
%%DATADIR%%/httpdocs/inc/sflows_stats_bottom.inc
%%DATADIR%%/httpdocs/inc/sflows_stats_top.inc
%%DATADIR%%/httpdocs/inc/sprobe_process.inc
%%DATADIR%%/httpdocs/inc/sprobe_process_header.inc
%%DATADIR%%/httpdocs/inc/vlan_stats_id.inc
%%DATADIR%%/httpdocs/inc/vlan_stats_top.inc
%%DATADIR%%/httpdocs/js/README.gauge
%%DATADIR%%/httpdocs/js/bootstrap-datatable.js
%%DATADIR%%/httpdocs/js/bootstrap-datetimepicker.js
%%DATADIR%%/httpdocs/js/bootstrap-slider.js
%%DATADIR%%/httpdocs/js/bootstrap.ajaxpager-0.8.js
%%DATADIR%%/httpdocs/js/bootstrap3-typeahead.js
%%DATADIR%%/httpdocs/js/bubble-chart.js
%%DATADIR%%/httpdocs/js/c3.js
%%DATADIR%%/httpdocs/js/cal-heatmap.js
%%DATADIR%%/httpdocs/js/cpu_bar.js
%%DATADIR%%/httpdocs/js/crossfilter.js
%%DATADIR%%/httpdocs/js/cubism.v1.js
%%DATADIR%%/httpdocs/js/d3.v3.js
%%DATADIR%%/httpdocs/js/dc.js
%%DATADIR%%/httpdocs/js/gauge.js
%%DATADIR%%/httpdocs/js/googleMapJson.js
%%DATADIR%%/httpdocs/js/handlebars-1.0.0.0.beta.6.js
%%DATADIR%%/httpdocs/js/highlight.js
%%DATADIR%%/httpdocs/js/html5shiv.js
%%DATADIR%%/httpdocs/js/jquery-ui.js
%%DATADIR%%/httpdocs/js/jquery.bootstrap-duallistbox.js
%%DATADIR%%/httpdocs/js/jquery.form.js
%%DATADIR%%/httpdocs/js/jquery.js
%%DATADIR%%/httpdocs/js/jquery.peity.js
%%DATADIR%%/httpdocs/js/jquery.sparkline.js
%%DATADIR%%/httpdocs/js/jquery.tablesorter.js
%%DATADIR%%/httpdocs/js/line-graph.js
%%DATADIR%%/httpdocs/js/markerclusterer.js
%%DATADIR%%/httpdocs/js/matrix_volume.js
%%DATADIR%%/httpdocs/js/moment.js
%%DATADIR%%/httpdocs/js/ntopng_utils.js
%%DATADIR%%/httpdocs/js/nv.d3.js
%%DATADIR%%/httpdocs/js/pdfmake.js
%%DATADIR%%/httpdocs/js/pie-chart.js
%%DATADIR%%/httpdocs/js/prettify.js
%%DATADIR%%/httpdocs/js/rickshaw.js
%%DATADIR%%/httpdocs/js/sankey.js
%%DATADIR%%/httpdocs/js/sequence_sunburst.js
%%DATADIR%%/httpdocs/js/springy-ntop.js
%%DATADIR%%/httpdocs/js/springyui-ntop.js
%%DATADIR%%/httpdocs/js/timeline.js
%%DATADIR%%/httpdocs/js/validator.js
%%DATADIR%%/httpdocs/js/vfs_fonts.js
%%DATADIR%%/httpdocs/misc/ntopng_template_elk.json
%%DATADIR%%/httpdocs/other/EtherOUI.txt
%%DATADIR%%/httpdocs/ssl/README
%%DATADIR%%/httpdocs/ssl/ntopng-cert.pem.dummy
%%DATADIR%%/httpdocs/test.lp
%%DATADIR%%/scripts/callbacks/daily.lua
%%DATADIR%%/scripts/callbacks/hourly.lua
%%DATADIR%%/scripts/callbacks/minute.lua
%%DATADIR%%/scripts/callbacks/second.lua
%%DATADIR%%/scripts/lua/API.lua
%%DATADIR%%/scripts/lua/about.lua
%%DATADIR%%/scripts/lua/admin/add_user.lua
%%DATADIR%%/scripts/lua/admin/change_user_prefs.lua
%%DATADIR%%/scripts/lua/admin/delete_user.lua
%%DATADIR%%/scripts/lua/admin/get_user_info.lua
%%DATADIR%%/scripts/lua/admin/get_users.lua
%%DATADIR%%/scripts/lua/admin/password_reset.lua
%%DATADIR%%/scripts/lua/admin/prefs.lua
%%DATADIR%%/scripts/lua/admin/users.lua
%%DATADIR%%/scripts/lua/admin/validate_new_user.lua
%%DATADIR%%/scripts/lua/as_stats.lua
%%DATADIR%%/scripts/lua/country_stats.lua
%%DATADIR%%/scripts/lua/db.lua
%%DATADIR%%/scripts/lua/db_query.lua
%%DATADIR%%/scripts/lua/do_export_data.lua
%%DATADIR%%/scripts/lua/examples/debug.lua
%%DATADIR%%/scripts/lua/examples/hello_world.lua
%%DATADIR%%/scripts/lua/examples/interface.lua
%%DATADIR%%/scripts/lua/examples/ntop.lua
%%DATADIR%%/scripts/lua/examples/sqlite.lua
%%DATADIR%%/scripts/lua/export_data.lua
%%DATADIR%%/scripts/lua/find_host.lua
%%DATADIR%%/scripts/lua/flow_details.lua
%%DATADIR%%/scripts/lua/flow_stats.lua
%%DATADIR%%/scripts/lua/flows_stats.lua
%%DATADIR%%/scripts/lua/get_alerts_data.lua
%%DATADIR%%/scripts/lua/get_db_data.lua
%%DATADIR%%/scripts/lua/get_db_flows.lua
%%DATADIR%%/scripts/lua/get_flow_data.lua
%%DATADIR%%/scripts/lua/get_flows_data.lua
%%DATADIR%%/scripts/lua/get_geo_hosts.lua
%%DATADIR%%/scripts/lua/get_grouped_hosts_data.lua
%%DATADIR%%/scripts/lua/get_historical_data.lua
%%DATADIR%%/scripts/lua/get_historical_favourites.lua
%%DATADIR%%/scripts/lua/get_hitters_data.lua
%%DATADIR%%/scripts/lua/get_host_activitymap.lua
%%DATADIR%%/scripts/lua/get_host_categories.lua
%%DATADIR%%/scripts/lua/get_host_contacts.lua
%%DATADIR%%/scripts/lua/get_host_daily_activity.lua
%%DATADIR%%/scripts/lua/get_host_data.lua
%%DATADIR%%/scripts/lua/get_host_traffic.lua
%%DATADIR%%/scripts/lua/get_hosts_data.lua
%%DATADIR%%/scripts/lua/get_hosts_interaction.lua
%%DATADIR%%/scripts/lua/get_http_hosts.lua
%%DATADIR%%/scripts/lua/get_http_hosts_data.lua
%%DATADIR%%/scripts/lua/get_nbox_data.lua
%%DATADIR%%/scripts/lua/get_process_info.lua
%%DATADIR%%/scripts/lua/get_processes_data.lua
%%DATADIR%%/scripts/lua/get_system_hosts_interaction.lua
%%DATADIR%%/scripts/lua/get_top_talkers.lua
%%DATADIR%%/scripts/lua/get_treemap.lua
%%DATADIR%%/scripts/lua/get_user_info.lua
%%DATADIR%%/scripts/lua/host_category_stats.lua
%%DATADIR%%/scripts/lua/host_details.lua
%%DATADIR%%/scripts/lua/host_details_categories.lua
%%DATADIR%%/scripts/lua/host_details_ndpi.lua
%%DATADIR%%/scripts/lua/host_dns_breakdown.lua
%%DATADIR%%/scripts/lua/host_get_json.lua
%%DATADIR%%/scripts/lua/host_http_breakdown.lua
%%DATADIR%%/scripts/lua/host_l4_stats.lua
%%DATADIR%%/scripts/lua/host_pkt_distro.lua
%%DATADIR%%/scripts/lua/host_sflow_distro.lua
%%DATADIR%%/scripts/lua/host_stats.lua
%%DATADIR%%/scripts/lua/host_top_peers_protocols.lua
%%DATADIR%%/scripts/lua/hosts_comparison.lua
%%DATADIR%%/scripts/lua/hosts_comparison_bubble.lua
%%DATADIR%%/scripts/lua/hosts_comparison_sankey.lua
%%DATADIR%%/scripts/lua/hosts_geomap.lua
%%DATADIR%%/scripts/lua/hosts_matrix.lua
%%DATADIR%%/scripts/lua/hosts_stats.lua
%%DATADIR%%/scripts/lua/hosts_treemap.lua
%%DATADIR%%/scripts/lua/http_servers_stats.lua
%%DATADIR%%/scripts/lua/if_pkt_distro.lua
%%DATADIR%%/scripts/lua/if_stats.lua
%%DATADIR%%/scripts/lua/if_stats_ndpi.lua
%%DATADIR%%/scripts/lua/iface_flows_sankey.lua
%%DATADIR%%/scripts/lua/iface_hosts_list.lua
%%DATADIR%%/scripts/lua/iface_local_stats.lua
%%DATADIR%%/scripts/lua/iface_ndpi_stats.lua
%%DATADIR%%/scripts/lua/iface_ports_list.lua
%%DATADIR%%/scripts/lua/inc/add_user_dialog.lua
%%DATADIR%%/scripts/lua/inc/change_user_password_form.lua
%%DATADIR%%/scripts/lua/inc/delete_user_dialog.lua
%%DATADIR%%/scripts/lua/inc/footer.lua
%%DATADIR%%/scripts/lua/inc/menu.lua
%%DATADIR%%/scripts/lua/inc/password_dialog.lua
%%DATADIR%%/scripts/lua/inc/sankey.lua
%%DATADIR%%/scripts/lua/inc/search_host_box.lua
%%DATADIR%%/scripts/lua/inc/sprobe.lua
%%DATADIR%%/scripts/lua/inc/users.lua
%%DATADIR%%/scripts/lua/index.lua
%%DATADIR%%/scripts/lua/login.lua
%%DATADIR%%/scripts/lua/logout.lua
%%DATADIR%%/scripts/lua/mac_stats.lua
%%DATADIR%%/scripts/lua/mesh_antenna_stats.lua
%%DATADIR%%/scripts/lua/modules/alert_utils.lua
%%DATADIR%%/scripts/lua/modules/db_utils.lua
%%DATADIR%%/scripts/lua/modules/dkjson.lua
%%DATADIR%%/scripts/lua/modules/flow_utils.lua
%%DATADIR%%/scripts/lua/modules/graph_utils.lua
%%DATADIR%%/scripts/lua/modules/historical_utils.lua
%%DATADIR%%/scripts/lua/modules/json.lua
%%DATADIR%%/scripts/lua/modules/lua_trace.lua
%%DATADIR%%/scripts/lua/modules/lua_utils.lua
%%DATADIR%%/scripts/lua/modules/persistence.lua
%%DATADIR%%/scripts/lua/modules/prefs_utils.lua
%%DATADIR%%/scripts/lua/modules/sqlite_utils.lua
%%DATADIR%%/scripts/lua/modules/template.lua
%%DATADIR%%/scripts/lua/modules/top_scripts/top_asn.lua
%%DATADIR%%/scripts/lua/modules/top_scripts/top_countries.lua
%%DATADIR%%/scripts/lua/modules/top_scripts/top_networks.lua
%%DATADIR%%/scripts/lua/modules/top_scripts/top_os.lua
%%DATADIR%%/scripts/lua/modules/top_scripts/top_os_local.lua
%%DATADIR%%/scripts/lua/modules/top_scripts/top_talkers.lua
%%DATADIR%%/scripts/lua/modules/top_scripts/top_vlan.lua
%%DATADIR%%/scripts/lua/modules/top_structure.lua
%%DATADIR%%/scripts/lua/modules/top_talkers.lua
%%DATADIR%%/scripts/lua/modules/traffic_stats.lua
%%DATADIR%%/scripts/lua/modules/voip_utils.lua
%%DATADIR%%/scripts/lua/network_details.lua
%%DATADIR%%/scripts/lua/network_load.lua
%%DATADIR%%/scripts/lua/network_stats.lua
%%DATADIR%%/scripts/lua/os_stats.lua
%%DATADIR%%/scripts/lua/page_not_found.lua
%%DATADIR%%/scripts/lua/pid_stats.lua
%%DATADIR%%/scripts/lua/popKeys.lua
%%DATADIR%%/scripts/lua/port_details.lua
%%DATADIR%%/scripts/lua/processes_stats.lua
%%DATADIR%%/scripts/lua/protocols/dns_aggregations.lua
%%DATADIR%%/scripts/lua/protocols/epp_aggregations.lua
%%DATADIR%%/scripts/lua/resolve_address.lua
%%DATADIR%%/scripts/lua/set_active_interface.lua
%%DATADIR%%/scripts/lua/set_if_prefs.lua
%%DATADIR%%/scripts/lua/sflow_tree.lua
%%DATADIR%%/scripts/lua/sflows_stats.lua
%%DATADIR%%/scripts/lua/show_alerts.lua
%%DATADIR%%/scripts/lua/sprobe.lua
%%DATADIR%%/scripts/lua/sprobe_data.lua
%%DATADIR%%/scripts/lua/sprobe_flow_data.lua
%%DATADIR%%/scripts/lua/sprobe_host_process.lua
%%DATADIR%%/scripts/lua/sprobe_host_process_data.lua
%%DATADIR%%/scripts/lua/sprobe_hosts.lua
%%DATADIR%%/scripts/lua/sprobe_hosts_data.lua
%%DATADIR%%/scripts/lua/sprobe_hosts_interactions.lua
%%DATADIR%%/scripts/lua/sprobe_hosts_interactions_data.lua
%%DATADIR%%/scripts/lua/system_hosts_interaction.lua
%%DATADIR%%/scripts/lua/test_snmp.lua
%%DATADIR%%/scripts/lua/top_generic.lua
%%DATADIR%%/scripts/lua/top_hosts.lua
%%DATADIR%%/scripts/lua/user_stats.lua
%%DATADIR%%/scripts/lua/vlan_details.lua
%%DATADIR%%/scripts/lua/vlan_stats.lua