Add ADMsnmp 0.1, SNMP audit scanner.

PR:		50642
Submitted by:	Yonatan@xpert.com
This commit is contained in:
Foxfair Hu 2003-05-08 05:07:22 +00:00
parent 968af1073d
commit 7656cb1993
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=80418
6 changed files with 112 additions and 0 deletions

33
security/ADMsnmp/Makefile Normal file
View File

@ -0,0 +1,33 @@
# Ports collection makefile for: ADMsnmp
# Date created: 16 Apr 2003
# Whom: Yonatan@xpert.com
#
# $FreeBSD$
#
PORTNAME= ADMsnmp
PORTVERSION= 0.1
CATEGORIES= security
MASTER_SITES= ftp://adm.freelsd.net/pub/ADM/ \
http://adm.freelsd.net/ADM/ \
${MASTER_SITE_PACKETSTORM:=groups/ADM/}
DISTNAME= ${PORTNAME}.${PORTVERSION}
EXTRACT_SUFX= .tgz
MAINTAINER= Yonatan@xpert.com
COMMENT= SNMP audit scanner
WRKSRC= ${WRKDIR}/ADMsnmp
do-build:
${CC} ${CFLAGS} -DPORTSHAREDIR="${PREFIX}/share/ADMsnmp" \
-o ${WRKSRC}/ADMsnmp ${WRKSRC}/snmp.c
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/ADMsnmp ${PREFIX}/bin
${MKDIR} ${PREFIX}/share/ADMsnmp
${MKDIR} ${PREFIX}/share/doc/ADMsnmp
${INSTALL_DATA} ${WRKSRC}/snmp.passwd ${PREFIX}/share/ADMsnmp
${INSTALL_DATA} ${WRKSRC}/ADMsnmp.README ${PREFIX}/share/doc/ADMsnmp
.include <bsd.port.mk>

View File

@ -0,0 +1 @@
MD5 (ADMsnmp.0.1.tgz) = 1b6909ab6ebaaaec49444f51d3162de2

View File

@ -0,0 +1,64 @@
--- snmp.c.orig Wed Feb 17 07:20:05 1999
+++ snmp.c Sun Apr 6 16:31:38 2003
@@ -33,6 +33,8 @@
#include <sys/stat.h>
#include <netdb.h>
#include <netinet/in.h>
+#include <sys/types.h>
+#include <sys/socket.h>
struct snmpchex
@@ -231,7 +233,7 @@
/** get the ID **/
sn->id = buf[i + 2];
for (i = i + (buf[i + 1] + 2); i < size && i + 2 < size; i++)
- if (buf[i] == '\x02')
+ if (buf[i] == '\x02') {
if (buf[i + 1] == '\x01')
{
/** return code **/
@@ -241,6 +243,7 @@
}
else
return (-1);
+ }
}
}
}
@@ -300,7 +303,7 @@
memset (buf, 0, sizeofbuf);
i = getreq (buf, namez, GETREQ_SYSDEC, id, set_req);
memcpy ((buf + i), sysdec, GETREQ_SYSDEC);
- return (sendto (sock, buf, i + GETREQ_SYSDEC, 0, sin, sizeof (struct sockaddr_in)));
+ return (sendto (sock, buf, i + GETREQ_SYSDEC, 0, (const struct sockaddr *)sin, sizeof (struct sockaddr_in)));
}
/** getreq paket **/
@@ -460,7 +463,7 @@
i = 0;
/** we get an answer !!!! */
- if ((i = recvfrom (sock, (char *) &buf, sizeof (buf), 0, &sin, &x)) > 0)
+ if ((i = recvfrom (sock, (char *) &buf, sizeof (buf), 0, (struct sockaddr *) &sin, &x)) > 0)
{
nd = 0;
/** extract the ID the return code and the community name **/
@@ -544,7 +547,7 @@
"[-waitfor] <mili> : time in milisecond in each send of snmprequest\n"
"[-sleep] <second> : time in second of the scan process life\n"
"[-manysend] <number>: how many paket to send by request \n"
- "[-inter] <mili> : time to wait in milisecond after each request");
+ "[-inter] <mili> : time to wait in milisecond after each request\n");
}
int
@@ -581,7 +584,7 @@
printf ("cant resolve hostname!\n");
exit (-1);
}
- opz.wordfile = strdup ("snmp.passwd");
+ opz.wordfile = strdup ("PORTSHAREDIR/snmp.passwd");
opz.outputfile = NULL;
opz.guess = -1;
opz.manysend = 2;

View File

@ -0,0 +1,7 @@
ADMsnmp is an snmpd audit scanner.
ADMsnmp can brute force the snmp community name (with a wordfile) or
make a wordfile list derived the hostname.
ADMsnmp can report to you all valid community
names found and inform you if writable access to the MIB has been attained.
ADMsnmp is very easy to use and designed with speed in mind!

View File

@ -0,0 +1,6 @@
@comment $FreeBSD$
bin/ADMsnmp
share/ADMsnmp/snmp.passwd
share/doc/ADMsnmp/ADMsnmp.README
@dirrm share/doc/ADMsnmp
@dirrm share/ADMsnmp

View File

@ -1,6 +1,7 @@
# $FreeBSD$
#
SUBDIR += ADMsnmp
SUBDIR += aafid2
SUBDIR += acid
SUBDIR += aescrypt