Removed due to dependency on expired linux-js.

Consider using emulators/joytran from the same author.

Approved by:	Timothy Beyer <beyert@cs.ucr.edu> (maintainer)
This commit is contained in:
Baptiste Daroussin 2013-06-05 06:41:32 +00:00
parent e1fc6b86e7
commit 764b2d06e7
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=319950
7 changed files with 1 additions and 80 deletions

1
MOVED
View File

@ -4379,3 +4379,4 @@ net/samba34|net/samba36|2013-06-04|Removed: Unmaintained by upstream
devel/linux-js||2013-06-04|Has expired: Broken for more than 6 month
emulators/osmose||2013-06-04|Removed: depends on expired devel/linux-js
security/pam_authsrv||2013-06-04|Removed: depends on expired and removed security/fwtk
emulators/linux-xjoypad||2013-06-05|Removed: depend on expired devel/linux-js, consider using emulators/joytran instead

View File

@ -1,42 +0,0 @@
# New ports collection makefile for: linux-xjoypad
# Date created: 17 Apr 2006
# Whom: Timothy Beyer <beyert@cs.ucr.edu>
#
# $FreeBSD$
#
PORTNAME= xjoypad
PORTVERSION= 1
PORTREVISION= 2
CATEGORIES= emulators
MASTER_SITES= http://members.chello.at/erich.kitzmueller/ammoq/down/
PKGNAMEPREFIX= linux-
DISTNAME= xjoypad
MAINTAINER= beyert@cs.ucr.edu
COMMENT= Joy-Device to X mapping (lets you play Linux games with a joypad)
RUN_DEPENDS= /boot/modules/linux_js.ko:${PORTSDIR}/devel/linux-js
USE_XORG= x11 xau xdmcp
WRKSRC= ${WRKDIR}/xjoypad/
USE_ZIP= yes
FILES= xjoypad.c sendevent.c
CFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib -lcompat -lX11 -lXau -lXdmcp
do-build:
(cd ${WRKSRC} && ${CC} ${CFLAGS} -o xjoypad ${FILES} ${LDFLAGS} )
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/xjoypad ${PREFIX}/bin
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/README.txt ${DOCSDIR}
.endif
@${CAT} ${PKGMESSAGE}
.include <bsd.port.mk>

View File

@ -1,2 +0,0 @@
SHA256 (xjoypad.zip) = 1e640c369191c977a9729deac422d97dcc964cec219e5e1fc953afaeab8e82a8
SIZE (xjoypad.zip) = 419299

View File

@ -1,10 +0,0 @@
--- xjoypad.c.orig 2008-04-20 20:07:58.000000000 -0700
+++ xjoypad.c 2008-04-20 20:11:19.000000000 -0700
@@ -20,6 +20,7 @@
#include <stdio.h>
#include <stdlib.h>
+#include <string.h>
#include <sys/types.h>
#include <sys/stat.h>
#include <fcntl.h>

View File

@ -1,12 +0,0 @@
excerpt from README.txt:
xjoypad allows an USB joypad (probably a USB joystick, too) to be used
with games on linux (probably other unix-like operating systems too).
This is done by mapping the joypad events to X keyboard events which
are sent to the window currently having the focus. Therefore only
keyboard-controlled games are currently supported by xjoypad. xjoypad
was written to add joypad support to the playstation emulator epsxe.
This is the Linux version.
WWW: http://members.chello.at/erich.kitzmueller/ammoq/download.html

View File

@ -1,11 +0,0 @@
===============================================================================
To activate the default joystick to key mapping, run the command
xjoypad -device /dev/input/js[device-id] &
where [device-id] depends on whether you are using using a standard game pad or
a usb game pad (it's probably going to be /dev/input/js0)
note that the -device switch is incorrectly stated as -devicefilename
in the documentation
===============================================================================

View File

@ -1,3 +0,0 @@
bin/xjoypad
%%PORTDOCS%%%%DOCSDIR%%/README.txt
%%PORTDOCS%%@dirrm %%DOCSDIR%%