sysutils/pecl-proctitle: PHP8.X compatibility
- add LICENSE
- add patches to make this work with PHP8.X
PR: 261621
Obtained from: 635dbe9a02
This commit is contained in:
parent
cfcafc3be8
commit
75f7b98a01
@ -2,13 +2,14 @@
|
||||
|
||||
PORTNAME= proctitle
|
||||
PORTVERSION= 0.1.2
|
||||
PORTREVISION= 1
|
||||
PORTREVISION= 2
|
||||
CATEGORIES= sysutils pear
|
||||
|
||||
MAINTAINER= flo@FreeBSD.org
|
||||
COMMENT= PECL extension that allows changing the current process' name
|
||||
|
||||
LICENSE= PHP301
|
||||
|
||||
USES= php:pecl
|
||||
IGNORE_WITH_PHP= 80 81
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
18
sysutils/pecl-proctitle/files/patch-php__proctitle.h
Normal file
18
sysutils/pecl-proctitle/files/patch-php__proctitle.h
Normal file
@ -0,0 +1,18 @@
|
||||
--- php_proctitle.h.orig 2012-05-11 08:49:30 UTC
|
||||
+++ php_proctitle.h
|
||||
@@ -21,6 +21,15 @@
|
||||
#ifndef PHP_PROCTITLE_H
|
||||
#define PHP_PROCTITLE_H
|
||||
|
||||
+
|
||||
+#if PHP_MAJOR_VERSION >= 8
|
||||
+#define TSRMLS_CC
|
||||
+#define TSRMLS_C
|
||||
+#define TSRMLS_DC
|
||||
+#define TSRMLS_D
|
||||
+#define TSRMLS_FETCH()
|
||||
+#endif
|
||||
+
|
||||
#define PHP_PROCTITLE_VERSION "0.1.2"
|
||||
|
||||
extern zend_module_entry proctitle_module_entry;
|
30
sysutils/pecl-proctitle/files/patch-proctitle.c
Normal file
30
sysutils/pecl-proctitle/files/patch-proctitle.c
Normal file
@ -0,0 +1,30 @@
|
||||
--- proctitle.c.orig 2012-05-11 08:49:30 UTC
|
||||
+++ proctitle.c
|
||||
@@ -23,6 +23,7 @@
|
||||
#endif
|
||||
|
||||
#include <php.h>
|
||||
+#include "ext/standard/info.h"
|
||||
#include <SAPI.h>
|
||||
#include <dlfcn.h>
|
||||
#include <string.h>
|
||||
@@ -138,9 +139,7 @@ PHP_MINFO_FUNCTION(proctitle)
|
||||
/* {{{ proctitle_module_entry
|
||||
*/
|
||||
zend_module_entry proctitle_module_entry = {
|
||||
-#if ZEND_MODULE_API_NO >= 20010901
|
||||
STANDARD_MODULE_HEADER,
|
||||
-#endif
|
||||
"proctitle",
|
||||
proctitle_functions,
|
||||
#ifndef PHP_SYSTEM_PROVIDES_SETPROCTITLE
|
||||
@@ -152,9 +151,7 @@ zend_module_entry proctitle_module_entry = {
|
||||
NULL,
|
||||
NULL,
|
||||
PHP_MINFO(proctitle),
|
||||
-#if ZEND_MODULE_API_NO >= 20010901
|
||||
PHP_PROCTITLE_VERSION,
|
||||
-#endif
|
||||
STANDARD_MODULE_PROPERTIES
|
||||
};
|
||||
/* }}} */
|
Loading…
Reference in New Issue
Block a user