Remove NoCatAuth-Server rev 1.1 for renaming.

Requested by:	kris
This commit is contained in:
Bruce M Simpson 2004-01-03 06:09:55 +00:00
parent c90d26d28b
commit 7589101656
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=97159
7 changed files with 0 additions and 207 deletions

View File

@ -1,42 +0,0 @@
# New ports collection makefile for: NoCatAuth
# Date created: 19 November 2003
# Whom: Bruce M Simpson <bms@FreeBSD.org>
#
# $FreeBSD$
#
PORTNAME= Server
PORTVERSION= 0.82
CATEGORIES= net
MASTER_SITES= http://nocat.net/download/NoCatAuth/
PKGNAMEPREFIX= NoCatAuth-
DISTNAME= ${PKGNAMEPREFIX}${PORTVERSION}
MAINTAINER= bms@FreeBSD.org
COMMENT= Open 802.11 Authentication Server
RUN_DEPENDS= \
${LOCALBASE}/bin/gpg:${PORTSDIR}/security/gnupg
CONFLICTS= NoCatAuth-Gateway-*
NO_BUILD= yes
INSTALL_TARGET= authserv
USE_PERL5_RUN= yes
USE_GMAKE= yes
USE_SUBMAKE= yes
WRAP_USER?= nocat
NOCATDIR?= nocat
MAKE_ARGS+= DESTDIR=${PREFIX}/ PREFIX=${NOCATDIR}
MAKE_ARGS+= WRAP_USER=${WRAP_USER}
MAKE_ARGS+= -w
pre-install:
@( ${FIND} ${WRKDIR} -type f -name '*.orig' -exec ${RM} '{}' ';' )
@${SETENV} NOCAT_DIR="${PREFIX}/${NOCATDIR}" WRAP=${WRAP_USER} \
${SH} ${PKGINSTALL} ${PKGNAME} PRE-INSTALL
.include <bsd.port.mk>

View File

@ -1 +0,0 @@
MD5 (NoCatAuth-0.82.tar.gz) = eaaa25b834c7f0bcfbe3270bc7b7f274

View File

@ -1,33 +0,0 @@
--- Makefile.orig Sat May 17 15:35:14 2003
+++ Makefile Wed Nov 19 15:51:41 2003
@@ -1,6 +1,6 @@
### Install somewhere else if you've a mind (or aren't root).
-PREFIX = /usr/local/nocat
+PREFIX ?= /usr/local/nocat
### DESTDIR allows packagers to temporarily install somewhere else.
@@ -35,7 +35,7 @@
check_fw:
@echo -n "Checking for firewall compatibility: "
- @bin/detect-fw.sh bin || ( echo "Can't seem to find supported firewall software. Check your path?" && exit 255 )
+ @bin/detect-fw.sh ${FIREWALL} bin || ( echo "Can't seem to find supported firewall software. Check your path?" && exit 255 )
check_gpg:
@echo "Looking for gpg..."
@@ -62,10 +62,10 @@
$(INSTALL) $(INST_GW) $(TARGET)
wrapper: check_fw
- FW_BIN=`bin/detect-fw.sh | cut -d' ' -f1`; \
- ln -sf fw-wrap bin/`basename $$FW_BIN`; \
+ FW_BIN=`bin/detect-fw.sh ${FIREWALL} bin | cut -d' ' -f1`; \
+ ln -sf fw-wrap bin/`basename ${FW_BIN}`; \
gcc -o bin/fw-wrap -Wall -DALLOWED_UID=\"$(WRAP_USER)\" \
- -DFW_BINARY=\"$$FW_BIN\" \
+ -DFW_BINARY=\"${FW_BINARY}\" \
etc/fw-wrap.c
chmod u+s bin/fw-wrap

View File

@ -1,11 +0,0 @@
--- bin/detect-fw.sh.orig Fri Aug 9 07:28:43 2002
+++ bin/detect-fw.sh Wed Nov 19 15:51:16 2003
@@ -3,7 +3,7 @@
export PATH=$PATH:/sbin:/usr/sbin:/usr/local/sbin
# Have we been explicitly told which firewall scripts to install?
-if [ -n "$1" -a -n "$2" -a -d "$2/$1" ]; then
+if [ -n "$1" -a -n "$2" ]; then
FIREWALL=$1
shift

View File

@ -1,6 +0,0 @@
This is the authorization server component of the NoCat system. Please note
that the gpg target is not currently used or installed, and the message
regarding 'make pgpkeys' should be disregarded for the time being.
Bruce
bms@FreeBSD.org

View File

@ -1,48 +0,0 @@
#!/bin/sh
PATH=/bin:/usr/sbin
if [ -z "${ENABLE_USER}" ]; then
ENABLE_USER=nocat
fi
if [ -z "${ENABLE_GROUP}" ]; then
ENABLE_GROUP=nocat
fi
case $2 in
PRE-INSTALL)
UID=181
GID=${UID}
if pw group show "${ENABLE_GROUP}" 2>/dev/null; then
echo "You already have a group \"${ENABLE_GROUP}\", so I will use it."
else
if pw groupadd ${ENABLE_GROUP} -g ${GID}; then
echo "Added group \"${ENABLE_GROUP}\."
else
echo "Adding group \"${ENABLE_GROUP}\" failed."
exit 1
fi
fi
if pw user show "${ENABLE_USER}" 2>/dev/null; then
echo "You already have a user \"${ENABLE_USER}\", so I will use it."
if pw usermod ${ENABLE_USER} -d ${NOCAT_DIR}
then
echo "Changed home directory of \"${ENABLE_USER}\" to \"${SYSCONF_DIR}\""
else
"${SYSCONF_DIR}\" failed..."
exit 1
fi
else
if pw useradd ${ENABLE_USER} -u ${UID} -g ${ENABLE_GROUP} -h \
-d ${SYSCONF_DIR} -s /sbin/nologin -c "NoCat Daemon"
then
echo "Added user \"${ENABLE_USER}\"."
else
echo "Adding user \"${ENABLE_USER}\" failed..."
exit 1
fi
fi
;;
esac

View File

@ -1,66 +0,0 @@
nocat/pgp/trustedkeys.gpg
@dirrm nocat/pgp
nocat/nocat.conf
nocat/lib/NoCat/User.pm
nocat/lib/NoCat/Source/Samba.pm
nocat/lib/NoCat/Source/RADIUS.pm
nocat/lib/NoCat/Source/Passwd.pm
nocat/lib/NoCat/Source/PAM.pm
nocat/lib/NoCat/Source/NIS.pm
nocat/lib/NoCat/Source/LDAP.pm
nocat/lib/NoCat/Source/IMAP.pm
nocat/lib/NoCat/Source/DBI.pm
nocat/lib/NoCat/Source.pm
@dirrm nocat/lib/NoCat/Source
nocat/lib/NoCat/Peer.pm
nocat/lib/NoCat/Message.pm
nocat/lib/NoCat/Group.pm
nocat/lib/NoCat/Gateway/Passive.pm
nocat/lib/NoCat/Gateway/Open.pm
nocat/lib/NoCat/Gateway/Captive.pm
nocat/lib/NoCat/Gateway.pm
@dirrm nocat/lib/NoCat/Gateway
nocat/lib/NoCat/Firewall.pm
nocat/lib/NoCat/AuthService.pm
nocat/lib/NoCat.pm
@dirrm nocat/lib/NoCat
@dirrm nocat/lib
nocat/httpd.conf
nocat/htdocs/update.html
nocat/htdocs/status.html
nocat/htdocs/splash.html
nocat/htdocs/renew_pasv.html
nocat/htdocs/renew.html
nocat/htdocs/register_ok.html
nocat/htdocs/register.html
nocat/htdocs/logout.html
nocat/htdocs/login_ok.html
nocat/htdocs/login.html
nocat/htdocs/login-no-skip.html
nocat/htdocs/images/update.gif
nocat/htdocs/images/skip.gif
nocat/htdocs/images/reset.gif
nocat/htdocs/images/register.gif
nocat/htdocs/images/logout.gif
nocat/htdocs/images/login.gif
nocat/htdocs/images/continue.gif
nocat/htdocs/images/auth_logo.gif
@dirrm nocat/htdocs/images
nocat/htdocs/fatal.html
nocat/htdocs/expired.html
@dirrm nocat/htdocs
nocat/etc/passwd
nocat/etc/groupadm
nocat/etc/group
@dirrm nocat/etc
nocat/cgi-bin/update
nocat/cgi-bin/register
nocat/cgi-bin/login
nocat/cgi-bin/admlogin
@dirrm nocat/cgi-bin
nocat/bin/vtun.sh
nocat/bin/gateway
nocat/bin/detect-fw.sh
nocat/bin/admintool
@dirrm nocat/bin
@dirrm nocat