x11-toolkits/granite: Update to 5.2.2
- Update WWW - Add missing gsettings-desktop-schemas dependency to prevent runtime crashes of applications using the DateTime widget - Bump revision of dependent ports Changes: https://github.com/elementary/granite/releases
This commit is contained in:
parent
141e065e28
commit
75603347c4
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=489174
@ -2,6 +2,7 @@
|
||||
|
||||
PORTNAME= lookbook
|
||||
DISTVERSION= 1.0.0
|
||||
PORTREVISION= 1
|
||||
CATEGORIES= deskutils
|
||||
|
||||
MAINTAINER= greg@unrelenting.technology
|
||||
|
@ -2,6 +2,7 @@
|
||||
|
||||
PORTNAME= minder
|
||||
PORTVERSION= 1.1.3
|
||||
PORTREVISION= 1
|
||||
CATEGORIES= graphics
|
||||
PKGNAMESUFFIX= -app # avoid PKGBASE collision with net-p2p/minder
|
||||
|
||||
|
@ -3,7 +3,7 @@
|
||||
|
||||
PORTNAME= pantheon-calculator
|
||||
PORTVERSION= 0.1.2
|
||||
PORTREVISION= 1
|
||||
PORTREVISION= 2
|
||||
CATEGORIES= math
|
||||
MASTER_SITES= https://launchpadlibrarian.net/303135059/ \
|
||||
https://launchpad.net/${PORTNAME}/0.4-loki/${PORTVERSION}/+download/
|
||||
|
@ -3,7 +3,7 @@
|
||||
#
|
||||
|
||||
PORTNAME= granite
|
||||
DISTVERSION= 0.5
|
||||
DISTVERSION= 5.2.2
|
||||
CATEGORIES= x11-toolkits
|
||||
|
||||
MAINTAINER= tobik@FreeBSD.org
|
||||
@ -14,9 +14,10 @@ LICENSE_FILE= ${WRKSRC}/COPYING
|
||||
|
||||
BUILD_DEPENDS= valac:lang/vala
|
||||
LIB_DEPENDS= libgee-0.8.so:devel/libgee
|
||||
RUN_DEPENDS= contractor:sysutils/contractor
|
||||
RUN_DEPENDS= contractor:sysutils/contractor \
|
||||
gsettings-desktop-schemas>=3.28.1:devel/gsettings-desktop-schemas
|
||||
|
||||
USES= cmake gettext pkgconfig tar:xz
|
||||
USES= cmake gettext gnome pkgconfig tar:xz
|
||||
USE_GITHUB= yes
|
||||
GH_ACCOUNT= elementary
|
||||
USE_GNOME= glib20 gtk30 cairo introspection:build
|
||||
@ -25,7 +26,4 @@ USE_LDCONFIG= yes
|
||||
|
||||
CFLAGS+= -Wno-return-type
|
||||
|
||||
post-patch:
|
||||
${REINPLACE_CMD} -e 's|FFREE_|FREE_|' ${WRKSRC}/CMakeLists.txt
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
@ -1,3 +1,3 @@
|
||||
TIMESTAMP = 1521380734
|
||||
SHA256 (elementary-granite-0.5_GH0.tar.gz) = cc4905ae70fddeba3d2ded44bb642be77d419aa090251a7ab24c155b8616be06
|
||||
SIZE (elementary-granite-0.5_GH0.tar.gz) = 365015
|
||||
TIMESTAMP = 1546508010
|
||||
SHA256 (elementary-granite-5.2.2_GH0.tar.gz) = a2bfb717570b2b7ffef8715fae0dcabe7e3de21f6cb9392f1184a57ae6436f6c
|
||||
SIZE (elementary-granite-5.2.2_GH0.tar.gz) = 430867
|
||||
|
11
x11-toolkits/granite/files/patch-CMakeLists.txt
Normal file
11
x11-toolkits/granite/files/patch-CMakeLists.txt
Normal file
@ -0,0 +1,11 @@
|
||||
--- CMakeLists.txt.orig 2018-12-17 13:02:11 UTC
|
||||
+++ CMakeLists.txt
|
||||
@@ -59,7 +59,7 @@ if (${CMAKE_SYSTEM_NAME} MATCHES "Linux")
|
||||
elseif (${CMAKE_SYSTEM_NAME} MATCHES "DragonFly")
|
||||
set (VALAC_OPTIONS ${VALAC_OPTIONS} --define=DRAGON_FLY)
|
||||
elseif (${CMAKE_SYSTEM_NAME} MATCHES "FreeBSD")
|
||||
- set (VALAC_OPTIONS ${VALAC_OPTIONS} --define=FFREE_BSD)
|
||||
+ set (VALAC_OPTIONS ${VALAC_OPTIONS} --define=FREE_BSD)
|
||||
elseif (${CMAKE_SYSTEM_NAME} MATCHES "NetBSD")
|
||||
set (VALAC_OPTIONS ${VALAC_OPTIONS} --define=NET_BSD)
|
||||
elseif (${CMAKE_SYSTEM_NAME} MATCHES "OpenBSD")
|
@ -1,8 +1,8 @@
|
||||
--- lib/Application.vala.orig 2015-08-30 10:13:06 UTC
|
||||
--- lib/Application.vala.orig 2018-12-17 13:02:11 UTC
|
||||
+++ lib/Application.vala
|
||||
@@ -157,7 +157,11 @@ namespace Granite {
|
||||
message ("Kernel version: %s", (string) un.release);
|
||||
Logger.DisplayLevel = LogLevel.WARN;
|
||||
Granite.Services.Logger.DisplayLevel = Granite.Services.LogLevel.WARN;
|
||||
|
||||
- Intl.bindtextdomain (exec_name, build_data_dir + "/locale");
|
||||
+ Intl.setlocale (LocaleCategory.ALL, "");
|
||||
@ -11,5 +11,5 @@
|
||||
+ Intl.bind_textdomain_codeset (exec_name, "UTF-8");
|
||||
+ Intl.textdomain (exec_name);
|
||||
|
||||
add_actions ();
|
||||
|
||||
handle_local_options.connect (on_handle_local_options);
|
||||
}
|
18
x11-toolkits/granite/files/patch-lib_DateTime.vala
Normal file
18
x11-toolkits/granite/files/patch-lib_DateTime.vala
Normal file
@ -0,0 +1,18 @@
|
||||
The io.elementary.desktop.wingpanel.datetime schema is not available,
|
||||
which leads to crashes when using the DateTime widget. Use the
|
||||
org.gnome.desktop.interface schema instead as documented in the API
|
||||
docs.
|
||||
|
||||
cf. https://github.com/elementary/granite/pull/222
|
||||
|
||||
--- lib/DateTime.vala.orig 2018-12-17 13:02:11 UTC
|
||||
+++ lib/DateTime.vala
|
||||
@@ -110,7 +110,7 @@ namespace Granite.DateTime {
|
||||
* @return true if the clock format is 12h based, false otherwise.
|
||||
*/
|
||||
private static bool is_clock_format_12h () {
|
||||
- var h24_settings = new Settings ("io.elementary.desktop.wingpanel.datetime");
|
||||
+ var h24_settings = new Settings ("org.gnome.desktop.interface");
|
||||
var format = h24_settings.get_string ("clock-format");
|
||||
return (format.contains ("12h"));
|
||||
}
|
@ -1,11 +1,11 @@
|
||||
--- lib/Widgets/DatePicker.vala.orig 2015-08-30 10:13:06 UTC
|
||||
--- lib/Widgets/DatePicker.vala.orig 2018-12-17 13:02:11 UTC
|
||||
+++ lib/Widgets/DatePicker.vala
|
||||
@@ -77,7 +77,7 @@ namespace Granite.Widgets {
|
||||
@@ -85,7 +85,7 @@ namespace Granite.Widgets {
|
||||
// Entry properties
|
||||
can_focus = false;
|
||||
editable = false; // user can't edit the entry directly
|
||||
- secondary_icon_gicon = new ThemedIcon.with_default_fallbacks ("office-calendar-symbolic");
|
||||
+ secondary_icon_gicon = new ThemedIcon.with_default_fallbacks ("x-office-calendar-symbolic");
|
||||
|
||||
dropdown.add_events (EventMask.FOCUS_CHANGE_MASK);
|
||||
dropdown.add_events (Gdk.EventMask.FOCUS_CHANGE_MASK);
|
||||
dropdown.add (calendar);
|
||||
|
@ -1,22 +0,0 @@
|
||||
--- ./lib/CMakeLists.txt.orig 2014-05-25 19:42:24.000000000 +0000
|
||||
+++ ./lib/CMakeLists.txt 2014-07-27 11:00:15.000000000 +0000
|
||||
@@ -62,7 +62,11 @@
|
||||
configure_file (${CMAKE_CURRENT_SOURCE_DIR}/${PKG_NAME}.pc.cmake ${CMAKE_CURRENT_BINARY_DIR}/${PKG_NAME}.pc)
|
||||
|
||||
include (GNUInstallDirs)
|
||||
-install (FILES ${CMAKE_CURRENT_BINARY_DIR}/${PKG_NAME}.pc DESTINATION ${CMAKE_INSTALL_FULL_LIBDIR}/pkgconfig)
|
||||
+if (${CMAKE_SYSTEM_NAME} MATCHES "DragonFly" OR ${CMAKE_SYSTEM_NAME} MATCHES "FreeBSD")
|
||||
+ install (FILES ${CMAKE_CURRENT_BINARY_DIR}/${PKG_NAME}.pc DESTINATION ${CMAKE_INSTALL_PREFIX}/libdata/pkgconfig)
|
||||
+else ()
|
||||
+ install (FILES ${CMAKE_CURRENT_BINARY_DIR}/${PKG_NAME}.pc DESTINATION ${CMAKE_INSTALL_FULL_LIBDIR}/pkgconfig)
|
||||
+endif ()
|
||||
|
||||
# Link all
|
||||
set (CFLAGS ${DEPS_CFLAGS} ${DEPS_CFLAGS_OTHER})
|
||||
@@ -114,4 +118,4 @@
|
||||
if (INTROSPECTION_FOUND)
|
||||
include (GObjectIntrospectionMacros)
|
||||
add_target_gir (${PKG_NAME} ${PKG_GIR_NAME} ${PKG_NAME}.h "${VALA_C}" "${DEPS_CFLAGS}" ${API_VERSION} ${GI_PKG_DEPS})
|
||||
-endif ()
|
||||
\ No newline at end of file
|
||||
+endif ()
|
@ -1,4 +1,4 @@
|
||||
Granite is an extension of Gtk+ toolkit. It provides several widgets and
|
||||
classes that ease desktop applications development.
|
||||
|
||||
WWW: https://launchpad.net/granite
|
||||
WWW: https://github.com/elementary/granite
|
||||
|
@ -3,8 +3,8 @@ include/granite/granite.h
|
||||
include/granite/widgets-utils.h
|
||||
lib/girepository-1.0/Granite-1.0.typelib
|
||||
lib/libgranite.so
|
||||
lib/libgranite.so.4
|
||||
lib/libgranite.so.4.0
|
||||
lib/libgranite.so.5
|
||||
lib/libgranite.so.5.0
|
||||
libdata/pkgconfig/granite.pc
|
||||
share/applications/granite-demo.desktop
|
||||
share/gir-1.0/Granite-1.0.gir
|
||||
|
Loading…
Reference in New Issue
Block a user