Update to 1.4.1:

- maketemp now creates an empty file with the given name, instead of merely
  returning the name of a nonexistent file.  This closes a security hole.
- minor fixes, port passes all checks
- use INFO-macro
- strip cruft from pkg-descr; add WWW:
- pet portlint
This commit is contained in:
Volker Stolz 2004-07-16 14:54:28 +00:00
parent d14b50236c
commit 74fd89ef1e
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=113771
5 changed files with 38 additions and 74 deletions

View File

@ -6,8 +6,7 @@
#
PORTNAME= m4
PORTVERSION= 1.4
PORTREVISION= 1
PORTVERSION= 1.4.1
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_GNU}
MASTER_SITE_SUBDIR= m4
@ -22,9 +21,13 @@ CONFIGURE_ARGS= --program-prefix=g
CONFIGURE_ARGS+= --enable-changeword
.endif
INFO= m4
EXAMPLESDIR= share/examples/gm4
post-install:
@${MKDIR} ${PREFIX}/share/examples/gm4
${INSTALL_DATA} ${WRKSRC}/examples/*.m4 ${PREFIX}/share/examples/gm4
@${MKDIR} ${PREFIX}/${EXAMPLESDIR}
${INSTALL_DATA} ${WRKSRC}/examples/*.m4 ${PREFIX}/${EXAMPLESDIR}
@install-info ${PREFIX}/info/m4.info ${PREFIX}/info/dir
.include <bsd.port.mk>

View File

@ -1,2 +1,2 @@
MD5 (m4-1.4.tar.gz) = 9eb2dd07740b2d2f3c7adb3e8d299bda
SIZE (m4-1.4.tar.gz) = 317588
MD5 (m4-1.4.1.tar.gz) = 76984d94e85afb21caa88b5cc5aea0b3
SIZE (m4-1.4.1.tar.gz) = 343133

View File

@ -1,20 +0,0 @@
--- src/m4.c Mon Oct 22 04:25:47 2001
+++ src/m4.c Mon Oct 22 04:26:03 2001
@@ -369,7 +369,7 @@
case 'o':
if (!debug_set_output (optarg))
- error (0, errno, optarg);
+ error (0, errno, "%s", optarg);
break;
case 's':
@@ -466,7 +466,7 @@
fp = path_search (argv[optind]);
if (fp == NULL)
{
- error (0, errno, argv[optind]);
+ error (0, errno, "%s", argv[optind]);
continue;
}
else

View File

@ -2,22 +2,6 @@
processor. It is mostly SVR4 compatible, although it has some
extensions (for example, handling more than 9 positional parameters to
macros). `m4' also has builtin functions for including files, running
shell commands, doing arithmetic, etc. Autoconf needs GNU `m4' for
generating `configure' scripts, but not for running them.
shell commands, doing arithmetic, etc.
GNU `m4' was originally written by Rene Seindal, with subsequent
changes by Franc,ois Pinard and other volunteers on the Internet. All
names and email addresses can be found in the file `THANKS' from the
GNU `m4' distribution.
This is release 1.3. It is now to be considered stable, future
releases are only meant to fix bugs, increase speed, or improve
documentation. However...
An experimental feature, which would improve `m4' usefulness, allows
for changing the syntax for what is a "word" in `m4'. You should use:
./configure --enable-changeword
if you want this feature compiled in. The current implementation slows
down `m4' considerably and is hardly acceptable. So, it might go away,
do not count on it yet.
WWW: http://www.gnu.org/software/m4/m4.html

View File

@ -1,31 +1,28 @@
bin/gm4
@unexec install-info --delete %D/info/m4.info %D/info/dir
info/m4.info
@exec install-info %D/info/m4.info %D/info/dir
share/examples/gm4/capitalize.m4
share/examples/gm4/comments.m4
share/examples/gm4/ddivert.m4
share/examples/gm4/debug.m4
share/examples/gm4/esyscmd.m4
share/examples/gm4/exp.m4
share/examples/gm4/file.m4
share/examples/gm4/foreach.m4
share/examples/gm4/forloop.m4
share/examples/gm4/fstab.m4
share/examples/gm4/hanoi.m4
share/examples/gm4/incl-test.m4
share/examples/gm4/include.m4
share/examples/gm4/indir.m4
share/examples/gm4/misc.m4
share/examples/gm4/multiquotes.m4
share/examples/gm4/patsubst.m4
share/examples/gm4/pushpop.m4
share/examples/gm4/regexp.m4
share/examples/gm4/reverse.m4
share/examples/gm4/sync-lines.m4
share/examples/gm4/sysv-args.m4
share/examples/gm4/trace.m4
share/examples/gm4/translit.m4
share/examples/gm4/undivert.m4
share/examples/gm4/wrap.m4
@dirrm share/examples/gm4
%%EXAMPLESDIR%%/capitalize.m4
%%EXAMPLESDIR%%/comments.m4
%%EXAMPLESDIR%%/ddivert.m4
%%EXAMPLESDIR%%/debug.m4
%%EXAMPLESDIR%%/esyscmd.m4
%%EXAMPLESDIR%%/exp.m4
%%EXAMPLESDIR%%/file.m4
%%EXAMPLESDIR%%/foreach.m4
%%EXAMPLESDIR%%/forloop.m4
%%EXAMPLESDIR%%/fstab.m4
%%EXAMPLESDIR%%/hanoi.m4
%%EXAMPLESDIR%%/incl-test.m4
%%EXAMPLESDIR%%/include.m4
%%EXAMPLESDIR%%/indir.m4
%%EXAMPLESDIR%%/misc.m4
%%EXAMPLESDIR%%/multiquotes.m4
%%EXAMPLESDIR%%/patsubst.m4
%%EXAMPLESDIR%%/pushpop.m4
%%EXAMPLESDIR%%/regexp.m4
%%EXAMPLESDIR%%/reverse.m4
%%EXAMPLESDIR%%/sync-lines.m4
%%EXAMPLESDIR%%/sysv-args.m4
%%EXAMPLESDIR%%/trace.m4
%%EXAMPLESDIR%%/translit.m4
%%EXAMPLESDIR%%/undivert.m4
%%EXAMPLESDIR%%/wrap.m4
@dirrm %%EXAMPLESDIR%%