- Update to 1.0.5
- Add desktop entry - Simplify the port
This commit is contained in:
parent
86e848ce5e
commit
747706742c
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=486552
@ -2,8 +2,7 @@
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= lpairs
|
||||
PORTVERSION= 1.0.4
|
||||
PORTREVISION= 4
|
||||
PORTVERSION= 1.0.5
|
||||
CATEGORIES= games
|
||||
MASTER_SITES= SF/lgames/${PORTNAME}/
|
||||
|
||||
@ -13,24 +12,29 @@ COMMENT= Classical memory game
|
||||
LICENSE= GPLv2+
|
||||
LICENSE_FILE= ${WRKSRC}/COPYING
|
||||
|
||||
USES= autoreconf
|
||||
GNU_CONFIGURE= yes
|
||||
USE_SDL= sdl
|
||||
CPPFLAGS+= -I${LOCALBASE}/include
|
||||
LDFLAGS+= -L${LOCALBASE}/lib
|
||||
|
||||
PLIST_FILES= bin/${PORTNAME}
|
||||
PORTDATA= *
|
||||
|
||||
DESKTOP_ENTRIES="LPairs" \
|
||||
"" \
|
||||
"${PORTNAME}" \
|
||||
"${PORTNAME}" \
|
||||
"Game;LogicGame;" \
|
||||
""
|
||||
|
||||
OPTIONS_DEFINE= NLS
|
||||
OPTIONS_SUB= yes
|
||||
|
||||
NLS_USES= gettext
|
||||
NLS_CONFIGURE_ENABLE= nls
|
||||
NLS_CONFIGURE_ON= --with-libintl-prefix=${LOCALBASE}
|
||||
NLS_PLIST_FILES= share/locale/de/LC_MESSAGES/lpairs.mo
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -e '/^LIBS =/ s|$$| $${INTLLIBS}|' \
|
||||
${WRKSRC}/lpairs/Makefile.in
|
||||
@${REINPLACE_CMD} -e 's|^\(inst_dir=\).*|\1$$datarootdir/lpairs|' \
|
||||
${WRKSRC}/configure
|
||||
@${REINPLACE_CMD} -e 's|games/lpairs|lpairs|' ${WRKSRC}/configure.in
|
||||
|
||||
post-install:
|
||||
${INSTALL_DATA} ${WRKSRC}/${PORTNAME}.png ${STAGEDIR}${PREFIX}/share/pixmaps
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
@ -1,2 +1,3 @@
|
||||
SHA256 (lpairs-1.0.4.tar.gz) = 350237a51a5de6b2a557af687b4f16678056a0e8d8d96d7e395f6629481462c5
|
||||
SIZE (lpairs-1.0.4.tar.gz) = 536625
|
||||
TIMESTAMP = 1542651898
|
||||
SHA256 (lpairs-1.0.5.tar.gz) = 57afe33d2a83229c3cff5efa6512fd2eeac4eacb92d37dd3070db6bbb024dc16
|
||||
SIZE (lpairs-1.0.5.tar.gz) = 557997
|
||||
|
@ -1,15 +0,0 @@
|
||||
--- lpairs/pairs.h.orig 2005-09-27 18:02:58.000000000 +0400
|
||||
+++ lpairs/pairs.h 2009-03-25 22:04:25.000000000 +0300
|
||||
@@ -102,10 +102,10 @@
|
||||
void draw_button( Pairs *pairs, int map_x, int map_y, int type );
|
||||
|
||||
/* get map contents at position */
|
||||
-inline int get_map_cont( Pairs *pairs, int map_x, int map_y );
|
||||
+int get_map_cont( Pairs *pairs, int map_x, int map_y );
|
||||
|
||||
/* set map contents at position */
|
||||
-inline void set_map_cont( Pairs *pairs, int map_x, int map_y, int cont );
|
||||
+void set_map_cont( Pairs *pairs, int map_x, int map_y, int cont );
|
||||
|
||||
/* draw all buttons */
|
||||
void draw_all_buttons( Pairs *pairs, int type );
|
@ -1,45 +0,0 @@
|
||||
--- lpairs/sdl.h.orig 2001-03-16 21:43:22.000000000 +0300
|
||||
+++ lpairs/sdl.h 2009-03-25 22:04:45.000000000 +0300
|
||||
@@ -40,8 +40,8 @@
|
||||
SDL_Surface* load_surf(char *fname, int f);
|
||||
SDL_Surface* create_surf(int w, int h, int f);
|
||||
int disp_format(SDL_Surface *sur);
|
||||
-inline void lock_surf(SDL_Surface *sur);
|
||||
-inline void unlock_surf(SDL_Surface *sur);
|
||||
+void lock_surf(SDL_Surface *sur);
|
||||
+void unlock_surf(SDL_Surface *sur);
|
||||
void blit_surf(void);
|
||||
void alpha_blit_surf(int alpha);
|
||||
void fill_surf(int c);
|
||||
@@ -86,8 +86,8 @@
|
||||
Font* load_fixed_font(char *fname, int off, int len, int w);
|
||||
void free_font(Font *sfnt);
|
||||
int write_text(Font *sfnt, SDL_Surface *dest, int x, int y, char *str, int alpha);
|
||||
-inline void lock_font(Font *sfnt);
|
||||
-inline void unlock_font(Font *sfnt);
|
||||
+void lock_font(Font *sfnt);
|
||||
+void unlock_font(Font *sfnt);
|
||||
SDL_Rect last_write_rect(Font *fnt);
|
||||
int text_width(Font *fnt, char *str);
|
||||
|
||||
@@ -116,16 +116,16 @@
|
||||
void quit_sdl();
|
||||
int set_video_mode( int w, int h, int d, int f );
|
||||
void hardware_cap();
|
||||
-inline void refresh_screen( int x, int y, int w, int h );
|
||||
+void refresh_screen( int x, int y, int w, int h );
|
||||
void refresh_rects();
|
||||
void add_refresh_rect(int x, int y, int w, int h);
|
||||
void dim_screen(int steps, int delay, int trp);
|
||||
void undim_screen(int steps, int delay, int trp);
|
||||
int wait_for_key();
|
||||
void wait_for_click();
|
||||
-inline void lock_screen();
|
||||
-inline void unlock_screen();
|
||||
-inline void flip_screen();
|
||||
+void lock_screen();
|
||||
+void unlock_screen();
|
||||
+void flip_screen();
|
||||
|
||||
/* cursor */
|
||||
/* creates cursor */
|
13
games/lpairs/files/patch-lpairs_Makefile.am
Normal file
13
games/lpairs/files/patch-lpairs_Makefile.am
Normal file
@ -0,0 +1,13 @@
|
||||
--- lpairs/Makefile.am.orig 2018-11-02 16:43:54 UTC
|
||||
+++ lpairs/Makefile.am
|
||||
@@ -6,6 +6,10 @@ DEFS = @DEFS@ @inst_flag@ @sound_flag@ @
|
||||
bin_PROGRAMS = lpairs
|
||||
lpairs_SOURCES = main.c pairs.c dynlist.c sdl.c cfg.c menu.c sndsrv.c
|
||||
|
||||
+lpairs_LDADD = \
|
||||
+ $(INTLLIBS)
|
||||
+
|
||||
+
|
||||
#source
|
||||
EXTRA_DIST = main.c pairs.c dynlist.c sdl.c cfg.c menu.c sndsrv.c \
|
||||
pairs.h dynlist.h sdl.h cfg.h menu.h sndsrv.h gettext.h \
|
3
games/lpairs/pkg-plist
Normal file
3
games/lpairs/pkg-plist
Normal file
@ -0,0 +1,3 @@
|
||||
bin/lpairs
|
||||
%%NLS%%share/locale/de/LC_MESSAGES/lpairs.mo
|
||||
share/pixmaps/lpairs.png
|
Loading…
Reference in New Issue
Block a user