- Update to 0.3.0.

- Remove round-trip option as this patch is included upstream now. See
  the new -t argument.
- Remove outdated perl version check.
- Re-add WWW in pkg-descr.
- Pass maintainership to upstream maintainer.
This commit is contained in:
Beat Gaetzi 2011-04-02 00:17:17 +00:00
parent 42e22e8692
commit 742d06bd88
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=272110
6 changed files with 8 additions and 224 deletions

View File

@ -6,30 +6,16 @@
#
PORTNAME= fastest_cvsup
PORTVERSION= 0.2.9
PORTREVISION= 6
PORTVERSION= 0.3.0
CATEGORIES= sysutils
MASTER_SITES= http://www.chruetertee.ch/files/download/
MASTER_SITES= SF/${PORTNAME:S/_/-/}
MAINTAINER= beat@FreeBSD.org
MAINTAINER= freebsd@hm2k.org
COMMENT= Finds fastest CVSup server
DISTVERSION= 0.2.8
USE_PERL5= yes
MAN7= fastest_cvsup.7
PLIST_FILES= bin/fastest_cvsup
OPTIONS= ROUNDTRIP "Build with round-trip patch" off
.include <bsd.port.pre.mk>
.if defined(WITH_ROUNDTRIP)
EXTRA_PATCHES= ${FILESDIR}/extrapatch-fastest_cvsup
.endif
.if ${PERL_LEVEL} < 500805
RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/Time/HiRes.pm:${PORTSDIR}/devel/p5-Time-HiRes
.endif
.include <bsd.port.post.mk>
.include <bsd.port.mk>

View File

@ -1,2 +1,2 @@
SHA256 (fastest_cvsup-0.2.8.tar.gz) = 2ad7211d54c8220bf99371dbc34c3095bb305a673e3543b173865d3ece10fd3f
SIZE (fastest_cvsup-0.2.8.tar.gz) = 7828
SHA256 (fastest_cvsup-0.3.0.tar.gz) = f148006ac5fbb900cb63ca84536354b6af9c4b51774efadf56cb6cf42e5c6ce0
SIZE (fastest_cvsup-0.3.0.tar.gz) = 8260

View File

@ -1,27 +0,0 @@
--- fastest_cvsup 2006/01/13 13:24:38 1.1
+++ fastest_cvsup 2006/01/13 13:43:08
@@ -526,9 +526,9 @@
if ( $VERBOSE ) { # print pretty display
- my $ms = sprintf("%.2f", 1000 * $time_taken); # time in ms
+ $time{$server} = 1000 * $time_taken ; # time in ms
print $SERVER_RESULT, "server replied: $reply\n";
- print $SERVER_RESULT, "time taken: $ms ms\n";
+ print $SERVER_RESULT, "time taken: " . sprintf("%.2f",$time{$server}) . " ms\n";
}
}
@@ -547,9 +547,9 @@
if ( $VERBOSE ) {
print "\n", $GENERAL_INFO, "Speed Daemons:\n" if $fastest[0]; # just checking ;)
- print $SERVER_RESULT, "1st: $fastest[0]\n" if $fastest[0];
- print $SERVER_RESULT, "2nd: $fastest[1]\n" if $fastest[1];
- print $SERVER_RESULT, "3rd: $fastest[2]\n" if $fastest[2];
+ printf("%s1st: %-24s %.2f ms\n", $SERVER_RESULT, $fastest[0], $time{$fastest[0]}) if $fastest[0];
+ printf("%s2st: %-24s %.2f ms\n", $SERVER_RESULT, $fastest[1], $time{$fastest[1]}) if $fastest[1];
+ printf("%s3st: %-24s %.2f ms\n", $SERVER_RESULT, $fastest[2], $time{$fastest[2]}) if $fastest[2];
}
else { # otherwise just output the fastest.
print $fastest[0];

View File

@ -1,13 +0,0 @@
--- Makefile.orig Wed Jul 17 15:16:50 2002
+++ Makefile Wed Jul 17 15:17:44 2002
@@ -8,8 +8,8 @@
--date="17 July 2002" fastest_cvsup > fastest_cvsup.7
install:
- install -o root -g wheel -m 0755 fastest_cvsup /usr/local/bin
- install -o root -g wheel -m 0644 fastest_cvsup.7 /usr/local/man/man7
+ ${BSD_INSTALL_SCRIPT} fastest_cvsup ${PREFIX}/bin
+ ${BSD_INSTALL_MAN} fastest_cvsup.7 ${PREFIX}/man/man7
clean:
rm fastest_cvsup.7

View File

@ -1,164 +0,0 @@
--- fastest_cvsup.orig 2002-09-19 14:12:17.000000000 +0200
+++ fastest_cvsup 2009-01-04 15:25:33.000000000 +0100
@@ -1,13 +1,15 @@
#!/usr/bin/perl
#-----------------------------------------------------------------------------#
#
-# Find fastest CVSup server script for FreeBSD - version 0.2.8
+# Find fastest CVSup server script for FreeBSD - version 0.2.9
# Copyright (c) A.J.Robinson (ajr@subdimension.com) 2002
# Distributed under the BSD license.
#
#-----------------------------------------------------------------------------#
#
# Changes:
+# 0.2.9 - added 'us' country code for USA hosts and 'tld' for top-level
+# domain machines (can be in any country)
# 0.2.8 - fixed the progress meter, timestamped %FREEBSD_SERVERS
# 0.2.7 - updated documentation, usage message and progress meter.
# 0.2.6 - changed from freebsdmirrors.org to the online handbook.
@@ -74,44 +76,50 @@
# How many FreeBSD CVSup servers has each country got? (well, not strictly
# true... what's the highest cvsup number in use?
-my %FREEBSD_SERVERS = ( # last updated: Thu Sep 19 12:56:23 2002
+my %FREEBSD_SERVERS = ( # last updated: Jan 04 15:02:20 GMT 2009
'ar' => 1, # Argentina
- 'at' => 1, # Austria
- 'au' => 5, # Australia
- 'br' => 4, # Brazil
+ 'am' => 1, # Armenia
+ 'at' => 2, # Austria
+ 'au' => 1, # Australia
+ 'br' => 3, # Brazil
'ca' => 2, # Canada
- 'cn' => 1, # China
+ 'ch' => 2, # Switzerland
+ 'cn' => 5, # China
'cz' => 1, # Czech Republic
- 'de' => 7, # Germany
- 'dk' => 1, # Denmark
- 'ee' => 1, # Estonia
+ 'de' => 8, # Germany
+ 'dk' => 3, # Denmark
+ 'ee' => 2, # Estonia
'es' => 3, # Spain
'fi' => 2, # Finland
'fr' => 8, # France
- 'gr' => 2, # Greece
+ 'gr' => 1, # Greece
'hu' => 1, # Hungary
- 'ie' => 1, # Ireland
+ 'ie' => 2, # Ireland
'is' => 1, # Iceland
'jp' => 6, # Japan
- 'kr' => 2, # Korea
- 'lt' => 2, # Lithuania
- 'lv' => 1, # Latvia
- 'nl' => 3, # Netherlands
+ 'kg' => 1, # Kyrgyzstan
+ 'kr' => 5, # Korea
+ 'kw' => 1, # Kuwait
+ 'lt' => 3, # Lithuania
+ 'lv' => 3, # Latvia
+ 'nl' => 6, # Netherlands
'no' => 1, # Norway
'nz' => 1, # New Zealand
'pl' => 1, # Poland
- 'pt' => 1, # Portugal
- 'ro' => 1, # Romania
- 'ru' => 6, # Russia
+ 'pt' => 3, # Portugal
+ 'ro' => 3, # Romania
+ 'ru' => 7, # Russia
'se' => 2, # Sweden
- 'si' => 1, # Slovenia
+ 'si' => 2, # Slovenia
'sk' => 2, # Slovak Republic
- 'sm' => 1, # San Marino
- 'tw' => 3, # Taiwan
- 'ua' => 5, # Ukraine
- 'uk' => 5, # United Kingdom
- 'us' => 17, # USA
+ 'th' => 1, # Thailand
+ 'tr' => 2, # Turkey
+ 'tw' => 14, # Taiwan
+ 'ua' => 11, # Ukraine
+ 'uk' => 4, # United Kingdom
+ 'us' => 18, # USA
'za' => 2, # South Africa
+ 'tld' => 18, # Top Level Domain
);
my %OTHER_SERVERS = (
@@ -141,6 +149,8 @@
'rt.fm',
'skeleton.phys.spbu.ru',
'cvsup.jp.openbsd.org',
+ 'cvsup.tw.openbsd.org',
+ 'openbsd.cc.ntu.edu.tw',
'wiretapped.net',
],
);
@@ -177,6 +187,7 @@
" -Q very quiet mode, no progress meter\n",
" -r uses remote server list from FreeBSD Handbook\n",
" -c aa,bb,cc queries servers in countries aa,bb,cc\n",
+ " tld queries servers in the top level domain\n",
" local queries servers set as local in the script\n",
" all queries all FreeBSD servers\n\n",
" See the man page, fastest_cvsup(7), for more details.\n\n";
@@ -281,6 +292,7 @@
# extract the country name and the rest (what a mess!)
+ s/^<a[^>]+><\/a>//;
if ( m/^(\w+)(\s{1}\w+)?\s*(.*)/s ) {
my $country = $1.$2; # for two word names
my $mess = $3; # the rest
@@ -307,12 +319,12 @@
unless ( $cc_name{$cc} ) { $cc_name{$cc} = $country }
}
- # parse US servers
+ # parse TLD servers
elsif ( $server =~ /cvsup([\d]*)\.freebsd\.org/i ) {
my $i = $1 || 1;
- if ( !$srv{'us'} or $srv{'us'} < $i ) { $srv{'us'} = $i }
- unless ( $cc_name{'us'} ) { $cc_name{'us'} = $country }
+ if ( !$srv{'tld'} or $srv{'tld'} < $i ) { $srv{'tld'} = $i }
+ unless ( $cc_name{'tld'} ) { $cc_name{'tld'} = $country }
}
}
}
@@ -419,7 +431,7 @@
for ( my $i=1; $i<=$FREEBSD_SERVERS{$cc}; $i++ ) {
- if ( $cc eq 'us' ) { # use no country code, include the '1'
+ if ( $cc eq 'tld' ) { # use no country code, include the '1'
if ( $i == 1 ) { push(@first,"cvsup$i.freebsd.org"); }
else { push(@others,"cvsup$i.freebsd.org"); }
}
@@ -575,7 +587,7 @@
=head1 SYNOPSIS
-B<fastest_cvsup> [B<-h>] [B<-(q|Q)>] [B<-r>] B<-c> (B<country codes>|B<local>|B<all>)
+B<fastest_cvsup> [B<-h>] [B<-(q|Q)>] [B<-r>] B<-c> (B<country codes>|B<tld>|B<local>|B<all>)
=head1 DESCRIPTION
@@ -620,6 +632,11 @@
NetBSD and OpenBSD servers are lumped together under the 'netbsd' and
'openbsd' codes respectively.
+=item B<-c tld>
+
+checks the servers in the Top Level Domain. These can be anywhere in the
+world.
+
=item B<-c local>
uses the countries specifed in the C<@LOCAL_CC> array. Edit the script to

View File

@ -12,3 +12,5 @@ Perl script to find fastest CVSup server:
* can re-write itself to update the CVSup server list, obtained
from the online FreeBSD Handbook
* can easily add other CVSup servers (NetBSD/OpenBSD...etc)
WWW: http://fastest-cvsup.sourceforge.net/