- Update to 3.7.1
PR: ports/128936 Submitted by: Yi-Jheng Lin <yzlin AT cs.nctu.edu.tw> Approved by: "Petr Holub" <hopet AT ics.muni.cz> (maintainer)
This commit is contained in:
parent
c78c4f90f3
commit
73e91847d9
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=222974
@ -6,7 +6,7 @@
|
||||
#
|
||||
|
||||
PORTNAME= jrtplib
|
||||
PORTVERSION= 3.7.0
|
||||
PORTVERSION= 3.7.1
|
||||
CATEGORIES= devel
|
||||
MASTER_SITES= http://research.edm.uhasselt.be/jori/jrtplib/
|
||||
|
||||
@ -19,6 +19,8 @@ USE_GMAKE= yes
|
||||
USE_LDCONFIG= yes
|
||||
CONFIGURE_ARGS= --disable-jthread
|
||||
|
||||
PLIST_SUB+= JRTPLIB_VER=${PORTVERSION}
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -e 's|\$$(libdir)/pkgconfig|\$$(prefix)/libdata/pkgconfig|' \
|
||||
${WRKSRC}/pkgconfig/Makefile.in
|
||||
|
@ -1,3 +1,3 @@
|
||||
MD5 (jrtplib-3.7.0.tar.gz) = 685488079c007383763acdf509d6f11c
|
||||
SHA256 (jrtplib-3.7.0.tar.gz) = c144afb896225297d2db042a00a6df8ff3b307804ebb7369b5f73a1a90e8e7f2
|
||||
SIZE (jrtplib-3.7.0.tar.gz) = 466289
|
||||
MD5 (jrtplib-3.7.1.tar.gz) = 18e33752ac51304cba7313c39ca39903
|
||||
SHA256 (jrtplib-3.7.1.tar.gz) = 9c098c4778aee40df55fd00831a29d247336c2a7a3ac0692e79e5693b6d87cd6
|
||||
SIZE (jrtplib-3.7.1.tar.gz) = 474916
|
||||
|
11
devel/jrtplib/files/patch-src-rtperrors.cpp
Normal file
11
devel/jrtplib/files/patch-src-rtperrors.cpp
Normal file
@ -0,0 +1,11 @@
|
||||
--- src/rtperrors.cpp.orig 2008-11-17 14:35:19.000000000 +0800
|
||||
+++ src/rtperrors.cpp 2008-11-17 14:35:50.000000000 +0800
|
||||
@@ -38,7 +38,7 @@
|
||||
struct RTPErrorInfo
|
||||
{
|
||||
int code;
|
||||
- char *description;
|
||||
+ std::string description;
|
||||
};
|
||||
|
||||
static RTPErrorInfo ErrorDescriptions[]=
|
@ -47,7 +47,7 @@ include/jrtplib3/rtptypes_unix.h
|
||||
include/jrtplib3/rtptypes_win.h
|
||||
include/jrtplib3/rtpudpv4transmitter.h
|
||||
include/jrtplib3/rtpudpv6transmitter.h
|
||||
lib/libjrtp-3.7.0.so
|
||||
lib/libjrtp-%%JRTPLIB_VER%%.so
|
||||
lib/libjrtp.a
|
||||
lib/libjrtp.la
|
||||
lib/libjrtp.so
|
||||
|
Loading…
Reference in New Issue
Block a user