Update to version 990623a.
PR: 12709 Submitted by: John Baldwin <jobaldwi@vt.edu>
This commit is contained in:
parent
dacc2a3ed4
commit
73c2bda784
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=20422
@ -1,16 +1,16 @@
|
||||
# New ports collection makefile for: bochs
|
||||
# Version required: 980513a
|
||||
# Version required: 990219a
|
||||
# Date created: 16 December 1997
|
||||
# Whom: alex
|
||||
#
|
||||
# $Id: Makefile,v 1.13 1998/12/01 08:04:23 asami Exp $
|
||||
# $Id: Makefile,v 1.14 1999/01/01 16:34:07 alex Exp $
|
||||
#
|
||||
|
||||
VGABIOS= VGABIOS-elpin-2.20
|
||||
BIOS= BIOS-bochs-980717a
|
||||
DATE= 981102
|
||||
BIOS= BIOS-bochs-990623a
|
||||
DATE= 990708
|
||||
|
||||
DISTNAME= bochs-${DATE}b
|
||||
DISTNAME= bochs-${DATE}a
|
||||
CATEGORIES= emulators
|
||||
MASTER_SITES= ftp://ftp.bochs.com/pub/
|
||||
|
||||
@ -18,10 +18,8 @@ MAINTAINER= ports@FreeBSD.ORG
|
||||
|
||||
USE_XLIB= yes
|
||||
GNU_CONFIGURE= YES
|
||||
CONFIGURE_ARGS= --enable-80386 --enable-memory=16 \
|
||||
--enable-v8086-mode --enable-paging --enable-vga \
|
||||
--enable-bochs-bios-hooks --enable-dma-floppy-io \
|
||||
--enable-processor-ips=200000
|
||||
CONFIGURE_ARGS= --enable-cpu-level=4 --enable-vga \
|
||||
--with-x11 --prefix=${PREFIX}
|
||||
|
||||
WRKSRC= ${WRKDIR}/bochs-${DATE}
|
||||
|
||||
@ -41,6 +39,7 @@ do-install:
|
||||
-@${MKDIR} ${PREFIX}/share/doc/bochs
|
||||
${INSTALL_MAN} ${WRKSRC}/docs-html/LICENSE ${PREFIX}/share/doc/bochs
|
||||
${INSTALL_MAN} ${WRKSRC}/docs-html/*.html ${PREFIX}/share/doc/bochs
|
||||
${INSTALL_MAN} ${WRKSRC}/docs-html/*.gif ${PREFIX}/share/doc/bochs
|
||||
.endif
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
@ -1 +1 @@
|
||||
MD5 (bochs-981102b.tar.gz) = 437e421df6d9843dd9dd734088955323
|
||||
MD5 (bochs-990708a.tar.gz) = 8dd96cfd9a5aa2870daaf6ba9b312d5a
|
||||
|
@ -1,21 +1,24 @@
|
||||
--- .bochsrc.old Mon Nov 2 13:06:25 1998
|
||||
+++ .bochsrc Mon Nov 2 13:07:47 1998
|
||||
@@ -39,21 +39,21 @@
|
||||
#floppya: 1_44=../1.44.yodlowsk
|
||||
#floppya: 1_2=../1.2
|
||||
#floppyb: 1_44=../1.680
|
||||
--- .bochsrc.orig Thu Jul 8 09:57:11 1999
|
||||
+++ .bochsrc Mon Jul 12 18:42:12 1999
|
||||
@@ -3,7 +3,7 @@
|
||||
megs: 16
|
||||
#megs: 8
|
||||
boot: c
|
||||
-vgaromimage: bios/VGABIOS-elpin-2.20
|
||||
+vgaromimage: /usr/local/lib/bochs/bios/VGABIOS-elpin-2.20
|
||||
#romimage: bios/rombios.bin
|
||||
#romimage: bios/BIOS-bochs-980331a
|
||||
#romimage: bios/BIOS-bochs-980622a
|
||||
#romimage: bios/BIOS-bochs-980702a
|
||||
#romimage: ../cbios961203
|
||||
#romimage: file=../r980820.rom, address=0xe0000
|
||||
-romimage: file=bios/BIOS-bochs-980717a, address=0xf0000
|
||||
+romimage: file=/usr/local/lib/bochs/bios/BIOS-bochs-980717a, address=0xf0000
|
||||
|
||||
#romimage: ../cbios961112
|
||||
# You many now use double quotes around pathnames, in case
|
||||
# your pathname includes spaces.
|
||||
@@ -60,7 +60,7 @@
|
||||
#romimage: file=bios/rombios.bin, address=0xf0000
|
||||
#romimage: file=../cbios961203
|
||||
#romimage: file=../r980820.rom, address=0xe0000
|
||||
-romimage: file=bios/BIOS-bochs-990623a, address=0xf0000
|
||||
+romimage: file=/usr/local/lib/bochs/bios/BIOS-bochs-990623a, address=0xf0000
|
||||
|
||||
#romimage: file=bios/BIOS-bochs-990218a, address=0xf0000
|
||||
#romimage: file=../dttest.bin, address=0xf0000
|
||||
@@ -69,8 +69,8 @@
|
||||
#vgaromimage: ../vgacbios961111
|
||||
#romimage: ../cbios961203
|
||||
|
||||
@ -23,6 +26,6 @@
|
||||
-log: ./bochs.out
|
||||
+log: /dev/null
|
||||
+#log: ./bochs.out
|
||||
keyboard_serial_delay: 200 #microseconds
|
||||
floppy_command_delay: 500 #microseconds
|
||||
keyboard_serial_delay: 200
|
||||
floppy_command_delay: 500
|
||||
#ips: 1500000
|
||||
|
@ -1,6 +1,6 @@
|
||||
bin/bochs
|
||||
lib/bochs/bios/VGABIOS-elpin-2.20
|
||||
lib/bochs/bios/BIOS-bochs-980717a
|
||||
lib/bochs/bios/BIOS-bochs-990623a
|
||||
lib/bochs/bochsrc.sample
|
||||
share/doc/bochs/3rdparty.license.html
|
||||
share/doc/bochs/DOS.html
|
||||
@ -12,18 +12,18 @@ share/doc/bochs/Windows31.html
|
||||
share/doc/bochs/Windows95.html
|
||||
share/doc/bochs/bugreports.html
|
||||
share/doc/bochs/changelog.html
|
||||
share/doc/bochs/company.html
|
||||
share/doc/bochs/construction.html
|
||||
share/doc/bochs/cosimulation.html
|
||||
share/doc/bochs/debugger.html
|
||||
share/doc/bochs/developers.html
|
||||
share/doc/bochs/drawing_board.html
|
||||
share/doc/bochs/faq.html
|
||||
share/doc/bochs/features.html
|
||||
share/doc/bochs/index.html
|
||||
share/doc/bochs/install.html
|
||||
share/doc/bochs/instrumentation.html
|
||||
share/doc/bochs/licensing.html
|
||||
share/doc/bochs/mtools.html
|
||||
share/doc/bochs/undercon.gif
|
||||
share/doc/bochs/whatisbochs.html
|
||||
share/doc/bochs/win32.html
|
||||
@dirrm lib/bochs/bios
|
||||
|
Loading…
Reference in New Issue
Block a user