Add libmesode a minimal XMPP library written in C.

This commit is contained in:
Tilman Keskinoz 2017-02-05 21:30:33 +00:00
parent 47323c9a59
commit 73a87c3752
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=433459
6 changed files with 62 additions and 0 deletions

View File

@ -58,6 +58,7 @@
SUBDIR += libaccounts-glib
SUBDIR += libaccounts-qt5
SUBDIR += libjreen
SUBDIR += libmesode
SUBDIR += libnice
SUBDIR += libnice-gst010
SUBDIR += libnice-gst1

23
net-im/libmesode/Makefile Normal file
View File

@ -0,0 +1,23 @@
# $FreeBSD$
PORTNAME= libmesode
PORTVERSION= 0.9.1
CATEGORIES= net-im
MAINTAINER= arved@FreeBSD.org
COMMENT= Lightweight XMPP library
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/MIT-LICENSE.txt
LIB_DEPENDS= libexpat.so:textproc/expat2
USE_GITHUB= yes
GH_ACCOUNT= boothj5
USES= libtool pkgconfig autoreconf ssl
GNU_CONFIGURE= yes
INSTALL_TARGET=install-strip
CONFIGURE_ARGS+= --with-pkgconfigdir=${PREFIX}/libdata/pkgconfig
USE_LDCONFIG= yes
.include <bsd.port.mk>

View File

@ -0,0 +1,3 @@
TIMESTAMP = 1486247536
SHA256 (boothj5-libmesode-0.9.1_GH0.tar.gz) = e693ea1577f0d9e6e58dd8ada9825c359784a225620cbc2fde7295369d295245
SIZE (boothj5-libmesode-0.9.1_GH0.tar.gz) = 142880

View File

@ -0,0 +1,26 @@
--- configure.ac.orig 2016-09-17 18:34:38.000000000 +0200
+++ configure.ac 2017-02-05 00:01:38.603627000 +0100
@@ -18,19 +18,19 @@
[PLATFORM="nix"])
PKG_CHECK_MODULES([expat], [expat >= 2.0.0],
- [PC_REQUIRES+=(expat)],
+ [PC_REQUIRES="expat ${PC_REQUIRES}"],
[AC_CHECK_HEADER([expat.h],
[
expat_LIBS="-lexpat"
- PC_LIBS+=($expat_LIBS)
+ PC_LIBS+=${expat_LIBS}
],
[AC_MSG_ERROR([expat not found; expat required.])]
)
])
with_parser=expat
PARSER_NAME=expat
-PARSER_CFLAGS=$expat_CFLAGS
-PARSER_LIBS=$expat_LIBS
+PARSER_CFLAGS=${expat_CFLAGS}
+PARSER_LIBS=${expat_LIBS}
AC_ARG_ENABLE([tls],
[AS_HELP_STRING([--disable-tls], [disable TLS support])])

View File

@ -0,0 +1,3 @@
libmesode is a fork of libstrophe, a minimal XMPP library written in C.
WWW: https://github.com/boothj5/libmesode

View File

@ -0,0 +1,6 @@
include/mesode.h
lib/libmesode.so.0.0.0
lib/libmesode.so.0
lib/libmesode.so
lib/libmesode.a
libdata/pkgconfig/libmesode.pc