New port: science/erkale: Quantum chemistry program to solve the electronic structure of atoms

This commit is contained in:
Yuri Victorovich 2018-10-21 17:56:11 +00:00
parent 856681c279
commit 738c292296
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=482718
6 changed files with 156 additions and 0 deletions

View File

@ -68,6 +68,7 @@
SUBDIR += elk
SUBDIR += epte
SUBDIR += erd
SUBDIR += erkale
SUBDIR += fastcap
SUBDIR += fasthenry
SUBDIR += fisicalab

39
science/erkale/Makefile Normal file
View File

@ -0,0 +1,39 @@
# $FreeBSD$
PORTNAME= erkale
DISTVERSION= g20181009
CATEGORIES= science
DIST_SUBDIR= ${PORTNAME}${PKGNAMESUFFIX}
MAINTAINER= yuri@FreeBSD.org
COMMENT= Quantum chemistry program to solve the electronic structure of atoms
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
BUILD_DEPENDS= armadillo>0:math/armadillo
LIB_DEPENDS= libderiv.so:science/libint \
libgsl.so:math/gsl \
libhdf5.so:science/hdf5 \
libint.so:science/libint \
libopenblas.so:math/openblas \
libsz.so:science/szip \
libxc.so:science/libxc
USES= cmake:outsource,noninja fortran localbase:ldflags pkgconfig
USE_GITHUB= yes
GH_ACCOUNT= susilehtola
GH_TAGNAME= f1e1ebc
USE_LDCONFIG= yes
TEST_TARGET= test # some tests fail: https://github.com/susilehtola/erkale/issues/29
CMAKE_ARGS= -DLAPACK_LIBRARIES=-lopenblas -DBLAS_LIBRARIES=-lopenblasp
CMAKE_ON= BUILD_SHARED_LIBS
OPTIONS_DEFINE= OPENMP
OPENMP_CMAKE_BOOL= USE_OPENMP
OPENMP_BROKEN= cmake can't fine OpenMP, see https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=223678
.include <bsd.port.mk>

3
science/erkale/distinfo Normal file
View File

@ -0,0 +1,3 @@
TIMESTAMP = 1540094810
SHA256 (erkale/susilehtola-erkale-g20181009-f1e1ebc_GH0.tar.gz) = 4d4eafae933c61e98326a94fa99de060ab2b7929390adb16e5d7fef874a44857
SIZE (erkale/susilehtola-erkale-g20181009-f1e1ebc_GH0.tar.gz) = 33623728

View File

@ -0,0 +1,12 @@
--- CMakeLists.txt.orig 2018-10-21 07:13:35 UTC
+++ CMakeLists.txt
@@ -20,6 +20,9 @@ set(CMAKE_MODULE_PATH ${CMAKE_CURRENT_SO
set(libint_DIR ${CMAKE_CURRENT_SOURCE_DIR}/config)
set(Armadillo_DIR ${CMAKE_CURRENT_SOURCE_DIR}/config)
+# fix wrapper_xx problem
+add_definitions(-DARMA_DONT_USE_WRAPPER)
+
# System default basis set repository (need not exist)
option(ERKALE_SYSTEM_LIBRARY "System default basis set repository (need not exist)" OFF)
if(ERKALE_SYSTEM_LIBRARY)

10
science/erkale/pkg-descr Normal file
View File

@ -0,0 +1,10 @@
ERKALE is a quantum chemistry program used to solve the electronic structure of
atoms, molecules and molecular clusters. It was originally developed at the
University of Helsinki for the computation of x-ray properties, such as
ground-state electron momentum densities and Compton profiles, and core (x-ray
absorption and x-ray Raman scattering) and valence electron excitation spectra
of atoms and molecules. Subsequently, it has gained unique functionalities for
basis set development as well as self-interaction corrected density-functional
theory calculations.
WWW: https://github.com/susilehtola/erkale

91
science/erkale/pkg-plist Normal file
View File

@ -0,0 +1,91 @@
bin/erkale
bin/erkale_adf_emd
bin/erkale_bastool
bin/erkale_casida
bin/erkale_copt
bin/erkale_copt_plateau
bin/erkale_cube
bin/erkale_emd
bin/erkale_fchkpt
bin/erkale_geom
bin/erkale_loc
bin/erkale_pop
bin/erkale_slaterfit
bin/erkale_xrs
include/erkale/bader.h
include/erkale/badergrid.h
include/erkale/basis.h
include/erkale/basislibrary.h
include/erkale/boys.h
include/erkale/broyden.h
include/erkale/casida/casida.h
include/erkale/casida/casida_grid.h
include/erkale/chebyshev.h
include/erkale/checkpoint.h
include/erkale/completeness/completeness_profile.h
include/erkale/completeness/optimize_completeness.h
include/erkale/density_fitting.h
include/erkale/dftfuncs.h
include/erkale/dftgrid.h
include/erkale/diis.h
include/erkale/elements.h
include/erkale/emd/emd.h
include/erkale/emd/emd_gto.h
include/erkale/emd/emd_similarity.h
include/erkale/emd/emd_sto.h
include/erkale/emd/emdcube.h
include/erkale/emd/gto_fourier.h
include/erkale/emd/spherical_expansion.h
include/erkale/eri_digest.h
include/erkale/erichol.h
include/erkale/erifit.h
include/erkale/eriscreen.h
include/erkale/eritable.h
include/erkale/eriworker.h
include/erkale/external/fchkpt_tools.h
include/erkale/external/storage.h
include/erkale/find_molecules.h
include/erkale/gaunt.h
include/erkale/gdm.h
include/erkale/global.h
include/erkale/guess.h
include/erkale/hirshfeld.h
include/erkale/hirshfeldi.h
include/erkale/integrals.h
include/erkale/lbfgs.h
include/erkale/lebedev.h
include/erkale/linalg.h
include/erkale/lmgrid.h
include/erkale/lobatto.h
include/erkale/localization.h
include/erkale/mathf.h
include/erkale/obara-saika.h
include/erkale/properties.h
include/erkale/pzstability.h
include/erkale/scf.h
include/erkale/settings.h
include/erkale/slaterfit/form_exponents.h
include/erkale/slaterfit/solve_coefficients.h
include/erkale/solidharmonics.h
include/erkale/spherical_harmonics.h
include/erkale/stockholder.h
include/erkale/stringutil.h
include/erkale/tempered.h
include/erkale/timer.h
include/erkale/trrh.h
include/erkale/unitary.h
include/erkale/xrs/bfprod.h
include/erkale/xrs/fourierprod.h
include/erkale/xrs/lmtrans.h
include/erkale/xrs/momentum_series.h
include/erkale/xrs/xrsscf.h
include/erkale/xyzutils.h
include/erkale/zmatrix.h
lib/liberkale.so
lib/liberkale.so.0.1.0
lib/liberkale_cmp.so
lib/liberkale_cmp.so.0.1.0
lib/liberkale_emd.so
lib/liberkale_emd.so.0.1.0
lib/liberkale_xrs.so
lib/liberkale_xrs.so.0.1.0