- Convert USE_AUTOTOOLS=libtool to USES=libtool.

- Fix build on FreeBSD 10 where libiconv isn't used.
- Remove post-install. Not needed with staging.

PR:		ports/186592
Submitted by:	tijl
This commit is contained in:
Johan van Selst 2014-02-09 16:36:35 +00:00
parent 89cd4179ec
commit 738b6555bb
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=343519
3 changed files with 12 additions and 37 deletions

View File

@ -3,7 +3,7 @@
PORTNAME= nvi
PORTVERSION= 1.81.6
PORTREVISION= 5
PORTREVISION= 6
CATEGORIES= editors
MASTER_SITES= http://garage.linux.student.kuleuven.be/~skimo/nvi/devel/ \
http://www.kotnet.org/~skimo/nvi/devel/
@ -19,9 +19,9 @@ WIDECHAR_DESC= Enable wide-character support (UTF-8)
USE_BZIP2= yes
WRKSRC= ${WRKDIR}/${DISTNAME}/build.unix
USE_AUTOTOOLS= libtool
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
USES= iconv pkgconfig
USES= iconv libtool pkgconfig
USE_BDB= 42+
CONFIGURE_ARGS+= --with-db-prefix=${LOCALBASE} \
--program-prefix=n
@ -38,15 +38,10 @@ LDFLAGS+= -L${BDB_LIB_DIR} -L${LOCALBASE}/lib
# configure is 555, so you can't do a "make configure" as non-root.
post-patch:
${REINPLACE_CMD} -e 's,%%LIBTOOL%%,${LIBTOOL},g ; \
s,%%LTMAIN%%,${LTMAIN},g ; \
s,-ldb,-l${BDB_LIB_NAME},g' ${WRKSRC}/../dist/configure
@${REINPLACE_CMD} -e '/libvi_la_LIBADD =/s,$$, ${ICONV_LIB},' \
${WRKSRC}/../dist/Makefile.in
@${REINPLACE_CMD} -e 's,-ldb,-l${BDB_LIB_NAME},g' \
${WRKSRC}/../dist/configure
@${CHMOD} 755 ${WRKSRC}/../dist/configure
post-install:
.for __p in nex nvi nview
# XXX: Hack the Makefile in the distribution so this isn't necessary.
${RM} ${STAGEDIR}${PREFIX}/man/cat1/${__p}.0
.endfor
.include <bsd.port.mk>

View File

@ -1,27 +1,6 @@
--- ../dist/configure.orig 2007-11-18 08:43:54.000000000 -0800
+++ ../dist/configure 2008-06-15 11:35:32.000000000 -0700
@@ -19433,10 +19433,10 @@ fi
# This can be used to rebuild libtool when needed
-LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
+LIBTOOL_DEPS=" %%LTMAIN%%"
# Always use our own libtool.
-LIBTOOL='$(SHELL) $(top_builddir)/libtool'
+LIBTOOL='$(SHELL) %%LIBTOOL%%'
# Prevent multiple expansion
@@ -22335,6 +22335,7 @@
#define USE_ICONV 1
_ACEOF
+LIBS="${LIBS} -liconv"
for ac_func in iswblank
do
@@ -27631,6 +27632,8 @@
@@ -27631,6 +27631,8 @@
cat confdefs.h >>conftest.$ac_ext
cat >>conftest.$ac_ext <<_ACEOF
/* end confdefs.h. */
@ -30,7 +9,7 @@
main(){char buf[20]; exit(sprintf(buf, "XXX") != 3);}
_ACEOF
rm -f conftest$ac_exeext
@@ -28624,7 +28627,7 @@
@@ -28624,7 +28626,7 @@
cat >>conftest.$ac_ext <<_ACEOF
/* end confdefs.h. */
#include <stdio.h>
@ -39,10 +18,10 @@
int
main ()
@@ -28755,5 +28758,6 @@
@@ -28755,5 +28757,6 @@
cat >>conftest.$ac_ext <<_ACEOF
/* end confdefs.h. */
+#include <sys/stddef.h>
+#include <stddef.h>
#include <db.h>
int
main ()

View File

@ -5,6 +5,7 @@ lib/libvi.a
lib/libvi.la
lib/libvi.so
lib/libvi.so.0
lib/libvi.so.0.0.0
man/man1/nex.1.gz
man/man1/nvi.1.gz
man/man1/nview.1.gz