sysutils/burp: Update 1.4.40_3 -> 2.1.32
Bump to the latest stable version. Submitter takes maintainership. PR: 233758 Submitted by: phascolarctos@protonmail.ch (maintainer) Reported by: fabio.prina@gmail.com Sponsored by: Miles AS
This commit is contained in:
parent
4a66b5dc32
commit
736335835a
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=496596
@ -2,48 +2,33 @@
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= burp
|
||||
PORTVERSION= 1.4.40
|
||||
PORTREVISION= 3
|
||||
PORTVERSION?= 2.1.32
|
||||
CATEGORIES= sysutils
|
||||
|
||||
MAINTAINER= ports@FreeBSD.org
|
||||
MAINTAINER= phascolarctos@protonmail.ch
|
||||
COMMENT= Network backup and restore program
|
||||
|
||||
LICENSE= AGPLv3
|
||||
LICENSE_FILE= ${WRKSRC}/LICENSE
|
||||
|
||||
BUILD_DEPENDS= ${LOCALBASE}/include/uthash.h:devel/uthash
|
||||
BUILD_DEPENDS= ${LOCALBASE}/include/uthash.h:devel/uthash \
|
||||
${LOCALBASE}/include/yajl/yajl_common.h:devel/yajl
|
||||
LIB_DEPENDS= librsync.so:net/librsync2
|
||||
|
||||
OPTIONS_DEFINE= IPV6
|
||||
|
||||
USES= autoreconf gmake libtool ncurses pkgconfig ssl
|
||||
USE_GITHUB= yes
|
||||
USE_RC_SUBR= burp
|
||||
|
||||
GH_ACCOUNT= grke
|
||||
|
||||
USE_RC_SUBR= burp
|
||||
GNU_CONFIGURE= yes
|
||||
USES= compiler:c++11-lib gmake localbase ncurses ssl
|
||||
CONFIGURE_ARGS= --sysconfdir=${ETCDIR}
|
||||
|
||||
PORTSCOUT= limit:^1\.4\.
|
||||
INSTALL_TARGET= install-all
|
||||
|
||||
CONFIGURE_ARGS= --sbindir="${PREFIX}/sbin" \
|
||||
--sysconfdir=${ETCDIR} \
|
||||
CONFLICTS_INSTALL?= burp-devel
|
||||
|
||||
OPTIONS_DEFINE= IPV6
|
||||
IPV6_CONFIGURE_ENABLE= ipv6
|
||||
|
||||
CONFIG_FILES= configs/server/burp.conf \
|
||||
configs/client/burp.conf \
|
||||
configs/certs/CA/CA.cnf
|
||||
|
||||
post-patch:
|
||||
.for f in ${CONFIG_FILES}
|
||||
@${REINPLACE_CMD} -e 's,/etc/burp,${PREFIX}/etc/burp,g' ${WRKSRC}/${f}
|
||||
@${REINPLACE_CMD} -e 's,/usr/sbin,${PREFIX}/sbin,g' ${WRKSRC}/${f}
|
||||
.endfor
|
||||
|
||||
post-install:
|
||||
@${STRIP_CMD} ${STAGEDIR}${PREFIX}/sbin/bedup
|
||||
@${STRIP_CMD} ${STAGEDIR}${PREFIX}/sbin/vss_strip
|
||||
@${STRIP_CMD} ${STAGEDIR}${PREFIX}/sbin/burp
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
@ -1,2 +1,3 @@
|
||||
SHA256 (grke-burp-1.4.40_GH0.tar.gz) = 2e6a9a28453a11f3e36d0beefa185e72e7781a8718b55d3101144c9900752d6f
|
||||
SIZE (grke-burp-1.4.40_GH0.tar.gz) = 858049
|
||||
TIMESTAMP = 1543919893
|
||||
SHA256 (grke-burp-2.1.32_GH0.tar.gz) = 1b2299670032eb5f0fc0783b7989b1cc6227d3d0758452a42b50d167b63d8d30
|
||||
SIZE (grke-burp-2.1.32_GH0.tar.gz) = 591737
|
||||
|
@ -1,15 +0,0 @@
|
||||
server.c:546:25: error: ordered comparison between pointer and zero ('struct strlist **' and 'int')
|
||||
if(!ret && cconf->keep>0)
|
||||
~~~~~~~~~~~^~
|
||||
|
||||
--- src/server.c.orig 2018-08-01 13:34:56 UTC
|
||||
+++ src/server.c
|
||||
@@ -543,7 +543,7 @@ static int do_backup_server(const char *basedir, const
|
||||
working, current, currentdata,
|
||||
finishing, cconf, client,
|
||||
p1cntr, cntr);
|
||||
- if(!ret && cconf->keep>0)
|
||||
+ if(!ret && cconf->keep != NULL)
|
||||
ret=remove_old_backups(basedir, cconf, client);
|
||||
}
|
||||
|
@ -1,24 +1,25 @@
|
||||
bin/vss_strip
|
||||
%%ETCDIR%%/CA.cnf
|
||||
%%ETCDIR%%/autoupgrade/server/win32/script
|
||||
%%ETCDIR%%/autoupgrade/server/win64/script
|
||||
%%ETCDIR%%/burp-server.conf
|
||||
%%ETCDIR%%/burp.conf
|
||||
%%ETCDIR%%/clientconfdir/incexc/example
|
||||
%%ETCDIR%%/clientconfdir/testclient
|
||||
%%ETCDIR%%/notify_script
|
||||
%%ETCDIR%%/ssl_extra_checks_script
|
||||
%%ETCDIR%%/summary_script
|
||||
%%ETCDIR%%/timer_script
|
||||
man/man8/bedup.8.gz
|
||||
man/man8/bsigs.8.gz
|
||||
man/man8/bsparse.8.gz
|
||||
man/man8/burp.8.gz
|
||||
man/man8/burp_ca.8.gz
|
||||
man/man8/vss_strip.8.gz
|
||||
sbin/bedup
|
||||
sbin/bsigs
|
||||
sbin/bsparse
|
||||
sbin/burp
|
||||
sbin/burp_ca
|
||||
sbin/vss_strip
|
||||
%%DATADIR%%/scripts/notify_script
|
||||
%%DATADIR%%/scripts/ssl_extra_checks_script
|
||||
%%DATADIR%%/scripts/summary_script
|
||||
%%DATADIR%%/scripts/timer_script
|
||||
@dir %%ETCDIR%%/CA-client
|
||||
@dir %%ETCDIR%%/autoupgrade/client
|
||||
@dir %%ETCDIR%%/autoupgrade/server/win32/1.4.40
|
||||
@dir %%ETCDIR%%/autoupgrade/server/win64/1.4.40
|
||||
@dir %%ETCDIR%%/autoupgrade/server/win32
|
||||
@dir %%ETCDIR%%/autoupgrade/server/win64/2.1.32
|
||||
@dir /var/spool/burp
|
||||
|
Loading…
Reference in New Issue
Block a user