math/suitesparse-spex: replace suitesparse-slip_lu and upgrade to 2.0.0
PR: 267742
This commit is contained in:
parent
90425c7cb9
commit
7330180f42
1
MOVED
1
MOVED
@ -17615,3 +17615,4 @@ devel/py-pytest4-asyncio||2022-11-19|Has expired: legacy version for pytest4 no
|
||||
devel/tokamak||2022-11-20|Has expired: Last release in 2008, abandoned upstream, not used, website disappeared
|
||||
net/libutp|net-p2p/libutp|2022-11-20|Moved to a more adequated category
|
||||
x11-wm/sway-devel|x11-wm/sway|2022-11-26|Out of date: use x11-wm/sway for now
|
||||
math/suitesparse-slip_lu|math/suitesparse-spex|2022-12-26|Renamed by upstream
|
||||
|
@ -1122,7 +1122,7 @@
|
||||
SUBDIR += suitesparse-ldl
|
||||
SUBDIR += suitesparse-mongoose
|
||||
SUBDIR += suitesparse-rbio
|
||||
SUBDIR += suitesparse-slip_lu
|
||||
SUBDIR += suitesparse-spex
|
||||
SUBDIR += suitesparse-spqr
|
||||
SUBDIR += suitesparse-umfpack
|
||||
SUBDIR += sundials
|
||||
|
@ -1,11 +0,0 @@
|
||||
--- SLIP_LU/Makefile.orig 2021-05-17 01:04:52 UTC
|
||||
+++ SLIP_LU/Makefile
|
||||
@@ -25,7 +25,7 @@ C:
|
||||
( cd Demo ; $(MAKE) )
|
||||
|
||||
# compile the dynamic library, and then run the demos and statement coverage
|
||||
-all: C cov
|
||||
+all: C
|
||||
|
||||
# compile the dynamic library only
|
||||
library:
|
@ -1,6 +0,0 @@
|
||||
include/suitesparse/SLIP_LU.h
|
||||
lib/libsliplu.so
|
||||
lib/libsliplu.so.1
|
||||
lib/libsliplu.so.1.0.2
|
||||
%%PORTDOCS%%%%DOCSDIR%%/SLIP_LU_README.md
|
||||
%%PORTDOCS%%%%DOCSDIR%%/SLIP_LU_UserGuide.pdf
|
@ -1,5 +1,5 @@
|
||||
PORTNAME= ${MPORTNAME:tl}
|
||||
PORTVERSION= 1.0.2
|
||||
PORTVERSION= 2.0.0
|
||||
CATEGORIES= math
|
||||
|
||||
COMMENT= Sparse Left-looking Integer-Preserving LU Factorization
|
||||
@ -7,7 +7,7 @@ WWW= https://faculty.cse.tamu.edu/davis/suitesparse.html
|
||||
|
||||
LICENSE= GPLv2+ LGPL3+
|
||||
LICENSE_COMB= dual
|
||||
LICENSE_FILE= ${BUILD_WRKSRC}/License/license.txt
|
||||
LICENSE_FILE= ${BUILD_WRKSRC}/LICENSE.txt
|
||||
|
||||
LIB_DEPENDS= libgmp.so:math/gmp \
|
||||
libmpfr.so:math/mpfr \
|
||||
@ -15,10 +15,17 @@ LIB_DEPENDS= libgmp.so:math/gmp \
|
||||
libcolamd.so:math/suitesparse-colamd
|
||||
|
||||
USES= localbase:ldflags
|
||||
OMP_NEEDED= yes
|
||||
|
||||
MPORTNAME= SLIP_LU
|
||||
MPORTNAME= SPEX
|
||||
USE_LDCONFIG= yes
|
||||
|
||||
.include "${.CURDIR}/../../math/suitesparse/bsd.suitesparse.mk"
|
||||
|
||||
post-stage-DOCS-on:
|
||||
@${MKDIR} ${STAGEDIR}${DOCSDIR}
|
||||
${INSTALL_DATA} ${BUILD_WRKSRC}/README.md \
|
||||
${STAGEDIR}${DOCSDIR}/${MPORTNAME}_README.md
|
||||
${INSTALL_DATA} ${BUILD_WRKSRC}/Doc/${MPORTNAME}_UserGuide.pdf \
|
||||
${STAGEDIR}${DOCSDIR}
|
||||
|
||||
.include <bsd.port.post.mk>
|
@ -1,9 +1,9 @@
|
||||
This port installs the module SLIP_LU of SuiteSparse.
|
||||
This port installs the module SPEX, previously known as SLIP_LU, of SuiteSparse.
|
||||
|
||||
SLIP_LU is software package used to solve a sparse systems of linear equations
|
||||
SPEX is a software package used to solve a sparse systems of linear equations
|
||||
exactly using the Sparse Left-looking Integer-Preserving LU factorization.
|
||||
|
||||
SLIPLU Purpose: Exactly solve a sparse system of linear equations using a given
|
||||
SPEX Purpose: Exactly solve a sparse system of linear equations using a given
|
||||
input matrix and right hand side vector file. This code can output the final
|
||||
solution to a user specified output file in either double precision or full
|
||||
precision rational numbers.
|
8
math/suitesparse-spex/pkg-plist
Normal file
8
math/suitesparse-spex/pkg-plist
Normal file
@ -0,0 +1,8 @@
|
||||
include/suitesparse/SPEX.h
|
||||
lib/cmake/SuiteSparse/FindSPEX.cmake
|
||||
lib/libspex.a
|
||||
lib/libspex.so
|
||||
lib/libspex.so.2
|
||||
lib/libspex.so.2.0.0
|
||||
%%PORTDOCS%%%%DOCSDIR%%/SPEX_README.md
|
||||
%%PORTDOCS%%%%DOCSDIR%%/SPEX_UserGuide.pdf
|
Loading…
Reference in New Issue
Block a user