Update to version 9.11.

PR:		25323
Submitted by:	KATO Tsuguru <tkato@prontomail.ne.jp>
This commit is contained in:
Steve Price 2001-02-26 03:22:33 +00:00
parent 476cb20216
commit 7307f39707
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=38725
14 changed files with 276 additions and 185 deletions

View File

@ -6,7 +6,7 @@
#
PORTNAME= netpbm
PORTVERSION= 9.10
PORTVERSION= 9.11
CATEGORIES= graphics
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@ -30,5 +30,6 @@ INSTALLS_SHLIB= yes
post-patch:
@${PERL} -pi -e "s|%%X11BASE%%|${X11BASE}|g" ${WRKSRC}/pbmplus.h
@${CP} ${FILESDIR}/Makefile.config.FreeBSD ${WRKSRC}/Makefile.config
.include <bsd.port.post.mk>

View File

@ -1 +1 @@
MD5 (netpbm-9.10.tgz) = b39c20ffcc83d5d8474ba4af204caec6
MD5 (netpbm-9.11.tgz) = 12ed6446d08aee8088744f9f9216f8cd

View File

@ -0,0 +1,28 @@
STATICLIB = N
LD = ${CC}
MANCP = ${BSD_INSTALL_MAN}
CFLAGS += $(CDEBUG)
LDFLAGS = -Wl,--rpath,$(INSTALLLIBS)
LDSHLIB = -shared -Wl,-soname,$(SONAME)
CFLAGS_SHLIB = -fpic -DPIC
TIFFLIB_DIR = ${LOCALBASE}/lib
TIFFHDR_DIR = ${LOCALBASE}/include
JPEGLIB_DIR = ${LOCALBASE}/lib
JPEGHDR_DIR = ${LOCALBASE}/include
PNGLIB_DIR = ${LOCALBASE}/lib
PNGHDR_DIR = ${LOCALBASE}/include
URTLIB_DIR = NONE
URTHDR_DIR = NONE
INSTALL_PREFIX = ${PREFIX}
INSTALLBINARIES = $(INSTALL_PREFIX)/bin
INSTALLSCRIPTS = $(INSTALLBINARIES)
INSTALLLIBS = $(INSTALL_PREFIX)/lib
INSTALLMANUALS1 = $(INSTALL_PREFIX)/man/man1
SUFFIXMANUALS1 = 1
INSTALLMANUALS3 = $(INSTALL_PREFIX)/man/man3
SUFFIXMANUALS3 = 3
INSTALLMANUALS5 = $(INSTALL_PREFIX)/man/man5
SUFFIXMANUALS5 = 5
INSTALLHDRS = $(INSTALL_PREFIX)/include
INSTALLDATA = $(INSTALL_PREFIX)/share/netpbm
NETPBMLIBSUFFIX = so

View File

@ -61,7 +61,6 @@ MAN1+= pbmtopgm.1
MAN1+= pbmtopi3.1
MAN1+= pbmtopk.1
MAN1+= pbmtoplot.1
MAN1+= pbmtoppa.1
MAN1+= pbmtoptx.1
MAN1+= pbmtowbmp.1
MAN1+= pbmtox10bm.1

View File

@ -1,12 +1,29 @@
--- Makefile.common.orig Thu Jan 11 07:20:19 2001
+++ Makefile.common Sat Jan 13 00:00:00 2001
@@ -117,24 +117,20 @@
--- Makefile.common.orig Wed Feb 21 13:04:34 2001
+++ Makefile.common Sat Feb 24 00:00:00 2001
@@ -135,14 +135,14 @@
$(LIBOBJECTS): %.o: $(SRCSUBDIR)/%.c
# MERGE STUFF
-$(MERGE_OBJECTS): %.o2: $(SRCSUBDIR)/%.c
+$(MERGE_OBJECTS): %.o2: $(SRCSUBDIR)/%.c $(HEADERLINKS)
# Note that the user may have configured -I options into CFLAGS.
$(CC) -c $(INCLUDE) $(CFLAGS) "-Dmain=$*_main" -o $@ $<
merge.h:
$(SRCDIR)/make_merge.sh $(MERGEBINARIES)
-$(MERGENAME).o: $(SRCSUBDIR)/$(MERGENAME).c merge.h
+$(MERGENAME).o: $(SRCSUBDIR)/$(MERGENAME).c merge.h $(HEADERLINKS)
$(CC) $(CFLAGS) -Wno-implicit $(INCLUDE) -c -o $@ $<
$(MERGENAME): $(MERGENAME).o $(MERGE_OBJECTS) $(NETPBMLIBS) $(LIBOPT)
@@ -155,24 +155,20 @@
$(LIBOBJECTS): %.o: $(SRCSUBDIR)/%.c $(HEADERLINKS)
# Note that the user may have configured -I options into CFLAGS.
+ $(CC) -c $(INCLUDE) $(CFLAGS) -o $@ $<
+
+$(SHLIBOBJECTS): %.lo: %.c
+$(SHLIBOBJECTS): %.lo: $(SRCSUBDIR)/%.c $(HEADERLINKS)
$(CC) -c $(INCLUDE) $(CFLAGS) $(CFLAGS_SHLIB) -o $@ $<
-SONAME = lib$(LIBROOT).so.$(MAJ)
@ -32,7 +49,7 @@
# Static library. Unused by default, but with a small change to make files...
lib$(LIBROOT).a: $(LIBOBJECTS) $(LIBOBJECTS_X)
@@ -164,7 +160,7 @@
@@ -202,7 +198,7 @@
install.merge.common: $(MERGENAME) $(NOMERGEBINARIES) install.script
cd $(INSTALLBINARIES) ; rm -f $(BINARIES) $(MERGE_ALIASES)
ifneq ($(MERGENAME)x,x)
@ -41,7 +58,7 @@
$(MERGENAME) $(INSTALLBINARIES)
cd $(INSTALLBINARIES) ; \
for i in $(MERGEBINARIES) $(MERGE_ALIASES) ; \
@@ -174,7 +170,7 @@
@@ -212,7 +208,7 @@
ifneq ($(NOMERGEBINARIES)x,x)
for x in $(NOMERGEBINARIES); \
do \
@ -50,7 +67,7 @@
$$x $(INSTALLBINARIES); \
done
endif
@@ -185,7 +181,7 @@
@@ -223,7 +219,7 @@
# Make and Install know that pbmmake.exe counts as pbmmake.
for x in $(BINARIES); \
do \
@ -59,7 +76,7 @@
$$x $(INSTALLBINARIES); \
done
@@ -194,7 +190,7 @@
@@ -232,7 +228,7 @@
ifneq ($(SCRIPTS)x,x)
for x in $(SCRIPTS); \
do \
@ -68,7 +85,7 @@
$(INSTALLSCRIPTS); \
done
endif
@@ -231,7 +227,7 @@
@@ -269,7 +265,7 @@
# directory when you compile your programs.
for x in $(INTERFACE_HEADERS); \
do \
@ -77,8 +94,8 @@
$(INSTALLHDRS); \
done
@@ -245,15 +241,14 @@
# here causes the static library to be built at that time.
@@ -277,15 +273,14 @@
#
.PHONY: install.staticlib
install.staticlib: lib$(LIBROOT).a
- $(INSTALL) -c -m $(INSTALL_PERM_LIBS) $< $(INSTALLLIBS)/$<

View File

@ -1,126 +0,0 @@
--- Makefile.config.orig Mon Jan 8 03:52:54 2001
+++ Makefile.config Sat Jan 13 00:00:00 2001
@@ -39,7 +39,7 @@
#Tru64 (= Digital Unix):
#CC = cc
#CC = gcc
-CC = gcc
+CC ?= gcc
# The linker.
LD = $(CC)
@@ -71,7 +71,7 @@
# calls compress or pack. Mantocat, included with Netpbm, is used on
# systems which use man pages in the "cat" format.
-MANCP = $(INSTALL) -m $(INSTALL_PERM_MAN)
+MANCP = ${BSD_INSTALL_MAN}
#DJGPP/Windows:
#MANCP = $(SRCDIR)/mantocat
@@ -85,7 +85,7 @@
# -ansi and -Werror should work too, but are not included
# by default because there's no point in daring the build to fail.
# -pedantic isn't a problem because it causes at worst a warning.
-CFLAGS = -pedantic -O3 -Wall -Wno-uninitialized $(CDEBUG)
+CFLAGS += $(CDEBUG)
# On DEC Tru64 4.0F (at least), you need -DLONG_32 for ppmtompeg.
#Tru64:
#CFLAGS = -O2 -std1 DLONG_32 $(CDEBUG)
@@ -100,7 +100,7 @@
# linker options.
-LDFLAGS =
+#LDFLAGS =
# Eunice users may want to use -noshare so that the executables can
# run standalone:
#LDFLAGS = -noshare
@@ -113,7 +113,7 @@
# For a traditional linker:
#LDFLAGS = -R$(INSTALLLIBS)
#If the linker is gcc (e.g. NetBSD):
-#LDFLAGS = -Wl,--rpath,$(INSTALLLIBS)
+LDFLAGS = -Wl,--rpath,$(INSTALLLIBS)
# Linker options for created Netpbm shared libraries.
@@ -139,7 +139,7 @@
# independent code, so you need -fpic or fPIC here. (The rule is: if
# -fpic works, use it. If it bombs, go to fPIC).
-CFLAGS_SHLIB =
+CFLAGS_SHLIB = -fpic -DPIC
# Solaris, SunOS, and NetBSD:
#CFLAGS_SHLIB = -fpic
#CFLAGS_SHLIB = -fPIC
@@ -155,11 +155,11 @@
# but otherwise will not.
# Use the Tiff library included with Netpbm:
-TIFFHDR_DIR = $(SRCDIR)/libtiff
-TIFFLIB_DIR = $(SRCDIR)/libtiff
+#TIFFHDR_DIR = $(SRCDIR)/libtiff
+#TIFFLIB_DIR = $(SRCDIR)/libtiff
#NetBSD:
-#TIFFHDR_DIR = $(LOCALBASE)/include
-#TIFFLIB_DIR = $(LOCALBASE)/lib
+TIFFHDR_DIR = $(LOCALBASE)/include
+TIFFLIB_DIR = $(LOCALBASE)/lib
# OSF, Tru64:
#TIFFHDR_DIR = /usr/local1/DEC/include
#TIFFLIB_DIR = /usr/local1/DEC/lib
@@ -186,11 +186,11 @@
# at least JPEGLIB_DIR here, or the tiff converters will not build at
# all.
-JPEGLIB_DIR = /usr/lib/jpeg
-JPEGHDR_DIR = /usr/include/jpeg
+#JPEGLIB_DIR = /usr/lib/jpeg
+#JPEGHDR_DIR = /usr/include/jpeg
# Netbsd:
-#JPEGLIB_DIR = ${LOCALBASE}/lib
-#JPEGHDR_DIR = ${LOCALBASE}/include
+JPEGLIB_DIR = ${LOCALBASE}/lib
+JPEGHDR_DIR = ${LOCALBASE}/include
# OSF, Tru64:
#JPEGLIB_DIR = /usr/local1/DEC/lib
#JPEGHDR_DIR = /usr/local1/DEC/include
@@ -208,11 +208,11 @@
# here. If you do not have the PNG library, and still want to
# successully build everything else, put NONE for these.
-PNGLIB_DIR = /lib
-PNGHDR_DIR = /usr/include/png
+#PNGLIB_DIR = /lib
+#PNGHDR_DIR = /usr/include/png
# NetBSD:
-#PNGLIB_DIR = $(LOCALBASE)/lib
-#PNGHDR_DIR = $(LOCALBASE)/include
+PNGLIB_DIR = $(LOCALBASE)/lib
+PNGHDR_DIR = $(LOCALBASE)/include
# OSF/Tru64:
#PNGLIB_DIR = /usr/local1/DEC/lib
#PNGHDR_DIR = /usr/local1/DEC/include
@@ -226,8 +226,10 @@
# And the Utah Raster Toolkit (aka URT aka RLE) library:
-URTHDR_DIR = $(SRCDIR)/urt
-URTLIB_DIR = $(SRCDIR)/urt
+#URTLIB_DIR = $(SRCDIR)/urt
+#URTHDR_DIR = $(SRCDIR)/urt
+URTLIB_DIR = NONE
+URTHDR_DIR = NONE
# These are -l options to link in the network libraries. Often, these are
# built into the standard C library, so this can be null. If you don't
@@ -321,7 +323,7 @@
# Specify the directory where you want data files that the Neptbm programs
# access to be installed
-INSTALLDATA = $(INSTALL_PREFIX)/lib
+INSTALLDATA = $(INSTALL_PREFIX)/share/netpbm
#NETPBMLIBSUFFIX is the suffix on the filename of the generated and installed

View File

@ -1,15 +1,6 @@
--- pbm/Makefile.orig Sat Sep 2 12:59:29 2000
+++ pbm/Makefile Fri Dec 8 00:00:00 2000
@@ -5,7 +5,7 @@
include $(BUILDDIR)/Makefile.config
-INCLUDE = -I$(SRCDIR) -I$(SRCDIR)/shhopt
+INCLUDE = -I$(SRCDIR)
# Shared library naming
LIBROOT = pbm
@@ -16,6 +16,8 @@
--- pbm/Makefile.orig Wed Feb 21 13:05:01 2001
+++ pbm/Makefile Sat Feb 24 00:00:00 2001
@@ -17,10 +17,12 @@
LIBLIBS =
NETPBMLIBS = $(LIBPBM)
@ -18,11 +9,34 @@
PORTBINARIES = atktopbm brushtopbm cmuwmtopbm g3topbm \
icontopbm macptopbm mdatopbm mgrtopbm \
pbmclean pbmlife pbmmake pbmmask pbmpscale \
@@ -38,11 +40,10 @@
- pbmreduce pbmtext \
+ pbmreduce \
pbmto10x pbmto4425 pbmtoascii pbmtoatk \
pbmtobbnbg pbmtocmuwm \
pbmtoepsi pbmtoepson \
@@ -29,21 +31,26 @@
pbmtopi3 pbmtoplot pbmtoptx pbmtowbmp \
pbmtox10bm pbmtoxbm pbmtoybm pbmtozinc \
pbmupc pi3topbm pktopbm wbmptopbm xbmtopbm ybmtopbm
+SHHOPTBINARIES = pbmtext
+
+NOMERGEBINARIES = $(SHHOPTBINARIES)
+
+MERGEBINARIES = $(PORTBINARIES) $(MATHBINARIES)
+
MATHBINARIES = pbmpage pbmtopk
-BINARIES = $(PORTBINARIES) $(MATHBINARIES)
+BINARIES = $(MERGEBINARIES) $(NOMERGEBINARIES)
OBJECTS = $(patsubst %, %.o, $(BINARIES))
-MERGEBINARIES = $(BINARIES)
MERGE_OBJECTS = $(patsubst %,%.o2, $(MERGEBINARIES))
# Library objects to be built and linked by Makefile.common:
LIBOBJECTS = libpbm1.o libpbm2.o libpbm3.o libpbm4.o libpbm5.o
+SHLIBOBJECTS = $(patsubst %.o, %.lo, $(LIBOBJECTS))
+LIBSHHOPT = $(SRCDIR)/shhopt/libshhopt.a
ifneq (${VMS}x,x)
LIBOBJECTS += libpbmvms.o
endif
@ -31,15 +45,49 @@
MANUALS1 = $(BINARIES)
MANUALS3 = libpbm
@@ -80,11 +81,6 @@
# Don't use $(SRCDIR) in the target below because Makefile.dep doesn't !
../compile.h:
$(MAKE) -C $(SRCDIR) compile.h
@@ -55,26 +62,24 @@
.PHONY: all
all: $(BINARIES)
- $(MAKE) -C pbmtoppa all
-
.PHONY: merge
-merge: $(MERGENAME)
- $(MAKE) -C pbmtoppa all
+merge: $(MERGENAME) $(NOMERGEBINARIES)
+
+$(SHHOPTBINARIES): %: %.o $(NETPBMLIBS) $(LIBOPT) $(LIBSHHOPT)
+ $(LD) $(LDFLAGS) -o $@ $@.o `$(LIBOPT) $(NETPBMLIBS)` \
+ $(LIBSHHOPT) $(CDEBUG)
.PHONY: install.bin
install.bin: install.bin.common
- $(MAKE) -C pbmtoppa install.bin
.PHONY: install.merge
install.merge: install.merge.common
- $(MAKE) -C pbmtoppa install.bin
.PHONY: install.lib
install.lib: install.lib.common
.PHONY: install.man
install.man: install.man.common
- $(MAKE) -C pbmtoppa install.man
HEADERLINKS = pbmplus.h version.h compile.h
@@ -88,13 +93,10 @@
compile.h:
$(SRCDIR)/stamp-date
-$(BUILDDIR)/shhopt/shhopt.o:
- cd ../shhopt; $(MAKE) shhopt.o
-$(BUILDDIR)/shhopt/libshhopt.a:
- cd ../shhopt; $(MAKE) libshhopt.a
$(BUILDDIR)/shhopt/libshhopt.a:
cd ../shhopt; $(MAKE) libshhopt.a
.PHONY: clean
clean: clean.common
- $(MAKE) -C pbmtoppa clean
FORCE:

View File

@ -1,6 +1,6 @@
--- pgm/Makefile.orig Sat Sep 2 13:00:08 2000
+++ pgm/Makefile Fri Dec 8 00:00:00 2000
@@ -16,18 +16,27 @@
--- pgm/Makefile.orig Thu Jan 18 12:39:28 2001
+++ pgm/Makefile Sat Feb 24 00:00:00 2001
@@ -15,18 +15,27 @@
NETPBMLIBS = $(LIBPGM) $(PBMDIR)/$(LIBPBM)
LIBLIBS = $(PBMDIR)/$(LIBPBM)
@ -31,7 +31,7 @@
MANUALS1 = $(BINARIES)
MANUALS3 = libpgm
@@ -40,7 +49,11 @@
@@ -39,7 +48,11 @@
.PHONY: all
all: $(BINARIES)
.PHONY: merge
@ -44,12 +44,12 @@
# LIBRARIES
@@ -60,6 +73,9 @@
install.man: install.man.common
@@ -61,6 +74,9 @@
HEADERLINKS = pbmplus.h pbm.h libpbm.h
include $(SRCDIR)/Makefile.common
+
+$(SRCDIR)/shhopt/libshhopt.a:
+$(BUILDDIR)/shhopt/libshhopt.a:
+ cd ../shhopt; $(MAKE) libshhopt.a
.PHONY: clean

View File

@ -1,6 +1,6 @@
--- pnm/Makefile.orig Mon Jan 8 03:54:37 2001
+++ pnm/Makefile Sat Jan 13 00:00:00 2001
@@ -48,6 +48,8 @@
--- pnm/Makefile.orig Tue Jan 23 14:05:35 2001
+++ pnm/Makefile Sat Feb 24 00:00:00 2001
@@ -47,6 +47,8 @@
JPEGLD = -L$(JPEGLIB_DIR) -ljpeg
endif
@ -9,7 +9,7 @@
# We tend to separate out the build targets so that we don't have
# any more dependencies for a given target than it really needs.
# That way, if there is a problem with a dependency, we can still
@@ -55,22 +57,24 @@
@@ -54,22 +56,24 @@
# This package is so big, it's useful even when some parts won't
# build.
@ -44,7 +44,7 @@
ifneq ($(PNGHDR_DIR),NONE)
ifneq ($(PNGLIB_DIR),NONE)
NOMERGEBINARIES += pnmtopng pngtopnm
@@ -107,6 +111,8 @@
@@ -106,6 +110,8 @@
MERGE_OBJECTS = $(patsubst %,%.o2, $(MERGEBINARIES))
LIBOBJECTS = libpnm1.o libpnm2.o libpnm3.o libpnm4.o libpam.o
@ -53,7 +53,7 @@
MANUALS1 = $(BINARIES) $(SCRIPTS)
MANUALS3 = libpnm
@@ -127,6 +133,14 @@
@@ -126,6 +132,14 @@
$(MAKE) -C jbig all
$(MAKE) -C pnmtopalm all
@ -68,7 +68,7 @@
ifeq ($(TIFFLIB_DIR),$(TIFFDIR))
# We're using the internal Tiff library, so make sure it's built
TIFFLIB_DEP = $(TIFFDIR)/$(LIBTIFF)
@@ -137,17 +151,18 @@
@@ -136,17 +150,18 @@
# The Tiff library references math functions.
tifftopnm pnmtotiff pnmtotiffcmyk: %: %.o \
@ -91,12 +91,12 @@
ifeq ($(URTLIB_DIR),$(URTDIR))
# We're using the internal URT library, so make sure it's built
@@ -202,6 +217,9 @@
@@ -203,6 +218,9 @@
$(MAKE) -C fiasco install.man
$(MAKE) -C jbig install.man
$(MAKE) -C pnmtopalm install.man
+
+$(SRCDIR)/shhopt/libshhopt.a:
+$(BUILDDIR)/shhopt/libshhopt.a:
+ cd ../shhopt; $(MAKE) libshhopt.a
.PHONY: clean

View File

@ -1,12 +1,13 @@
--- ppm/Makefile.orig Sun Dec 3 07:41:51 2000
+++ ppm/Makefile Sat Jan 13 00:00:00 2001
--- ppm/Makefile.orig Thu Jan 25 13:38:27 2001
+++ ppm/Makefile Sat Feb 24 00:00:00 2001
@@ -22,26 +22,31 @@
NETPBMLIBS = $(LIBPPM) $(PBMDIR)/$(LIBPBM) $(PGMDIR)/$(LIBPGM)
LIBLIBS = $(PBMDIR)/$(LIBPBM) $(PGMDIR)/$(LIBPGM)
-PORTBINARIES = bmptoppm eyuvtoppm gouldtoppm ilbmtoppm imgtoppm \
+SOVER = 1
+
PORTBINARIES = bmptoppm eyuvtoppm gouldtoppm ilbmtoppm imgtoppm \
+PORTBINARIES = eyuvtoppm gouldtoppm ilbmtoppm imgtoppm \
leaftoppm mtvtoppm pcxtoppm pgmtoppm pi1toppm picttoppm \
pjtoppm \
- ppm3d ppmbrighten ppmchange ppmcolormask \
@ -26,8 +27,8 @@
- sputoppm tgatoppm winicontoppm ximtoppm xpmtoppm xvminitoppm \
+ sputoppm winicontoppm xpmtoppm xvminitoppm \
yuvtoppm yuvsplittoppm
+SHHOPTBINARIES = ppmchange ppmcolormask ppmhist ppmtobmp ppmtogif \
+ tgatoppm ximtoppm
+SHHOPTBINARIES = bmptoppm ppmchange ppmcolormask ppmhist ppmtobmp \
+ ppmtogif tgatoppm ximtoppm
# We don't build vidtoppm by default, because it requires special libraries
# and there is no known requirement for vidtoppm.
@ -83,12 +84,12 @@
# And libraries.
$(PBMDIR)/$(LIBPBM): FORCE
@@ -106,6 +121,9 @@
$(MAKE) -C hpcdtoppm install.man
@@ -108,6 +123,9 @@
HEADERLINKS = pbmplus.h pbm.h libpbm.h pbmfont.h pgm.h libpgm.h
include $(SRCDIR)/Makefile.common
+
+$(SRCDIR)/shhopt/libshhopt.a:
+$(BUILDDIR)/shhopt/libshhopt.a:
+ cd ../shhopt; $(MAKE) libshhopt.a
.PHONY: clean

View File

@ -0,0 +1,42 @@
--- pbm/pbmtext.c.orig Tue Jan 30 06:33:13 2001
+++ pbm/pbmtext.c Sat Feb 24 00:00:00 2001
@@ -14,6 +14,7 @@
#include "pbm.h"
#include "pbmfont.h"
+#include "shhopt.h"
struct cmdline_info {
/* All the information the user supplied in the command line,
@@ -48,12 +49,22 @@
unsigned int option_def_index;
+ /* Create the OptStruct structure describing our options */
+ #define OPTENTRY(shortvalue,longvalue,typevalue,outputvalue,flagvalue) {\
+ option_def[option_def_index].shortName = (shortvalue); \
+ option_def[option_def_index].longName = (longvalue); \
+ option_def[option_def_index].type = (typevalue); \
+ option_def[option_def_index].arg = (outputvalue); \
+ option_def[option_def_index].flags = (flagvalue); \
+ option_def_index++; \
+ }
option_def_index = 0; /* incremented by OPTENTRY */
OPTENTRY(0, "font", OPT_STRING, &cmdline_p->font, 0);
OPTENTRY(0, "builtin", OPT_STRING, &cmdline_p->builtin, 0);
OPTENTRY(0, "dump", OPT_INT, &cmdline_p->dump, 0);
OPTENTRY(0, "space", OPT_FLOAT, &cmdline_p->space, 0);
OPTENTRY(0, "width", OPT_INT, &cmdline_p->width, 0);
+ option_def[option_def_index].type = OPT_END;
/* Set the defaults */
cmdline_p->font = NULL;
@@ -65,7 +76,7 @@
opt.short_allowed = FALSE; /* We have no short (old-fashioned) options */
opt.allowNegNum = FALSE; /* We have no parms that are negative numbers */
- pm_optParseOptions2(&argc, argv, opt, 0);
+ optParseOptions2(&argc, argv, opt, 0);
/* Uses and sets argc, argv, and some of *cmdline_p and others. */
if (argc-1 == 0)

View File

@ -0,0 +1,44 @@
--- pnm/pnmtotiff.c.orig Tue Feb 20 14:50:18 2001
+++ pnm/pnmtotiff.c Sat Feb 24 00:00:00 2001
@@ -34,6 +34,8 @@
#include "ppmcmap.h"
#define MAXCOLORS 256
+#include "shhopt.h"
+
struct cmdline_info {
/* All the information the user supplied in the command line,
in a form easy for the program to use.
@@ -67,6 +69,15 @@
unsigned int option_def_index;
+ /* Create the OptStruct structure describing our options */
+ #define OPTENTRY(shortvalue,longvalue,typevalue,outputvalue,flagvalue) {\
+ option_def[option_def_index].shortName = (shortvalue); \
+ option_def[option_def_index].longName = (longvalue); \
+ option_def[option_def_index].type = (typevalue); \
+ option_def[option_def_index].arg = (outputvalue); \
+ option_def[option_def_index].flags = (flagvalue); \
+ option_def_index++; \
+ }
option_def_index = 0; /* incremented by OPTENTRY */
OPTENTRY(0, "none", OPT_FLAG, &none, 0);
OPTENTRY(0, "packbits", OPT_FLAG, &packbits, 0);
@@ -83,6 +94,7 @@
OPTENTRY(0, "rowsperstrip", OPT_UINT, &cmdline_p->rowsperstrip, 0);
OPTENTRY(0, "xresolution", OPT_FLOAT, &cmdline_p->xresolution, 0);
OPTENTRY(0, "yresolution", OPT_FLOAT, &cmdline_p->yresolution, 0);
+ option_def[option_def_index].type = OPT_END;
/* Set the defaults */
none = packbits = lzw = g3 = g4 = msb2lsb = lsb2msb = opt_2d = FALSE;
@@ -97,7 +109,7 @@
opt.short_allowed = FALSE; /* We have no short (old-fashioned) options */
opt.allowNegNum = FALSE; /* We have no parms that are negative numbers */
- pm_optParseOptions2(&argc, argv, opt, 0);
+ optParseOptions2(&argc, argv, opt, 0);
/* Uses and sets argc, argv, and some of *cmdline_p and others. */
if (none + packbits + lzw + g3 + g4 > 1)

View File

@ -0,0 +1,38 @@
--- ppm/bmptoppm.c.orig Sat Jan 13 14:19:01 2001
+++ ppm/bmptoppm.c Sat Feb 24 00:00:00 2001
@@ -54,6 +54,7 @@
#include "bmp.h"
#include "ppm.h"
#include "bitio.h"
+#include "shhopt.h"
/* MAXCOLORS is the maximum size of a color map in a BMP image */
#define MAXCOLORS 256
@@ -113,8 +114,18 @@
unsigned int option_def_index;
+ /* Create the OptStruct structure describing our options */
+ #define OPTENTRY(shortvalue,longvalue,typevalue,outputvalue,flagvalue) {\
+ option_def[option_def_index].shortName = (shortvalue); \
+ option_def[option_def_index].longName = (longvalue); \
+ option_def[option_def_index].type = (typevalue); \
+ option_def[option_def_index].arg = (outputvalue); \
+ option_def[option_def_index].flags = (flagvalue); \
+ option_def_index++; \
+ }
option_def_index = 0; /* incremented by OPTENTRY */
OPTENTRY(0, "verbose", OPT_FLAG, &cmdline_p->verbose, 0);
+ option_def[option_def_index].type = OPT_END;
/* Set the defaults */
cmdline_p->verbose = FALSE;
@@ -123,7 +134,7 @@
opt.short_allowed = FALSE; /* We have no short (old-fashioned) options */
opt.allowNegNum = FALSE; /* We have no parms that are negative numbers */
- pm_optParseOptions2(&argc, argv, opt, 0);
+ optParseOptions2(&argc, argv, opt, 0);
/* Uses and sets argc, argv, and some of *cmdline_p and others. */
if (argc-1 == 0)

View File

@ -63,7 +63,6 @@ bin/pbmtopgm
bin/pbmtopi3
bin/pbmtopk
bin/pbmtoplot
bin/pbmtoppa
bin/pbmtoptx
bin/pbmtowbmp
bin/pbmtox10bm