- Remove some patches as I added them as REINPLACE_
- Rename the patches to make them less confusing - Add a hack to replace all %%LOCALBASE%% to ${LOCALBASE} PR: 140233 Submitted by: Chris Petrik <chris@officialunix.com> (maintainer)
This commit is contained in:
parent
13c9c6cb03
commit
72ddf7d5d7
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=243741
@ -7,7 +7,7 @@
|
||||
|
||||
PORTNAME= doom
|
||||
PORTVERSION= 1.10
|
||||
PORTREVISION= 4
|
||||
PORTREVISION= 5
|
||||
CATEGORIES= games
|
||||
MASTER_SITES= ${MASTER_SITE_IDSOFTWARE:S|$|source/|}
|
||||
DISTNAME= doomsrc
|
||||
@ -30,6 +30,24 @@ post-extract:
|
||||
@cd ${WRKDIR} && ${TAR} xzf linuxdoom-1.10.src.tgz && ${TAR} xzf sndserv.tgz
|
||||
|
||||
post-patch:
|
||||
${REINPLACE_CMD} 's|<linux/soundcard.h>|<sys/soundcard.h>|g'\
|
||||
${WRKSRC}/sndserv/linux.c \
|
||||
${WRKSRC}/linuxdoom-1.10/i_sound.c
|
||||
${REINPLACE_CMD} 's|<errnos.h>|<errno.h>|g' \
|
||||
${WRKSRC}/linuxdoom-1.10/i_video.c
|
||||
${REINPLACE_CMD} 's|#include <alloca.h>|//#include <alloca.h>|g'\
|
||||
${WRKSRC}/linuxdoom-1.10/r_data.c
|
||||
${REINPLACE_CMD} 's|#include <alloca.h>|//#include <alloca.h>|g'\
|
||||
${WRKSRC}/linuxdoom-1.10/w_wad.c
|
||||
${REINPLACE_CMD} 's|<malloc.c>|<stdlib.h>|g'\
|
||||
${WRKSRC}/linuxdoom-1.10/w_wad.c \
|
||||
${WRKSRC}/sndserv/soundsrv.c \
|
||||
${WRKSRC}/sndserv/wadread.c
|
||||
${REINPLACE_CMD} 's|<values.h>|<limits.h>|g'\
|
||||
${WRKSRC}/linuxdoom-1.10/m_bbox.h \
|
||||
${WRKSRC}/linuxdoom-1.10/doomtype.h
|
||||
${REINPLACE_CMD} 's|%%LOCALBASE%%|${LOCALBASE}|g'\
|
||||
${WRKSRC}/linuxdoom-1.10/Makefile
|
||||
@${FIND} ${WRKSRC} -type f | ${XARGS} ${REINPLACE_CMD} \
|
||||
-E -e 's|#include +<malloc.h>|#include <stdlib.h>|g'
|
||||
|
||||
|
@ -11,8 +11,8 @@
|
||||
-LDFLAGS=-L/usr/X11R6/lib
|
||||
-LIBS=-lXext -lX11 -lnsl -lm
|
||||
+CFLAGS?= -O
|
||||
+CFLAGS+=-g -I${LOCALBASE}/include -Wall -DNORMALUNIX -DSNDSERV -DSNDSRV # -DUSEASM
|
||||
+LDFLAGS=-L${LOCALBASE}/lib
|
||||
+CFLAGS+=-g -I%%LOCALBASE%%/include -Wall -DNORMALUNIX -DSNDSERV -DSNDSRV # -DUSEASM
|
||||
+LDFLAGS=-L%%LOCALBASE%%/lib
|
||||
+LIBS=-lXext -lX11 -lm
|
||||
|
||||
# subdirectory for objects
|
@ -1,11 +0,0 @@
|
||||
--- sndserv/linux.c~ Sun Jan 26 08:45:01 1997
|
||||
+++ sndserv/linux.c Mon Dec 14 21:15:21 1998
|
||||
@@ -40,7 +40,7 @@
|
||||
#include <fcntl.h>
|
||||
#include <unistd.h>
|
||||
|
||||
-#include <linux/soundcard.h>
|
||||
+#include <sys/soundcard.h>
|
||||
|
||||
#include "soundsrv.h"
|
||||
|
@ -1,11 +0,0 @@
|
||||
--- linuxdoom-1.10/i_video.c~ Mon Dec 22 21:39:01 1997
|
||||
+++ linuxdoom-1.10/i_video.c Mon Dec 14 03:24:45 1998
|
||||
@@ -46,7 +46,7 @@
|
||||
#include <sys/socket.h>
|
||||
|
||||
#include <netinet/in.h>
|
||||
-#include <errnos.h>
|
||||
+#include <errno.h>
|
||||
#include <signal.h>
|
||||
|
||||
#include "doomstat.h"
|
@ -1,11 +0,0 @@
|
||||
--- linuxdoom-1.10/r_data.c~ Mon Dec 22 21:57:47 1997
|
||||
+++ linuxdoom-1.10/r_data.c Mon Dec 14 03:27:49 1998
|
||||
@@ -42,7 +42,7 @@
|
||||
#include "r_sky.h"
|
||||
|
||||
#ifdef LINUX
|
||||
-#include <alloca.h>
|
||||
+//#include <alloca.h>
|
||||
#endif
|
||||
|
||||
|
@ -1,14 +0,0 @@
|
||||
--- linuxdoom-1.10/w_wad.c~ Mon Dec 22 22:05:36 1997
|
||||
+++ linuxdoom-1.10/w_wad.c Mon Dec 14 03:29:18 1998
|
||||
@@ -32,9 +32,9 @@
|
||||
#include <string.h>
|
||||
#include <unistd.h>
|
||||
-#include <malloc.h>
|
||||
+#include <stdlib.h>
|
||||
#include <fcntl.h>
|
||||
#include <sys/stat.h>
|
||||
-#include <alloca.h>
|
||||
+//#include <alloca.h>
|
||||
#define O_BINARY 0
|
||||
#endif
|
||||
|
@ -1,22 +0,0 @@
|
||||
--- linuxdoom-1.10/m_bbox.h~ Mon Dec 22 21:12:16 1997
|
||||
+++ linuxdoom-1.10/m_bbox.h Mon Dec 14 03:31:32 1998
|
||||
@@ -23,7 +23,7 @@
|
||||
#ifndef __M_BBOX__
|
||||
#define __M_BBOX__
|
||||
|
||||
-#include <values.h>
|
||||
+#include <limits.h>
|
||||
|
||||
#include "m_fixed.h"
|
||||
|
||||
--- linuxdoom-1.10/doomtype.h~ Mon Dec 22 21:05:27 1997
|
||||
+++ linuxdoom-1.10/doomtype.h Mon Dec 14 03:31:14 1998
|
||||
@@ -39,7 +39,7 @@
|
||||
|
||||
// Predefined with some OS.
|
||||
#ifdef LINUX
|
||||
-#include <values.h>
|
||||
+#include <limits.h>
|
||||
#else
|
||||
#define MAXCHAR ((char)0x7f)
|
||||
#define MAXSHORT ((short)0x7fff)
|
Loading…
Reference in New Issue
Block a user