- Fix build with CLANG.

PR:		ports/160327
Reported by:	"Hartmann, O." <ohartman@zedat.fu-berlin.de>
Submitted by:	h h <aakuusta@gmail.com>
Obtained from:	sbcl bugtracker: https://bugs.launchpad.net/sbcl/+
This commit is contained in:
Stanislav Sedov 2011-09-22 02:33:08 +00:00
parent b4099e68ca
commit 72aedf500f
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=282152
2 changed files with 21 additions and 0 deletions

View File

@ -0,0 +1,8 @@
--- contrib/asdf-module.mk.orig 2011-09-21 17:44:49.000000000 -0700
+++ contrib/asdf-module.mk 2011-09-21 17:45:24.000000000 -0700
@@ -1,4 +1,4 @@
-CC=cc
+CC?=cc
# We need to extend flags to the C compiler and the linker
# here. sb-posix, sb-grovel, and sb-bsd-sockets depends upon these

View File

@ -0,0 +1,13 @@
--- src/runtime/gencgc-internal.h.orig 2011-09-21 17:45:32.000000000 -0700
+++ src/runtime/gencgc-internal.h 2011-09-21 17:46:00.000000000 -0700
@@ -25,8 +25,8 @@
#include "genesis/code.h"
void gc_free_heap(void);
-inline page_index_t find_page_index(void *);
-inline void *page_address(page_index_t);
+extern page_index_t find_page_index(void *);
+extern void *page_address(page_index_t);
int gencgc_handle_wp_violation(void *);