- Update to version 1.30.

- This version fixes a startup crash [1].
- Add a patch to fix crash when resuming from a paused game.

PR:		ports/116140 [1]
Submitted by:	Edwin Groothuis <edwin@mavetju.org>
This commit is contained in:
Alejandro Pulver 2007-10-01 00:45:35 +00:00
parent a0d4f109be
commit 72658dc246
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=200490
11 changed files with 96 additions and 210 deletions

View File

@ -6,8 +6,7 @@
#
PORTNAME= orbital_eunuchs_sniper
PORTVERSION= 1.29
PORTREVISION= 4
PORTVERSION= 1.30
CATEGORIES= games
MASTER_SITES= http://filesingularity.timedoctor.org/
@ -15,12 +14,11 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= An overhead shooting game
USE_SDL= sdl image mixer
USE_X_PREFIX= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="`${SDL_CONFIG} --cflags`" \
LDFLAGS="`${SDL_CONFIG} --libs`"
CONFIGURE_ARGS= --with-games-dir=${PREFIX}/share
CONFIGURE_ARGS= --with-games-dir=${PREFIX}/share \
--program-transform-name=
PORTDOCS= AUTHORS ChangeLog README TODO readme.txt

View File

@ -1,3 +1,3 @@
MD5 (orbital_eunuchs_sniper-1.29.tar.gz) = 78701333a1fe43b7198d55586b77c46d
SHA256 (orbital_eunuchs_sniper-1.29.tar.gz) = 45d4aef3d911780e5cfa69717d7ef751273ee81beb265551e9b7eae15ac8799b
SIZE (orbital_eunuchs_sniper-1.29.tar.gz) = 4043177
MD5 (orbital_eunuchs_sniper-1.30.tar.gz) = 8b71cdfd835eeab1d974ca0e32f3e9d6
SHA256 (orbital_eunuchs_sniper-1.30.tar.gz) = 4c9c909183d27309cb967f64fef13f8c69f1c9a9d559bffb87045d21059ee70a
SIZE (orbital_eunuchs_sniper-1.30.tar.gz) = 4056847

View File

@ -1,10 +1,10 @@
--- configure.orig Wed Jan 21 11:43:15 2004
+++ configure Wed Jan 21 11:43:47 2004
@@ -6150,17 +6150,6 @@
--- ./configure.orig Thu Oct 19 00:38:43 2006
+++ ./configure Sat Sep 29 19:05:01 2007
@@ -6778,17 +6778,6 @@
-echo $ac_n "ordering crap from http://www.amazon.com/exec/obidos/wishlist/296ST2NHEBO0Z $ac_c" 1>&6
-echo $ac_n "ordering crap from http://www.amazon.com/gp/registry/296ST2NHEBO0Z" 1>&6
-sleep 1
-echo $ac_n ".$ac_c" 1>&6
-sleep 1

View File

@ -1,85 +1,23 @@
--- src/Makefile.in.orig Wed Jan 21 12:10:25 2004
+++ src/Makefile.in Wed Jan 21 12:25:03 2004
@@ -52,7 +52,7 @@
install_sh_SCRIPT = $(install_sh) -c
INSTALL_SCRIPT = @INSTALL_SCRIPT@
INSTALL_HEADER = $(INSTALL_DATA)
-transform = @program_transform_name@
+transform =
NORMAL_INSTALL = :
PRE_INSTALL = :
POST_INSTALL = :
@@ -87,7 +87,7 @@
am__include = @am__include@
am__quote = @am__quote@
install_sh = @install_sh@
-pkgdata_PROGRAMS = snipe2d.@CPU_IS@.dynamic snipe2d.@CPU_IS@.static
+pkgdata_PROGRAMS = snipe2d-bin
BUILT_SOURCES = snipe2d
bin_SCRIPTS = snipe2d
snipe2d_common = \
@@ -118,7 +118,7 @@
sexpr/parser.c
-snipe2d_@CPU_IS@_dynamic_SOURCES = $(snipe2d_common)
+snipe2d_bin_SOURCES = $(snipe2d_common)
#snipe2d_@CPU_IS@_static_LDFLAGS = -static
snipe2d_@CPU_IS@_static_SOURCES = $(snipe2d_common)
@@ -126,8 +126,8 @@
mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
CONFIG_HEADER = $(top_builddir)/config.h
CONFIG_CLEAN_FILES = snipe2d
--- ./src/Makefile.in.orig Thu Oct 19 00:38:42 2006
+++ ./src/Makefile.in Sun Sep 30 21:02:31 2007
@@ -38,8 +38,7 @@
build_triplet = @build@
host_triplet = @host@
target_triplet = @target@
-pkgdata_PROGRAMS = snipe2d.@CPU_IS@.dynamic$(EXEEXT) \
- snipe2d.@CPU_IS@.static$(EXEEXT)
+pkgdata_PROGRAMS = snipe2d-bin$(EXEEXT)
+
PROGRAMS = $(pkgdata_PROGRAMS)
subdir = src
DIST_COMMON = $(srcdir)/Makefile.am $(srcdir)/Makefile.in \
$(srcdir)/snipe2d.in
@@ -275,8 +274,8 @@
am__objects_1 = ai.$(OBJEXT) binds.$(OBJEXT) gameover.$(OBJEXT) \
@@ -136,12 +136,12 @@
snipe2d.$(OBJEXT) target.$(OBJEXT) ui.$(OBJEXT) zooms.$(OBJEXT) \
sexp.$(OBJEXT) sexp_ops.$(OBJEXT) faststack.$(OBJEXT) \
io.$(OBJEXT) parser.$(OBJEXT)
-am_snipe2d_@CPU_IS@_dynamic_OBJECTS = $(am__objects_1)
-snipe2d_@CPU_IS@_dynamic_OBJECTS = \
- $(am_snipe2d_@CPU_IS@_dynamic_OBJECTS)
-snipe2d_@CPU_IS@_dynamic_LDADD = $(LDADD)
-snipe2d_@CPU_IS@_dynamic_DEPENDENCIES =
-snipe2d_@CPU_IS@_dynamic_LDFLAGS =
+am_snipe2d_bin_OBJECTS = $(am__objects_1)
+snipe2d_bin_OBJECTS = \
+ $(am_snipe2d_bin_OBJECTS)
+snipe2d_bin_LDADD = $(LDADD)
+snipe2d_bin_DEPENDENCIES =
+snipe2d_bin_LDFLAGS =
am_snipe2d_@CPU_IS@_static_OBJECTS = $(am__objects_1)
snipe2d_@CPU_IS@_static_OBJECTS = $(am_snipe2d_@CPU_IS@_static_OBJECTS)
snipe2d_@CPU_IS@_static_LDADD = $(LDADD)
@@ -177,10 +177,10 @@
CXXLINK = $(CXXLD) $(AM_CXXFLAGS) $(CXXFLAGS) $(AM_LDFLAGS) $(LDFLAGS) \
-o $@
CXXFLAGS = @CXXFLAGS@
-DIST_SOURCES = $(snipe2d_@CPU_IS@_dynamic_SOURCES) \
+DIST_SOURCES = $(snipe2d_bin_SOURCES) \
$(snipe2d_@CPU_IS@_static_SOURCES)
DIST_COMMON = Makefile.am Makefile.in snipe2d.in
-SOURCES = $(snipe2d_@CPU_IS@_dynamic_SOURCES) $(snipe2d_@CPU_IS@_static_SOURCES)
+SOURCES = $(snipe2d_bin_SOURCES) $(snipe2d_@CPU_IS@_static_SOURCES)
all: $(BUILT_SOURCES)
$(MAKE) $(AM_MAKEFLAGS) all-am
@@ -223,9 +223,9 @@
faststack.$(OBJEXT): sexpr/faststack.c
io.$(OBJEXT): sexpr/io.c
parser.$(OBJEXT): sexpr/parser.c
clean-pkgdataPROGRAMS:
-test -z "$(pkgdata_PROGRAMS)" || rm -f $(pkgdata_PROGRAMS)
-snipe2d.@CPU_IS@.dynamic$(EXEEXT): $(snipe2d_@CPU_IS@_dynamic_OBJECTS) $(snipe2d_@CPU_IS@_dynamic_DEPENDENCIES)
- @rm -f snipe2d.@CPU_IS@.dynamic$(EXEEXT)
- $(CXXLINK) $(snipe2d_@CPU_IS@_dynamic_LDFLAGS) $(snipe2d_@CPU_IS@_dynamic_OBJECTS) $(snipe2d_@CPU_IS@_dynamic_LDADD) $(LIBS)
+snipe2d-bin$(EXEEXT): $(snipe2d_bin_OBJECTS) $(snipe2d_bin_DEPENDENCIES)
+snipe2d-bin$(EXEEXT): $(snipe2d_@CPU_IS@_dynamic_OBJECTS) $(snipe2d_@CPU_IS@_dynamic_DEPENDENCIES)
+ @rm -f snipe2d-bin$(EXEEXT)
+ $(CXXLINK) $(snipe2d_bin_LDFLAGS) $(snipe2d_bin_OBJECTS) $(snipe2d_bin_LDADD) $(LIBS)
binSCRIPT_INSTALL = $(INSTALL_SCRIPT)
$(CXXLINK) $(snipe2d_@CPU_IS@_dynamic_LDFLAGS) $(snipe2d_@CPU_IS@_dynamic_OBJECTS) $(snipe2d_@CPU_IS@_dynamic_LDADD) $(LIBS)
install-binSCRIPTS: $(bin_SCRIPTS)
@$(NORMAL_INSTALL)

View File

@ -1,13 +0,0 @@
--- src/binds.cpp.orig Wed Jan 21 11:44:39 2004
+++ src/binds.cpp Wed Jan 21 11:44:49 2004
@@ -6,8 +6,8 @@
#include <stdio.h>
#include <stdlib.h>
#include <string.h>
-#include <SDL/SDL_keyboard.h>
-#include <SDL/SDL_keysym.h>
+#include <SDL_keyboard.h>
+#include <SDL_keysym.h>
#include "sexpr/sexp.h"
#include "binds.h"

View File

@ -0,0 +1,20 @@
--- src/snipe2d.cpp.orig Thu Oct 19 00:35:42 2006
+++ src/snipe2d.cpp Sun Sep 30 21:41:40 2007
@@ -800,7 +800,7 @@
{
if (Game.GameState != OESGAME_PLAY) return 0;
sniperbgm_release(Game.BGM);
- oes_audio_close();
+ //oes_audio_close();
SDL_WM_GrabInput(SDL_GRAB_OFF);
SDL_ShowCursor(1);
Game.GameState = OESGAME_PAUSED;
@@ -817,7 +817,7 @@
SDL_ShowCursor(0);
SDL_WM_GrabInput(SDL_GRAB_ON);
}
- oes_audio_open();
+ //oes_audio_open();
sniperbgm_grab(Game.BGM);
Game.GameState = OESGAME_UNPAUSED;
return 0;

View File

@ -1,21 +0,0 @@
--- src/snipe2d.h.orig Wed Jan 21 11:41:53 2004
+++ src/snipe2d.h Wed Jan 21 11:42:04 2004
@@ -36,14 +36,14 @@
//
//#include <windows.h>
#include <iostream>
-#include <linux/limits.h>
+#include <limits.h>
#include <stdlib.h>
#include <math.h>
#include <string.h>
#include <libgen.h>
-#include <SDL/SDL.h>
-#include <SDL/SDL_image.h>
-#include <SDL/SDL_mixer.h>
+#include <SDL.h>
+#include <SDL_image.h>
+#include <SDL_mixer.h>
#include <sys/types.h>
#include <sys/stat.h>
#include <fcntl.h>

View File

@ -1,9 +1,8 @@
--- src/snipe2d.in.orig Wed Jan 21 11:56:07 2004
+++ src/snipe2d.in Wed Jan 21 12:19:02 2004
@@ -1,4 +1,4 @@
--- src/snipe2d.in.orig Sat Sep 23 15:07:31 2006
+++ src/snipe2d.in Sun Sep 30 20:53:38 2007
@@ -1,3 +1,3 @@
-#! /bin/bash
+#! /bin/sh
prefix=@prefix@
cd @datadir@/@PACKAGE@
-./snipe2d.x86.dynamic $*
+./snipe2d-bin $*
-@datadir@/@PACKAGE_NAME@/snipe2d.@CPU_IS@.dynamic $*
+@datadir@/@PACKAGE_NAME@/snipe2d-bin $*

View File

@ -1,11 +0,0 @@
--- src/ui.cpp.orig Wed Jan 21 11:45:37 2004
+++ src/ui.cpp Wed Jan 21 11:45:43 2004
@@ -2,7 +2,7 @@
ui system
*/
-#include <SDL/SDL.h>
+#include <SDL.h>
#include <stdarg.h>
#include <stdio.h>
#include <stdlib.h>

View File

@ -1,24 +0,0 @@
--- src/target.cpp.orig 2007-08-03 14:40:26.000000000 +0200
+++ src/target.cpp 2007-08-03 14:41:39.000000000 +0200
@@ -186,9 +186,9 @@
print(238, row, COLOR_YELLOW, "%20s", "VPB file ID");
row += 7;
print(238, row, COLOR_YELLOW, " %03X-%07X/%02X",
- ((((unsigned int)Game.SightedCharacter) * 7001337) & 0xfff),
- (((unsigned int)Game.SightedCharacter) * 1337357) & 0xfffffff,
- (((unsigned int)Game.SightedCharacter) * 70741) & 0xff);
+ ((((unsigned intptr_t)Game.SightedCharacter) * 7001337) & 0xfff),
+ (((unsigned intptr_t)Game.SightedCharacter) * 1337357) & 0xfffffff,
+ (((unsigned intptr_t)Game.SightedCharacter) * 70741) & 0xff);
break;
@@ -217,7 +217,7 @@
row += 7;
print(238, row, COLOR_YELLOW, "%20s", "Net worth");
row += 7;
- print(238, row, COLOR_YELLOW, "%17u KC", (((unsigned int)Game.SightedCharacter) * 1337357) % 71937);
+ print(238, row, COLOR_YELLOW, "%17u KC", (((unsigned intptr_t)Game.SightedCharacter) * 1337357) % 71937);
break;
case 3:
print(238, row, COLOR_YELLOW, "%20s", "Splat.");

View File

@ -1,48 +1,48 @@
bin/snipe2d
share/orbital_eunuchs_sniper/aimap.png
share/orbital_eunuchs_sniper/audiooff.png
share/orbital_eunuchs_sniper/audiooffh.png
share/orbital_eunuchs_sniper/audioon.png
share/orbital_eunuchs_sniper/audioonh.png
share/orbital_eunuchs_sniper/binds.cfg
share/orbital_eunuchs_sniper/camera_in.wav
share/orbital_eunuchs_sniper/camera_out.wav
share/orbital_eunuchs_sniper/charseq.png
share/orbital_eunuchs_sniper/citee2.png
share/orbital_eunuchs_sniper/easy.png
share/orbital_eunuchs_sniper/easyh.png
share/orbital_eunuchs_sniper/fish1.png
share/orbital_eunuchs_sniper/fish2.png
share/orbital_eunuchs_sniper/font4x6.png
share/orbital_eunuchs_sniper/fullscreen.png
share/orbital_eunuchs_sniper/fullscreenh.png
share/orbital_eunuchs_sniper/hard.png
share/orbital_eunuchs_sniper/hardh.png
share/orbital_eunuchs_sniper/highscores.png
share/orbital_eunuchs_sniper/highscoresh.png
share/orbital_eunuchs_sniper/hisfatj1.png
share/orbital_eunuchs_sniper/hisfatj2.png
share/orbital_eunuchs_sniper/icculus_logoscreen1.png
share/orbital_eunuchs_sniper/icculus_logoscreen2.png
share/orbital_eunuchs_sniper/keys.cfg
share/orbital_eunuchs_sniper/logoscreen.png
share/orbital_eunuchs_sniper/medium.png
share/orbital_eunuchs_sniper/mediumh.png
share/orbital_eunuchs_sniper/menus.cfg
share/orbital_eunuchs_sniper/newgame.png
share/orbital_eunuchs_sniper/newgameh.png
share/orbital_eunuchs_sniper/oes.ogg
share/orbital_eunuchs_sniper/oes_link1.png
share/orbital_eunuchs_sniper/oes_link2.png
share/orbital_eunuchs_sniper/prefs.png
share/orbital_eunuchs_sniper/prefsh.png
share/orbital_eunuchs_sniper/quit.png
share/orbital_eunuchs_sniper/quith.png
share/orbital_eunuchs_sniper/recharge.ogg
share/orbital_eunuchs_sniper/resumegame.png
share/orbital_eunuchs_sniper/resumegameh.png
share/orbital_eunuchs_sniper/snipe2d-bin
share/orbital_eunuchs_sniper/twang.wav
share/orbital_eunuchs_sniper/window.png
share/orbital_eunuchs_sniper/windowh.png
@dirrm share/orbital_eunuchs_sniper
%%DATADIR%%/aimap.png
%%DATADIR%%/audiooff.png
%%DATADIR%%/audiooffh.png
%%DATADIR%%/audioon.png
%%DATADIR%%/audioonh.png
%%DATADIR%%/binds.cfg
%%DATADIR%%/camera_in.wav
%%DATADIR%%/camera_out.wav
%%DATADIR%%/charseq.png
%%DATADIR%%/citee2.png
%%DATADIR%%/easy.png
%%DATADIR%%/easyh.png
%%DATADIR%%/fish1.png
%%DATADIR%%/fish2.png
%%DATADIR%%/font4x6.png
%%DATADIR%%/fullscreen.png
%%DATADIR%%/fullscreenh.png
%%DATADIR%%/hard.png
%%DATADIR%%/hardh.png
%%DATADIR%%/highscores.png
%%DATADIR%%/highscoresh.png
%%DATADIR%%/hisfatj1.png
%%DATADIR%%/hisfatj2.png
%%DATADIR%%/icculus_logoscreen1.png
%%DATADIR%%/icculus_logoscreen2.png
%%DATADIR%%/keys.cfg
%%DATADIR%%/logoscreen.png
%%DATADIR%%/medium.png
%%DATADIR%%/mediumh.png
%%DATADIR%%/menus.cfg
%%DATADIR%%/newgame.png
%%DATADIR%%/newgameh.png
%%DATADIR%%/oes.ogg
%%DATADIR%%/oes_link1.png
%%DATADIR%%/oes_link2.png
%%DATADIR%%/prefs.png
%%DATADIR%%/prefsh.png
%%DATADIR%%/quit.png
%%DATADIR%%/quith.png
%%DATADIR%%/recharge.ogg
%%DATADIR%%/resumegame.png
%%DATADIR%%/resumegameh.png
%%DATADIR%%/snipe2d-bin
%%DATADIR%%/twang.wav
%%DATADIR%%/window.png
%%DATADIR%%/windowh.png
@dirrm %%DATADIR%%