Add libsigc++12 after repo copy from libsigc++. Libsigc++2 is the typesafe
callback library for C++. PR: 36945 Submitted by: garrett rooney <rooneg@electricjellyfish.net> Martin Klaffenboeck <martin.klaffenboeck@gmx.at>
This commit is contained in:
parent
1bb2f017ac
commit
71eb095fd4
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=67852
@ -1,46 +1,23 @@
|
||||
# New ports collection makefile for: libsigc++
|
||||
# Date created: 27 January 2000
|
||||
# Whom: Joe Lu <JoeLu@JoeLu.m8.ntu.edu.tw>
|
||||
# Date created: 30 September 2002
|
||||
# Whom: Martin Klaffenboeck <martin.klaffenboeck@gmx.at>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= libsigc++
|
||||
PORTVERSION= 1.0.4
|
||||
PORTVERSION= 1.1.13
|
||||
CATEGORIES= devel gnome
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
|
||||
${MASTER_SITE_GNOME}
|
||||
MASTER_SITE_SUBDIR= libsigc \
|
||||
sources/libsigc++/1.0
|
||||
|
||||
#DIST_SUBDIR= gnome
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
|
||||
MASTER_SITE_SUBDIR= libsigc
|
||||
|
||||
MAINTAINER= gnome@FreeBSD.org
|
||||
|
||||
USE_LIBTOOL= yes
|
||||
USE_GMAKE= yes
|
||||
NO_LATEST_LINK= yes
|
||||
INSTALLS_SHLIB= yes
|
||||
USE_REINPLACE= yes
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g' \
|
||||
${WRKSRC}/configure
|
||||
|
||||
post-install:
|
||||
.if !defined(NOPORTDOCS)
|
||||
@${MKDIR} ${PREFIX}/share/doc/libsigc++
|
||||
${INSTALL_DATA} ${WRKSRC}/README ${PREFIX}/share/doc/libsigc++
|
||||
${INSTALL_DATA} ${WRKSRC}/FEATURES ${PREFIX}/share/doc/libsigc++
|
||||
${INSTALL_DATA} ${WRKSRC}/doc/API ${PREFIX}/share/doc/libsigc++
|
||||
${INSTALL_DATA} ${WRKSRC}/doc/FAQ ${PREFIX}/share/doc/libsigc++
|
||||
${INSTALL_DATA} ${WRKSRC}/doc/UML ${PREFIX}/share/doc/libsigc++
|
||||
${INSTALL_DATA} ${WRKSRC}/doc/conventions ${PREFIX}/share/doc/libsigc++
|
||||
${INSTALL_DATA} ${WRKSRC}/doc/diagrams ${PREFIX}/share/doc/libsigc++
|
||||
${INSTALL_DATA} ${WRKSRC}/doc/marshal ${PREFIX}/share/doc/libsigc++
|
||||
${INSTALL_DATA} ${WRKSRC}/doc/powerusers ${PREFIX}/share/doc/libsigc++
|
||||
${INSTALL_DATA} ${WRKSRC}/doc/requirements ${PREFIX}/share/doc/libsigc++
|
||||
${INSTALL_DATA} ${WRKSRC}/doc/riscos ${PREFIX}/share/doc/libsigc++/
|
||||
${INSTALL_DATA} ${WRKSRC}/doc/signals ${PREFIX}/share/doc/libsigc++
|
||||
${INSTALL_DATA} ${WRKSRC}/doc/win32 ${PREFIX}/share/doc/libsigc++
|
||||
.endif
|
||||
USE_GNOMENG= yes
|
||||
USE_GNOME= gnomehack
|
||||
USE_LIBTOOL= yes
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
@ -1 +1 @@
|
||||
MD5 (libsigc++-1.0.4.tar.gz) = 88d34840acc1cc5d47b347726e4a09e0
|
||||
MD5 (libsigc++-1.1.13.tar.gz) = e9cb92067e109884b156caab390c3620
|
||||
|
@ -1,11 +0,0 @@
|
||||
--- Makefile.in Thu Jan 20 03:40:54 2000
|
||||
+++ Makefile.in Thu Jan 27 23:34:05 1994
|
||||
@@ -80,7 +80,7 @@
|
||||
USE_SYMBOL_UNDERSCORE = @USE_SYMBOL_UNDERSCORE@
|
||||
VERSION = @VERSION@
|
||||
|
||||
-SUBDIRS = sigc++ tests
|
||||
+SUBDIRS = sigc++
|
||||
DIST_SUBDIRS = sigc++ examples tests scripts
|
||||
|
||||
bin_SCRIPTS = sigc-config
|
@ -1,21 +0,0 @@
|
||||
--- sigc++/Makefile.in.orig Tue Oct 23 07:40:58 2001
|
||||
+++ sigc++/Makefile.in Tue Aug 6 16:13:28 2002
|
||||
@@ -66,7 +66,7 @@
|
||||
DLLTOOL = @DLLTOOL@
|
||||
DLL_DEFINE = @DLL_DEFINE@
|
||||
EXEEXT = @EXEEXT@
|
||||
-LIBSIGC_SO_VERSION = @LIBSIGC_SO_VERSION@
|
||||
+LIBSIGC_SO_VERSION = 1:0:1
|
||||
LIBTOOL = @LIBTOOL@
|
||||
LN_S = @LN_S@
|
||||
M4 = @M4@
|
||||
@@ -94,8 +94,7 @@
|
||||
|
||||
EXTRA_libsigc_la_SOURCES = sigc_res.rc
|
||||
|
||||
-libsigc_la_LDFLAGS = -version-info $(LIBSIGC_SO_VERSION) -release $(SIGC_RELEASE) -no-undefined
|
||||
-
|
||||
+libsigc_la_LDFLAGS = -version-info $(LIBSIGC_SO_VERSION) -no-undefined
|
||||
|
||||
lib_LTLIBRARIES = libsigc.la
|
||||
|
@ -1,11 +0,0 @@
|
||||
--- sigc++/config/Makefile.in.orig Tue Aug 6 16:14:37 2002
|
||||
+++ sigc++/config/Makefile.in Tue Aug 6 16:16:36 2002
|
||||
@@ -82,7 +82,7 @@
|
||||
|
||||
EXTRA_DIST = sigc++config.h.in
|
||||
|
||||
-includedir = $(libdir)/sigc++-1.0/include
|
||||
+includedir = $(prefix)/include/sigc++-1.0
|
||||
include_HEADERS = sigc++config.h
|
||||
mkinstalldirs = $(SHELL) $(top_srcdir)/scripts/mkinstalldirs
|
||||
CONFIG_HEADER = sigc++config.h
|
@ -1,11 +0,0 @@
|
||||
--- sigc++/macros/Makefile.in.orig Tue Oct 23 07:40:58 2001
|
||||
+++ sigc++/macros/Makefile.in Tue Aug 6 13:52:37 2002
|
||||
@@ -84,7 +84,7 @@
|
||||
templates = template.macros.m4 slot.h.m4 func_slot.h.m4 class_slot.h.m4 object_slot.h.m4 basic_signal.h.m4 bind.h.m4 rettype.h.m4 convert.h.m4 retbind.h.m4
|
||||
|
||||
|
||||
-m4includedir = $(includedir)/sigc++-1.0/sigc++/macros
|
||||
+m4includedir = $(prefix)/share/sigc++-1.0/sigc++/macros
|
||||
m4include_HEADERS = $(templates)
|
||||
|
||||
EXTRA_DIST = README $(templates)
|
@ -1,11 +0,0 @@
|
||||
--- sigc-config.in.orig Sat Oct 20 11:38:36 2001
|
||||
+++ sigc-config.in Tue Aug 6 13:53:55 2002
|
||||
@@ -217,7 +217,7 @@
|
||||
if test "@libdir@" != /usr/lib ; then
|
||||
libs="-L@libdir@"
|
||||
fi
|
||||
-af_cflags="$af_cflags -I@libdir@/sigc++-1.0/include -I@includedir@/sigc++-1.0"
|
||||
+af_cflags="$af_cflags -I@includedir@/sigc++-1.0"
|
||||
af_libs="$libs -lsigc @THREAD_LIB@ $af_libs"
|
||||
|
||||
|
10
devel/libsigc++12/files/patch-configure
Normal file
10
devel/libsigc++12/files/patch-configure
Normal file
@ -0,0 +1,10 @@
|
||||
--- configure.orig Sat Oct 12 00:29:28 2002
|
||||
+++ configure Sat Oct 12 00:29:50 2002
|
||||
@@ -6817,6 +6817,7 @@
|
||||
|
||||
# This can be used to rebuild libtool when needed
|
||||
LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
|
||||
+$ac_aux_dir/ltconfig $LIBTOOL_DEPS
|
||||
|
||||
# Always use our own libtool.
|
||||
LIBTOOL='$(SHELL) $(top_builddir)/libtool'
|
@ -1,54 +1,38 @@
|
||||
bin/sigc-config
|
||||
include/sigc++-1.0/sigc++/adaptor.h
|
||||
include/sigc++-1.0/sigc++/basic_signal.h
|
||||
include/sigc++-1.0/sigc++/bind.h
|
||||
include/sigc++-1.0/sigc++/class_slot.h
|
||||
include/sigc++-1.0/sigc++/convert.h
|
||||
include/sigc++-1.0/sigc++/func_slot.h
|
||||
include/sigc++-1.0/sigc++/generator.h
|
||||
include/sigc++-1.0/sigc++/handle.h
|
||||
include/sigc++-1.0/sigc++/handle_system.h
|
||||
include/sigc++-1.0/sigc++/marshal.h
|
||||
include/sigc++-1.0/sigc++/object.h
|
||||
include/sigc++-1.0/sigc++/object_slot.h
|
||||
include/sigc++-1.0/sigc++/retbind.h
|
||||
include/sigc++-1.0/sigc++/rettype.h
|
||||
include/sigc++-1.0/sigc++/scope.h
|
||||
include/sigc++-1.0/sigc++/signal_system.h
|
||||
include/sigc++-1.0/sigc++/slot.h
|
||||
include/sigc++-1.0/sigc++/thread.h
|
||||
include/sigc++-1.0/sigc++/type.h
|
||||
include/sigc++-1.0/sigc++config.h
|
||||
lib/libsigc.a
|
||||
lib/libsigc.so
|
||||
lib/libsigc.so.1
|
||||
share/aclocal/sigc++.m4
|
||||
%%PORTDOCS%%share/doc/libsigc++/API
|
||||
%%PORTDOCS%%share/doc/libsigc++/FAQ
|
||||
%%PORTDOCS%%share/doc/libsigc++/FEATURES
|
||||
%%PORTDOCS%%share/doc/libsigc++/README
|
||||
%%PORTDOCS%%share/doc/libsigc++/UML
|
||||
%%PORTDOCS%%share/doc/libsigc++/conventions
|
||||
%%PORTDOCS%%share/doc/libsigc++/diagrams
|
||||
%%PORTDOCS%%share/doc/libsigc++/marshal
|
||||
%%PORTDOCS%%share/doc/libsigc++/powerusers
|
||||
%%PORTDOCS%%share/doc/libsigc++/requirements
|
||||
%%PORTDOCS%%share/doc/libsigc++/riscos
|
||||
%%PORTDOCS%%share/doc/libsigc++/signals
|
||||
%%PORTDOCS%%share/doc/libsigc++/win32
|
||||
share/sigc++-1.0/sigc++/macros/basic_signal.h.m4
|
||||
share/sigc++-1.0/sigc++/macros/bind.h.m4
|
||||
share/sigc++-1.0/sigc++/macros/class_slot.h.m4
|
||||
share/sigc++-1.0/sigc++/macros/convert.h.m4
|
||||
share/sigc++-1.0/sigc++/macros/func_slot.h.m4
|
||||
share/sigc++-1.0/sigc++/macros/object_slot.h.m4
|
||||
share/sigc++-1.0/sigc++/macros/retbind.h.m4
|
||||
share/sigc++-1.0/sigc++/macros/rettype.h.m4
|
||||
share/sigc++-1.0/sigc++/macros/slot.h.m4
|
||||
share/sigc++-1.0/sigc++/macros/template.macros.m4
|
||||
@dirrm include/sigc++-1.0/sigc++
|
||||
@dirrm include/sigc++-1.0
|
||||
%%PORTDOCS%%@dirrm share/doc/libsigc++
|
||||
@dirrm share/sigc++-1.0/sigc++/macros
|
||||
@dirrm share/sigc++-1.0/sigc++
|
||||
@dirrm share/sigc++-1.0
|
||||
include/sigc++-1.2/sigc++/adaptor.h
|
||||
include/sigc++-1.2/sigc++/bind.h
|
||||
include/sigc++-1.2/sigc++/bind_return.h
|
||||
include/sigc++-1.2/sigc++/class_slot.h
|
||||
include/sigc++-1.2/sigc++/connection.h
|
||||
include/sigc++-1.2/sigc++/hide.h
|
||||
include/sigc++-1.2/sigc++/macros/bind.h.m4
|
||||
include/sigc++-1.2/sigc++/macros/bind_return.h.m4
|
||||
include/sigc++-1.2/sigc++/macros/class_slot.h.m4
|
||||
include/sigc++-1.2/sigc++/macros/hide.h.m4
|
||||
include/sigc++-1.2/sigc++/macros/method_slot.h.m4
|
||||
include/sigc++-1.2/sigc++/macros/object_slot.h.m4
|
||||
include/sigc++-1.2/sigc++/macros/retype.h.m4
|
||||
include/sigc++-1.2/sigc++/macros/retype_return.h.m4
|
||||
include/sigc++-1.2/sigc++/macros/signal.h.m4
|
||||
include/sigc++-1.2/sigc++/macros/slot.h.m4
|
||||
include/sigc++-1.2/sigc++/macros/template.macros.m4
|
||||
include/sigc++-1.2/sigc++/marshal.h
|
||||
include/sigc++-1.2/sigc++/method_slot.h
|
||||
include/sigc++-1.2/sigc++/node.h
|
||||
include/sigc++-1.2/sigc++/object.h
|
||||
include/sigc++-1.2/sigc++/object_slot.h
|
||||
include/sigc++-1.2/sigc++/retype.h
|
||||
include/sigc++-1.2/sigc++/retype_return.h
|
||||
include/sigc++-1.2/sigc++/sigc++.h
|
||||
include/sigc++-1.2/sigc++/signal.h
|
||||
include/sigc++-1.2/sigc++/slot.h
|
||||
include/sigc++-1.2/sigc++/trait.h
|
||||
lib/libsigc-1.1.a
|
||||
lib/libsigc-1.1.so
|
||||
lib/libsigc-1.1.so.5
|
||||
lib/sigc++-1.2/include/sigcconfig.h
|
||||
libdata/pkgconfig/sigc++-1.2.pc
|
||||
@dirrm lib/sigc++-1.2/include
|
||||
@dirrm lib/sigc++-1.2
|
||||
@dirrm include/sigc++-1.2/sigc++/macros
|
||||
@dirrm include/sigc++-1.2/sigc++
|
||||
@dirrm include/sigc++-1.2
|
||||
|
@ -1,46 +1,23 @@
|
||||
# New ports collection makefile for: libsigc++
|
||||
# Date created: 27 January 2000
|
||||
# Whom: Joe Lu <JoeLu@JoeLu.m8.ntu.edu.tw>
|
||||
# Date created: 30 September 2002
|
||||
# Whom: Martin Klaffenboeck <martin.klaffenboeck@gmx.at>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= libsigc++
|
||||
PORTVERSION= 1.0.4
|
||||
PORTVERSION= 1.1.13
|
||||
CATEGORIES= devel gnome
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
|
||||
${MASTER_SITE_GNOME}
|
||||
MASTER_SITE_SUBDIR= libsigc \
|
||||
sources/libsigc++/1.0
|
||||
|
||||
#DIST_SUBDIR= gnome
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
|
||||
MASTER_SITE_SUBDIR= libsigc
|
||||
|
||||
MAINTAINER= gnome@FreeBSD.org
|
||||
|
||||
USE_LIBTOOL= yes
|
||||
USE_GMAKE= yes
|
||||
NO_LATEST_LINK= yes
|
||||
INSTALLS_SHLIB= yes
|
||||
USE_REINPLACE= yes
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g' \
|
||||
${WRKSRC}/configure
|
||||
|
||||
post-install:
|
||||
.if !defined(NOPORTDOCS)
|
||||
@${MKDIR} ${PREFIX}/share/doc/libsigc++
|
||||
${INSTALL_DATA} ${WRKSRC}/README ${PREFIX}/share/doc/libsigc++
|
||||
${INSTALL_DATA} ${WRKSRC}/FEATURES ${PREFIX}/share/doc/libsigc++
|
||||
${INSTALL_DATA} ${WRKSRC}/doc/API ${PREFIX}/share/doc/libsigc++
|
||||
${INSTALL_DATA} ${WRKSRC}/doc/FAQ ${PREFIX}/share/doc/libsigc++
|
||||
${INSTALL_DATA} ${WRKSRC}/doc/UML ${PREFIX}/share/doc/libsigc++
|
||||
${INSTALL_DATA} ${WRKSRC}/doc/conventions ${PREFIX}/share/doc/libsigc++
|
||||
${INSTALL_DATA} ${WRKSRC}/doc/diagrams ${PREFIX}/share/doc/libsigc++
|
||||
${INSTALL_DATA} ${WRKSRC}/doc/marshal ${PREFIX}/share/doc/libsigc++
|
||||
${INSTALL_DATA} ${WRKSRC}/doc/powerusers ${PREFIX}/share/doc/libsigc++
|
||||
${INSTALL_DATA} ${WRKSRC}/doc/requirements ${PREFIX}/share/doc/libsigc++
|
||||
${INSTALL_DATA} ${WRKSRC}/doc/riscos ${PREFIX}/share/doc/libsigc++/
|
||||
${INSTALL_DATA} ${WRKSRC}/doc/signals ${PREFIX}/share/doc/libsigc++
|
||||
${INSTALL_DATA} ${WRKSRC}/doc/win32 ${PREFIX}/share/doc/libsigc++
|
||||
.endif
|
||||
USE_GNOMENG= yes
|
||||
USE_GNOME= gnomehack
|
||||
USE_LIBTOOL= yes
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
@ -1 +1 @@
|
||||
MD5 (libsigc++-1.0.4.tar.gz) = 88d34840acc1cc5d47b347726e4a09e0
|
||||
MD5 (libsigc++-1.1.13.tar.gz) = e9cb92067e109884b156caab390c3620
|
||||
|
@ -1,11 +0,0 @@
|
||||
--- Makefile.in Thu Jan 20 03:40:54 2000
|
||||
+++ Makefile.in Thu Jan 27 23:34:05 1994
|
||||
@@ -80,7 +80,7 @@
|
||||
USE_SYMBOL_UNDERSCORE = @USE_SYMBOL_UNDERSCORE@
|
||||
VERSION = @VERSION@
|
||||
|
||||
-SUBDIRS = sigc++ tests
|
||||
+SUBDIRS = sigc++
|
||||
DIST_SUBDIRS = sigc++ examples tests scripts
|
||||
|
||||
bin_SCRIPTS = sigc-config
|
@ -1,21 +0,0 @@
|
||||
--- sigc++/Makefile.in.orig Tue Oct 23 07:40:58 2001
|
||||
+++ sigc++/Makefile.in Tue Aug 6 16:13:28 2002
|
||||
@@ -66,7 +66,7 @@
|
||||
DLLTOOL = @DLLTOOL@
|
||||
DLL_DEFINE = @DLL_DEFINE@
|
||||
EXEEXT = @EXEEXT@
|
||||
-LIBSIGC_SO_VERSION = @LIBSIGC_SO_VERSION@
|
||||
+LIBSIGC_SO_VERSION = 1:0:1
|
||||
LIBTOOL = @LIBTOOL@
|
||||
LN_S = @LN_S@
|
||||
M4 = @M4@
|
||||
@@ -94,8 +94,7 @@
|
||||
|
||||
EXTRA_libsigc_la_SOURCES = sigc_res.rc
|
||||
|
||||
-libsigc_la_LDFLAGS = -version-info $(LIBSIGC_SO_VERSION) -release $(SIGC_RELEASE) -no-undefined
|
||||
-
|
||||
+libsigc_la_LDFLAGS = -version-info $(LIBSIGC_SO_VERSION) -no-undefined
|
||||
|
||||
lib_LTLIBRARIES = libsigc.la
|
||||
|
@ -1,11 +0,0 @@
|
||||
--- sigc++/config/Makefile.in.orig Tue Aug 6 16:14:37 2002
|
||||
+++ sigc++/config/Makefile.in Tue Aug 6 16:16:36 2002
|
||||
@@ -82,7 +82,7 @@
|
||||
|
||||
EXTRA_DIST = sigc++config.h.in
|
||||
|
||||
-includedir = $(libdir)/sigc++-1.0/include
|
||||
+includedir = $(prefix)/include/sigc++-1.0
|
||||
include_HEADERS = sigc++config.h
|
||||
mkinstalldirs = $(SHELL) $(top_srcdir)/scripts/mkinstalldirs
|
||||
CONFIG_HEADER = sigc++config.h
|
@ -1,11 +0,0 @@
|
||||
--- sigc++/macros/Makefile.in.orig Tue Oct 23 07:40:58 2001
|
||||
+++ sigc++/macros/Makefile.in Tue Aug 6 13:52:37 2002
|
||||
@@ -84,7 +84,7 @@
|
||||
templates = template.macros.m4 slot.h.m4 func_slot.h.m4 class_slot.h.m4 object_slot.h.m4 basic_signal.h.m4 bind.h.m4 rettype.h.m4 convert.h.m4 retbind.h.m4
|
||||
|
||||
|
||||
-m4includedir = $(includedir)/sigc++-1.0/sigc++/macros
|
||||
+m4includedir = $(prefix)/share/sigc++-1.0/sigc++/macros
|
||||
m4include_HEADERS = $(templates)
|
||||
|
||||
EXTRA_DIST = README $(templates)
|
@ -1,11 +0,0 @@
|
||||
--- sigc-config.in.orig Sat Oct 20 11:38:36 2001
|
||||
+++ sigc-config.in Tue Aug 6 13:53:55 2002
|
||||
@@ -217,7 +217,7 @@
|
||||
if test "@libdir@" != /usr/lib ; then
|
||||
libs="-L@libdir@"
|
||||
fi
|
||||
-af_cflags="$af_cflags -I@libdir@/sigc++-1.0/include -I@includedir@/sigc++-1.0"
|
||||
+af_cflags="$af_cflags -I@includedir@/sigc++-1.0"
|
||||
af_libs="$libs -lsigc @THREAD_LIB@ $af_libs"
|
||||
|
||||
|
10
devel/libsigc++20/files/patch-configure
Normal file
10
devel/libsigc++20/files/patch-configure
Normal file
@ -0,0 +1,10 @@
|
||||
--- configure.orig Sat Oct 12 00:29:28 2002
|
||||
+++ configure Sat Oct 12 00:29:50 2002
|
||||
@@ -6817,6 +6817,7 @@
|
||||
|
||||
# This can be used to rebuild libtool when needed
|
||||
LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
|
||||
+$ac_aux_dir/ltconfig $LIBTOOL_DEPS
|
||||
|
||||
# Always use our own libtool.
|
||||
LIBTOOL='$(SHELL) $(top_builddir)/libtool'
|
@ -1,54 +1,38 @@
|
||||
bin/sigc-config
|
||||
include/sigc++-1.0/sigc++/adaptor.h
|
||||
include/sigc++-1.0/sigc++/basic_signal.h
|
||||
include/sigc++-1.0/sigc++/bind.h
|
||||
include/sigc++-1.0/sigc++/class_slot.h
|
||||
include/sigc++-1.0/sigc++/convert.h
|
||||
include/sigc++-1.0/sigc++/func_slot.h
|
||||
include/sigc++-1.0/sigc++/generator.h
|
||||
include/sigc++-1.0/sigc++/handle.h
|
||||
include/sigc++-1.0/sigc++/handle_system.h
|
||||
include/sigc++-1.0/sigc++/marshal.h
|
||||
include/sigc++-1.0/sigc++/object.h
|
||||
include/sigc++-1.0/sigc++/object_slot.h
|
||||
include/sigc++-1.0/sigc++/retbind.h
|
||||
include/sigc++-1.0/sigc++/rettype.h
|
||||
include/sigc++-1.0/sigc++/scope.h
|
||||
include/sigc++-1.0/sigc++/signal_system.h
|
||||
include/sigc++-1.0/sigc++/slot.h
|
||||
include/sigc++-1.0/sigc++/thread.h
|
||||
include/sigc++-1.0/sigc++/type.h
|
||||
include/sigc++-1.0/sigc++config.h
|
||||
lib/libsigc.a
|
||||
lib/libsigc.so
|
||||
lib/libsigc.so.1
|
||||
share/aclocal/sigc++.m4
|
||||
%%PORTDOCS%%share/doc/libsigc++/API
|
||||
%%PORTDOCS%%share/doc/libsigc++/FAQ
|
||||
%%PORTDOCS%%share/doc/libsigc++/FEATURES
|
||||
%%PORTDOCS%%share/doc/libsigc++/README
|
||||
%%PORTDOCS%%share/doc/libsigc++/UML
|
||||
%%PORTDOCS%%share/doc/libsigc++/conventions
|
||||
%%PORTDOCS%%share/doc/libsigc++/diagrams
|
||||
%%PORTDOCS%%share/doc/libsigc++/marshal
|
||||
%%PORTDOCS%%share/doc/libsigc++/powerusers
|
||||
%%PORTDOCS%%share/doc/libsigc++/requirements
|
||||
%%PORTDOCS%%share/doc/libsigc++/riscos
|
||||
%%PORTDOCS%%share/doc/libsigc++/signals
|
||||
%%PORTDOCS%%share/doc/libsigc++/win32
|
||||
share/sigc++-1.0/sigc++/macros/basic_signal.h.m4
|
||||
share/sigc++-1.0/sigc++/macros/bind.h.m4
|
||||
share/sigc++-1.0/sigc++/macros/class_slot.h.m4
|
||||
share/sigc++-1.0/sigc++/macros/convert.h.m4
|
||||
share/sigc++-1.0/sigc++/macros/func_slot.h.m4
|
||||
share/sigc++-1.0/sigc++/macros/object_slot.h.m4
|
||||
share/sigc++-1.0/sigc++/macros/retbind.h.m4
|
||||
share/sigc++-1.0/sigc++/macros/rettype.h.m4
|
||||
share/sigc++-1.0/sigc++/macros/slot.h.m4
|
||||
share/sigc++-1.0/sigc++/macros/template.macros.m4
|
||||
@dirrm include/sigc++-1.0/sigc++
|
||||
@dirrm include/sigc++-1.0
|
||||
%%PORTDOCS%%@dirrm share/doc/libsigc++
|
||||
@dirrm share/sigc++-1.0/sigc++/macros
|
||||
@dirrm share/sigc++-1.0/sigc++
|
||||
@dirrm share/sigc++-1.0
|
||||
include/sigc++-1.2/sigc++/adaptor.h
|
||||
include/sigc++-1.2/sigc++/bind.h
|
||||
include/sigc++-1.2/sigc++/bind_return.h
|
||||
include/sigc++-1.2/sigc++/class_slot.h
|
||||
include/sigc++-1.2/sigc++/connection.h
|
||||
include/sigc++-1.2/sigc++/hide.h
|
||||
include/sigc++-1.2/sigc++/macros/bind.h.m4
|
||||
include/sigc++-1.2/sigc++/macros/bind_return.h.m4
|
||||
include/sigc++-1.2/sigc++/macros/class_slot.h.m4
|
||||
include/sigc++-1.2/sigc++/macros/hide.h.m4
|
||||
include/sigc++-1.2/sigc++/macros/method_slot.h.m4
|
||||
include/sigc++-1.2/sigc++/macros/object_slot.h.m4
|
||||
include/sigc++-1.2/sigc++/macros/retype.h.m4
|
||||
include/sigc++-1.2/sigc++/macros/retype_return.h.m4
|
||||
include/sigc++-1.2/sigc++/macros/signal.h.m4
|
||||
include/sigc++-1.2/sigc++/macros/slot.h.m4
|
||||
include/sigc++-1.2/sigc++/macros/template.macros.m4
|
||||
include/sigc++-1.2/sigc++/marshal.h
|
||||
include/sigc++-1.2/sigc++/method_slot.h
|
||||
include/sigc++-1.2/sigc++/node.h
|
||||
include/sigc++-1.2/sigc++/object.h
|
||||
include/sigc++-1.2/sigc++/object_slot.h
|
||||
include/sigc++-1.2/sigc++/retype.h
|
||||
include/sigc++-1.2/sigc++/retype_return.h
|
||||
include/sigc++-1.2/sigc++/sigc++.h
|
||||
include/sigc++-1.2/sigc++/signal.h
|
||||
include/sigc++-1.2/sigc++/slot.h
|
||||
include/sigc++-1.2/sigc++/trait.h
|
||||
lib/libsigc-1.1.a
|
||||
lib/libsigc-1.1.so
|
||||
lib/libsigc-1.1.so.5
|
||||
lib/sigc++-1.2/include/sigcconfig.h
|
||||
libdata/pkgconfig/sigc++-1.2.pc
|
||||
@dirrm lib/sigc++-1.2/include
|
||||
@dirrm lib/sigc++-1.2
|
||||
@dirrm include/sigc++-1.2/sigc++/macros
|
||||
@dirrm include/sigc++-1.2/sigc++
|
||||
@dirrm include/sigc++-1.2
|
||||
|
Loading…
Reference in New Issue
Block a user