add new port: games/chessx

ChessX is an open source chess database based on Qt4. With ChessX you
can operate on your collection of chess games in many ways: browse,
edit, add, organize, analyze, etc. Additionally ChessX can interface
with chess engines via UCI and Winboard protocol.

WWW: http://chessx.sourceforge.net/

PR:		177338
Submitted by:	yamagi@yamagi.org
This commit is contained in:
Jason Helfman 2013-03-29 16:16:18 +00:00
parent 58bf0488f4
commit 71e408cd92
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=315544
5 changed files with 73 additions and 0 deletions

View File

@ -129,6 +129,7 @@
SUBDIR += cgoban
SUBDIR += chanta
SUBDIR += chapping
SUBDIR += chessx
SUBDIR += chocolate-doom
SUBDIR += cheech
SUBDIR += childsplay

48
games/chessx/Makefile Normal file
View File

@ -0,0 +1,48 @@
# $FreeBSD$
PORTNAME= chessx
PORTVERSION= 0.9.6
CATEGORIES= games
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTVERSION}
DISTNAME= ${PORTNAME}-${PORTVERSION:S/./-/g}
MAINTAINER= yamagi@yamagi.org
COMMENT= Qt4 chess database application
LICENSE= GPLv2 # (or later)
WRKSRC= ${WRKDIR}/${PORTNAME}
USE_QT4= corelib gui svg xml network moc_build qmake_build rcc_build uic_build
MAKE_JOBS_SAVE= yes
OPTIONS_DEFINE= STOCKFISH CRAFTY
STOCKFISH_DESC= Build with Stockfish Chess Engine
CRAFTY_DESC= Build with Crafty Chess Application
OPTIONS_DEFAULT=STOCKFISH CRAFTY
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MSTOCKFISH}
RUN_DEPENDS+= stockfish:${PORTSDIR}/games/stockfish
.endif
.if ${PORT_OPTIONS:MCRAFTY}
RUN_DEPENDS+= crafty:${PORTSDIR}/games/crafty
.endif
PLIST_FILES= bin/${PORTNAME} \
share/pixmaps/${PORTNAME}.png
DESKTOP_ENTRIES="ChessX" "" "${PREFIX}/share/pixmaps/${PORTNAME}.png" \
"${PORTNAME}" "Game;BoardGame;" true
do-configure:
@(cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${QMAKE} ${QMAKEFLAGS})
do-install:
(cd ${WRKSRC} && ${INSTALL_PROGRAM} release/${PORTNAME} ${PREFIX}/bin)
(cd ${WRKSRC}/data/images && ${INSTALL_DATA} chessx.png \
${PREFIX}/share/pixmaps/${PORTNAME}.png)
.include <bsd.port.mk>

2
games/chessx/distinfo Normal file
View File

@ -0,0 +1,2 @@
SHA256 (chessx-0-9-6.tar.gz) = 37ec638736b0e20fbdfb5db374bf971d76d81fe267ace3bde8b4e5c2d2e9c601
SIZE (chessx-0-9-6.tar.gz) = 3213601

View File

@ -0,0 +1,16 @@
--- src/database/enginelist.cpp_orig 2013-03-24 11:48:27.000000000 +0100
+++ src/database/enginelist.cpp 2013-03-24 11:48:59.000000000 +0100
@@ -50,7 +50,12 @@
QString path1 = path + "/engines-linux/uci";
QString path2 = path + "/engines-linux/winboard";
#endif
-
+
+#ifdef Q_OS_FREEBSD
+ QString path1 = path + "/engines-freebsd/uci";
+ QString path2 = path + "/engines-freebsd/winboard";
+#endif
+
restoreEmptyFromPath(path1, EngineData::UCI);
restoreEmptyFromPath(path2, EngineData::WinBoard);
}

6
games/chessx/pkg-descr Normal file
View File

@ -0,0 +1,6 @@
ChessX is an open source chess database based on Qt4. With ChessX you
can operate on your collection of chess games in many ways: browse,
edit, add, organize, analyze, etc. Additionally ChessX can interface
with chess engines via UCI and Winboard protocol.
WWW: http://chessx.sourceforge.net/