biology/canu: Upgrade to 2.1
Numerous functional improvements for ease of use and output quality A few bug fixes Reported by: portscout
This commit is contained in:
parent
fafc1b8e31
commit
719076a220
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=548685
@ -1,9 +1,10 @@
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= canu
|
||||
DISTVERSIONPREFIX= v
|
||||
DISTVERSION= 2.0
|
||||
DISTVERSION= 2.1
|
||||
CATEGORIES= biology java perl5
|
||||
# Github auto-generated tarballs lack submodules
|
||||
MASTER_SITES= https://github.com/marbl/canu/releases/download/v2.1/
|
||||
|
||||
MAINTAINER= jwb@FreeBSD.org
|
||||
COMMENT= Single molecule sequence assembler
|
||||
@ -12,17 +13,17 @@ LICENSE= GPLv2
|
||||
LICENSE_FILE= ${WRKDIR}/${PORTNAME}-${PORTVERSION}/README.license.GPL
|
||||
|
||||
BROKEN_powerpc64= fails to build: utgcns/libboost/boost/smart_ptr/detail/sp_counted_impl.hpp:81:5: error: 'get_deleter' declared as a 'virtual' field
|
||||
NOT_FOR_ARCHS= armv6 armv7 i386 powerpc
|
||||
NOT_FOR_ARCHS_REASON= __int128 is not supported on this target
|
||||
|
||||
LIB_DEPENDS= libboost_regex.so:devel/boost-libs
|
||||
RUN_DEPENDS= gnuplot:math/gnuplot
|
||||
|
||||
USES= compiler:openmp gmake perl5
|
||||
USE_JAVA= yes
|
||||
USE_GITHUB= yes
|
||||
|
||||
JAVA_RUN= yes
|
||||
JAVA_VERSION= 1.8+
|
||||
GH_ACCOUNT= marbl
|
||||
|
||||
WRKSRC_SUBDIR= src
|
||||
# Upstream Makefile compiles directly into ${DESTDIR}${PREFIX} rather than
|
||||
@ -43,24 +44,22 @@ pre-configure:
|
||||
-e 's|-fexpensive-optimizations||g' \
|
||||
${WRKSRC}/Makefile
|
||||
@${REINPLACE_CMD} \
|
||||
-e 's|RealBin/lib|RealBin/../${SITE_PERL_REL}/canu|g' \
|
||||
-e 's|RealBin/../lib/site_perl|RealBin/../${SITE_PERL_REL}/canu|g' \
|
||||
${WRKSRC}/pipelines/canu.pl
|
||||
|
||||
# Upstream does not want to use lib/perl5/site_perl
|
||||
post-build:
|
||||
@${MKDIR} ${WRKSRC}${PREFIX}/FreeBSD-${ARCH}/lib/perl5
|
||||
${MV} ${WRKSRC}${PREFIX}/FreeBSD-${ARCH}/lib/site_perl \
|
||||
${WRKSRC}${PREFIX}/FreeBSD-${ARCH}/lib/perl5
|
||||
@${MKDIR} ${WRKSRC}/build/lib/perl5
|
||||
${MV} ${WRKSRC}/build/lib/site_perl ${WRKSRC}/build/lib/perl5
|
||||
|
||||
do-install:
|
||||
@${MKDIR} ${STAGEDIR}${PREFIX}
|
||||
(cd ${WRKSRC}${PREFIX}/FreeBSD-${ARCH} && \
|
||||
${COPYTREE_BIN} bin ${STAGEDIR}${PREFIX})
|
||||
# STRIP_CMD fails without this on 11.1 under poudriere
|
||||
(cd ${WRKSRC}/build && ${COPYTREE_BIN} bin ${STAGEDIR}${PREFIX})
|
||||
# STRIP_CMD fails without this under poudriere
|
||||
@${CHMOD} u+w ${STAGEDIR}${PREFIX}/bin/*
|
||||
@${STRIP_CMD} \
|
||||
`file ${STAGEDIR}${PREFIX}/bin/* | ${GREP} ELF | cut -d : -f 1`
|
||||
(cd ${WRKSRC}${PREFIX}/FreeBSD-${ARCH} && \
|
||||
(cd ${WRKSRC}/build && \
|
||||
${COPYTREE_SHARE} "lib share" ${STAGEDIR}${PREFIX})
|
||||
|
||||
.include <bsd.port.post.mk>
|
||||
|
@ -1,3 +1,3 @@
|
||||
TIMESTAMP = 1584624503
|
||||
SHA256 (marbl-canu-v2.0_GH0.tar.gz) = e2e6e8b5ec4dd4cfba5e372f4a64b2c01fbd544d4b5867746021f10771a6f4ef
|
||||
SIZE (marbl-canu-v2.0_GH0.tar.gz) = 3443777
|
||||
TIMESTAMP = 1599584712
|
||||
SHA256 (canu-2.1.tar.gz) = 73c70d2d6326bdaf471549f2d1eb7a1bf1e0fbf45cdc4a830bd6ce9fe3f3c231
|
||||
SIZE (canu-2.1.tar.gz) = 3313120
|
||||
|
@ -1,17 +1,6 @@
|
||||
--- pipelines/canu/Execution.pm.orig 2018-10-22 16:47:31 UTC
|
||||
--- pipelines/canu/Execution.pm.orig 2020-09-07 19:08:24 UTC
|
||||
+++ pipelines/canu/Execution.pm
|
||||
@@ -333,10 +333,6 @@ sub resetIteration ($) {
|
||||
sub getInstallDirectory () {
|
||||
my $installDir = $FindBin::RealBin;
|
||||
|
||||
- if ($installDir =~ m!^(.*)/\w+-\w+/bin$!) {
|
||||
- $installDir = $1;
|
||||
- }
|
||||
-
|
||||
return($installDir);
|
||||
}
|
||||
|
||||
@@ -784,8 +780,8 @@ sub submitScript ($$) {
|
||||
@@ -762,8 +762,8 @@ sub submitScript ($$) {
|
||||
|
||||
|
||||
|
||||
@ -22,7 +11,7 @@
|
||||
my $off = 0;
|
||||
|
||||
# In some grids (SGE) this is the maximum size of an array job.
|
||||
@@ -823,8 +819,42 @@ sub buildGridArray ($$$$) {
|
||||
@@ -803,9 +803,43 @@ sub buildGridArray ($$$$) {
|
||||
$off = "-F \"$off\"";
|
||||
}
|
||||
|
||||
@ -35,7 +24,7 @@
|
||||
+ elsif( $opt =~ m/(ARRAY_JOBS)/ )
|
||||
+ {
|
||||
+ $opt =~ s/$1/$bgn-$end/; # Replace ARRAY_JOBS with 'bgn-end'
|
||||
+
|
||||
|
||||
+ if( lc( getGlobal( 'gridEngine' ) ) eq 'slurm' && $end > 1 )
|
||||
+ {
|
||||
+ if( $name =~ m/^cormhap_/i && defined getGlobal( 'slurmCormhapCoreLimit' ) )
|
||||
@ -64,10 +53,11 @@
|
||||
+ }
|
||||
+ }
|
||||
+ }
|
||||
|
||||
+
|
||||
return($opt, $off);
|
||||
}
|
||||
@@ -973,7 +1003,7 @@ sub buildGridJob ($$$$$$$$$) {
|
||||
|
||||
@@ -951,7 +985,7 @@ sub buildGridJob ($$$$$$$$$) {
|
||||
my $jobNameT = makeUniqueJobName($jobType, $asm);
|
||||
|
||||
my ($jobName, $jobOff) = buildGridArray($jobNameT, $bgnJob, $endJob, getGlobal("gridEngineArrayName"));
|
||||
|
@ -5,6 +5,7 @@ bin/canu
|
||||
bin/canu-time
|
||||
bin/canu.defaults
|
||||
bin/correctOverlaps
|
||||
bin/draw-tig
|
||||
bin/dumpBlob
|
||||
bin/edalign
|
||||
bin/errorEstimate
|
||||
@ -13,14 +14,14 @@ bin/filterCorrectionLayouts
|
||||
bin/filterCorrectionOverlaps
|
||||
bin/findErrors
|
||||
bin/findErrors-Dump
|
||||
bin/fixErrors
|
||||
bin/generateCorrectionLayouts
|
||||
bin/layoutReads
|
||||
bin/loadCorrectedReads
|
||||
bin/loadErates
|
||||
bin/loadTrimmedReads
|
||||
bin/mergeRanges
|
||||
bin/meryl
|
||||
bin/meryl-import
|
||||
bin/meryl-lookup
|
||||
bin/mhapConvert
|
||||
bin/mmapConvert
|
||||
bin/ovStoreBucketizer
|
||||
@ -37,7 +38,6 @@ bin/overlapInCore
|
||||
bin/overlapInCorePartition
|
||||
bin/overlapPair
|
||||
bin/prefixEditDistance-matchLimitGenerate
|
||||
bin/sequence
|
||||
bin/splitHaplotype
|
||||
bin/splitReads
|
||||
bin/sqStoreCreate
|
||||
@ -45,12 +45,10 @@ bin/sqStoreDumpFASTQ
|
||||
bin/sqStoreDumpMetaData
|
||||
bin/tgStoreCompress
|
||||
bin/tgStoreDump
|
||||
bin/tgStoreFilter
|
||||
bin/tgStoreLoad
|
||||
bin/tgTigDisplay
|
||||
bin/trimReads
|
||||
bin/utgcns
|
||||
bin/wtdbgConvert
|
||||
lib/libcanu.a
|
||||
%%SITE_PERL%%/canu/Configure.pm
|
||||
%%SITE_PERL%%/canu/Consensus.pm
|
||||
@ -77,6 +75,3 @@ lib/libcanu.a
|
||||
%%SITE_PERL%%/canu/SequenceStore.pm
|
||||
%%SITE_PERL%%/canu/Unitig.pm
|
||||
%%JAVAJARDIR%%/mhap-2.1.3.jar
|
||||
share/sequence/pacbio
|
||||
share/sequence/pacbio-hifi
|
||||
share/sequence/ultra-long-nanopore
|
||||
|
Loading…
Reference in New Issue
Block a user