Remove USE_GCC

Add patch proudly supplied by Max Khon <fjoe@samodelkin.net>

Submitted by:	Max Khon <fjoe@samodelkin.net>
This commit is contained in:
Edwin Groothuis 2006-12-19 22:29:34 +00:00
parent 071735165a
commit 7172d9b55b
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=180207
2 changed files with 36 additions and 2 deletions

View File

@ -7,7 +7,7 @@
PORTNAME= groundhog
PORTVERSION= 1.4
PORTREVISION= 7
PORTREVISION= 8
CATEGORIES= games
MASTER_SITES= http://home-2.tiscali.nl/~cb007736/
@ -16,7 +16,6 @@ COMMENT= Groundhog, a simple logic game
USE_GMAKE= yes
USE_GNOME= gtk20
USE_GCC= 3.4
GNU_CONFIGURE= yes
.include <bsd.port.mk>

View File

@ -0,0 +1,35 @@
Index: files/patch-src-element.h
===================================================================
RCS file: files/patch-src-element.h
diff -N files/patch-src-element.h
--- /dev/null 1 Jan 1970 00:00:00 -0000
+++ files/patch-src-element.h 16 Dec 2006 13:15:54 -0000
@@ -0,0 +1,10 @@
+--- src/element.h.orig Sat Dec 16 18:57:18 2006
++++ src/element.h Sat Dec 16 18:57:31 2006
+@@ -24,6 +24,7 @@
+ class Element {
+ public:
+ Element() {}
++ virtual ~Element() {}
+ virtual void PutBall(Ball* ball);
+ virtual void MoveBall(Ball* ball) = 0;
+ virtual void ConnectLeft(Element* element) = 0;
Index: files/patch-src-options_dialog.h
===================================================================
RCS file: files/patch-src-options_dialog.h
diff -N files/patch-src-options_dialog.h
--- /dev/null 1 Jan 1970 00:00:00 -0000
+++ files/patch-src-options_dialog.h 16 Dec 2006 13:16:14 -0000
@@ -0,0 +1,11 @@
+--- src/options_dialog.h.orig Sat Dec 16 18:57:43 2006
++++ src/options_dialog.h Sat Dec 16 18:57:50 2006
+@@ -28,7 +28,7 @@
+ Game* _game;
+ GtkWidget* _tooltips;
+
+- void OptionsDialog::OnOk();
++ void OnOk();
+ public:
+ OptionsDialog(Game* game);
+ };