- Fix build with clang

This commit is contained in:
Dennis Herrmann 2011-06-21 19:32:30 +00:00
parent bd329b55b0
commit 715aebf704
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=276028
2 changed files with 7 additions and 3 deletions

View File

@ -20,6 +20,9 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
MAN1= smu.1
PLIST_FILES= bin/smu
post-patch:
@${REINPLACE_CMD} -e 's|cc|${CC}|g' ${WRKSRC}/config.mk
do-install:
@${INSTALL_PROGRAM} ${WRKSRC}/smu ${PREFIX}/bin
@${INSTALL_MAN} ${WRKSRC}/smu.1 ${MAN1PREFIX}/man/man1

View File

@ -1,12 +1,13 @@
--- Makefile.orig 1999-10-28 21:04:24.000000000 +0200
+++ Makefile 2008-10-07 18:48:41.000000000 +0200
--- ./Makefile.orig 1999-10-28 21:04:24.000000000 +0200
+++ ./Makefile 2011-06-21 21:30:39.000000000 +0200
@@ -1,9 +1,10 @@
-#
-# $Id: Makefile,v 1.1 1999/01/14 19:05:35 xach Exp $
-#
-
-CC = gcc
+PREFIX?= /usr/local
CC = gcc
+CC?= gcc
CFLAGS = -Wall -g -O2
-multisort: multisort.c