- Fix a buffer overflow [1]

- Fix install location of capplet files
- Do not run install-info, bsd.port.mk does it for us
- Remove obsolete configure patch
- Remove obsolete USE_REINPLACE

[1]:
PR:		ports/92912
Submitted by:	Victor Snezhko <snezhko@indorsoft.ru>
This commit is contained in:
Jean-Yves Lefort 2006-02-08 03:39:18 +00:00
parent 9c19dc1066
commit 7141a7fcf2
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=155475
5 changed files with 25 additions and 34 deletions

View File

@ -7,7 +7,7 @@
PORTNAME= sawfish2
PORTVERSION= 1.3
PORTREVISION= 10
PORTREVISION= 11
PORTEPOCH= 2
CATEGORIES= x11-wm
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
@ -26,7 +26,6 @@ GNUHOST= ${ARCH}-pc-freebsd${OSREL:C/\..*//}
PLIST_SUB= GNUHOST=${GNUHOST} VERSION=${PORTVERSION}
USE_X_PREFIX= yes
USE_REINPLACE= yes
USE_GMAKE= yes
USE_GNOME= gnomehier gnomehack esound
WANT_GNOME= yes
@ -47,9 +46,4 @@ post-patch:
@${REINPLACE_CMD} -e 's|USE_INCLUDED_LIBINTL=yes|#USE_INCLUDED_LIBINTL=yes|g ; \
s|[$$][(]top_builddir[)]/intl/libintl.a|-lintl|g' ${WRKSRC}/configure
post-install:
install-info --section="X11 window manager" \
--entry="* sawfish: (sawfish). sawfish programming manual" \
${PREFIX}/info/sawfish.info ${PREFIX}/info/dir
.include <bsd.port.mk>

View File

@ -1,11 +0,0 @@
--- configure.in.orig Mon Dec 4 21:03:30 2000
+++ configure.in Tue Dec 5 14:57:18 2000
@@ -56,7 +56,7 @@
sawfishdir='${datadir}/sawfish'
lispdir='${sawfishdir}/${version}/lisp'
-localedir='${datadir}/locale'
+localedir='${prefix}/share/locale'
sawfishexecdir='${libexecdir}/sawfish/${version}/${host_type}'
dnl Checks for programs.

View File

@ -1,15 +1,12 @@
$FreeBSD$
--- capplet/Makefile.in.orig Mon Apr 29 21:43:11 2002
+++ capplet/Makefile.in Mon Apr 29 21:44:12 2002
--- capplet/Makefile.in.orig Sun Jan 12 21:30:41 2003
+++ capplet/Makefile.in Wed Feb 8 04:25:14 2006
@@ -26,8 +26,8 @@
srcdir=@srcdir@
VPATH=@srcdir@:@top_srcdir@
-G_CC_DIR = $(GNOMEDIR)/share/control-center-2.0/capplets
-G_PIXMAP_DIR = $(GNOMEDIR)/share/pixmaps
+G_CC_DIR = $(GNOMEDIR)/share/gnome/control-center-2.0/capplets
+G_CC_DIR = $(GNOMEDIR)/share/gnome/applications
+G_PIXMAP_DIR = $(GNOMEDIR)/share/gnome/pixmaps
all :

View File

@ -0,0 +1,11 @@
--- src/fonts.c.orig Sun Nov 3 22:00:36 2002
+++ src/fonts.c Wed Feb 8 04:22:13 2006
@@ -131,7 +131,7 @@
if (end == 0)
end = p + strlen (p);
len = end - (p + 1);
- buf = malloc (len);
+ buf = malloc (len + 1);
memcpy (buf, p + 1, len);
buf[len] = 0;
return buf;

View File

@ -23,16 +23,16 @@ libexec/sawfish/%%VERSION%%/%%GNUHOST%%/selection.la
libexec/sawfish/%%VERSION%%/%%GNUHOST%%/selection.so
libexec/sawfish/%%VERSION%%/%%GNUHOST%%/x.la
libexec/sawfish/%%VERSION%%/%%GNUHOST%%/x.so
share/gnome/control-center-2.0/capplets/appearance-properties.desktop
share/gnome/control-center-2.0/capplets/bindings-properties.desktop
share/gnome/control-center-2.0/capplets/focus-properties.desktop
share/gnome/control-center-2.0/capplets/match-properties.desktop
share/gnome/control-center-2.0/capplets/maximize-properties.desktop
share/gnome/control-center-2.0/capplets/misc-properties.desktop
share/gnome/control-center-2.0/capplets/move-properties.desktop
share/gnome/control-center-2.0/capplets/placement-properties.desktop
share/gnome/control-center-2.0/capplets/sound-properties.desktop
share/gnome/control-center-2.0/capplets/workspace-properties.desktop
share/gnome/applications/appearance-properties.desktop
share/gnome/applications/bindings-properties.desktop
share/gnome/applications/focus-properties.desktop
share/gnome/applications/match-properties.desktop
share/gnome/applications/maximize-properties.desktop
share/gnome/applications/misc-properties.desktop
share/gnome/applications/move-properties.desktop
share/gnome/applications/placement-properties.desktop
share/gnome/applications/sound-properties.desktop
share/gnome/applications/workspace-properties.desktop
share/gnome/pixmaps/sawfish-appearance.png
share/gnome/pixmaps/sawfish-edgeflip.png
share/gnome/pixmaps/sawfish-focus.png