Minor cleanups: Use gtk12 and ${INSTALL_*}.

PR:		ports/10936
Submitted by:	Chris Piazza <cpiazza@home.net>
This commit is contained in:
Justin M. Seger 1999-04-06 09:36:44 +00:00
parent d02e46d897
commit 70f4095e5b
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=17664
2 changed files with 12 additions and 13 deletions

View File

@ -3,7 +3,7 @@
# Date created: 25 February 1999
# Whom: Chris Piazza <cpiazza@home.net>
#
# $Id$
# $Id: Makefile,v 1.1.1.1 1999/04/03 01:48:17 steve Exp $
#
DISTNAME= gmixer-0.98c
@ -12,11 +12,14 @@ MASTER_SITES= http://junior.technion.ac.il/~sergey/linux/
MAINTAINER= cpiazza@home.net
LIB_DEPENDS= gtk11d.1:${PORTSDIR}/x11-toolkits/gtk11-devel
LIB_DEPENDS= gtk12.1:${PORTSDIR}/x11-toolkits/gtk12
ALL_TARGET= gmixer
pre-install:
@ ${MKDIR} ${PREFIX}/share/pixmaps
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/gmixer ${PREFIX}/bin
${INSTALL_DATA} ${WRKSRC}/icons/gmixer.xpm ${PREFIX}/share/pixmaps
.include <bsd.port.mk>

View File

@ -1,18 +1,14 @@
--- Makefile.orig Thu Feb 25 21:31:39 1999
+++ Makefile Thu Feb 25 21:36:58 1999
@@ -1,11 +1,11 @@
--- Makefile.orig Sat Apr 3 13:33:52 1999
+++ Makefile Sat Apr 3 13:33:54 1999
@@ -1,9 +1,9 @@
-CC = gcc
+#CC = gcc
+CC ?= gcc
#CC = egcs
#FLAGS = -g
gmixer: gmixer.c
- $(CC) $(FLAGS) `gtk-config --cflags` `gtk-config --libs` gmixer.c -o gmixer
+ $(CC) $(CFLAGS) `gtk11d-config --cflags` `gtk11d-config --libs` gmixer.c -o gmixer
+ $(CC) $(CFLAGS) `gtk12-config --cflags` `gtk12-config --libs` gmixer.c -o gmixer
install: gmixer
- install -s -m 755 -o 0 -g 0 gmixer /usr/X11R6/bin/
- install -m 644 -o 0 -g 0 icons/gmixer.xpm /usr/share/pixmaps/
+ install -c -s -m 755 -o 0 -g 0 gmixer $(PREFIX)/bin
+ install -c -m 644 -o 0 -g 0 icons/gmixer.xpm $(PREFIX)/share/pixmaps
clean:
rm -f gmixer
install -s -m 755 -o 0 -g 0 gmixer /usr/X11R6/bin/
install -m 644 -o 0 -g 0 icons/gmixer.xpm /usr/share/pixmaps/