- Fix build with gcc 4.2

- Pass maintainership to submitter

PR:		118633
Submitted by:	Pietro Cerutti <gahr@gahr.ch>
This commit is contained in:
Martin Wilke 2007-12-14 19:08:27 +00:00
parent 814956e97e
commit 70e8b85a57
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=203614
4 changed files with 39 additions and 8 deletions

View File

@ -12,13 +12,14 @@ PORTREVISION= 3
CATEGORIES= games devel
MASTER_SITES= http://adgali.apiou.org/download/
MAINTAINER= ports@FreeBSD.org
MAINTAINER= gahr@gahr.ch
COMMENT= An open source game library useful for 2D game development
LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
png.5:${PORTSDIR}/graphics/png \
tiff.4:${PORTSDIR}/graphics/tiff \
freetype.9:${PORTSDIR}/print/freetype2
freetype.9:${PORTSDIR}/print/freetype2 \
execinfo.1:${PORTSDIR}/devel/libexecinfo
USE_AUTOTOOLS= libtool:15
USE_BZIP2= yes
@ -28,18 +29,14 @@ USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
LDFLAGS="-L${LOCALBASE}/lib -lexecinfo"
CONFIGURE_ARGS= --enable-compile-optim=no
USE_LDCONFIG= yes
.include <bsd.port.pre.mk>
.if ${OSVERSION} >= 700042
BROKEN= "Does not build with gcc 4.2"
.endif
.if ${ARCH} == "alpha" && ${OSVERSION} >= 502102
BROKEN= "Configure fails"
BROKEN= Configure fails
.endif
post-install:

View File

@ -0,0 +1,11 @@
--- src/input/fontio/agl_bfontio.c 2007-12-12 23:43:53.000000000 +0100
+++ src/input/fontio/agl_bfontio.c.orig 2007-12-12 23:43:41.000000000 +0100
@@ -387,7 +387,7 @@
return 0;
}
-static agl_fontio agl_bfnt_fontio = {
+agl_fontio agl_bfnt_fontio = {
agl_bfntis,
agl_bfntopen,
agl_bfntloadglyph,

View File

@ -0,0 +1,11 @@
--- src/input/fontio/agl_ttfio.c.orig 2007-12-12 23:42:15.000000000 +0100
+++ src/input/fontio/agl_ttfio.c 2007-12-12 23:43:00.000000000 +0100
@@ -481,7 +481,7 @@
return 1;
}
-static agl_fontio agl_ttf_fontio = {
+agl_fontio agl_ttf_fontio = {
agl_ttfis,
agl_ttfopen,
agl_ttfloadglyph,

View File

@ -0,0 +1,12 @@
--- src/agl_main.c.orig 2007-12-12 23:45:13.000000000 +0100
+++ src/agl_main.c 2007-12-12 23:47:00.000000000 +0100
@@ -65,7 +65,8 @@
if (agl_initparachute() < 0)
return -1;
- *phandle = (agl_handle) handle = (agl_container *) agl_malloc(sizeof(agl_container));
+ handle = agl_malloc(sizeof(agl_container));
+ *phandle = (agl_container *)handle;
if (*phandle == NULL)
{
agl_memerr();