Upgrade to lmbench 1.1

This commit is contained in:
Bill Fenner 1997-05-28 02:18:20 +00:00
parent f53e58d1c8
commit 70e0e2f636
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=6581
3 changed files with 22 additions and 11 deletions

View File

@ -1,18 +1,20 @@
# New ports collection makefile for: lmbench
# Version required: 1.0
# Version required: 1.1
# Date created: 6 May 1995
# Whom: asami
#
# $Id: Makefile,v 1.5 1996/03/21 11:35:08 asami Exp $
# $Id: Makefile,v 1.6 1996/11/18 11:21:57 asami Exp $
#
DISTNAME= lmbench-1.0
DISTNAME= lmbench-1.1
CATEGORIES= benchmarks
MASTER_SITES= ftp://forte.mathematik.uni-bremen.de/pub/unix/benchmarks/
MASTER_SITES= ftp://forte.mathematik.uni-bremen.de/pub/comp/benchmarks/
MAINTAINER= asami@FreeBSD.ORG
MAINTAINER= fenner@FreeBSD.ORG
WRKSRC= ${WRKDIR}/lmbench
ALL_TARGET= build
MAKE_ENV= PATH=${PATH}:${WRKSRC}/scripts
MAN1= bargraph.1 graph.1
MAN8= bw_file_rd.8 bw_mem_cp.8 bw_mem_rd.8 bw_mem_wr.8 \
bw_mmap_rd.8 bw_pipe.8 bw_tcp.8 lat_connect.8 lat_ctx.8 \

View File

@ -1 +1 @@
MD5 (lmbench-1.0.tar.gz) = 22651dd664376a13279f02af4eaacf84
MD5 (lmbench-1.1.tar.gz) = 8dad46afd0c7fbaf8967d22b9d157da8

View File

@ -1,11 +1,20 @@
--- ./src/Makefile.org Fri Nov 25 08:53:00 1994
+++ ./src/Makefile Sat May 6 03:38:01 1995
@@ -91,7 +91,7 @@
$(MAKE) O=$O CC=cc CFLAGS="$(CFLAGS) -Dvfork=fork" all
--- src/Makefile.orig Wed May 28 01:21:10 1997
+++ src/Makefile Wed May 28 01:19:40 1997
@@ -93,7 +93,7 @@
$(MAKE) O=$O CC=cc CFLAGS="$(CFLAGS)" all
bsd:
- $(MAKE) O=$O CC=$(CC) CFLAGS="$CFLAGS -Duint='unsigned int'" all
- $(MAKE) O=$O CC=$(CC) CFLAGS="$(CFLAGS) -Duint='unsigned int'" all
+ $(MAKE) O=$O CC=$(CC) CFLAGS="$(CFLAGS)" all
Wall:
@$(MAKE) clean
@@ -131,7 +131,7 @@
$O/lat_pagefault: lat_pagefault.c timing.c bench.h
if [ $O = ../bin/linux -o $O = ../bin/bsd ]; \
- then cp /bin/true $O/lat_pagefault; \
+ then cp /usr/bin/true $O/lat_pagefault; \
else $(COMPILE) -o $O/lat_pagefault lat_pagefault.c $(LDLIBS); \
fi