MFH: r473910 r473925 r474258 r474906
Updated gitlab to 11.0.2. For detailed list of changes please see here: https://about.gitlab.com/2018/06/22/gitlab-11-0-released/ Please make sure before you upgrade you read the entry in UPDATING. Reviewed by: swills (mentor) Approved by: swills (mentor) Differential Revision: https://reviews.freebsd.org/D16127 Renamed gitlab to gitlab-ce in Makefile. PR: 229519 Reported by: Trond.Endrestol@ximalas.info Reviewed by: swills (mentor) Approved by: swills (mentor) Differential Revision: https://reviews.freebsd.org/D16127 Upgrade gitlab to 11.0.3 and fix problem with sidekiq-cron reported by swills which requires rubygem-rufus-scheduler version 3.4.0, alle other newer versions are failing. PR: 229557 Reported by: swills Reviewed by: tz (mentor) Approved by: tz (mentor) Differential Revision: https://reviews.freebsd.org/D16160 Made it possible to use another PREFIX for gitlab-ce. Reviewed by: swills (mentor) Approved by: swills (mentor) Differential Revision: https://reviews.freebsd.org/D16266 Approved by: ports-secteam (miwi)
This commit is contained in:
parent
f24fa7ef4e
commit
70ccba0215
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/branches/2018Q3/; revision=474954
1
MOVED
1
MOVED
@ -10294,3 +10294,4 @@ www/libxul||2018-06-22|Has expired: NPAPI are no longer supported
|
||||
mail/postfix211||2018-06-24|Has expired: Not supported anymore by vendor. Please choose a new one version
|
||||
mail/postfix211-sasl||2018-06-24|Has expired: Not supported anymore by vendor. Please choose a new one version
|
||||
devel/py-binplist||2018-06-26|Has expired: Not depended upon anymore, no longer maintained upstream
|
||||
www/gitlab|www/gitlab-ce|2018-07-04|Port renamed to match name on gitlab.org
|
||||
|
17
UPDATING
17
UPDATING
@ -5,6 +5,23 @@ they are unavoidable.
|
||||
You should get into the habit of checking this file for changes each time
|
||||
you update your ports collection, before attempting any port upgrades.
|
||||
|
||||
20180704:
|
||||
AFFECTS: users of www/gitlab
|
||||
AUTHOR: mfechner@FreeBSD.org
|
||||
|
||||
The gitlab port uses the package from gitlab.org instead of github.org.
|
||||
For this the port was renamed from gitlab to gitlab-ce.
|
||||
Please follow the instructions very carefully to not lose your data!
|
||||
Not only the package was renamed, also the directory name changed.
|
||||
|
||||
You can find the current instruction here:
|
||||
https://gitlab.fechner.net/mfechner/Gitlab-docu/blob/master/update/10.8-11.0-freebsd.md
|
||||
|
||||
Please note the update was only tested for an update from 10.8.5 to 11.0.2.
|
||||
If your version of gitlab was released before 2014-03-13 you cannot update
|
||||
to this version. You need to make an intermediate update to an earlier
|
||||
version before.
|
||||
|
||||
20180701:
|
||||
AFFECTS: users of devel/bats
|
||||
AUTHOR: lifanov@FreeBSD.org
|
||||
|
@ -200,7 +200,7 @@
|
||||
SUBDIR += getleft
|
||||
SUBDIR += gist
|
||||
SUBDIR += gitea
|
||||
SUBDIR += gitlab
|
||||
SUBDIR += gitlab-ce
|
||||
SUBDIR += gitlab-pages
|
||||
SUBDIR += gitlab-workhorse
|
||||
SUBDIR += glassfish
|
||||
|
@ -1,9 +1,8 @@
|
||||
# Created by: Torsten Zuehlsdorff <tz@FreeBSD.org>
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= gitlab
|
||||
PORTVERSION= 10.8.5
|
||||
DISTVERSIONPREFIX= v
|
||||
PORTNAME= gitlab-ce
|
||||
PORTVERSION= 11.0.3
|
||||
CATEGORIES= www devel
|
||||
|
||||
MAINTAINER= mfechner@FreeBSD.org
|
||||
@ -25,9 +24,9 @@ BUILD_DEPENDS= gem:devel/ruby-gems
|
||||
# only rubygem-pg and rubygem-mysql are defined later as RUN_DEPENDS
|
||||
# for the options
|
||||
RUN_DEPENDS= git>=2.16.2:devel/git \
|
||||
gitlab-shell>=7.1.2:devel/gitlab-shell \
|
||||
gitlab-workhorse>=4.1.0:www/gitlab-workhorse \
|
||||
gitaly>=0.100.0:devel/gitaly \
|
||||
gitlab-shell>=7.1.4:devel/gitlab-shell \
|
||||
gitlab-workhorse>=4.3.1:www/gitlab-workhorse \
|
||||
gitaly>=0.105.0:devel/gitaly \
|
||||
gitlab-pages>=0.9.1:www/gitlab-pages \
|
||||
redis>=2.8.23:databases/redis \
|
||||
npm>=4.3.0:www/npm \
|
||||
@ -38,7 +37,7 @@ RUN_DEPENDS= git>=2.16.2:devel/git \
|
||||
rubygem-sprockets3>=3.7:devel/rubygem-sprockets3 \
|
||||
rubygem-default_value_for30>=3.0.5:devel/rubygem-default_value_for30 \
|
||||
rubygem-rugged>=0.27.0:devel/rubygem-rugged \
|
||||
rubygem-grape-route-helpers>=2.1.0:devel/rubygem-grape-route-helpers \
|
||||
rubygem-grape-path-helpers>=1.0:devel/rubygem-grape-path-helpers \
|
||||
rubygem-faraday>=0.12.0:www/rubygem-faraday \
|
||||
rubygem-devise>=4.4:devel/rubygem-devise \
|
||||
rubygem-doorkeeper>=4.3:security/rubygem-doorkeeper \
|
||||
@ -57,7 +56,7 @@ RUN_DEPENDS= git>=2.16.2:devel/git \
|
||||
rubygem-omniauth-shibboleth12>=1.2.0:security/rubygem-omniauth-shibboleth12 \
|
||||
rubygem-omniauth-twitter>=1.4:net/rubygem-omniauth-twitter \
|
||||
rubygem-omniauth_crowd22>=2.2.0:devel/rubygem-omniauth_crowd22 \
|
||||
rubygem-omniauth-authentiq>=0.3.1:net/rubygem-omniauth-authentiq \
|
||||
rubygem-omniauth-authentiq>=0.3.3:net/rubygem-omniauth-authentiq \
|
||||
rubygem-rack-oauth212>=1.2.1:security/rubygem-rack-oauth212 \
|
||||
rubygem-jwt1>=1.5.6:www/rubygem-jwt1 \
|
||||
rubygem-recaptcha3>=3.0:devel/rubygem-recaptcha3 \
|
||||
@ -77,10 +76,13 @@ RUN_DEPENDS= git>=2.16.2:devel/git \
|
||||
rubygem-grape>=1.0:devel/rubygem-grape \
|
||||
rubygem-grape-entity>=0.7.1:devel/rubygem-grape-entity \
|
||||
rubygem-rack-cors>=1.0.0:www/rubygem-rack-cors \
|
||||
rubygem-graphql>=1.8.0:devel/rubygem-graphql \
|
||||
rubygem-graphiql-rails>=1.4.10:devel/rubygem-graphiql-rails \
|
||||
rubygem-hashie-forbidden_attributes>=0:devel/rubygem-hashie-forbidden_attributes \
|
||||
rubygem-kaminari-rails4>=1.0:www/rubygem-kaminari-rails4 \
|
||||
rubygem-hamlit26>=2.6.1:www/rubygem-hamlit26 \
|
||||
rubygem-carrierwave>=1.1:www/rubygem-carrierwave \
|
||||
rubygem-mini_magick>=0:graphics/rubygem-mini_magick \
|
||||
rubygem-dropzonejs-rails07>=0.7.1:www/rubygem-dropzonejs-rails07 \
|
||||
rubygem-fog-aws2>=2.0.1:net/rubygem-fog-aws2 \
|
||||
rubygem-fog-core1>=1.44:devel/rubygem-fog-core1 \
|
||||
@ -98,7 +100,7 @@ RUN_DEPENDS= git>=2.16.2:devel/git \
|
||||
rubygem-redcarpet>=3.4:textproc/rubygem-redcarpet \
|
||||
rubygem-commonmarker>=0.17:textproc/rubygem-commonmarker \
|
||||
rubygem-redcloth>=4.3.2:www/rubygem-redcloth \
|
||||
rubygem-rdoc>=4.2:devel/rubygem-rdoc \
|
||||
rubygem-rdoc>=6.0:devel/rubygem-rdoc \
|
||||
rubygem-org-ruby>=0.9.12:textproc/rubygem-org-ruby \
|
||||
rubygem-creole>=0.5.0:textproc/rubygem-creole \
|
||||
rubygem-wikicloth081>=0.8.1:textproc/rubygem-wikicloth081 \
|
||||
@ -108,18 +110,20 @@ RUN_DEPENDS= git>=2.16.2:devel/git \
|
||||
rubygem-truncato>=0.7.9:textproc/rubygem-truncato \
|
||||
rubygem-bootstrap_form>=2.7.0:devel/rubygem-bootstrap_form \
|
||||
rubygem-nokogiri>=1.8.2:textproc/rubygem-nokogiri \
|
||||
rubygem-icalendar>=0:devel/rubygem-icalendar \
|
||||
rubygem-diffy31>=3.1.0:textproc/rubygem-diffy31 \
|
||||
rubygem-unicorn51>=5.1.0:www/rubygem-unicorn51 \
|
||||
rubygem-unicorn-worker-killer044>=0.4.4:www/rubygem-unicorn-worker-killer044 \
|
||||
rubygem-state_machines-activerecord>=0.5.1:databases/rubygem-state_machines-activerecord \
|
||||
rubygem-acts-as-taggable-on>=5.0:www/rubygem-acts-as-taggable-on \
|
||||
rubygem-sidekiq>=5.0.0:devel/rubygem-sidekiq \
|
||||
rubygem-sidekiq>=5.1.0:devel/rubygem-sidekiq \
|
||||
rubygem-sidekiq-cron>=0.6.0:devel/rubygem-sidekiq-cron \
|
||||
rubygem-redis-namespace15>=1.5.2:databases/rubygem-redis-namespace15 \
|
||||
rubygem-redis-namespace>=1.6.0:databases/rubygem-redis-namespace \
|
||||
rubygem-sidekiq-limit_fetch>=3.4:devel/rubygem-sidekiq-limit_fetch \
|
||||
rubygem-rufus-scheduler>=3.4.0:devel/rubygem-rufus-scheduler \
|
||||
rubygem-rufus-scheduler342>=3.4.0:devel/rubygem-rufus-scheduler342 \
|
||||
rubygem-httparty>=0.13.3:www/rubygem-httparty \
|
||||
rubygem-rainbow2>=2.2:devel/rubygem-rainbow2 \
|
||||
rubygem-ruby-progressbar>=0:devel/rubygem-ruby-progressbar \
|
||||
rubygem-settingslogic>=2.0.9:devel/rubygem-settingslogic \
|
||||
rubygem-re2>=1.1.1:devel/rubygem-re2 \
|
||||
rubygem-version_sorter21>=2.1.0:textproc/rubygem-version_sorter21 \
|
||||
@ -134,8 +138,7 @@ RUN_DEPENDS= git>=2.16.2:devel/git \
|
||||
rubygem-slack-notifier1>=1.5.1:devel/rubygem-slack-notifier1 \
|
||||
rubygem-asana>=0.6.0:www/rubygem-asana \
|
||||
rubygem-ruby-fogbugz>=0.2.1:devel/rubygem-ruby-fogbugz \
|
||||
rubygem-kubeclient>=3.0.0:www/rubygem-kubeclient \
|
||||
rubygem-d3_rails-rails4>=3.5.0:www/rubygem-d3_rails-rails4 \
|
||||
rubygem-kubeclient>=3.1.0:www/rubygem-kubeclient \
|
||||
rubygem-sanitize>=4.6.5:textproc/rubygem-sanitize \
|
||||
rubygem-babosa>=1.0.2:textproc/rubygem-babosa \
|
||||
rubygem-loofah>=2.2:textproc/rubygem-loofah \
|
||||
@ -144,7 +147,6 @@ RUN_DEPENDS= git>=2.16.2:devel/git \
|
||||
rubygem-ace-rails-ap>=4.1.0:www/rubygem-ace-rails-ap \
|
||||
rubygem-mousetrap-rails>=1.4.6:www/rubygem-mousetrap-rails \
|
||||
rubygem-charlock_holmes>=0.7.5:textproc/rubygem-charlock_holmes \
|
||||
rubygem-oj2>=2.17.4:devel/rubygem-oj2 \
|
||||
rubygem-fast_blank>=0:devel/rubygem-fast_blank \
|
||||
rubygem-chronic>=0.10.2:devel/rubygem-chronic \
|
||||
rubygem-chronic_duration>=0.10.6:devel/rubygem-chronic_duration \
|
||||
@ -153,10 +155,9 @@ RUN_DEPENDS= git>=2.16.2:devel/git \
|
||||
rubygem-sass-rails-rails4>=5.0.6:textproc/rubygem-sass-rails-rails4 \
|
||||
rubygem-uglifier27>=2.7.2:www/rubygem-uglifier27 \
|
||||
rubygem-addressable>=2.5.2:www/rubygem-addressable \
|
||||
rubygem-bootstrap-sass>=3.3.0:www/rubygem-bootstrap-sass \
|
||||
rubygem-font-awesome-rails-rails4>=4.7:devel/rubygem-font-awesome-rails-rails4 \
|
||||
rubygem-gemojione>=3.3:graphics/rubygem-gemojione \
|
||||
rubygem-gon61>=6.1.0:www/rubygem-gon61 \
|
||||
rubygem-gon>=6.2.0:www/rubygem-gon \
|
||||
rubygem-jquery-atwho-rails13>=1.3.2:www/rubygem-jquery-atwho-rails13 \
|
||||
rubygem-request_store>=1.3:devel/rubygem-request_store \
|
||||
rubygem-select2-rails3>=3.5.9:www/rubygem-select2-rails3 \
|
||||
@ -176,7 +177,7 @@ RUN_DEPENDS= git>=2.16.2:devel/git \
|
||||
rubygem-peek-redis>=1.2.0:devel/rubygem-peek-redis \
|
||||
rubygem-peek-sidekiq>=1.0.3:devel/rubygem-peek-sidekiq \
|
||||
rubygem-prometheus-client-mmap>=0.9.3:devel/rubygem-prometheus-client-mmap \
|
||||
rubygem-octokit>=4.8:net/rubygem-octokit \
|
||||
rubygem-octokit>=4.9:net/rubygem-octokit \
|
||||
rubygem-mail_room>=0.9.1:mail/rubygem-mail_room \
|
||||
rubygem-email_reply_trimmer>=0.1:mail/rubygem-email_reply_trimmer \
|
||||
rubygem-html2text>=0:textproc/rubygem-html2text \
|
||||
@ -185,12 +186,11 @@ RUN_DEPENDS= git>=2.16.2:devel/git \
|
||||
rubygem-health_check26>=2.6.0:devel/rubygem-health_check26 \
|
||||
rubygem-vmstat>=2.3.0:sysutils/rubygem-vmstat \
|
||||
rubygem-sys-filesystem>=1.1.6:sysutils/rubygem-sys-filesystem \
|
||||
rubygem-net-ssh4>=4.2.0:security/rubygem-net-ssh4 \
|
||||
rubygem-net-ssh>=5.0:security/rubygem-net-ssh \
|
||||
rubygem-sshkey>=1.9.0:security/rubygem-sshkey \
|
||||
rubygem-rbnacl4<=4.0.2:security/rubygem-rbnacl4 \
|
||||
rubygem-rbnacl-libsodium>=0:security/rubygem-rbnacl-libsodium \
|
||||
rubygem-ed25519>=1.2:security/rubygem-ed25519 \
|
||||
rubygem-bcrypt_pbkdf>=1.0:security/rubygem-bcrypt_pbkdf \
|
||||
rubygem-gitaly-proto099>=0.99.0:net/rubygem-gitaly-proto099 \
|
||||
rubygem-gitaly-proto>=0.101.0:net/rubygem-gitaly-proto \
|
||||
rubygem-grpc>=1.11.0:net/rubygem-grpc \
|
||||
rubygem-gitaly>=0.8.0:net/rubygem-gitaly \
|
||||
rubygem-google-protobuf351>=3.5.1:devel/rubygem-google-protobuf351 \
|
||||
@ -200,7 +200,7 @@ RUN_DEPENDS= git>=2.16.2:devel/git \
|
||||
rubygem-flipper-active_support_cache_store013>=0.13.0:devel/rubygem-flipper-active_support_cache_store013 \
|
||||
rubygem-lograge>=0.5:www/rubygem-lograge \
|
||||
rubygem-grape_logging>=1.7:devel/rubygem-grape_logging \
|
||||
rubygem-asset_sync220>=2.2.0:net/rubygem-asset_sync220
|
||||
rubygem-asset_sync>=2.4:net/rubygem-asset_sync
|
||||
|
||||
PGSQL_RUN_DEPENDS= rubygem-pg018>=0.18.2:databases/rubygem-pg018 \
|
||||
rubygem-peek-pg>=1.3.0:databases/rubygem-peek-pg
|
||||
@ -210,9 +210,10 @@ MYSQL_RUN_DEPENDS= rubygem-mysql2>=0.4.5:databases/rubygem-mysql2 \
|
||||
USE_RUBY= yes
|
||||
|
||||
USE_RC_SUBR= gitlab
|
||||
USE_GITHUB= yes
|
||||
GH_ACCOUNT= gitlabhq
|
||||
GH_PROJECT= gitlabhq
|
||||
USE_GITLAB= yes
|
||||
GL_ACCOUNT= gitlab-org
|
||||
# Find the here: https://gitlab.com/gitlab-org/gitlab-ce/tags
|
||||
GL_COMMIT= aa6207551b023ecba0dba332c6358e1007f4b0eb
|
||||
|
||||
USERS= git
|
||||
GROUPS= git
|
||||
@ -220,6 +221,12 @@ GROUPS= git
|
||||
NO_ARCH= yes
|
||||
NO_BUILD= yes
|
||||
|
||||
post-patch:
|
||||
${REINPLACE_CMD} -e "s|%%PREFIX%%|${PREFIX}|" ${WRKSRC}/config/gitlab.yml.example \
|
||||
${WRKSRC}/config/unicorn.rb.example \
|
||||
${WRKSRC}/lib/support/nginx/gitlab \
|
||||
${WRKSRC}/lib/support/nginx/gitlab-ssl
|
||||
|
||||
post-patch-MYSQL-on:
|
||||
${CP} ${WRKSRC}/config/database.yml.mysql ${WRKSRC}/config/database.yml.sample
|
||||
|
3
www/gitlab-ce/distinfo
Normal file
3
www/gitlab-ce/distinfo
Normal file
@ -0,0 +1,3 @@
|
||||
TIMESTAMP = 1530814728
|
||||
SHA256 (gitlab-org-gitlab-ce-aa6207551b023ecba0dba332c6358e1007f4b0eb_GL0.tar.gz) = b3e32c199deca93729eed2c6b20fb23b35962fcbc249045a89abea7e05342782
|
||||
SIZE (gitlab-org-gitlab-ce-aa6207551b023ecba0dba332c6358e1007f4b0eb_GL0.tar.gz) = 49743048
|
@ -24,7 +24,7 @@
|
||||
#
|
||||
# gitlab_enable="YES"
|
||||
|
||||
PATH="/sbin:/bin:/usr/sbin:/usr/bin:/usr/local/sbin:/usr/local/bin"
|
||||
PATH="/sbin:/bin:/usr/sbin:/usr/bin:%%LOCALBASE%%/sbin:%%LOCALBASE%%/bin"
|
||||
|
||||
. /etc/rc.subr
|
||||
|
||||
@ -51,7 +51,7 @@ RAILS_ENV="production"
|
||||
# Script variable names should be lower-case not to conflict with
|
||||
# internal /bin/sh variables such as PATH, EDITOR or SHELL.
|
||||
app_user="git"
|
||||
app_root="/usr/local/www/gitlab"
|
||||
app_root="%%PREFIX%%/www/gitlab-ce"
|
||||
pid_path="$app_root/tmp/pids"
|
||||
socket_path="$app_root/tmp/sockets"
|
||||
rails_socket="$socket_path/gitlab.socket"
|
||||
@ -79,7 +79,7 @@ gitlab_pages_options="-pages-domain example.com -pages-root $app_root/shared/pag
|
||||
gitlab_pages_log="$app_root/log/gitlab-pages.log"
|
||||
shell_path="/bin/bash"
|
||||
gitaly_enabled=true
|
||||
gitaly_dir="/usr/local/share/gitaly"
|
||||
gitaly_dir="%%PREFIX%%/share/gitaly"
|
||||
gitaly_pid_path="$pid_path/gitaly.pid"
|
||||
gitaly_log="$app_root/log/gitaly.log"
|
||||
|
||||
@ -91,18 +91,18 @@ if [ "$USER" != "$app_user" ]; then
|
||||
# Regenerate the Gemfile.lock for all related products
|
||||
echo "Regenerate Gitlab Gemfile.lock"
|
||||
rm -f "${app_root}"/Gemfile.lock
|
||||
if ! su -l ${app_user} -c "cd ${app_root} && /usr/local/bin/bundle install --local --quiet"; then
|
||||
if ! su -l ${app_user} -c "cd ${app_root} && %%LOCALBASE%%/bin/bundle install --local --quiet"; then
|
||||
echo "Could not create Gemfile.lock for gitlab, please report this using FreeBSD Bugtracker, https://bugs.freebsd.org/"
|
||||
exit 1
|
||||
fi
|
||||
echo "Regenerate Gitaly Gemfile.lock"
|
||||
rm -f "${gitaly_dir}"/ruby/Gemfile.lock
|
||||
if ! su -l root -c "cd ${gitaly_dir}/ruby && /usr/local/bin/bundle install --local --quiet"; then
|
||||
if ! su -l root -c "cd ${gitaly_dir}/ruby && %%LOCALBASE%%/bin/bundle install --local --quiet"; then
|
||||
echo "Could not create Gemfile.lock for gitaly, please report this using FreeBSD Bugtracker, https://bugs.freebsd.org/"
|
||||
exit 1
|
||||
fi
|
||||
|
||||
eval su - "$app_user" -c $(echo \")/usr/local/etc/rc.d/gitlab "$@"$(echo \"); exit;
|
||||
eval su - "$app_user" -c $(echo \")%%LOCALBASE%%/etc/rc.d/gitlab "$@"$(echo \"); exit;
|
||||
fi
|
||||
|
||||
# Switch to the gitlab path, exit on failure.
|
@ -1,4 +1,4 @@
|
||||
--- Gemfile.orig 2018-06-20 17:48:20 UTC
|
||||
--- Gemfile.orig 2018-06-21 15:14:17 UTC
|
||||
+++ Gemfile
|
||||
@@ -24,7 +24,7 @@ gem 'sprockets', '~> 3.7.0'
|
||||
gem 'default_value_for', gem_versions['default_value_for']
|
||||
@ -9,7 +9,7 @@
|
||||
gem 'pg', '~> 0.18.2', group: :postgres
|
||||
|
||||
gem 'rugged', '~> 0.27'
|
||||
@@ -118,7 +118,7 @@ gem 'fog-rackspace', '~> 0.1.1'
|
||||
@@ -123,7 +123,7 @@ gem 'fog-rackspace', '~> 0.1.1'
|
||||
gem 'fog-aliyun', '~> 0.2.0'
|
||||
|
||||
# for Google storage
|
||||
@ -18,7 +18,7 @@
|
||||
|
||||
# for aws storage
|
||||
gem 'unf', '~> 0.1.4'
|
||||
@@ -169,7 +169,7 @@ gem 'sidekiq-limit_fetch', '~> 3.4', req
|
||||
@@ -177,7 +177,7 @@ gem 'sidekiq-limit_fetch', '~> 3.4', req
|
||||
gem 'rufus-scheduler', '~> 3.4'
|
||||
|
||||
# HTTP requests
|
||||
@ -27,7 +27,7 @@
|
||||
|
||||
# Colored output to console
|
||||
gem 'rainbow', '~> 2.2'
|
||||
@@ -284,7 +284,7 @@ gem 'batch-loader', '~> 1.2.1'
|
||||
@@ -291,7 +291,7 @@ gem 'batch-loader', '~> 1.2.1'
|
||||
# Perf bar
|
||||
gem 'peek', '~> 1.0.1'
|
||||
gem 'peek-gc', '~> 0.0.2'
|
||||
@ -36,7 +36,7 @@
|
||||
gem 'peek-pg', '~> 1.3.0', group: :postgres
|
||||
gem 'peek-rblineprof', '~> 0.2.0'
|
||||
gem 'peek-redis', '~> 1.2.0'
|
||||
@@ -292,99 +292,11 @@ gem 'peek-sidekiq', '~> 1.0.3'
|
||||
@@ -299,96 +299,11 @@ gem 'peek-sidekiq', '~> 1.0.3'
|
||||
|
||||
# Metrics
|
||||
group :metrics do
|
||||
@ -69,15 +69,13 @@
|
||||
- gem 'pry-byebug', '~> 3.4.1', platform: :mri
|
||||
- gem 'pry-rails', '~> 0.3.4'
|
||||
-
|
||||
- gem 'awesome_print', '~> 1.2.0', require: false
|
||||
- gem 'awesome_print', require: false
|
||||
- gem 'fuubar', '~> 2.2.0'
|
||||
-
|
||||
- gem 'database_cleaner', '~> 1.5.0'
|
||||
- gem 'factory_bot_rails', '~> 4.8.2'
|
||||
- gem 'rspec-rails', '~> 3.6.0'
|
||||
- gem 'rspec-retry', '~> 0.4.5'
|
||||
- gem 'spinach-rails', '~> 0.2.1'
|
||||
- gem 'spinach-rerun-reporter', '~> 0.0.2'
|
||||
- gem 'rspec_profiling', '~> 0.0.5'
|
||||
- gem 'rspec-set', '~> 0.1.3'
|
||||
- gem 'rspec-parameterized', require: false
|
||||
@ -90,11 +88,10 @@
|
||||
-
|
||||
- gem 'capybara', '~> 2.15'
|
||||
- gem 'capybara-screenshot', '~> 1.0.0'
|
||||
- gem 'selenium-webdriver', '~> 3.5'
|
||||
- gem 'selenium-webdriver', '~> 3.12'
|
||||
-
|
||||
- gem 'spring', '~> 2.0.0'
|
||||
- gem 'spring-commands-rspec', '~> 1.0.4'
|
||||
- gem 'spring-commands-spinach', '~> 1.1.0'
|
||||
-
|
||||
- gem 'gitlab-styles', '~> 2.3', require: false
|
||||
- # Pin these dependencies, otherwise a new rule could break the CI pipelines
|
||||
@ -123,7 +120,7 @@
|
||||
-
|
||||
-group :test do
|
||||
- gem 'shoulda-matchers', '~> 3.1.2', require: false
|
||||
- gem 'email_spec', '~> 1.6.0'
|
||||
- gem 'email_spec', '~> 2.2.0'
|
||||
- gem 'json-schema', '~> 2.8.0'
|
||||
- gem 'webmock', '~> 2.3.2'
|
||||
- gem 'rails-controller-testing' if rails5? # Rails5 only gem.
|
||||
@ -133,6 +130,15 @@
|
||||
- gem 'test-prof', '~> 0.2.5'
|
||||
-end
|
||||
-
|
||||
gem 'octokit', '~> 4.8'
|
||||
gem 'octokit', '~> 4.9'
|
||||
|
||||
gem 'mail_room', '~> 0.9.1'
|
||||
@@ -419,7 +334,7 @@ group :ed25519 do
|
||||
end
|
||||
|
||||
# Gitaly GRPC client
|
||||
-gem 'gitaly-proto', '~> 0.100.0', require: 'gitaly'
|
||||
+gem 'gitaly-proto', '~> 0.101.0', require: 'gitaly'
|
||||
gem 'grpc', '~> 1.11.0'
|
||||
|
||||
# Locked until https://github.com/google/protobuf/issues/4210 is closed
|
@ -1,42 +1,42 @@
|
||||
--- config/gitlab.yml.example.orig 2018-06-06 20:30:27 UTC
|
||||
--- config/gitlab.yml.example.orig 2018-06-21 15:14:17 UTC
|
||||
+++ config/gitlab.yml.example
|
||||
@@ -213,7 +213,7 @@ production: &base
|
||||
@@ -218,7 +218,7 @@ production: &base
|
||||
# external_http: ["1.1.1.1:80", "[2001::1]:80"] # If defined, enables custom domain support in GitLab Pages
|
||||
# external_https: ["1.1.1.1:443", "[2001::1]:443"] # If defined, enables custom domain and certificate support in GitLab Pages
|
||||
admin:
|
||||
- address: unix:/home/git/gitlab/tmp/sockets/private/pages-admin.socket # TCP connections are supported too (e.g. tcp://host:port)
|
||||
+ address: unix:/usr/local/www/gitlab/tmp/sockets/private/pages-admin.socket # TCP connections are supported too (e.g. tcp://host:port)
|
||||
+ address: unix:%%PREFIX%%/www/gitlab-ce/tmp/sockets/private/pages-admin.socket # TCP connections are supported too (e.g. tcp://host:port)
|
||||
|
||||
## Mattermost
|
||||
## For enabling Add to Mattermost button
|
||||
@@ -572,7 +572,7 @@ production: &base
|
||||
@@ -577,7 +577,7 @@ production: &base
|
||||
# Gitaly settings
|
||||
gitaly:
|
||||
# Path to the directory containing Gitaly client executables.
|
||||
- client_path: /home/git/gitaly/bin
|
||||
+ client_path: /usr/local/share/gitaly/bin
|
||||
+ client_path: %%PREFIX%%/share/gitaly/bin
|
||||
# Default Gitaly authentication token. Can be overriden per storage. Can
|
||||
# be left blank when Gitaly is running locally on a Unix socket, which
|
||||
# is the normal way to deploy Gitaly.
|
||||
@@ -590,8 +590,8 @@ production: &base
|
||||
@@ -595,8 +595,8 @@ production: &base
|
||||
# real path not the symlink.
|
||||
storages: # You must have at least a `default` storage path.
|
||||
default:
|
||||
- path: /home/git/repositories/
|
||||
- gitaly_address: unix:/home/git/gitlab/tmp/sockets/private/gitaly.socket # TCP connections are supported too (e.g. tcp://host:port)
|
||||
+ path: /usr/home/git/repositories/
|
||||
+ gitaly_address: unix:/usr/local/www/gitlab/tmp/sockets/private/gitaly.socket # TCP connections are supported too (e.g. tcp://host:port)
|
||||
+ gitaly_address: unix:%%PREFIX%%/www/gitlab-ce/tmp/sockets/private/gitaly.socket # TCP connections are supported too (e.g. tcp://host:port)
|
||||
# gitaly_token: 'special token' # Optional: override global gitaly.token for this storage.
|
||||
|
||||
## Backup settings
|
||||
@@ -619,12 +619,12 @@ production: &base
|
||||
@@ -624,12 +624,12 @@ production: &base
|
||||
|
||||
## GitLab Shell settings
|
||||
gitlab_shell:
|
||||
- path: /home/git/gitlab-shell/
|
||||
- hooks_path: /home/git/gitlab-shell/hooks/
|
||||
+ path: /usr/local/share/gitlab-shell/
|
||||
+ hooks_path: /usr/local/share/gitlab-shell/hooks/
|
||||
+ path: %%PREFIX%%/share/gitlab-shell/
|
||||
+ hooks_path: %%PREFIX/share/gitlab-shell/hooks/
|
||||
|
||||
# File that contains the secret key for verifying access for gitlab-shell.
|
||||
# Default is '.gitlab_shell_secret' relative to Rails.root (i.e. root of the GitLab app).
|
||||
@ -45,12 +45,12 @@
|
||||
|
||||
# Git over HTTP
|
||||
upload_pack: true
|
||||
@@ -645,7 +645,7 @@ production: &base
|
||||
@@ -650,7 +650,7 @@ production: &base
|
||||
# CAUTION!
|
||||
# Use the default values unless you really know what you are doing
|
||||
git:
|
||||
- bin_path: /usr/bin/git
|
||||
+ bin_path: /usr/local/bin/git
|
||||
+ bin_path: %%PREFIX%%/bin/git
|
||||
|
||||
## Webpack settings
|
||||
# If enabled, this will tell rails to serve frontend assets from the webpack-dev-server running
|
@ -5,13 +5,13 @@
|
||||
# Help ensure your application will always spawn in the symlinked
|
||||
# "current" directory that Capistrano sets up.
|
||||
-working_directory "/home/git/gitlab" # available in 0.94.0+
|
||||
+working_directory "/usr/local/www/gitlab" # available in 0.94.0+
|
||||
+working_directory "%%PREFIX%%/www/gitlab-ce" # available in 0.94.0+
|
||||
|
||||
# Listen on both a Unix domain socket and a TCP port.
|
||||
# If you are load-balancing multiple Unicorn masters, lower the backlog
|
||||
# setting to e.g. 64 for faster failover.
|
||||
-listen "/home/git/gitlab/tmp/sockets/gitlab.socket", :backlog => 1024
|
||||
+listen "/usr/local/www/gitlab/tmp/sockets/gitlab.socket", :backlog => 1024
|
||||
+listen "%%PREFIX%%/www/gitlab-ce/tmp/sockets/gitlab.socket", :backlog => 1024
|
||||
listen "127.0.0.1:8080", :tcp_nopush => true
|
||||
|
||||
# nuke workers after 30 seconds instead of 60 seconds (the default)
|
||||
@ -20,15 +20,15 @@
|
||||
|
||||
# feel free to point this anywhere accessible on the filesystem
|
||||
-pid "/home/git/gitlab/tmp/pids/unicorn.pid"
|
||||
+pid "/usr/local/www/gitlab/tmp/pids/unicorn.pid"
|
||||
+pid "%%PREFIX%%/www/gitlab-ce/tmp/pids/unicorn.pid"
|
||||
|
||||
# By default, the Unicorn logger will write to stderr.
|
||||
# Additionally, some applications/frameworks log to stderr or stdout,
|
||||
# so prevent them from going to /dev/null when daemonized here:
|
||||
-stderr_path "/home/git/gitlab/log/unicorn.stderr.log"
|
||||
-stdout_path "/home/git/gitlab/log/unicorn.stdout.log"
|
||||
+stderr_path "/usr/local/www/gitlab/log/unicorn.stderr.log"
|
||||
+stdout_path "/usr/local/www/gitlab/log/unicorn.stdout.log"
|
||||
+stderr_path "%%PREFIX%%/www/gitlab-ce/log/unicorn.stderr.log"
|
||||
+stdout_path "%%PREFIX%%/www/gitlab-ce/log/unicorn.stdout.log"
|
||||
|
||||
# combine Ruby 2.0.0dev or REE with "preload_app true" for memory savings
|
||||
# http://rubyenterpriseedition.com/faq.html#adapt_apps_for_cow
|
@ -5,7 +5,7 @@
|
||||
# Gitlab socket file,
|
||||
# for Omnibus this would be: unix:/var/opt/gitlab/gitlab-workhorse/socket
|
||||
- server unix:/home/git/gitlab/tmp/sockets/gitlab-workhorse.socket fail_timeout=0;
|
||||
+ server unix:/usr/local/www/gitlab/tmp/sockets/gitlab-workhorse.socket fail_timeout=0;
|
||||
+ server unix:%%PREFIX%%/www/gitlab-ce/tmp/sockets/gitlab-workhorse.socket fail_timeout=0;
|
||||
}
|
||||
|
||||
map $http_upgrade $connection_upgrade_gitlab {
|
||||
@ -14,7 +14,7 @@
|
||||
# Location to the Gitlab's public directory,
|
||||
# for Omnibus this would be: /opt/gitlab/embedded/service/gitlab-rails/public.
|
||||
- root /home/git/gitlab/public;
|
||||
+ root /usr/local/www/gitlab/public;
|
||||
+ root %%PREFIX%%/www/gitlab-ce/public;
|
||||
internal;
|
||||
}
|
||||
|
@ -5,7 +5,7 @@
|
||||
# Gitlab socket file,
|
||||
# for Omnibus this would be: unix:/var/opt/gitlab/gitlab-workhorse/socket
|
||||
- server unix:/home/git/gitlab/tmp/sockets/gitlab-workhorse.socket fail_timeout=0;
|
||||
+ server unix:/usr/local/www/gitlab/tmp/sockets/gitlab-workhorse.socket fail_timeout=0;
|
||||
+ server unix:%%PREFIX%%/www/gitlab-ce/tmp/sockets/gitlab-workhorse.socket fail_timeout=0;
|
||||
}
|
||||
|
||||
map $http_upgrade $connection_upgrade_gitlab_ssl {
|
||||
@ -14,7 +14,7 @@
|
||||
# Location to the Gitlab's public directory,
|
||||
# for Omnibus this would be: /opt/gitlab/embedded/service/gitlab-rails/public
|
||||
- root /home/git/gitlab/public;
|
||||
+ root /usr/local/www/gitlab/public;
|
||||
+ root %%PREFIX%%/www/gitlab-ce/public;
|
||||
internal;
|
||||
}
|
||||
}
|
@ -7,9 +7,9 @@ follow the instructions in the guide at:
|
||||
https://gitlab.fechner.net/mfechner/Gitlab-docu/blob/master/install/10.8-freebsd.md
|
||||
|
||||
If you just installed an major upgrade of GitLab, for example you
|
||||
switched from 10.7.x to 10.8.x, please follow the instructions in the guide at:
|
||||
switched from 10.8.x to 11.0.x, please follow the instructions in the guide at:
|
||||
|
||||
https://gitlab.fechner.net/mfechner/Gitlab-docu/blob/master/update/10.7-10.8-freebsd.md
|
||||
https://gitlab.fechner.net/mfechner/Gitlab-docu/blob/master/update/10.8-11.0-freebsd.md
|
||||
|
||||
If you just installed an minor upgrade of GitLab please follow
|
||||
the instructions in the guide at:
|
File diff suppressed because it is too large
Load Diff
@ -1,3 +0,0 @@
|
||||
TIMESTAMP = 1529946907
|
||||
SHA256 (gitlabhq-gitlabhq-v10.8.5_GH0.tar.gz) = 3ed384557531485ae79f6549c6e8738ee8b0ee859f729b617bf4a58b3cec0006
|
||||
SIZE (gitlabhq-gitlabhq-v10.8.5_GH0.tar.gz) = 48454668
|
@ -1,11 +0,0 @@
|
||||
--- app/uploaders/object_storage.rb.orig 2018-05-31 10:45:20 UTC
|
||||
+++ app/uploaders/object_storage.rb
|
||||
@@ -11,7 +11,7 @@ module ObjectStorage
|
||||
ObjectStorageUnavailable = Class.new(StandardError)
|
||||
|
||||
DIRECT_UPLOAD_TIMEOUT = 4.hours
|
||||
- TMP_UPLOAD_PATH = 'tmp/upload'.freeze
|
||||
+ TMP_UPLOAD_PATH = 'tmp/uploads'.freeze
|
||||
|
||||
module Store
|
||||
LOCAL = 1
|
Loading…
Reference in New Issue
Block a user