- Update to 0.82

- Fix packages
This commit is contained in:
Pav Lucistnik 2004-04-28 22:57:58 +00:00
parent 13b89e0f9b
commit 70b88ad66f
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=107894
7 changed files with 30 additions and 4 deletions

View File

@ -12,6 +12,8 @@ COMMENT= Multisync backup plugin
RUN_DEPENDS= multisync:${PORTSDIR}/deskutils/multisync
MD5_FILE= ${MASTERDIR}/distinfo
PATCHDIR= ${.CURDIR}/files
PLIST= ${.CURDIR}/pkg-plist
WRKSRC= ${WRKDIR}/multisync-${PORTVERSION}/plugins/backup_plugin

View File

@ -9,11 +9,13 @@ PORTNAME= multisync-evolution
MAINTAINER= pav@FreeBSD.org
COMMENT= Evolution synchronization plugin for Multisync
BUILD_DEPENDS= evolution:${PORTSDIR}/mail/evolution
RUN_DEPENDS= multisync:${PORTSDIR}/deskutils/multisync \
evolution:${PORTSDIR}/mail/evolution
MD5_FILE= ${MASTERDIR}/distinfo
PATCHDIR= ${.CURDIR}/files
PLIST= ${.CURDIR}/pkg-plist
WRKSRC= ${WRKDIR}/multisync-${PORTVERSION}/plugins/evolution_sync

View File

@ -12,6 +12,8 @@ COMMENT= Multisync plugin for SyncML targets
RUN_DEPENDS= multisync:${PORTSDIR}/deskutils/multisync
MD5_FILE= ${MASTERDIR}/distinfo
PATCHDIR= ${.CURDIR}/files
PLIST= ${.CURDIR}/pkg-plist
WRKSRC= ${WRKDIR}/multisync-${PORTVERSION}/plugins/syncml_plugin

View File

@ -5,8 +5,7 @@
# $FreeBSD$
PORTNAME?= multisync
PORTVERSION= 0.81
PORTREVISION= 2
PORTVERSION= 0.82
CATEGORIES= deskutils
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= multisync

View File

@ -1,2 +1,2 @@
MD5 (multisync-0.81.tar.bz2) = e9091a2a1a364f2afb71149928a26c78
SIZE (multisync-0.81.tar.bz2) = 1727892
MD5 (multisync-0.82.tar.bz2) = 499aaa3d41e33276ab162db1d1912a16
SIZE (multisync-0.82.tar.bz2) = 1432473

View File

@ -0,0 +1,19 @@
--- src/syncengine.c.orig Mon Apr 12 06:23:21 2004
+++ src/syncengine.c Thu Apr 29 00:11:08 2004
@@ -1097,6 +1097,7 @@
for (n = 0; n < g_list_length(remotechanges); n++) {
changed_object *robj, *lobj;
char *luid, *uid;
+ sync_compare_result compare;
robj = g_list_nth_data(remotechanges, n);
lobj = g_list_nth_data(localchanges, t);
@@ -1135,7 +1136,7 @@
if (!uid) {*/
// None of the two objects has a UID connection
// If they are equal, just connect them
- sync_compare_result compare =
+ compare =
sync_compare_objects(robj->comp, lobj->comp, lobj->object_type);
if (compare == SYNC_COMPARE_EQUAL) {
sync_insert_idpair(lobj->uid, robj->uid,

View File

@ -1,9 +1,11 @@
bin/multisync
include/multisync/multisync.h
share/gnome/applications/multisync.desktop
share/gnome/multisync/pixmaps/multisync.png
share/gnome/multisync/pixmaps/multisync.xpm
share/gnome/multisync/pixmaps/multisync-16.png
share/gnome/multisync/pixmaps/multisync_small.png
share/gnome/multisync/pixmaps/resync_small.png
@dirrm share/gnome/multisync/pixmaps
@dirrm share/gnome/multisync
@dirrm include/multisync