net-im/nheko: update to latest 0.8.2 release
nheko is a Matrix IM client. Release notes at https://github.com/Nheko-Reborn/nheko/releases/tag/v0.8.2 they are quite extensive as this is a big feature release.
This commit is contained in:
parent
46752077e9
commit
70adcb500a
@ -1,7 +1,6 @@
|
||||
PORTNAME= nheko
|
||||
DISTVERSIONPREFIX=v
|
||||
DISTVERSION= 0.8.1
|
||||
PORTREVISION= 1
|
||||
DISTVERSION= 0.8.2
|
||||
CATEGORIES= net-im
|
||||
|
||||
MAINTAINER= adridg@FreeBSD.org
|
||||
@ -34,24 +33,14 @@ USE_QT= concurrent core dbus declarative gui multimedia network \
|
||||
quickcontrols2 svg widgets \
|
||||
buildtools_build linguist_build qmake_build
|
||||
|
||||
# There are two external dependencies: lmdb++ and tweeny.
|
||||
# There is one external dependencie: lmdb++
|
||||
# - lmdb++ is a single header file, it just needs to be included
|
||||
# - tweeny is a library, but only one header is needed; it is normally
|
||||
# installed into a tweeny/ subdirectory, but its sources place it
|
||||
# in include/. Add one more symlink to the build for that.
|
||||
# We don't actually use the bundled versions, we get them via
|
||||
# the ports system (see GH_TUPLE, below).
|
||||
CMAKE_ARGS= -DLMDBXX_INCLUDE_DIR=${WRKSRC}/deps/lmdb \
|
||||
-DTWEENY_INCLUDE_DIR=${WRKSRC}/deps/tweeny/include \
|
||||
CMAKE_ARGS= -DLMDBXX_INCLUDE_DIR=${WRKSRC}/deps/lmdb
|
||||
CFLAGS+= -DSPDLOG_FMT_EXTERNAL=1
|
||||
LDFLAGS+= -L${LOCALBASE}/lib -lfmt
|
||||
|
||||
USE_GITHUB= yes
|
||||
GH_ACCOUNT= Nheko-Reborn
|
||||
GH_TUPLE= drycpp:lmdbxx:0b43ca87d8cfabba392dfe884eb1edb83874de02:lmdb/deps/lmdb \
|
||||
mobius3:tweeny:6a5033372fe53c4c731c66c8a2d56261746cd85c:tweeny/deps/tweeny
|
||||
|
||||
post-extract:
|
||||
cd ${WRKSRC}/deps/tweeny && ${LN} -s include tweeny
|
||||
GH_TUPLE= hoytech:lmdbxx:029fb681213af3020f5e3a86045445552bd024c5:lmdb/deps/lmdb
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
@ -1,7 +1,5 @@
|
||||
TIMESTAMP = 1611962793
|
||||
SHA256 (Nheko-Reborn-nheko-v0.8.1_GH0.tar.gz) = c9e11b763f39d18a899125678daa7a05cd80aa6acfcad0329485c2034f4a4d27
|
||||
SIZE (Nheko-Reborn-nheko-v0.8.1_GH0.tar.gz) = 1176445
|
||||
SHA256 (drycpp-lmdbxx-0b43ca87d8cfabba392dfe884eb1edb83874de02_GH0.tar.gz) = 93721132bbf5045d38ad62de2997655e9984c48ea5c9886746d42128f4b26fbd
|
||||
SIZE (drycpp-lmdbxx-0b43ca87d8cfabba392dfe884eb1edb83874de02_GH0.tar.gz) = 47524
|
||||
SHA256 (mobius3-tweeny-6a5033372fe53c4c731c66c8a2d56261746cd85c_GH0.tar.gz) = c9fcabcdbeb89e4236bbb773ddacf6293ca2a8618f2b1a67e689e3edb704ecd3
|
||||
SIZE (mobius3-tweeny-6a5033372fe53c4c731c66c8a2d56261746cd85c_GH0.tar.gz) = 49038
|
||||
TIMESTAMP = 1619428220
|
||||
SHA256 (Nheko-Reborn-nheko-v0.8.2_GH0.tar.gz) = df4575c47daab47d418637a4637b599e3848dd749132ca1e92f981d9212eabb2
|
||||
SIZE (Nheko-Reborn-nheko-v0.8.2_GH0.tar.gz) = 1232245
|
||||
SHA256 (hoytech-lmdbxx-029fb681213af3020f5e3a86045445552bd024c5_GH0.tar.gz) = f1d048d7ec720667a3ea091ed44f06eb79171e77d646a59dac45b9e5ff75f33b
|
||||
SIZE (hoytech-lmdbxx-029fb681213af3020f5e3a86045445552bd024c5_GH0.tar.gz) = 52468
|
||||
|
@ -1,55 +0,0 @@
|
||||
--- CMakeLists.txt.orig 2020-04-21 08:42:46 UTC
|
||||
+++ CMakeLists.txt
|
||||
@@ -171,6 +171,9 @@ if(NOT MSVC)
|
||||
endif()
|
||||
endif()
|
||||
|
||||
+# Fix build with Qt 5.13
|
||||
+set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -DQT_NO_DEPRECATED_WARNINGS=Y")
|
||||
+
|
||||
if (MSVC)
|
||||
set(
|
||||
CMAKE_CXX_FLAGS
|
||||
@@ -391,35 +394,14 @@ set_package_properties(nlohmann_json PROPERTIES
|
||||
TYPE REQUIRED
|
||||
)
|
||||
|
||||
-if(USE_BUNDLED_LMDBXX)
|
||||
- hunter_add_package(lmdbxx)
|
||||
- find_package(lmdbxx CONFIG REQUIRED)
|
||||
-else()
|
||||
- if(NOT LMDBXX_INCLUDE_DIR)
|
||||
- find_path(LMDBXX_INCLUDE_DIR
|
||||
- NAMES lmdb++.h
|
||||
- PATHS /usr/include
|
||||
- /usr/local/include
|
||||
- $ENV{LIB_DIR}/include
|
||||
- $ENV{LIB_DIR}/include/lmdbxx)
|
||||
+message(STATUS "Using LMDB: ${LMDBXX_INCLUDE_DIR}")
|
||||
+add_library(lmdbxx INTERFACE)
|
||||
+target_include_directories(lmdbxx INTERFACE ${LMDBXX_INCLUDE_DIR})
|
||||
+add_library(lmdbxx::lmdbxx ALIAS lmdbxx)
|
||||
|
||||
- endif()
|
||||
- add_library(lmdbxx INTERFACE)
|
||||
- target_include_directories(lmdbxx INTERFACE ${LMDBXX_INCLUDE_DIR})
|
||||
- add_library(lmdbxx::lmdbxx ALIAS lmdbxx)
|
||||
-endif()
|
||||
-
|
||||
-if(USE_BUNDLED_TWEENY)
|
||||
- include(FetchContent)
|
||||
- FetchContent_Declare(
|
||||
- Tweeny
|
||||
- GIT_REPOSITORY https://github.com/mobius3/tweeny.git
|
||||
- GIT_TAG 6a5033372fe53c4c731c66c8a2d56261746cd85c #v3 <- v3 has unfixed warnings
|
||||
- )
|
||||
- FetchContent_MakeAvailable(Tweeny)
|
||||
-else()
|
||||
- find_package(Tweeny REQUIRED)
|
||||
-endif()
|
||||
+message(STATUS "Using Tweeny: ${TWEENY_INCLUDE_DIR}")
|
||||
+add_library(tweeny INTERFACE)
|
||||
+target_include_directories(tweeny INTERFACE ${TWEENY_INCLUDE_DIR})
|
||||
|
||||
# single instance functionality
|
||||
set(QAPPLICATION_CLASS QApplication CACHE STRING "Inheritance class for SingleApplication")
|
Loading…
Reference in New Issue
Block a user