- Add PORTSCOUT to ignore old version
- Regenerate patches - Add TIMESTAMP to distinfo PR: 211469 Submitted by: dbaio@bsd.com.br
This commit is contained in:
parent
f518dc45f1
commit
709be99b77
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=420861
@ -18,6 +18,8 @@ LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
|
||||
BUILD_DEPENDS= icont:lang/icon
|
||||
RUN_DEPENDS= iconx:lang/icon
|
||||
|
||||
PORTSCOUT= skipv:2.11
|
||||
|
||||
USES= tar:tgz
|
||||
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}/src
|
||||
INSTALL_TARGET= install-code install-man install-elisp
|
||||
|
@ -1,2 +1,3 @@
|
||||
TIMESTAMP = 1469909017
|
||||
SHA256 (noweb-2.11b.tgz) = c913f26c1edb37e331c747619835b4cade000b54e459bb08f4d38899ab690d82
|
||||
SIZE (noweb-2.11b.tgz) = 738870
|
||||
|
@ -1,5 +1,5 @@
|
||||
--- Makefile.orig 2006-06-12 20:14:20.000000000 +0000
|
||||
+++ Makefile 2014-08-21 23:22:20.000000000 +0000
|
||||
--- Makefile.orig 2006-06-12 20:14:20 UTC
|
||||
+++ Makefile
|
||||
@@ -2,13 +2,14 @@
|
||||
# See file COPYRIGHT for more information.
|
||||
#
|
||||
@ -19,7 +19,7 @@
|
||||
ICONT=icont
|
||||
|
||||
# BIN is where the commands (notangle, noweave, nountangle, noroots) land
|
||||
@@ -18,13 +19,13 @@
|
||||
@@ -18,13 +19,13 @@ ICONT=icont
|
||||
# MAN7EXT is the extension for the nowebstyle man page (usually 7)
|
||||
# TEXINPUTS is the directory for TeX macro files
|
||||
# ELISP is the directory for emacs lisp files, or /dev/null not to install
|
||||
@ -38,7 +38,7 @@
|
||||
|
||||
# change WEAVE if you want a different version of noweave to be installed
|
||||
WEAVE=noweave
|
||||
@@ -37,7 +38,7 @@
|
||||
@@ -37,7 +38,7 @@ MANDIR=$(MAN)/man$(MANEXT)
|
||||
MAN7DIR=$(MAN)/man$(MAN7EXT)
|
||||
CATDIR=$(MAN)/cat$(MANEXT)
|
||||
CAT7DIR=$(MAN)/cat$(MAN7EXT)
|
||||
@ -47,7 +47,7 @@
|
||||
TEXNAME=$(TEXINPUTS)
|
||||
|
||||
all:
|
||||
@@ -179,7 +180,7 @@
|
||||
@@ -179,7 +180,7 @@ install-preformat-man:
|
||||
rm -f $(CATDIR)/nountangle.$(MANEXT).gz
|
||||
(cd $(CATDIR); ln notangle.$(MANEXT).gz nountangle.$(MANEXT).gz)
|
||||
install-tex:
|
||||
@ -56,7 +56,7 @@
|
||||
cp tex/nwmac.tex tex/noweb.sty $(TEXINPUTS)
|
||||
-texhash || echo "Program texhash not found or failed"
|
||||
|
||||
@@ -187,7 +188,7 @@
|
||||
@@ -187,7 +188,7 @@ uninstall-tex:
|
||||
rm -f $(TEXINPUTS)/nwmac.tex $(TEXINPUTS)/noweb.sty
|
||||
|
||||
install-elisp:
|
||||
|
@ -1,6 +1,6 @@
|
||||
--- c/modules.c.orig Wed Mar 28 14:49:00 2001
|
||||
+++ c/modules.c Thu Nov 13 20:15:53 2003
|
||||
@@ -17,7 +17,7 @@
|
||||
--- c/modules.c.orig 2006-06-12 21:16:23 UTC
|
||||
+++ c/modules.c
|
||||
@@ -17,7 +17,7 @@ newmodpart(int type, char *s, Location *
|
||||
|
||||
static
|
||||
void append(Module mp, struct modpart *p);
|
||||
@ -9,7 +9,7 @@
|
||||
static int seekcycle(Module mp, Parent parent);
|
||||
#line 132 "modules.nw"
|
||||
static char *lastfilename = 0;
|
||||
@@ -81,12 +81,12 @@
|
||||
@@ -81,12 +81,12 @@ int expand (Module mp, int indent, int p
|
||||
struct parent thismodule; /* the value only matters when we're expanding a module */
|
||||
|
||||
|
||||
@ -24,7 +24,7 @@
|
||||
if (seekcycle(mp, parent)) {
|
||||
errormsg(Error, "<<%s>>", mp->name);
|
||||
return Error;
|
||||
@@ -111,11 +111,12 @@
|
||||
@@ -111,11 +111,12 @@ if (*(p->contents) != '\0') {
|
||||
#line 157 "modules.nw"
|
||||
; break;
|
||||
case MODULE:
|
||||
@ -39,7 +39,7 @@
|
||||
} else {
|
||||
int retcode;
|
||||
if (*locformat == 0 && partial_distance == 0) {
|
||||
@@ -142,7 +143,7 @@
|
||||
@@ -142,7 +143,7 @@ lastlineno++;
|
||||
}
|
||||
return error;
|
||||
}
|
||||
@ -48,7 +48,7 @@
|
||||
static int seekcycle(Module mp, Parent parent) {
|
||||
if (parent == NULL) {
|
||||
return 0;
|
||||
@@ -155,14 +156,14 @@
|
||||
@@ -155,14 +156,14 @@ static int seekcycle(Module mp, Parent p
|
||||
return 0;
|
||||
}
|
||||
}
|
||||
@ -65,7 +65,7 @@
|
||||
for (p = fmt; *p; p++) {
|
||||
if (*p == '%') {
|
||||
switch (*++p) {
|
||||
@@ -177,35 +178,35 @@
|
||||
@@ -177,35 +178,35 @@ for (p = fmt; *p; p++) {
|
||||
p += 2;
|
||||
} else
|
||||
|
||||
|
@ -1,6 +1,6 @@
|
||||
--- c/modules.nw.orig Wed Mar 28 14:44:00 2001
|
||||
+++ c/modules.nw Mon Nov 10 09:25:05 2003
|
||||
@@ -197,11 +197,17 @@
|
||||
--- c/modules.nw.orig 2006-06-12 21:03:54 UTC
|
||||
+++ c/modules.nw
|
||||
@@ -197,11 +197,17 @@ would be done above for a string of leng
|
||||
out as a special case.
|
||||
This change probably blows the case where the module being expanded is
|
||||
empty.
|
||||
|
@ -1,6 +1,6 @@
|
||||
--- lib/Makefile.orig 2000-06-17 00:25:51.000000000 +0400
|
||||
+++ lib/Makefile 2015-02-26 03:38:28.000000000 +0300
|
||||
@@ -12,7 +12,7 @@
|
||||
--- lib/Makefile.orig 2000-06-16 20:25:51 UTC
|
||||
+++ lib/Makefile
|
||||
@@ -12,7 +12,7 @@ all: toascii
|
||||
|
||||
install: all
|
||||
cp unmarkup emptydefn toascii nwmtime h2a btdefn $(LIB)
|
||||
|
Loading…
Reference in New Issue
Block a user