- Respect CC/CFLAGS

- Support staging

PR:		ports/184845
Submitted by:	KATO Tsuguru <tkato432@yahoo.com>
This commit is contained in:
Pawel Pekala 2013-12-25 13:20:09 +00:00
parent ae7854c559
commit 708626061d
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=337414
2 changed files with 18 additions and 48 deletions

View File

@ -5,21 +5,32 @@ PORTNAME= sectok
PORTVERSION= 20030825
CATEGORIES= security
MASTER_SITES= http://www.citi.umich.edu/projects/smartcard/
DISTNAME= sectok-${PORTVERSION}
EXTRACT_SUFX= .tgz
MAINTAINER= ports@FreeBSD.org
COMMENT= ISO 7816 Smartcard Utility
LIB_DEPENDS= sectok.3:${PORTSDIR}/security/libsectok
LIB_DEPENDS= libsectok.so:${PORTSDIR}/security/libsectok
USE_OPENSSL= yes
USE_LDCONFIG= yes
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
MAN1= sectok.1
PLIST_FILES= bin/sectok
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
PLIST_FILES= bin/${PORTNAME} man/man1/${PORTNAME}.1.gz
post-patch:
@${REINPLACE_CMD} -e \
'/^INCLUDES=/s|$$| $${CPPFLAGS}| ; \
/^LIBS=/s|$$| $${LDFLAGS}| ; \
s|^CC=|CC?=| ; \
s|^CFLAGS=|CFLAGS?=|' ${WRKSRC}/Makefile
do-install:
(cd ${WRKSRC} && ${INSTALL_PROGRAM} ${PORTNAME} \
${STAGEDIR}${PREFIX}/bin)
(cd ${WRKSRC} && ${INSTALL_MAN} ${PORTNAME}.1 \
${STAGEDIR}${MANPREFIX}/man/man1)
NO_STAGE= yes
.include <bsd.port.mk>

View File

@ -1,41 +0,0 @@
--- Makefile.orig Thu Jan 3 21:16:01 2002
+++ Makefile Mon Sep 29 01:00:21 2003
@@ -1,13 +1,19 @@
# Standard installation:
-INCLUDES=
-LIBS= -lsectok -lcrypto
+#INCLUDES=
+#LIBS= -lsectok -lcrypto
+
+# FreeBSD
+#PREFIX?= ${PREFIX}
+#LOCALBASE?= ${LOCALBASE}
+INCLUDES= -I$(LOCALBASE)/include
+LIBS= -L$(LOCALBASE)/lib -lsectok -lcrypto
# For building locally (libsectok not installed)
#INCLUDES= -I../libsectok
#LIBS= ../libsectok/libsectok.a -lcrypto
# If crypto is included with openssl you might need this
-#INCLUDES= -I/usr/include/openssl
+INCLUDES+= -I${OPENSSLINC}
# You shouldn't have to change anything below this line
@@ -17,7 +23,6 @@
CC= gcc
CFLAGS= -g -Wall
INSTALL= install
-PREFIX= /usr/local
RELEASE= sectok-`date "+%Y%m%d"`
all : $(TARGETS)
@@ -30,6 +35,7 @@
install :
$(INSTALL) $(TARGETS) $(PREFIX)/bin
+ $(INSTALL) sectok.1 $(PREFIX)/man/man1
release :
rm -rf $(RELEASE)