- Update to 5.13
PR: ports/154488 Submitted by: chris petrik <c.petrik.sosa@gmail.com>
This commit is contained in:
parent
e82fd02c2e
commit
706aa436e7
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=270247
@ -6,14 +6,12 @@
|
||||
#
|
||||
|
||||
PORTNAME= csound
|
||||
PORTVERSION= 5.12.1
|
||||
PORTREVISION= 3
|
||||
PORTVERSION= 5.13
|
||||
CATEGORIES= audio lang
|
||||
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}5/${PORTNAME}5.12/:src \
|
||||
SF/${PORTNAME}/${PORTNAME}5/${PORTNAME}5.10/:manual
|
||||
# Developer does not include a newer version of the manual.
|
||||
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}5/${PORTNAME}5.13/:src \
|
||||
SF/${PORTNAME}/${PORTNAME}5/${PORTNAME}5.13/manual:manual
|
||||
MASTER_SITE_SUBDIR= ${PORTNAME:S/$/:src/}
|
||||
DISTNAME= ${PORTNAME:S/c/C/}${PORTVERSION}
|
||||
DISTNAME= ${PORTNAME:S/c/C/}${PORTVERSION}.0
|
||||
DISTFILES= ${DISTNAME}${EXTRACT_SUFX}:src
|
||||
DIST_SUBDIR= csound
|
||||
|
||||
@ -21,7 +19,8 @@ MAINTAINER= ports@FreeBSD.org
|
||||
COMMENT= Sound synthesizer
|
||||
|
||||
LIB_DEPENDS= sndfile:${PORTSDIR}/audio/libsndfile
|
||||
BUILD_DEPENDS= ${LOCALBASE}/bin/swig:${PORTSDIR}/devel/swig13
|
||||
BUILD_DEPENDS= ${LOCALBASE}/bin/swig:${PORTSDIR}/devel/swig13 \
|
||||
${LOCALBASE}/bin/bison:${PORTSDIR}/devel/bison
|
||||
|
||||
WRKSRC= ${WRKDIR}/${DISTNAME}/
|
||||
USE_PYTHON= 2.6+
|
||||
@ -34,6 +33,8 @@ SCONS_ARGS+= prefix=${PREFIX} CC=${CC} CXX=${CXX} \
|
||||
buildVirtual=1 buildCSEditor=1 buildDSSI=0 \
|
||||
useGettext=1 dynamicCsoundLibrary=1 useDouble=1
|
||||
|
||||
CONFLICTS_INSTALL= outguess-*
|
||||
|
||||
OPTIONS= FLTKGUI "Build fltk plugin and GUI" on
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
@ -55,7 +56,7 @@ SCONS_ARGS+= useFLTK=0 buildCsound5GUI=0
|
||||
|
||||
.if !defined(NOPORTDOCS)
|
||||
BUILD_DEPENDS+= ${LOCALBASE}/bin/unzip:${PORTSDIR}/archivers/unzip
|
||||
DISTFILES+= Csound5.10_manual_html.zip:manual
|
||||
DISTFILES+= Csound5.13_manual_html.zip:manual
|
||||
.endif
|
||||
|
||||
post-patch: apply-slist
|
||||
|
@ -1,6 +1,4 @@
|
||||
MD5 (csound/Csound5.12.1.tar.gz) = 70b0c4a159c4960a09719674657949c9
|
||||
SHA256 (csound/Csound5.12.1.tar.gz) = 89173d666df4e109e6bbbd9232e68f7710711fa0e853a29f7704aa01d502360d
|
||||
SIZE (csound/Csound5.12.1.tar.gz) = 6121581
|
||||
MD5 (csound/Csound5.10_manual_html.zip) = e1eba0da11cfc1d85ef2113a81af91eb
|
||||
SHA256 (csound/Csound5.10_manual_html.zip) = 2c544a1bda8897a8364fa806109bdfca6f9e01495bace014d207db145f8324b1
|
||||
SIZE (csound/Csound5.10_manual_html.zip) = 5381988
|
||||
SHA256 (csound/Csound5.13.0.tar.gz) = 0552b5de4641bf95069422ed7c45b4aa613938c2fc643788be770dc82b213305
|
||||
SIZE (csound/Csound5.13.0.tar.gz) = 9813643
|
||||
SHA256 (csound/Csound5.13_manual_html.zip) = 4b040b03afb10215d22eb5deea482c5349aafc3d814c29322f137b28c6b1ed04
|
||||
SIZE (csound/Csound5.13_manual_html.zip) = 8411633
|
||||
|
47
audio/csound/files/patch-Engine-csound_orc.l
Normal file
47
audio/csound/files/patch-Engine-csound_orc.l
Normal file
@ -0,0 +1,47 @@
|
||||
--- Engine/csound_orc.l.old 2011-02-03 05:49:04.000000000 -0600
|
||||
+++ Engine/csound_orc.l 2011-02-03 05:49:33.000000000 -0600
|
||||
@@ -202,7 +202,7 @@
|
||||
alt_stack[macro_stack_ptr++] = macros;
|
||||
/* printf("Push %p macro stack; new body #%s#\n", macros, mm->body); */
|
||||
/* printf("Push buffer %p -> ", YY_CURRENT_BUFFER); */
|
||||
- yypush_buffer_state(YY_CURRENT_BUFFER);
|
||||
+ //yypush_buffer_state(YY_CURRENT_BUFFER);
|
||||
yy_scan_string(mm->body);
|
||||
/* printf("%p\n", YY_CURRENT_BUFFER); */
|
||||
}
|
||||
@@ -228,7 +228,7 @@
|
||||
alt_stack[macro_stack_ptr++] = macros;
|
||||
/* printf("Push %p macro stack\n", mm_save); */
|
||||
/* printf("Push buffer %p -> ", YY_CURRENT_BUFFER); */
|
||||
- yypush_buffer_state(YY_CURRENT_BUFFER);
|
||||
+ //yypush_buffer_state(YY_CURRENT_BUFFER);
|
||||
yy_scan_string(mm->body);
|
||||
/* printf("%p\n", YY_CURRENT_BUFFER); */
|
||||
}
|
||||
@@ -280,7 +280,7 @@
|
||||
//include_stack[include_stack_ptr++] = YY_CURRENT_BUFFER;
|
||||
alt_stack[macro_stack_ptr++] = mm_save;
|
||||
/* printf("Push %p macro stack\n", mm_save); */
|
||||
- yypush_buffer_state(YY_CURRENT_BUFFER);
|
||||
+ //yypush_buffer_state(YY_CURRENT_BUFFER);
|
||||
yy_scan_string(mm->body);
|
||||
}
|
||||
{MACRONAMEDA} { printf("Macro with arguments call not written\n");}
|
||||
@@ -307,7 +307,7 @@
|
||||
<<EOF>> {
|
||||
MACRO *x, *y=macros;
|
||||
/* printf("Leaving buffer %p\n", YY_CURRENT_BUFFER); */
|
||||
- yypop_buffer_state();
|
||||
+ //yypop_buffer_state();
|
||||
if ( !YY_CURRENT_BUFFER ) yyterminate();
|
||||
/* printf("End of input; popping to %p\n", YY_CURRENT_BUFFER); */
|
||||
macros = alt_stack[--macro_stack_ptr];
|
||||
@@ -388,7 +388,7 @@
|
||||
exit(1);
|
||||
}
|
||||
alt_stack[macro_stack_ptr++] = macros;
|
||||
- yypush_buffer_state(yy_create_buffer( yyin, YY_BUF_SIZE ) );
|
||||
+ //yypush_buffer_state(yy_create_buffer( yyin, YY_BUF_SIZE ) );
|
||||
}
|
||||
|
||||
static inline int isNameChar(int c, int pos)
|
10
audio/csound/files/patch-Opcodes-urandom.c
Normal file
10
audio/csound/files/patch-Opcodes-urandom.c
Normal file
@ -0,0 +1,10 @@
|
||||
--- Opcodes/urandom.c.old 2011-01-30 02:14:59.000000000 -0600
|
||||
+++ Opcodes/urandom.c 2011-01-30 02:15:08.000000000 -0600
|
||||
@@ -22,7 +22,6 @@
|
||||
*/
|
||||
|
||||
#include "csdl.h"
|
||||
-#include <ieee754.h>
|
||||
|
||||
typedef struct {
|
||||
OPDS h;
|
@ -1,63 +1,68 @@
|
||||
--- Top/csound.c.old 2009-10-15 16:24:10.000000000 -0500
|
||||
+++ Top/csound.c 2009-10-15 16:25:28.000000000 -0500
|
||||
@@ -58,6 +58,7 @@
|
||||
--- Top/csound.c.old 2011-01-30 01:43:37.000000000 -0600
|
||||
+++ Top/csound.c 2011-01-30 01:46:42.000000000 -0600
|
||||
@@ -58,7 +58,9 @@
|
||||
#include "namedins.h"
|
||||
#include "pvfileio.h"
|
||||
#include "fftlib.h"
|
||||
-
|
||||
+#if defined(__FreeBSD__)
|
||||
+#include <sys/sysctl.h>
|
||||
|
||||
extern void MakeAscii(CSOUND *, WINDAT *, const char *);
|
||||
extern void DrawAscii(CSOUND *, WINDAT *);
|
||||
@@ -2566,46 +2567,17 @@
|
||||
static int getTimeResolution(void)
|
||||
{
|
||||
+#endif
|
||||
#if defined(USE_OPENMP)
|
||||
#include <omp.h>
|
||||
#endif
|
||||
@@ -2641,49 +2643,14 @@
|
||||
static int getTimeResolution(void)
|
||||
{
|
||||
#if defined(HAVE_RDTSC)
|
||||
- FILE *f;
|
||||
- char buf[256];
|
||||
- FILE *f;
|
||||
- char buf[256];
|
||||
+ size_t size;
|
||||
+ int timeResolutionSeconds;
|
||||
+ size = sizeof timeResolutionSeconds;
|
||||
+ sysctlbyname("hw.clockrate", &timeResolutionSeconds, &size, NULL, 0);
|
||||
|
||||
- /* if frequency is not known yet */
|
||||
- f = fopen("/proc/cpuinfo", "r");
|
||||
- if (UNLIKELY(f == NULL)) {
|
||||
- fprintf(stderr, Str("Cannot open /proc/cpuinfo. "
|
||||
- "Support for RDTSC is not available.\n"));
|
||||
- return -1;
|
||||
- }
|
||||
- /* find CPU frequency */
|
||||
- while (fgets(buf, 256, f) != NULL) {
|
||||
- int i;
|
||||
- char *s = (char*) buf - 1;
|
||||
-
|
||||
- buf[255] = '\0'; /* safety */
|
||||
- if (strlen(buf) < 9)
|
||||
- continue; /* too short, skip */
|
||||
- while (*++s != '\0')
|
||||
- if (isupper(*s))
|
||||
- *s = tolower(*s); /* convert to lower case */
|
||||
- if (strncmp(buf, "cpu mhz", 7) != 0)
|
||||
- continue; /* check key name */
|
||||
- s = strchr(buf, ':'); /* find frequency value */
|
||||
- if (s == NULL) continue; /* invalid entry */
|
||||
- do {
|
||||
- s++;
|
||||
- } while (*s == ' ' || *s == '\t'); /* skip white space */
|
||||
- i = sscanf(s, "%lf", &timeResolutionSeconds);
|
||||
- if (i < 1 || timeResolutionSeconds < 1.0) {
|
||||
- timeResolutionSeconds = -1.0; /* invalid entry */
|
||||
- continue;
|
||||
- /* if frequency is not known yet */
|
||||
- f = fopen("/proc/cpuinfo", "r");
|
||||
- if (UNLIKELY(f == NULL)) {
|
||||
- fprintf(stderr, Str("Cannot open /proc/cpuinfo. "
|
||||
- "Support for RDTSC is not available.\n"));
|
||||
- return -1;
|
||||
- }
|
||||
- }
|
||||
- fclose(f);
|
||||
if (UNLIKELY(timeResolutionSeconds <= 0.0)) {
|
||||
fprintf(stderr, Str("No valid CPU frequency entry "
|
||||
- "was found in /proc/cpuinfo.\n"));
|
||||
+ "was found \n"));
|
||||
return -1;
|
||||
}
|
||||
+
|
||||
/* MHz -> seconds */
|
||||
timeResolutionSeconds = 0.000001 / timeResolutionSeconds;
|
||||
#elif defined(WIN32)
|
||||
- /* find CPU frequency */
|
||||
- while (fgets(buf, 256, f) != NULL) {
|
||||
- int i;
|
||||
- char *s = (char*) buf - 1;
|
||||
-
|
||||
- buf[255] = '\0'; /* safety */
|
||||
- if (strlen(buf) < 9) {
|
||||
- continue; /* too short, skip */
|
||||
- }
|
||||
- while (*++s != '\0')
|
||||
- if (isupper(*s)) {
|
||||
- *s = tolower(*s); /* convert to lower case */
|
||||
- }
|
||||
- if (strncmp(buf, "cpu mhz", 7) != 0) {
|
||||
- continue; /* check key name */
|
||||
- }
|
||||
- s = strchr(buf, ':'); /* find frequency value */
|
||||
- if (s == NULL) {
|
||||
- continue; /* invalid entry */
|
||||
- }
|
||||
- do {
|
||||
- s++;
|
||||
- } while (*s == ' ' || *s == '\t'); /* skip white space */
|
||||
- i = sscanf(s, "%lf", &timeResolutionSeconds);
|
||||
- if (i < 1 || timeResolutionSeconds < 1.0) {
|
||||
- timeResolutionSeconds = -1.0; /* invalid entry */
|
||||
- continue;
|
||||
- }
|
||||
- }
|
||||
- fclose(f);
|
||||
if (UNLIKELY(timeResolutionSeconds <= 0.0)) {
|
||||
fprintf(stderr, Str("No valid CPU frequency entry "
|
||||
- "was found in /proc/cpuinfo.\n"));
|
||||
+ "was found.\n"));
|
||||
return -1;
|
||||
}
|
||||
/* MHz -> seconds */
|
||||
|
@ -2,3 +2,8 @@
|
||||
%%PREFIX%%/bin/mixer has been renamed to %%PREFIX%%/bin/cs_mixer so it
|
||||
won't conflict with /usr/bin/mixer
|
||||
=====================================================================
|
||||
|
||||
===================-Support:-========================================
|
||||
Due to the complexity of this port, support requests must be done using
|
||||
http://www.cpetservices.com/site/tickets/misc.htm
|
||||
=====================================================================
|
||||
|
File diff suppressed because it is too large
Load Diff
Loading…
Reference in New Issue
Block a user