dns/adns: Update to 1.6.0
Update dns/adns to 1.6.0. This fixes several security issues in adns. This fixes the build with -fno-common, which is the default with llvm 11. PR: 248780 Approved by: pi@ (maintainer) MFH: 2020Q3 Security: 08de38d2-e2d0-11ea-9538-0c9d925bbbc0
This commit is contained in:
parent
d385be88a9
commit
7051d36f6b
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=545535
@ -2,7 +2,7 @@
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= adns
|
||||
PORTVERSION= 1.5.1
|
||||
PORTVERSION= 1.6.0
|
||||
CATEGORIES= dns
|
||||
MASTER_SITES= http://www.chiark.greenend.org.uk/~ian/adns/ftp/
|
||||
|
||||
@ -11,11 +11,14 @@ COMMENT= Easy to use asynchronous-capable DNS client library and utilities
|
||||
|
||||
LICENSE= GPLv3
|
||||
|
||||
BUILD_DEPENDS= m4>=1.4.11:devel/m4
|
||||
|
||||
USES= gmake
|
||||
GNU_CONFIGURE= yes
|
||||
USE_LDCONFIG= yes
|
||||
PORTSCOUT= skipv:1.5.0~rc0,1.5.0~rc1
|
||||
|
||||
BINARY_ALIAS= m4=${LOCALBASE}/bin/gm4
|
||||
LIBVERSION= 1
|
||||
PLIST_SUB+= LIBVERSION="${LIBVERSION}"
|
||||
|
||||
@ -29,7 +32,7 @@ TOSTRIP= bin/adnsheloex \
|
||||
bin/adnsresfilter \
|
||||
bin/adnslogres \
|
||||
bin/adnshost \
|
||||
lib/libadns.so.1
|
||||
lib/libadns.so.1.6
|
||||
|
||||
OPTIONS_DEFINE= DOCS
|
||||
|
||||
|
@ -1,3 +1,3 @@
|
||||
TIMESTAMP = 1471808918
|
||||
SHA256 (adns-1.5.1.tar.gz) = 5b1026f18b8274be869245ed63427bf8ddac0739c67be12c4a769ac948824eeb
|
||||
SIZE (adns-1.5.1.tar.gz) = 319774
|
||||
TIMESTAMP = 1597925576
|
||||
SHA256 (adns-1.6.0.tar.gz) = fb427265a981e033d1548f2b117cc021073dc8be2eaf2c45fd64ab7b00ed20de
|
||||
SIZE (adns-1.6.0.tar.gz) = 323474
|
||||
|
@ -1,14 +0,0 @@
|
||||
--- client/Makefile.in.orig 2014-10-19 23:07:01 UTC
|
||||
+++ client/Makefile.in
|
||||
@@ -58,9 +58,9 @@ ALL_OBJS= $(ADH_OBJS) $(TARG_OBJS)
|
||||
all: $(TARGETS)
|
||||
|
||||
install: $(TARG_INSTALL)
|
||||
- mkdir -p $(bindir)
|
||||
+ mkdir -p $(DESTDIR)$(bindir)
|
||||
set -xe; for f in $(TARG_INSTALL); \
|
||||
- do $(INSTALL_PROGRAM) $$f $(bindir)/$$f; done
|
||||
+ do $(INSTALL_PROGRAM) $$f $(DESTDIR)$(bindir)/$$f; done
|
||||
|
||||
uninstall:
|
||||
for f in $(TARGETS); do rm -f $(bindir)/$$f; done
|
@ -1,11 +0,0 @@
|
||||
--- configure.orig 2014-10-26 13:22:06 UTC
|
||||
+++ configure
|
||||
@@ -4047,7 +4047,7 @@ $as_echo "no" >&6; }
|
||||
|
||||
SHLIBFORLINK='libadns.so'
|
||||
SHLIBSONAME='$(SHLIBFORLINK).$(MAJOR)'
|
||||
-SHLIBFILE='$(SHLIBSONAME).$(MINOR)'
|
||||
+SHLIBFILE='$(SHLIBSONAME)'
|
||||
|
||||
SHLIBCC='$(CC) $(CFLAGS) -fpic'
|
||||
MKSHLIB_1='$(CC) $(LDFLAGS) -shared -Wl,-soname=$(SHLIBSONAME) -o'
|
@ -1,11 +0,0 @@
|
||||
--- configure.in.orig 2014-10-20 00:14:40 UTC
|
||||
+++ configure.in
|
||||
@@ -140,7 +140,7 @@ AC_SUBST(SHLIBSONAME)
|
||||
|
||||
SHLIBFORLINK='libadns.so'
|
||||
SHLIBSONAME='$(SHLIBFORLINK).$(MAJOR)'
|
||||
-SHLIBFILE='$(SHLIBSONAME).$(MINOR)'
|
||||
+SHLIBFILE='$(SHLIBSONAME)'
|
||||
|
||||
SHLIBCC='$(CC) $(CFLAGS) -fpic'
|
||||
MKSHLIB_1='$(CC) $(LDFLAGS) -shared -Wl,-soname=$(SHLIBSONAME) -o'
|
@ -1,16 +0,0 @@
|
||||
--- dynamic/Makefile.in.orig 2014-10-19 23:07:01 UTC
|
||||
+++ dynamic/Makefile.in
|
||||
@@ -30,10 +30,9 @@ include $(srcdir)/../src/adns.make
|
||||
ALLOBJS= $(addsuffix _p.o, $(basename $(LIBOBJS)))
|
||||
|
||||
install:
|
||||
- mkdir -p $(libdir)
|
||||
- $(INSTALL_PROGRAM) $(SHLIBFILE) $(libdir)/$(SHLIBFILE)
|
||||
- ln -sf $(SHLIBFILE) $(libdir)/$(SHLIBSONAME)
|
||||
- ln -sf $(SHLIBSONAME) $(libdir)/$(SHLIBFORLINK)
|
||||
+ mkdir -p $(DESTDIR)$(libdir)
|
||||
+ $(INSTALL_PROGRAM) $(SHLIBFILE) $(DESTDIR)$(libdir)/$(SHLIBFILE)
|
||||
+ (cd $(DESTDIR)$(libdir) && ln -sf $(SHLIBSONAME) $(SHLIBFORLINK))
|
||||
|
||||
uninstall:
|
||||
rm -f $(libdir)/$(SHLIBFILE) $(libdir)/$(SHLIBSONAME)
|
@ -1,11 +0,0 @@
|
||||
--- regress/Makefile.in.orig 2014-10-26 12:03:41 UTC
|
||||
+++ regress/Makefile.in
|
||||
@@ -25,7 +25,7 @@ VPATH= @srcdir@
|
||||
|
||||
PROGS_SYSDEP= @PROGS_HAVE_TSEARCH@
|
||||
|
||||
-CLIENTS= adnstest adnshost adnslogres $(PROGS_SYSDEP)
|
||||
+CLIENTS= adnstest adnslogres $(PROGS_SYSDEP)
|
||||
AUTOCHDRS= harness.h hsyscalls.h hredirect.h
|
||||
AUTOCSRCS= hrecord.c hplayback.c hcommon.c
|
||||
include ../settings.make
|
@ -1,16 +0,0 @@
|
||||
--- src/Makefile.in.orig 2014-10-19 23:07:03 UTC
|
||||
+++ src/Makefile.in
|
||||
@@ -30,10 +30,10 @@ include $(srcdir)/adns.make
|
||||
DIRCFLAGS= -I. -I$(srcdir)
|
||||
|
||||
install:
|
||||
- mkdir -p $(libdir) $(includedir)
|
||||
+ mkdir -p $(DESTDIR)$(libdir) $(DESTDIR)$(includedir)
|
||||
set -xe; for f in $(TARGETS); \
|
||||
- do $(INSTALL_DATA) $$f $(libdir)/$$f; done
|
||||
- $(INSTALL_DATA) $(srcdir)/../src/adns.h $(includedir)/adns.h
|
||||
+ do $(INSTALL_DATA) $$f $(DESTDIR)$(libdir)/$$f; done
|
||||
+ $(INSTALL_DATA) $(srcdir)/../src/adns.h $(DESTDIR)$(includedir)/adns.h
|
||||
|
||||
uninstall:
|
||||
for f in $(TARGETS); do rm -f $(libdir)/$$f; done
|
@ -6,6 +6,7 @@ include/adns.h
|
||||
lib/libadns.a
|
||||
lib/libadns.so
|
||||
lib/libadns.so.%%LIBVERSION%%
|
||||
lib/libadns.so.%%LIBVERSION%%.6
|
||||
%%PORTDOCS%%%%DOCSDIR%%/COPYING
|
||||
%%PORTDOCS%%%%DOCSDIR%%/GPL-vs-LGPL
|
||||
%%PORTDOCS%%%%DOCSDIR%%/INSTALL
|
||||
|
Loading…
Reference in New Issue
Block a user