Upgrade to 1.2.7. This port is not BROKEN anymore!
Submitted by: chuckr@glue.umd.edu
This commit is contained in:
parent
dcb0b1d0a8
commit
701949611f
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=3093
@ -1,26 +1,16 @@
|
||||
# New ports collection makefile for: Mesa
|
||||
# Version required: 1.1.3beta
|
||||
# Version required: 1.2.7
|
||||
# Date created: Tue Feb 7 12:02:49 1995
|
||||
# Whom: hsu
|
||||
#
|
||||
# $Id: Makefile,v 1.8 1995/04/09 07:09:32 asami Exp $
|
||||
# $Id: Makefile,v 1.9 1996/04/12 08:29:07 asami Exp $
|
||||
#
|
||||
|
||||
DISTNAME= Mesa-1.1.3beta
|
||||
PKGNAME= Mesa-1.1.3b
|
||||
DISTNAME= Mesa-1.2.7
|
||||
CATEGORIES+= graphics
|
||||
MASTER_SITES= ftp://iris.ssec.wisc.edu/pub/misc/
|
||||
MASTER_SITES= ftp://iris.ssec.wisc.edu/pub/Mesa/
|
||||
|
||||
BROKEN= yes # won't install until I convert the Makefiles to Imakefiles
|
||||
WRKSRC= ${WRKDIR}/Mesa
|
||||
USE_GMAKE= yes
|
||||
ALL_TARGET= freebsd
|
||||
USE_X11= yes
|
||||
ALL_TARGET= freebsd
|
||||
|
||||
# won't need this after I convert the Makefiles to Imakefiles
|
||||
pre-build:
|
||||
if [ ! -e /usr/include/X11 ]; then \
|
||||
ln -s /usr/X11R6/include/X11 /usr/include; \
|
||||
fi
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
@ -1 +1 @@
|
||||
MD5 (Mesa-1.1.3beta.tar.gz) = d39371f1f3423d9ed8d86bdbcfd1cea6
|
||||
MD5 (Mesa-1.2.7.tar.gz) = 58a39f8da88fe17815a9ca71fe1c22df
|
||||
|
@ -1,29 +1,32 @@
|
||||
*** samples/speed.c.0 Fri Mar 3 16:38:42 1995
|
||||
--- samples/speed.c Sun Mar 5 18:59:23 1995
|
||||
***************
|
||||
*** 35,40 ****
|
||||
--- 35,44 ----
|
||||
#include <sys/param.h>
|
||||
#endif
|
||||
|
||||
+ #ifdef __STDC__
|
||||
+ #include <time.h>
|
||||
+ #endif
|
||||
+
|
||||
|
||||
#define GAP 10
|
||||
#define ROWS 1
|
||||
***************
|
||||
*** 122,128 ****
|
||||
--- 126,136 ----
|
||||
clock_t clk;
|
||||
|
||||
clk = times(&tm);
|
||||
+ #ifdef __STDC__
|
||||
+ return (double)clk / (double)CLOCKS_PER_SEC;
|
||||
+ #else
|
||||
return (double)clk / (double)HZ;
|
||||
+ #endif
|
||||
#else
|
||||
return 0;
|
||||
#endif
|
||||
--- Makefile.orig Wed May 8 21:34:09 1996
|
||||
+++ Makefile Wed May 8 21:44:14 1996
|
||||
@@ -178,6 +178,29 @@
|
||||
cd samples ; $(MAKE) $@
|
||||
cd book ; $(MAKE) $@
|
||||
|
||||
+install:
|
||||
+ install -c -m 444 lib/libMesaGL.a ${X11BASE}/lib
|
||||
+ install -c -m 444 lib/libMesaGL.so.12.7 ${X11BASE}/lib
|
||||
+ install -c -m 444 lib/libMesaGLU.a ${X11BASE}/lib
|
||||
+ install -c -m 444 lib/libMesaGLU.so.12.7 ${X11BASE}/lib
|
||||
+ install -c -m 444 lib/libMesaaux.a ${X11BASE}/lib
|
||||
+ install -c -m 444 lib/libMesaaux.so.12.7 ${X11BASE}/lib
|
||||
+ install -c -m 444 lib/libMesatk.a ${X11BASE}/lib
|
||||
+ install -c -m 444 lib/libMesatk.so.12.7 ${X11BASE}/lib
|
||||
+ mkdir -p -m 0775 ${X11BASE}/include/Mesa/GL
|
||||
+ install -c include/glaux.h ${X11BASE}/include/Mesa
|
||||
+ install -c include/gltk.h ${X11BASE}/include/Mesa
|
||||
+ install -c include/GL/amesa.h ${X11BASE}/include/Mesa/GL
|
||||
+ install -c include/GL/fgl.h ${X11BASE}/include/Mesa/GL
|
||||
+ install -c include/GL/gl.h ${X11BASE}/include/Mesa/GL
|
||||
+ install -c include/GL/glu.h ${X11BASE}/include/Mesa/GL
|
||||
+ install -c include/GL/glx.h ${X11BASE}/include/Mesa/GL
|
||||
+ install -c include/GL/osmesa.h ${X11BASE}/include/Mesa/GL
|
||||
+ install -c include/GL/svgamesa.h ${X11BASE}/include/Mesa/GL
|
||||
+ install -c include/GL/wmesa.h ${X11BASE}/include/Mesa/GL
|
||||
+ install -c include/GL/xmesa.h ${X11BASE}/include/Mesa/GL
|
||||
+ ldconfig -m ${X11BASE}/lib
|
||||
+
|
||||
next:
|
||||
-mkdir lib
|
||||
cd src ; $(MAKE) -f Makefile.NeXT $@
|
||||
|
1
graphics/Mesa3/pkg-comment
Normal file
1
graphics/Mesa3/pkg-comment
Normal file
@ -0,0 +1 @@
|
||||
Mesa is a graphics library similar to SGI's OpenGL.
|
9
graphics/Mesa3/pkg-descr
Normal file
9
graphics/Mesa3/pkg-descr
Normal file
@ -0,0 +1,9 @@
|
||||
Mesa is a 3-D graphics library with an API which is very similar to that
|
||||
of OpenGL*. To the extent that Mesa utilizes the OpenGL command syntax
|
||||
or state machine, it is being used with authorization from Silicon Graphics,
|
||||
Inc. However, the author makes no claim that Mesa is in any way a
|
||||
compatible replacement for OpenGL or associated with Silicon Graphics, Inc.
|
||||
Those who want a licensed implementation of OpenGL should contact a licensed
|
||||
vendor. This software is distributed under the terms of the GNU Library
|
||||
General Public License, see the LICENSE file for details.
|
||||
|
19
graphics/Mesa3/pkg-plist
Normal file
19
graphics/Mesa3/pkg-plist
Normal file
@ -0,0 +1,19 @@
|
||||
lib/libMesaGL.a
|
||||
lib/libMesaGL.so.12.7
|
||||
lib/libMesaGLU.a
|
||||
lib/libMesaGLU.so.12.7
|
||||
lib/libMesaaux.a
|
||||
lib/libMesaaux.so.12.7
|
||||
lib/libMesatk.a
|
||||
lib/libMesatk.so.12.7
|
||||
include/Mesa/glaux.h
|
||||
include/Mesa/gltk.h
|
||||
include/Mesa/GL/amesa.h
|
||||
include/Mesa/GL/fgl.h
|
||||
include/Mesa/GL/gl.h
|
||||
include/Mesa/GL/glu.h
|
||||
include/Mesa/GL/glx.h
|
||||
include/Mesa/GL/osmesa.h
|
||||
include/Mesa/GL/svgamesa.h
|
||||
include/Mesa/GL/wmesa.h
|
||||
include/Mesa/GL/xmesa.h
|
@ -1,26 +1,16 @@
|
||||
# New ports collection makefile for: Mesa
|
||||
# Version required: 1.1.3beta
|
||||
# Version required: 1.2.7
|
||||
# Date created: Tue Feb 7 12:02:49 1995
|
||||
# Whom: hsu
|
||||
#
|
||||
# $Id: Makefile,v 1.8 1995/04/09 07:09:32 asami Exp $
|
||||
# $Id: Makefile,v 1.9 1996/04/12 08:29:07 asami Exp $
|
||||
#
|
||||
|
||||
DISTNAME= Mesa-1.1.3beta
|
||||
PKGNAME= Mesa-1.1.3b
|
||||
DISTNAME= Mesa-1.2.7
|
||||
CATEGORIES+= graphics
|
||||
MASTER_SITES= ftp://iris.ssec.wisc.edu/pub/misc/
|
||||
MASTER_SITES= ftp://iris.ssec.wisc.edu/pub/Mesa/
|
||||
|
||||
BROKEN= yes # won't install until I convert the Makefiles to Imakefiles
|
||||
WRKSRC= ${WRKDIR}/Mesa
|
||||
USE_GMAKE= yes
|
||||
ALL_TARGET= freebsd
|
||||
USE_X11= yes
|
||||
ALL_TARGET= freebsd
|
||||
|
||||
# won't need this after I convert the Makefiles to Imakefiles
|
||||
pre-build:
|
||||
if [ ! -e /usr/include/X11 ]; then \
|
||||
ln -s /usr/X11R6/include/X11 /usr/include; \
|
||||
fi
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
@ -1 +1 @@
|
||||
MD5 (Mesa-1.1.3beta.tar.gz) = d39371f1f3423d9ed8d86bdbcfd1cea6
|
||||
MD5 (Mesa-1.2.7.tar.gz) = 58a39f8da88fe17815a9ca71fe1c22df
|
||||
|
@ -1,29 +1,32 @@
|
||||
*** samples/speed.c.0 Fri Mar 3 16:38:42 1995
|
||||
--- samples/speed.c Sun Mar 5 18:59:23 1995
|
||||
***************
|
||||
*** 35,40 ****
|
||||
--- 35,44 ----
|
||||
#include <sys/param.h>
|
||||
#endif
|
||||
|
||||
+ #ifdef __STDC__
|
||||
+ #include <time.h>
|
||||
+ #endif
|
||||
+
|
||||
|
||||
#define GAP 10
|
||||
#define ROWS 1
|
||||
***************
|
||||
*** 122,128 ****
|
||||
--- 126,136 ----
|
||||
clock_t clk;
|
||||
|
||||
clk = times(&tm);
|
||||
+ #ifdef __STDC__
|
||||
+ return (double)clk / (double)CLOCKS_PER_SEC;
|
||||
+ #else
|
||||
return (double)clk / (double)HZ;
|
||||
+ #endif
|
||||
#else
|
||||
return 0;
|
||||
#endif
|
||||
--- Makefile.orig Wed May 8 21:34:09 1996
|
||||
+++ Makefile Wed May 8 21:44:14 1996
|
||||
@@ -178,6 +178,29 @@
|
||||
cd samples ; $(MAKE) $@
|
||||
cd book ; $(MAKE) $@
|
||||
|
||||
+install:
|
||||
+ install -c -m 444 lib/libMesaGL.a ${X11BASE}/lib
|
||||
+ install -c -m 444 lib/libMesaGL.so.12.7 ${X11BASE}/lib
|
||||
+ install -c -m 444 lib/libMesaGLU.a ${X11BASE}/lib
|
||||
+ install -c -m 444 lib/libMesaGLU.so.12.7 ${X11BASE}/lib
|
||||
+ install -c -m 444 lib/libMesaaux.a ${X11BASE}/lib
|
||||
+ install -c -m 444 lib/libMesaaux.so.12.7 ${X11BASE}/lib
|
||||
+ install -c -m 444 lib/libMesatk.a ${X11BASE}/lib
|
||||
+ install -c -m 444 lib/libMesatk.so.12.7 ${X11BASE}/lib
|
||||
+ mkdir -p -m 0775 ${X11BASE}/include/Mesa/GL
|
||||
+ install -c include/glaux.h ${X11BASE}/include/Mesa
|
||||
+ install -c include/gltk.h ${X11BASE}/include/Mesa
|
||||
+ install -c include/GL/amesa.h ${X11BASE}/include/Mesa/GL
|
||||
+ install -c include/GL/fgl.h ${X11BASE}/include/Mesa/GL
|
||||
+ install -c include/GL/gl.h ${X11BASE}/include/Mesa/GL
|
||||
+ install -c include/GL/glu.h ${X11BASE}/include/Mesa/GL
|
||||
+ install -c include/GL/glx.h ${X11BASE}/include/Mesa/GL
|
||||
+ install -c include/GL/osmesa.h ${X11BASE}/include/Mesa/GL
|
||||
+ install -c include/GL/svgamesa.h ${X11BASE}/include/Mesa/GL
|
||||
+ install -c include/GL/wmesa.h ${X11BASE}/include/Mesa/GL
|
||||
+ install -c include/GL/xmesa.h ${X11BASE}/include/Mesa/GL
|
||||
+ ldconfig -m ${X11BASE}/lib
|
||||
+
|
||||
next:
|
||||
-mkdir lib
|
||||
cd src ; $(MAKE) -f Makefile.NeXT $@
|
||||
|
1
graphics/mesagl/pkg-comment
Normal file
1
graphics/mesagl/pkg-comment
Normal file
@ -0,0 +1 @@
|
||||
Mesa is a graphics library similar to SGI's OpenGL.
|
9
graphics/mesagl/pkg-descr
Normal file
9
graphics/mesagl/pkg-descr
Normal file
@ -0,0 +1,9 @@
|
||||
Mesa is a 3-D graphics library with an API which is very similar to that
|
||||
of OpenGL*. To the extent that Mesa utilizes the OpenGL command syntax
|
||||
or state machine, it is being used with authorization from Silicon Graphics,
|
||||
Inc. However, the author makes no claim that Mesa is in any way a
|
||||
compatible replacement for OpenGL or associated with Silicon Graphics, Inc.
|
||||
Those who want a licensed implementation of OpenGL should contact a licensed
|
||||
vendor. This software is distributed under the terms of the GNU Library
|
||||
General Public License, see the LICENSE file for details.
|
||||
|
19
graphics/mesagl/pkg-plist
Normal file
19
graphics/mesagl/pkg-plist
Normal file
@ -0,0 +1,19 @@
|
||||
lib/libMesaGL.a
|
||||
lib/libMesaGL.so.12.7
|
||||
lib/libMesaGLU.a
|
||||
lib/libMesaGLU.so.12.7
|
||||
lib/libMesaaux.a
|
||||
lib/libMesaaux.so.12.7
|
||||
lib/libMesatk.a
|
||||
lib/libMesatk.so.12.7
|
||||
include/Mesa/glaux.h
|
||||
include/Mesa/gltk.h
|
||||
include/Mesa/GL/amesa.h
|
||||
include/Mesa/GL/fgl.h
|
||||
include/Mesa/GL/gl.h
|
||||
include/Mesa/GL/glu.h
|
||||
include/Mesa/GL/glx.h
|
||||
include/Mesa/GL/osmesa.h
|
||||
include/Mesa/GL/svgamesa.h
|
||||
include/Mesa/GL/wmesa.h
|
||||
include/Mesa/GL/xmesa.h
|
Loading…
Reference in New Issue
Block a user