- Fix build with clang

- Trim header

PR:		175039
Submitted by:	Ports Fury
This commit is contained in:
Martin Wilke 2013-02-07 14:43:48 +00:00
parent a0d9dff4cb
commit 700101774d
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=311855
2 changed files with 19 additions and 11 deletions

View File

@ -1,10 +1,5 @@
# ex:ts=8
# Ports collection makefile for: dhcp
# Date created: 21 November 1995
# Whom: Yoshiro MIHIRA <sanpei@yy.cs.keio.ac.jp>
#
# Created by: Yoshiro MIHIRA <sanpei@yy.cs.keio.ac.jp>
# $FreeBSD$
#
PORTNAME= wide-dhcp
PORTVERSION= 1.4.0.7
@ -13,12 +8,12 @@ MASTER_SITES= ftp://sh.wide.ad.jp/WIDE/free-ware/dhcp/ \
ftp://ftp.st.ryukoku.ac.jp/pub/network/dhcp/wide/
DISTNAME= dhcp-${PORTVERSION:R}p${PORTVERSION:E}
LICENSE= BSD
LICENSE_FILE= ${WRKSRC}/Copyright
MAINTAINER= ports@FreeBSD.org
COMMENT= Dynamic Host Configuration Protocol, WIDE Implementation
LICENSE= BSD
LICENSE_FILE= ${WRKSRC}/Copyright
MAKE_ENV= OSTYPE="${OPSYS}"
MAKE_JOBS_SAFE= yes
@ -27,6 +22,8 @@ MAN8= dhcpc.8 dhcps.8 relay.8 dhcpm.8
DOCS= README README.jis db_sample/intro.dhcp db_sample/intro.dhcp.jis
EXAMPLES= dhcpdb.pool dhcpdb.relay dhcpdb.server
.include <bsd.port.options.mk>
post-patch:
.for dir in client relay server tools
@${REINPLACE_CMD} -e \
@ -39,11 +36,11 @@ post-patch:
post-install:
${INSTALL_SCRIPT} ${FILESDIR}/wide-dhcps.sh.sample ${PREFIX}/etc/rc.d
.if !defined(NOPORTDOCS)
.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
@cd ${WRKSRC} && ${INSTALL_DATA} ${DOCS} ${DOCSDIR}
.endif
.if !defined(NOPORTEXAMPLES)
.if ${PORT_OPTIONS:MEXAMPLES}
@${MKDIR} ${EXAMPLESDIR}
@cd ${WRKSRC}/db_sample && ${INSTALL_DATA} ${EXAMPLES} ${EXAMPLESDIR}
.endif

View File

@ -0,0 +1,11 @@
--- relay/relay.c.orig 1999-01-01 19:28:04.000000000 +0900
+++ relay/relay.c 2012-10-25 18:05:55.000000000 +0900
@@ -123,7 +123,7 @@
static void forwarding();
int open_if();
-void
+int
main(argc, argv)
int argc;
char **argv;