Add py-geomet 0.2.1
GeoMet converts GeoJSON to WKT/WKB (Well-Known Text/Binary), and vice versa. Extended WKB/WKT are also supported. Conversion functions are exposed through idiomatic load/loads/dump/dumps interfaces. GeoMet is intended to cover all common use cases for dealing with 2D, 3D, and 4D geometries (including 'Z', 'M', and 'ZM'). WWW: https://github.com/geomet/geomet
This commit is contained in:
parent
6272f4bbab
commit
6ff8f71a76
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=521284
@ -239,6 +239,7 @@
|
||||
SUBDIR += py-coards
|
||||
SUBDIR += py-dlib
|
||||
SUBDIR += py-eccodes-python
|
||||
SUBDIR += py-geomet
|
||||
SUBDIR += py-geometer
|
||||
SUBDIR += py-gpaw
|
||||
SUBDIR += py-gsd
|
||||
|
24
science/py-geomet/Makefile
Normal file
24
science/py-geomet/Makefile
Normal file
@ -0,0 +1,24 @@
|
||||
# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= geomet
|
||||
PORTVERSION= 0.2.1
|
||||
CATEGORIES= science python
|
||||
MASTER_SITES= CHEESESHOP
|
||||
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
|
||||
|
||||
MAINTAINER= sunpoet@FreeBSD.org
|
||||
COMMENT= GeoJSON <-> WKT/WKB conversion utilities
|
||||
|
||||
LICENSE= APACHE20
|
||||
LICENSE_FILE= ${WRKSRC}/LICENSE
|
||||
|
||||
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}click>=0:devel/py-click@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}six>=0:devel/py-six@${PY_FLAVOR}
|
||||
|
||||
USES= python
|
||||
USE_PYTHON= autoplist concurrent distutils
|
||||
|
||||
NO_ARCH= yes
|
||||
|
||||
.include <bsd.port.mk>
|
3
science/py-geomet/distinfo
Normal file
3
science/py-geomet/distinfo
Normal file
@ -0,0 +1,3 @@
|
||||
TIMESTAMP = 1577523846
|
||||
SHA256 (geomet-0.2.1.tar.gz) = adfafeac8d0b6ccc509f67c61ce6db7feb27a3eca40eaad93b2e29669e3c0297
|
||||
SIZE (geomet-0.2.1.tar.gz) = 19527
|
9
science/py-geomet/files/patch-setup.py
Normal file
9
science/py-geomet/files/patch-setup.py
Normal file
@ -0,0 +1,9 @@
|
||||
--- setup.py.orig 2019-08-20 22:39:12 UTC
|
||||
+++ setup.py
|
||||
@@ -61,5 +61,5 @@ setup(
|
||||
],
|
||||
zip_safe=False,
|
||||
install_requires=['click', 'six'],
|
||||
- python_requires=">2.6, !=3.3.*, <3.8",
|
||||
+ python_requires=">2.6, !=3.3.*, <4",
|
||||
)
|
8
science/py-geomet/pkg-descr
Normal file
8
science/py-geomet/pkg-descr
Normal file
@ -0,0 +1,8 @@
|
||||
GeoMet converts GeoJSON to WKT/WKB (Well-Known Text/Binary), and vice versa.
|
||||
Extended WKB/WKT are also supported. Conversion functions are exposed through
|
||||
idiomatic load/loads/dump/dumps interfaces.
|
||||
|
||||
GeoMet is intended to cover all common use cases for dealing with 2D, 3D, and 4D
|
||||
geometries (including 'Z', 'M', and 'ZM').
|
||||
|
||||
WWW: https://github.com/geomet/geomet
|
Loading…
Reference in New Issue
Block a user