Update to 1.8
- Add LICENSE - Update PORTDOCS - While I'm here: - Remove .include <bsd.port.options.mk> - Use MAKE_CMD instead of GMAKE Changes: http://sun.hasenbraten.de/vasm/ PR: 219741 Submitted by: Carsten Larsen <cs@innolan.dk> (maintainer)
This commit is contained in:
parent
b0dde3ce63
commit
6fd9b04a2b
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=443408
@ -2,32 +2,48 @@
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= vasm
|
||||
PORTVERSION= 1.7g
|
||||
PORTREVISION= 1
|
||||
PORTVERSION= 1.8
|
||||
CATEGORIES= devel
|
||||
MASTER_SITES= http://server.owl.de/%SUBDIR%/
|
||||
MASTER_SITE_SUBDIR= ~frank/tags/
|
||||
DISTNAME= vasm1_7g
|
||||
MASTER_SITES= http://server.owl.de/~frank/tags/
|
||||
DISTNAME= vasm1_8
|
||||
|
||||
MAINTAINER= cs@innolan.dk
|
||||
COMMENT= Portable 6502 6800 arm c16x jagrisc m68k ppc vidcore x86 z80 assembler
|
||||
|
||||
LEGAL_TEXT= This archive may be redistributed without modifications and used for non-commercial purposes.
|
||||
LICENSE= VASMBSD
|
||||
LICENSE_NAME= vasm license for FreeBSD
|
||||
LICENSE_TEXT= vasm comes with its own license. The source archive may be redistributed \
|
||||
without modifications and used for non-commercial purposes. \
|
||||
Binary packages are distributed with permission of the author by FreeBSD
|
||||
LICENSE_PERMS= dist-mirror no-dist-sell pkg-mirror no-pkg-sell auto-accept
|
||||
|
||||
USES= gmake pathfix
|
||||
WRKSRC= ${WRKDIR}/vasm
|
||||
|
||||
CPU_LIST= 6502 6800 arm c16x jagrisc m68k ppc test tr3200 vidcore x86 z80
|
||||
OPTIONS_DEFINE= DOCS
|
||||
OPTIONS_DEFAULT= DOCS
|
||||
DOCS_USES= makeinfo
|
||||
|
||||
CPU_LIST= 6502 6800 arm c16x jagrisc m68k ppc qnice tr3200 vidcore x86 z80
|
||||
SYNTAX_LIST= std madmac mot oldstyle test
|
||||
OUTPUT_LIST= aout bin elf hunk test tos vobj
|
||||
DOC_LIST= cpu_6502 cpu_jagrisc cpu_x86 output_bin output_test syntax_mot vasm_main \
|
||||
cpu_6800 cpu_m68k cpu_z80 output_elf output_tos syntax_oldstyle cpu_arm \
|
||||
cpu_ppc interface output_hunk output_vobj syntax_std cpu_c16x cpu_tr3200 \
|
||||
output_aout output_srec syntax_madmac vasm
|
||||
|
||||
do-build:
|
||||
.for CPU in ${CPU_LIST}
|
||||
.for SYNTAX in ${SYNTAX_LIST}
|
||||
${GMAKE} -C ${WRKSRC} CC=${CC} CPU=${CPU} SYNTAX=${SYNTAX} >/dev/null 2>&1
|
||||
${MAKE_CMD} -C ${WRKSRC} CC=${CC} CPU=${CPU} SYNTAX=${SYNTAX}
|
||||
.endfor
|
||||
.endfor
|
||||
|
||||
do-build-DOCS-on:
|
||||
.for DOC in ${DOC_LIST}
|
||||
makeinfo --plaintext --force --no-validate ${WRKSRC}/doc/${DOC}.texi -o ${WRKSRC}/doc/${DOC}
|
||||
.endfor
|
||||
|
||||
do-install:
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/vobjdump ${STAGEDIR}${PREFIX}/bin
|
||||
.for CPU in ${CPU_LIST}
|
||||
@ -35,18 +51,11 @@ do-install:
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/vasm${CPU}_${SYNTAX} ${STAGEDIR}${PREFIX}/bin
|
||||
.endfor
|
||||
.endfor
|
||||
|
||||
do-install-DOCS-on:
|
||||
${MKDIR} ${STAGEDIR}${DOCSDIR}
|
||||
.for CPU in ${CPU_LIST}
|
||||
.for SYNTAX in ${SYNTAX_LIST}
|
||||
-test -f ${WRKSRC}/doc/cpu_${CPU}.texi && ${INSTALL_MAN} ${WRKSRC}/doc/cpu_${CPU}.texi ${STAGEDIR}${DOCSDIR}
|
||||
-test -f ${WRKSRC}/doc/syntax_${SYNTAX}.texi && ${INSTALL_MAN} ${WRKSRC}/doc/syntax_${SYNTAX}.texi ${STAGEDIR}${DOCSDIR}
|
||||
.for OUTPUT in ${OUTPUT_LIST}
|
||||
-test -f ${WRKSRC}/doc/output_${OUTPUT}.texi && ${INSTALL_MAN} ${WRKSRC}/doc/output_${OUTPUT}.texi ${STAGEDIR}${DOCSDIR}
|
||||
.for DOC in ${DOC_LIST}
|
||||
${INSTALL_MAN} ${WRKSRC}/doc/${DOC} ${STAGEDIR}${DOCSDIR}
|
||||
.endfor
|
||||
.endfor
|
||||
.endfor
|
||||
${INSTALL_MAN} ${WRKSRC}/doc/vasm.texi ${STAGEDIR}${DOCSDIR}
|
||||
${INSTALL_MAN} ${WRKSRC}/doc/vasm_main.texi ${STAGEDIR}${DOCSDIR}
|
||||
${INSTALL_MAN} ${WRKSRC}/doc/interface.texi ${STAGEDIR}${DOCSDIR}
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
@ -1,3 +1,3 @@
|
||||
TIMESTAMP = 1480238303
|
||||
SHA256 (vasm1_7g.tar.gz) = 9cfca33c348fe10419cb2ef59a7ff25c262cd6cf1d353bb51d4468f1f1535c55
|
||||
SIZE (vasm1_7g.tar.gz) = 393623
|
||||
TIMESTAMP = 1496435956
|
||||
SHA256 (vasm1_8.tar.gz) = 0d106ee05b13c62c8423f7a6f310b43ff038eae1d93774dc3130c1a407e07db3
|
||||
SIZE (vasm1_8.tar.gz) = 405385
|
||||
|
11
devel/vasm/files/patch-Makefile
Normal file
11
devel/vasm/files/patch-Makefile
Normal file
@ -0,0 +1,11 @@
|
||||
--- Makefile.orig 2017-06-02 21:05:38 UTC
|
||||
+++ Makefile
|
||||
@@ -5,7 +5,7 @@ TARGETEXTENSION =
|
||||
OUTFMTS = -DOUTAOUT -DOUTBIN -DOUTELF -DOUTHUNK -DOUTSREC -DOUTTOS -DOUTVOBJ
|
||||
|
||||
CCOUT = -o
|
||||
-COPTS = -c -O2 $(OUTFMTS)
|
||||
+COPTS = -c -O2 $(OUTFMTS) -Wno-parentheses -Wno-return-type
|
||||
|
||||
LD = $(CC)
|
||||
LDOUT = $(CCOUT)
|
@ -1,9 +1,7 @@
|
||||
vasm is a portable and retargetable assembler to create linkable
|
||||
objects in various formats or absolute code.
|
||||
Multiple CPU-, syntax and output-modules can be selected.
|
||||
|
||||
Currently the following CPUs are officially supported by vasm:
|
||||
vasm is a portable and retargetable assembler to create linkable objects in
|
||||
various formats or absolute code.
|
||||
|
||||
Currently the following CPUs are officially supported:
|
||||
M680x0 family (including M6888x, M68851 and CPU32)
|
||||
ColdFire family (all models of V2, V3, V4, V4e)
|
||||
80x86 family (IA32 8/16/32 bit, using MIT-syntax)
|
||||
@ -12,13 +10,15 @@ Currently the following CPUs are officially supported by vasm:
|
||||
Jaguar RISC (GPU and DSP instruction sets)
|
||||
Z80 family (Z80, 8080, GBZ80, 64180, RCM2/3/4k)
|
||||
C16x/ST10
|
||||
6502 family
|
||||
6800 family (6800, 6801, 6803, 68HC11)
|
||||
6502 & 6800 family (6800, 6801, 6803, 68HC11)
|
||||
QNICE (elegant 16-bit FPGA CPU)
|
||||
TR3200 (virtual CPU from 0x10c)
|
||||
Raspberry-Pi VideoCore IV
|
||||
|
||||
These syntax flavours are supported:
|
||||
|
||||
Standard MIT (GNU-as style) syntax
|
||||
Motorola/Freescale 68k syntax (Devpac compatible)
|
||||
Atari MadMac syntax (6502, 68k, Jaguar)
|
||||
Old 8-bit style syntax
|
||||
|
||||
WWW: http://sun.hasenbraten.de/vasm/
|
||||
|
@ -33,11 +33,11 @@ bin/vasmppc_mot
|
||||
bin/vasmppc_oldstyle
|
||||
bin/vasmppc_std
|
||||
bin/vasmppc_test
|
||||
bin/vasmtest_madmac
|
||||
bin/vasmtest_mot
|
||||
bin/vasmtest_oldstyle
|
||||
bin/vasmtest_std
|
||||
bin/vasmtest_test
|
||||
bin/vasmqnice_madmac
|
||||
bin/vasmqnice_mot
|
||||
bin/vasmqnice_oldstyle
|
||||
bin/vasmqnice_std
|
||||
bin/vasmqnice_test
|
||||
bin/vasmtr3200_madmac
|
||||
bin/vasmtr3200_mot
|
||||
bin/vasmtr3200_oldstyle
|
||||
@ -59,27 +59,28 @@ bin/vasmz80_oldstyle
|
||||
bin/vasmz80_std
|
||||
bin/vasmz80_test
|
||||
bin/vobjdump
|
||||
%%PORTDOCS%%%%DOCSDIR%%/cpu_6502.texi
|
||||
%%PORTDOCS%%%%DOCSDIR%%/cpu_6800.texi
|
||||
%%PORTDOCS%%%%DOCSDIR%%/cpu_arm.texi
|
||||
%%PORTDOCS%%%%DOCSDIR%%/cpu_c16x.texi
|
||||
%%PORTDOCS%%%%DOCSDIR%%/cpu_jagrisc.texi
|
||||
%%PORTDOCS%%%%DOCSDIR%%/cpu_m68k.texi
|
||||
%%PORTDOCS%%%%DOCSDIR%%/cpu_ppc.texi
|
||||
%%PORTDOCS%%%%DOCSDIR%%/cpu_tr3200.texi
|
||||
%%PORTDOCS%%%%DOCSDIR%%/cpu_x86.texi
|
||||
%%PORTDOCS%%%%DOCSDIR%%/cpu_z80.texi
|
||||
%%PORTDOCS%%%%DOCSDIR%%/interface.texi
|
||||
%%PORTDOCS%%%%DOCSDIR%%/output_aout.texi
|
||||
%%PORTDOCS%%%%DOCSDIR%%/output_bin.texi
|
||||
%%PORTDOCS%%%%DOCSDIR%%/output_elf.texi
|
||||
%%PORTDOCS%%%%DOCSDIR%%/output_hunk.texi
|
||||
%%PORTDOCS%%%%DOCSDIR%%/output_test.texi
|
||||
%%PORTDOCS%%%%DOCSDIR%%/output_tos.texi
|
||||
%%PORTDOCS%%%%DOCSDIR%%/output_vobj.texi
|
||||
%%PORTDOCS%%%%DOCSDIR%%/syntax_madmac.texi
|
||||
%%PORTDOCS%%%%DOCSDIR%%/syntax_mot.texi
|
||||
%%PORTDOCS%%%%DOCSDIR%%/syntax_oldstyle.texi
|
||||
%%PORTDOCS%%%%DOCSDIR%%/syntax_std.texi
|
||||
%%PORTDOCS%%%%DOCSDIR%%/vasm.texi
|
||||
%%PORTDOCS%%%%DOCSDIR%%/vasm_main.texi
|
||||
%%PORTDOCS%%%%DOCSDIR%%/cpu_6502
|
||||
%%PORTDOCS%%%%DOCSDIR%%/cpu_6800
|
||||
%%PORTDOCS%%%%DOCSDIR%%/cpu_arm
|
||||
%%PORTDOCS%%%%DOCSDIR%%/cpu_c16x
|
||||
%%PORTDOCS%%%%DOCSDIR%%/cpu_jagrisc
|
||||
%%PORTDOCS%%%%DOCSDIR%%/cpu_m68k
|
||||
%%PORTDOCS%%%%DOCSDIR%%/cpu_ppc
|
||||
%%PORTDOCS%%%%DOCSDIR%%/cpu_tr3200
|
||||
%%PORTDOCS%%%%DOCSDIR%%/cpu_x86
|
||||
%%PORTDOCS%%%%DOCSDIR%%/cpu_z80
|
||||
%%PORTDOCS%%%%DOCSDIR%%/interface
|
||||
%%PORTDOCS%%%%DOCSDIR%%/output_aout
|
||||
%%PORTDOCS%%%%DOCSDIR%%/output_bin
|
||||
%%PORTDOCS%%%%DOCSDIR%%/output_elf
|
||||
%%PORTDOCS%%%%DOCSDIR%%/output_hunk
|
||||
%%PORTDOCS%%%%DOCSDIR%%/output_srec
|
||||
%%PORTDOCS%%%%DOCSDIR%%/output_test
|
||||
%%PORTDOCS%%%%DOCSDIR%%/output_tos
|
||||
%%PORTDOCS%%%%DOCSDIR%%/output_vobj
|
||||
%%PORTDOCS%%%%DOCSDIR%%/syntax_madmac
|
||||
%%PORTDOCS%%%%DOCSDIR%%/syntax_mot
|
||||
%%PORTDOCS%%%%DOCSDIR%%/syntax_oldstyle
|
||||
%%PORTDOCS%%%%DOCSDIR%%/syntax_std
|
||||
%%PORTDOCS%%%%DOCSDIR%%/vasm
|
||||
%%PORTDOCS%%%%DOCSDIR%%/vasm_main
|
||||
|
Loading…
Reference in New Issue
Block a user