Update to 5.6.11-rc60.3

This commit is contained in:
Florian Smeets 2013-06-07 15:05:38 +00:00
parent 64eed4ceaa
commit 6fd6d4dccb
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=320208
6 changed files with 31 additions and 34 deletions

View File

@ -2,12 +2,12 @@
# $FreeBSD$
PORTNAME?= percona
DISTVERSION= 5.6.10-alpha60.2
DISTVERSION= 5.6.11-rc60.3
PORTREVISION?= 0
CATEGORIES= databases ipv6
MASTER_SITES= http://www.percona.com/downloads/Percona-Server-5.6/LATEST/source/
PKGNAMESUFFIX?= -server
DISTNAME= Percona-Server-5.6.10-alpha60.2
DISTNAME= Percona-Server-5.6.11-rc60.3
MAINTAINER= flo@FreeBSD.org
COMMENT?= Multithreaded SQL database (server)
@ -78,6 +78,8 @@ MAN1= my_print_defaults.1 myisam_ftdump.1 myisamchk.1 myisamlog.1 myisampack.1
mysqld_multi.1 mysqld_safe.1 mysqldumpslow.1 mysqlhotcopy.1 mysqlman.1 \
mysqltest.1 perror.1 replace.1 resolve_stack_dump.1 resolveip.1
MAN8= mysqld.8
CMAKE_ARGS+= -DWITH_EMBEDDED_SERVER="ON"
post-install:

View File

@ -1,2 +1,2 @@
SHA256 (Percona-Server-5.6.10-alpha60.2.tar.gz) = 25d0e4d309dd9dd6ac6b35363b5c02aa44a5263e46f7b28e4b05a846dbc24eff
SIZE (Percona-Server-5.6.10-alpha60.2.tar.gz) = 32654985
SHA256 (Percona-Server-5.6.11-rc60.3.tar.gz) = 8f8626811087eb177561c16870d290a41a0950edd9ac02f9bbab73ff01786921
SIZE (Percona-Server-5.6.11-rc60.3.tar.gz) = 33327340

View File

@ -1,5 +1,5 @@
--- client/CMakeLists.txt.orig 2013-01-22 17:54:50.000000000 +0100
+++ client/CMakeLists.txt 2013-02-13 14:47:51.000000000 +0100
--- client/CMakeLists.txt.orig 2013-06-03 00:02:34.000000000 +0200
+++ client/CMakeLists.txt 2013-06-06 00:49:27.110952603 +0200
@@ -33,17 +33,20 @@
ADD_DEFINITIONS(${READLINE_DEFINES})
@ -40,7 +40,7 @@
TARGET_LINK_LIBRARIES(mysql_plugin mysqlclient)
+IF(FALSE)
MYSQL_ADD_EXECUTABLE(mysqlbinlog mysqlbinlog.cc)
MYSQL_ADD_EXECUTABLE(mysqlbinlog mysqlbinlog.cc sql_string.cc)
TARGET_LINK_LIBRARIES(mysqlbinlog mysqlclient)
@@ -75,6 +82,7 @@

View File

@ -1,9 +1,9 @@
--- libmysql/CMakeLists.txt.orig 2010-12-03 18:58:26.000000000 +0100
+++ libmysql/CMakeLists.txt 2010-12-23 22:01:37.000000000 +0100
@@ -153,13 +153,14 @@
--- libmysql/CMakeLists.txt.orig 2013-06-03 00:02:34.000000000 +0200
+++ libmysql/CMakeLists.txt 2013-06-06 00:54:32.603753815 +0200
@@ -173,13 +173,14 @@
ENDIF()
# Merge several convenience libraries into one big mysqlclient
# and link them together into shared library.
-MERGE_LIBRARIES(mysqlclient STATIC ${LIBS} COMPONENT Development)
+MERGE_LIBRARIES(mysqlclient STATIC ${LIBS} COMPONENT Development NOINSTALL)
@ -16,20 +16,24 @@
IF(UNIX)
MACRO(GET_VERSIONED_LIBNAME LIBNAME EXTENSION VERSION OUTNAME)
SET(DOT_VERSION ".${VERSION}")
@@ -174,9 +175,11 @@
@@ -194,13 +195,15 @@
ENDMACRO()
INSTALL_SYMLINK(${CMAKE_STATIC_LIBRARY_PREFIX}mysqlclient_r.a mysqlclient ${INSTALL_LIBDIR} Development)
ENDIF()
+ENDIF()
IF(NOT DISABLE_SHARED)
- MERGE_LIBRARIES(libmysql SHARED ${LIBS} EXPORTS ${CLIENT_API_FUNCTIONS} COMPONENT SharedLibraries)
+ MERGE_LIBRARIES(libmysql SHARED ${LIBS} EXPORTS ${CLIENT_API_FUNCTIONS} COMPONENT SharedLibraries NOINSTALL)
# Merge several convenience libraries into one big mysqlclient
# and link them together into shared library.
MERGE_LIBRARIES(libmysql SHARED ${LIBS}
EXPORTS ${CLIENT_API_FUNCTIONS}
- COMPONENT SharedLibraries)
+ COMPONENT SharedLibraries NOINSTALL)
+IF(FALSE)
IF(UNIX)
# libtool compatability
IF(CMAKE_SYSTEM_NAME MATCHES "FreeBSD" OR APPLE)
@@ -223,3 +226,4 @@
@@ -252,3 +255,4 @@
ENDFOREACH()
ENDIF()
ENDIF()

View File

@ -1,14 +1,14 @@
--- sql/CMakeLists.txt.orig 2010-12-23 17:31:28.000000000 +0100
+++ sql/CMakeLists.txt 2010-12-23 17:33:36.000000000 +0100
@@ -245,6 +245,7 @@
--- sql/CMakeLists.txt.orig 2013-06-03 00:02:34.000000000 +0200
+++ sql/CMakeLists.txt 2013-06-06 00:56:54.121744790 +0200
@@ -430,6 +430,7 @@
IF(INSTALL_LAYOUT STREQUAL "STANDALONE")
+IF(FALSE)
# We need to create empty directories (data/test) the installation.
# This does not work with current CPack due to http://www.cmake.org/Bug/view.php?id=8767
# Avoid completely empty directories and install dummy file instead.
@@ -286,6 +287,7 @@
# Copy db.opt into data/test/
SET(DBOPT_FILE ${CMAKE_CURRENT_SOURCE_DIR}/db.opt )
INSTALL(FILES ${DBOPT_FILE} DESTINATION data/test COMPONENT DataFiles)
@@ -474,6 +475,7 @@
INSTALL(FILES ${DUMMY_FILE} DESTINATION data/mysql COMPONENT DataFiles)
ENDIF()
ENDIF()

View File

@ -1,6 +1,6 @@
--- sql/mysqld.cc.orig 2013-03-05 00:04:54.000000000 +0100
+++ sql/mysqld.cc 2013-03-18 09:55:35.499120018 +0100
@@ -6291,7 +6291,7 @@
--- sql/mysqld.cc.orig 2013-06-03 00:02:34.000000000 +0200
+++ sql/mysqld.cc 2013-06-06 00:57:21.510741832 +0200
@@ -6422,7 +6422,7 @@
#ifdef HAVE_LIBWRAP
{
@ -9,12 +9,3 @@
{
struct request_info req;
signal(SIGCHLD, SIG_DFL);
@@ -6323,7 +6323,7 @@
The connection was refused by TCP wrappers.
There are no details (by client IP) available to update the host_cache.
*/
- statistic_increment(connection_tcpwrap_errors, &LOCK_status);
+ statistic_increment(connection_errors_tcpwrap, &LOCK_status);
continue;
}
}