port update: www/dansguardian to version 2.6.1-3
The latest stable release of DansGuardian is 2.6.1-3. This release fixes a few security glitches in earlier releases, and adds several new features to improve filtering, throughput, and resource usage. A recommended update for all DG users. PR: ports/54199 Submitted by: Freddie Cash <fcash@sd73.bc.ca>
This commit is contained in:
parent
7d10f08253
commit
6fabfb1992
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=88469
@ -1,19 +1,18 @@
|
||||
# New ports collection makefile for: dansguardian
|
||||
# Date created: March 26, 2002
|
||||
# Whom: Freddie Cash <fcash@bigfoot.com>
|
||||
# Whom: Freddie Cash <fcash@sd73.bc.ca>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= dansguardian
|
||||
PORTVERSION= 2.2.10.0
|
||||
PORTREVISION= 1
|
||||
PORTVERSION= 2.6.1.3
|
||||
CATEGORIES= www
|
||||
MASTER_SITES= # empty, see below
|
||||
DISTNAME= DansGuardian-${PORTVERSION:R}-${PORTVERSION:E}.source
|
||||
|
||||
MAINTAINER= fcash@bigfoot.com
|
||||
COMMENT= A fast, simple web content filter for Squid proxy servers
|
||||
MAINTAINER= fcash@sd73.bc.ca
|
||||
COMMENT= A fast, featureful web content filter for Squid proxy servers
|
||||
|
||||
RUN_DEPENDS= ${LOCALBASE}/sbin/squid:${PORTSDIR}/www/squid24:install \
|
||||
${LOCALBASE}/sbin/httpd:${PORTSDIR}/www/apache13:install
|
||||
@ -31,17 +30,20 @@ CONFIGURE_ARGS= --prefix=${PREFIX} \
|
||||
|
||||
DG_URL= http://dansguardian.org/index.php?page=copyright2
|
||||
|
||||
.if defined(WITHOUT_PICS)
|
||||
CONFIGURE_ARGS+= --without-pics-filter
|
||||
.endif
|
||||
|
||||
MAN8= dansguardian.8
|
||||
|
||||
NO_CDROM= "Commercial download is restricted. Check ${DG_URL} for more info"
|
||||
NO_PACKAGE= "Redistribution is restricted. Check ${DG_URL} for more info"
|
||||
RESTRICTED= ${NO_PACKAGE}
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if ${OSVERSION} > 500000 || defined(WITH_GCC3)
|
||||
CONFIGURE_ARGS+= --gccver=3
|
||||
.else
|
||||
CONFIGURE_ARGS+= --gccver=2
|
||||
.endif
|
||||
|
||||
.if !(exists(${DISTDIR}/${DISTNAME}${EXTRACT_SUFX}))
|
||||
IGNORE= "Commercial source download is restricted. Please visit and read ${DG_URL} and download ${DISTNAME}${EXTRACT_SUFX} into ${DISTDIR} before running make"
|
||||
.endif
|
||||
|
@ -1 +1 @@
|
||||
MD5 (DansGuardian-2.2.10-0.source.tar.gz) = 1249c28c02fe1abb8313c9f71086a2c5
|
||||
MD5 (DansGuardian-2.6.1-3.source.tar.gz) = 21fa3b79fb66817c95003d320b62a4c1
|
||||
|
11
www/dansguardian/files/patch-FatController.cpp
Normal file
11
www/dansguardian/files/patch-FatController.cpp
Normal file
@ -0,0 +1,11 @@
|
||||
--- FatController.cpp.orig Mon Jul 7 14:59:33 2003
|
||||
+++ FatController.cpp Mon Jul 7 14:59:52 2003
|
||||
@@ -513,7 +513,7 @@
|
||||
if (conn) {
|
||||
if (report) {
|
||||
if (!isDaemonised) {
|
||||
- std::cerr << "Error creating connecting to test proxy" << std::endl;
|
||||
+ std::cerr << "Error creating connection to test proxy" << std::endl;
|
||||
}
|
||||
syslog(LOG_ERR, "%s","Error creating connection to test proxy");
|
||||
}
|
37
www/dansguardian/files/patch-autoconf::bsdv.in
Normal file
37
www/dansguardian/files/patch-autoconf::bsdv.in
Normal file
@ -0,0 +1,37 @@
|
||||
--- autoconf/bsdv.in.orig Mon Jul 7 12:04:33 2003
|
||||
+++ autoconf/bsdv.in Mon Jul 7 12:07:11 2003
|
||||
@@ -1,16 +1,26 @@
|
||||
#!/bin/sh
|
||||
#
|
||||
-# BSD startup script for dansguardian
|
||||
-# partly based on httpd startup script
|
||||
+# BSD startup script for dansguardian.
|
||||
#
|
||||
-# description: A web content filtering plugin for web \
|
||||
-# proxies, developed to filter using lists of \
|
||||
-# banned phrases, MIME types, filename \
|
||||
+# description: A web content filtering plugin for web
|
||||
+# proxies, developed to filter using lists of
|
||||
+# banned phrases, MIME types, filename
|
||||
# extensions and PICS labling.
|
||||
# processname: dansguardian
|
||||
|
||||
-
|
||||
-# See how we were called.
|
||||
-
|
||||
case "$1" in
|
||||
start)
|
||||
+ [ -x /usr/local/sbin/dansguardian ] && /usr/local/sbin/dansguardian
|
||||
+ echo -n " dansguardian"
|
||||
+ ;;
|
||||
+stop)
|
||||
+ /usr/local/sbin/dansguardian -q
|
||||
+ rm -f /tmp/.dguardianipc
|
||||
+ echo -n " dansguardian"
|
||||
+ ;;
|
||||
+*)
|
||||
+ echo "Usage: $0 {start|stop|restart}"
|
||||
+ ;;
|
||||
+esac
|
||||
+exit 0
|
||||
+
|
@ -1,7 +1,7 @@
|
||||
--- autoconf/fbsd.in.orig Tue Apr 2 11:51:15 2002
|
||||
+++ autoconf/fbsd.in Tue Apr 2 11:54:12 2002
|
||||
@@ -17,7 +17,7 @@
|
||||
dansguardian.conf config.cache Makefile logrotation
|
||||
--- autoconf/fbsd.in.orig Mon Jul 7 02:47:25 2003
|
||||
+++ autoconf/fbsd.in Mon Jul 7 14:51:43 2003
|
||||
@@ -20,7 +20,7 @@
|
||||
logrotate.dansguardian
|
||||
|
||||
PASSVARS = -DPROXYUSER=\"${PROXYUSER}\"
|
||||
-PASSVARS += -DLOGLOCATION=\"${LOGLOCATION}access.log\"
|
||||
@ -9,67 +9,125 @@
|
||||
PASSVARS += -DCONFFILELOCATION=\"${CONFFILELOCATION}dansguardian.conf\"
|
||||
PASSVARS += -DPIDDIR=\"${PIDDIR}\"
|
||||
|
||||
@@ -34,36 +34,31 @@
|
||||
@@ -37,56 +37,86 @@
|
||||
.cpp.o:
|
||||
$(CPP) $(DEBUG) $(CFLAGS) -c $<
|
||||
|
||||
all: $(OBJ)
|
||||
-all: $(OBJ)
|
||||
+all: $(OBJ)
|
||||
$(CPP) -o dansguardian $(DGCFLAGS) $(DEBUG) $(OBJ) $(LIBS) dansguardian.cpp
|
||||
|
||||
install:
|
||||
@test -d $(SYSVLOCATION) || install -d $(SYSVLOCATION)
|
||||
@test -d $(CONFFILELOCATION) || install -d $(CONFFILELOCATION)
|
||||
@test -d $(CGIBINLOCATION) || install -d $(CGIBINLOCATION)
|
||||
- @test -d $(MANUALFILES)man8/ || install -d $(MANUALFILES)man8/
|
||||
- @test -d $(LOGLOCATION) || install -d $(LOGLOCATION)
|
||||
- @test -d $(BINARYLOCATION) || /usr/sbin/install -d $(BINARYLOCATION)
|
||||
- cp -f ./dansguardian $(BINARYLOCATION)dansguardian
|
||||
- cp -f ./dansguardian.conf $(CONFFILELOCATION)dansguardian.conf
|
||||
- cp -f ./bannedphraselist $(CONFFILELOCATION)bannedphraselist
|
||||
- cp -f ./bannedextensionlist $(CONFFILELOCATION)bannedextensionlist
|
||||
- cp -f ./bannedmimetypelist $(CONFFILELOCATION)bannedmimetypelist
|
||||
- cp -f ./bannedurllist $(CONFFILELOCATION)bannedurllist
|
||||
- cp -f ./bannedregexpurllist $(CONFFILELOCATION)bannedregexpurllist
|
||||
- cp -f ./bannedsitelist $(CONFFILELOCATION)bannedsitelist
|
||||
- cp -f ./exceptionsitelist $(CONFFILELOCATION)exceptionsitelist
|
||||
- cp -f ./exceptionuserlist $(CONFFILELOCATION)exceptionuserlist
|
||||
- cp -f ./exceptioniplist $(CONFFILELOCATION)exceptioniplist
|
||||
- cp -f ./pics $(CONFFILELOCATION)pics
|
||||
- cp -f ./logrotation $(CONFFILELOCATION)logrotation
|
||||
- cp -f ./dansguardian.bsdv $(SYSVLOCATION)dansguardian.sh
|
||||
- cp -f ./dansguardian.pl $(CGIBINLOCATION)dansguardian.pl
|
||||
- chmod o+x $(CGIBINLOCATION)dansguardian.pl
|
||||
- cp -f ./dansguardian.8.gz $(MANUALFILES)man8/dansguardian.8.gz
|
||||
- chown -R $(PROXYUSER).$(PROXYGROUP) $(LOGLOCATION)
|
||||
- chmod -R u+wr $(LOGLOCATION)
|
||||
- chmod u+wrx $(LOGLOCATION)
|
||||
+ @test -d $(BINARYLOCATION) || install -d $(BINARYLOCATION)
|
||||
+ @install -m 755 -o root -g wheel ./dansguardian $(BINARYLOCATION)dansguardian
|
||||
+ @install -m 644 -o root -g wheel ./dansguardian.conf $(CONFFILELOCATION)dansguardian.conf
|
||||
+ @install -m 644 -o root -g wheel ./bannedphraselist $(CONFFILELOCATION)bannedphraselist
|
||||
+ @install -m 644 -o root -g wheel ./bannedextensionlist $(CONFFILELOCATION)bannedextensionlist
|
||||
+ @install -m 644 -o root -g wheel ./bannedmimetypelist $(CONFFILELOCATION)bannedmimetypelist
|
||||
+ @install -m 644 -o root -g wheel ./bannedurllist $(CONFFILELOCATION)bannedurllist
|
||||
+ @install -m 644 -o root -g wheel ./bannedregexpurllist $(CONFFILELOCATION)bannedregexpurllist
|
||||
+ @install -m 644 -o root -g wheel ./bannedsitelist $(CONFFILELOCATION)bannedsitelist
|
||||
+ @install -m 644 -o root -g wheel ./exceptionsitelist $(CONFFILELOCATION)exceptionsitelist
|
||||
+ @install -m 644 -o root -g wheel ./exceptionuserlist $(CONFFILELOCATION)exceptionuserlist
|
||||
+ @install -m 644 -o root -g wheel ./exceptioniplist $(CONFFILELOCATION)exceptioniplist
|
||||
+ @install -m 644 -o root -g wheel ./pics $(CONFFILELOCATION)pics
|
||||
+ @install -m 755 -o root -g wheel ./dansguardian.bsdv $(SYSVLOCATION)start-dg.sh
|
||||
+ @install -m 755 -o root -g wheel ./dansguardian.pl $(CGIBINLOCATION)dansguardian.pl
|
||||
+ @install -m 644 -o root -g wheel ./dansguardian.8 $(MANUALFILES)man8/dansguardian.8
|
||||
+ @touch $(LOGLOCATION)dansguardian.log
|
||||
+ @chown $(PROXYUSER):$(PROXYGROUP) $(LOGLOCATION)dansguardian.log
|
||||
@test -d $I$(SYSVLOCATION) || install -d $I$(SYSVLOCATION)
|
||||
@test -d $I$(CONFFILELOCATION) || install -d $I$(CONFFILELOCATION)
|
||||
@test -d $I$(CONFFILELOCATION)phraselists || install -d $I$(CONFFILELOCATION)phraselists
|
||||
+ @test -d $I$(CONFFILELOCATION)phraselists/chat || install -d $I$(CONFFILELOCATION)phraselists/chat
|
||||
+ @test -d $I$(CONFFILELOCATION)phraselists/drugadvocacy || install -d $I$(CONFFILELOCATION)phraselists/drugadvocacy
|
||||
+ @test -d $I$(CONFFILELOCATION)phraselists/dutchbadwords || install -d $I$(CONFFILELOCATION)phraselists/dutchbadwords
|
||||
+ @test -d $I$(CONFFILELOCATION)phraselists/frenchbadwords || install -d $I$(CONFFILELOCATION)phraselists/frenchbadwords
|
||||
+ @test -d $I$(CONFFILELOCATION)phraselists/gambling || install -d $I$(CONFFILELOCATION)phraselists/gambling
|
||||
+ @test -d $I$(CONFFILELOCATION)phraselists/goodphrases || install -d $I$(CONFFILELOCATION)phraselists/goodphrases
|
||||
+ @test -d $I$(CONFFILELOCATION)phraselists/gore || install -d $I$(CONFFILELOCATION)phraselists/gore
|
||||
+ @test -d $I$(CONFFILELOCATION)phraselists/illegaldrugs || install -d $I$(CONFFILELOCATION)phraselists/illegaldrugs
|
||||
+ @test -d $I$(CONFFILELOCATION)phraselists/intolerance || install -d $I$(CONFFILELOCATION)phraselists/intolerance
|
||||
+ @test -d $I$(CONFFILELOCATION)phraselists/italianbadwords || install -d $I$(CONFFILELOCATION)phraselists/italianbadwords
|
||||
+ @test -d $I$(CONFFILELOCATION)phraselists/legaldrugs || install -d $I$(CONFFILELOCATION)phraselists/legaldrugs
|
||||
+ @test -d $I$(CONFFILELOCATION)phraselists/personals || install -d $I$(CONFFILELOCATION)phraselists/personals
|
||||
+ @test -d $I$(CONFFILELOCATION)phraselists/pornography || install -d $I$(CONFFILELOCATION)phraselists/pornography
|
||||
+ @test -d $I$(CONFFILELOCATION)phraselists/violence || install -d $I$(CONFFILELOCATION)phraselists/violence
|
||||
+ @test -d $I$(CONFFILELOCATION)phraselists/warezhacking || install -d $I$(CONFFILELOCATION)phraselists/warezhacking
|
||||
+ @test -d $I$(CONFFILELOCATION)phraselists/weapons || install -d $I$(CONFFILELOCATION)phraselists/weapons
|
||||
@test -d $I$(CGIBINLOCATION) || install -d $I$(CGIBINLOCATION)
|
||||
@test -d $I$(MANUALFILES)man8/ || install -d $I$(MANUALFILES)man8/
|
||||
@test -d $I$(LOGLOCATION) || install -d $I$(LOGLOCATION)
|
||||
- @test -d $I$(BINARYLOCATION) || /usr/sbin/install -d $I$(BINARYLOCATION)
|
||||
- cp -f ./dansguardian $I$(BINARYLOCATION)dansguardian
|
||||
- cp -f ./dansguardian.conf $I$(CONFFILELOCATION)dansguardian.conf
|
||||
- cp -f ./bannedphraselist $I$(CONFFILELOCATION)bannedphraselist
|
||||
- cp -f ./exceptionphraselist $I$(CONFFILELOCATION)exceptionphraselist
|
||||
- cp -f ./weightedphraselist $I$(CONFFILELOCATION)weightedphraselist
|
||||
- cp -f -R ./phraselists/* $I$(CONFFILELOCATION)phraselists/
|
||||
- cp -f ./bannediplist $I$(CONFFILELOCATION)bannediplist
|
||||
- cp -f ./banneduserlist $I$(CONFFILELOCATION)banneduserlist
|
||||
- cp -f ./bannedextensionlist $I$(CONFFILELOCATION)bannedextensionlist
|
||||
- cp -f ./bannedmimetypelist $I$(CONFFILELOCATION)bannedmimetypelist
|
||||
- cp -f ./bannedurllist $I$(CONFFILELOCATION)bannedurllist
|
||||
- cp -f ./bannedregexpurllist $I$(CONFFILELOCATION)bannedregexpurllist
|
||||
- cp -f ./bannedsitelist $I$(CONFFILELOCATION)bannedsitelist
|
||||
- cp -f ./contentregexplist $I$(CONFFILELOCATION)contentregexplist
|
||||
- cp -f ./exceptionsitelist $I$(CONFFILELOCATION)exceptionsitelist
|
||||
- cp -f ./exceptionurllist $I$(CONFFILELOCATION)exceptionurllist
|
||||
- cp -f ./exceptionuserlist $I$(CONFFILELOCATION)exceptionuserlist
|
||||
- cp -f ./exceptioniplist $I$(CONFFILELOCATION)exceptioniplist
|
||||
- cp -f ./pics $I$(CONFFILELOCATION)pics
|
||||
- cp -f ./template.html $I$(CONFFILELOCATION)template.html
|
||||
- cp -f ./messages $I$(CONFFILELOCATION)messages
|
||||
- cp -f ./logrotation $I$(CONFFILELOCATION)logrotation
|
||||
- cp -f ./dansguardian.bsdv $I$(SYSVLOCATION)dansguardian.sh
|
||||
- cp -f ./dansguardian.pl $I$(CGIBINLOCATION)dansguardian.pl
|
||||
- chmod o+x $I$(CGIBINLOCATION)dansguardian.pl
|
||||
- cp -f ./dansguardian.8.gz $I$(MANUALFILES)man8/dansguardian.8.gz
|
||||
- chown -R $(PROXYUSER).$(PROXYGROUP) $I$(LOGLOCATION)
|
||||
- chmod -R u+wr $I$(LOGLOCATION)
|
||||
- chmod u+wrx $I$(LOGLOCATION)
|
||||
- if [ -d $(LOGROTATELOCATION) ]; then cp -f ./logrotate.dansguardian $I$(LOGROTATELOCATION)dansguardian; fi
|
||||
+ @test -d $I$(BINARYLOCATION) || install -d $I$(BINARYLOCATION)
|
||||
+ install -o root -g wheel -m 755 ./dansguardian $I$(BINARYLOCATION)dansguardian
|
||||
+ install -o root -g wheel -m 644 ./dansguardian.conf $I$(CONFFILELOCATION)dansguardian.conf
|
||||
+ install -o root -g wheel -m 644 ./bannedphraselist $I$(CONFFILELOCATION)bannedphraselist
|
||||
+ install -o root -g wheel -m 644 ./exceptionphraselist $I$(CONFFILELOCATION)exceptionphraselist
|
||||
+ install -o root -g wheel -m 644 ./weightedphraselist $I$(CONFFILELOCATION)weightedphraselist
|
||||
+ install -o root -g wheel -m 644 ./phraselists/chat/weighted $I$(CONFFILELOCATION)phraselists/chat/weighted
|
||||
+ install -o root -g wheel -m 644 ./phraselists/drugadvocacy/weighted $I$(CONFFILELOCATION)phraselists/drugadvocacy/weighted
|
||||
+ install -o root -g wheel -m 644 ./phraselists/dutchbadwords/weighted $I$(CONFFILELOCATION)phraselists/dutchbadwords/weighted
|
||||
+ install -o root -g wheel -m 644 ./phraselists/frenchbadwords/weighted $I$(CONFFILELOCATION)phraselists/frenchbadwords/weighted
|
||||
+ install -o root -g wheel -m 644 ./phraselists/gambling/banned $I$(CONFFILELOCATION)phraselists/gambling/banned
|
||||
+ install -o root -g wheel -m 644 ./phraselists/gambling/weighted $I$(CONFFILELOCATION)phraselists/gambling/weighted
|
||||
+ install -o root -g wheel -m 644 ./phraselists/goodphrases/exception $I$(CONFFILELOCATION)phraselists/goodphrases/exception
|
||||
+ install -o root -g wheel -m 644 ./phraselists/goodphrases/weighted $I$(CONFFILELOCATION)phraselists/goodphrases/weighted
|
||||
+ install -o root -g wheel -m 644 ./phraselists/gore/weighted $I$(CONFFILELOCATION)phraselists/gore/weighted
|
||||
+ install -o root -g wheel -m 644 ./phraselists/illegaldrugs/banned $I$(CONFFILELOCATION)phraselists/illegaldrugs/banned
|
||||
+ install -o root -g wheel -m 644 ./phraselists/illegaldrugs/weighted $I$(CONFFILELOCATION)phraselists/illegaldrugs/weighted
|
||||
+ install -o root -g wheel -m 644 ./phraselists/intolerance/banned $I$(CONFFILELOCATION)phraselists/intolerance/banned
|
||||
+ install -o root -g wheel -m 644 ./phraselists/intolerance/weighted $I$(CONFFILELOCATION)phraselists/intolerance/weighted
|
||||
+ install -o root -g wheel -m 644 ./phraselists/italianbadwords/weighted $I$(CONFFILELOCATION)phraselists/italianbadwords/weighted
|
||||
+ install -o root -g wheel -m 644 ./phraselists/legaldrugs/weighted $I$(CONFFILELOCATION)phraselists/legaldrugs/weighted
|
||||
+ install -o root -g wheel -m 644 ./phraselists/personals/weighted $I$(CONFFILELOCATION)phraselists/personals/weighted
|
||||
+ install -o root -g wheel -m 644 ./phraselists/pornography/banned $I$(CONFFILELOCATION)phraselists/pornography/banned
|
||||
+ install -o root -g wheel -m 644 ./phraselists/pornography/weighted $I$(CONFFILELOCATION)phraselists/pornography/weighted
|
||||
+ install -o root -g wheel -m 644 ./phraselists/violence/weighted $I$(CONFFILELOCATION)phraselists/violence/weighted
|
||||
+ install -o root -g wheel -m 644 ./phraselists/warezhacking/weighted $I$(CONFFILELOCATION)phraselists/warezhacking/weighted
|
||||
+ install -o root -g wheel -m 644 ./phraselists/weapons/weighted $I$(CONFFILELOCATION)phraselists/weapons/weighted
|
||||
+ install -o root -g wheel -m 644 ./bannediplist $I$(CONFFILELOCATION)bannediplist
|
||||
+ install -o root -g wheel -m 644 ./banneduserlist $I$(CONFFILELOCATION)banneduserlist
|
||||
+ install -o root -g wheel -m 644 ./bannedextensionlist $I$(CONFFILELOCATION)bannedextensionlist
|
||||
+ install -o root -g wheel -m 644 ./bannedmimetypelist $I$(CONFFILELOCATION)bannedmimetypelist
|
||||
+ install -o root -g wheel -m 644 ./bannedurllist $I$(CONFFILELOCATION)bannedurllist
|
||||
+ install -o root -g wheel -m 644 ./bannedregexpurllist $I$(CONFFILELOCATION)bannedregexpurllist
|
||||
+ install -o root -g wheel -m 644 ./bannedsitelist $I$(CONFFILELOCATION)bannedsitelist
|
||||
+ install -o root -g wheel -m 644 ./contentregexplist $I$(CONFFILELOCATION)contentregexplist
|
||||
+ install -o root -g wheel -m 644 ./exceptionsitelist $I$(CONFFILELOCATION)exceptionsitelist
|
||||
+ install -o root -g wheel -m 644 ./exceptionurllist $I$(CONFFILELOCATION)exceptionurllist
|
||||
+ install -o root -g wheel -m 644 ./exceptionuserlist $I$(CONFFILELOCATION)exceptionuserlist
|
||||
+ install -o root -g wheel -m 644 ./exceptioniplist $I$(CONFFILELOCATION)exceptioniplist
|
||||
+ install -o root -g wheel -m 644 ./pics $I$(CONFFILELOCATION)pics
|
||||
+ install -o root -g wheel -m 644 ./template.html $I$(CONFFILELOCATION)template.html
|
||||
+ install -o root -g wheel -m 644 ./messages $I$(CONFFILELOCATION)messages
|
||||
+ install -o root -g wheel -m 755 ./dansguardian.bsdv $I$(SYSVLOCATION)start-dg.sh
|
||||
+ install -o root -g wheel -m 755 ./dansguardian.pl $I$(CGIBINLOCATION)dansguardian.pl
|
||||
+ install -o root -g wheel -m 644 ./dansguardian.8 $I$(MANUALFILES)man8/dansguardian.8
|
||||
+ install -o nobody -g nogroup -m 644 /dev/null $I$(LOGLOCATION)dansguardian.log
|
||||
|
||||
uninstall:
|
||||
rm -f $(BINARYLOCATION)dansguardian
|
||||
@@ -71,7 +66,7 @@
|
||||
rm -f $(SYSVLOCATION)dansguardian
|
||||
rm -f $(CGIBINLOCATION)dansguardian.pl
|
||||
rm -f $(MANUALFILES)man8/dansguardian.8.gz
|
||||
- rm -f $(MANUALFILES)man8/dansguardian.8.gz
|
||||
+ rm -f $(MANUALFILES)man8/dansguardian.8*
|
||||
rm -fr $(CONFFILELOCATION)
|
||||
- rm -fr $(LOGLOCATION)
|
||||
+ rm -f $(LOGLOCATION)dansguardian.log
|
||||
- if [ -f $(LOGROTATELOCATION)dansguardian ]; then rm -f $(LOGROTATELOCATION)dansguardian; fi
|
||||
+ rm -f $(LOGLOCATION)/dansguardian.log
|
||||
|
||||
clean:
|
||||
rm -f $(OBJ) $(PROG)
|
||||
|
@ -1,11 +1,57 @@
|
||||
--- configure.orig Tue Apr 2 09:15:26 2002
|
||||
+++ configure Tue Apr 2 09:29:41 2002
|
||||
@@ -2667,7 +2667,7 @@
|
||||
--- configure.orig Mon Jul 7 12:09:35 2003
|
||||
+++ configure Mon Jul 7 12:10:25 2003
|
||||
@@ -2540,7 +2540,7 @@
|
||||
$extendedecho "SYSVLOCATION = \${PREFIX}$sysvdir" >>Makefile
|
||||
$extendedecho "CGIBINLOCATION = \${PREFIX}$cgidir" >>Makefile
|
||||
$extendedecho "MANUALFILES = \${PREFIX}$mandir" >>Makefile
|
||||
-$extendedecho "LOGLOCATION = \${PREFIX}$logdir" >>Makefile
|
||||
+$extendedecho "LOGLOCATION = $logdir" >>Makefile
|
||||
$extendedecho "LOGROTATELOCATION = \${PREFIX}$logrotatedir" >>Makefile
|
||||
echo "PROXYUSER = $runas_usr" >>Makefile
|
||||
echo "PROXYGROUP = $runas_grp" >>Makefile
|
||||
echo "PIDDIR = $piddir" >>Makefile
|
||||
@@ -2665,27 +2665,6 @@
|
||||
rm -f dansguardian.bsdv
|
||||
fi
|
||||
cat autoconf/bsdv.in > dansguardian.bsdv
|
||||
- $extendedecho " [ -x $prefixdir$bindir\c" >> dansguardian.bsdv
|
||||
- $extendedecho "dansguardian ] && $prefixdir$bindir\c" >> dansguardian.bsdv
|
||||
- echo "dansguardian > /dev/null && $extendedecho ' dansguardian\c'" >> dansguardian.bsdv
|
||||
- echo " ;;" >> dansguardian.bsdv
|
||||
- echo "stop)" >> dansguardian.bsdv
|
||||
- $extendedecho " $prefixdir$bindir\c" >> dansguardian.bsdv
|
||||
- echo "dansguardian -q" >> dansguardian.bsdv
|
||||
- $extendedecho " [ -r /tmp/\c" >> dansguardian.bsdv
|
||||
- echo ".dguardianipc ] && $extendedecho ' dansguardian\c'" >> dansguardian.bsdv
|
||||
- echo " rm -f /tmp/.dguardianipc" >> dansguardian.bsdv
|
||||
- echo " ;;" >> dansguardian.bsdv
|
||||
- echo "restart)" >> dansguardian.bsdv
|
||||
- echo " \$0 stop" >> dansguardian.bsdv
|
||||
- echo " \$0 start" >> dansguardian.bsdv
|
||||
- echo " ;;" >> dansguardian.bsdv
|
||||
- echo "*)" >> dansguardian.bsdv
|
||||
- echo " echo \"Usage: `basename \$0` {start|stop|restart}\" >&2" >> dansguardian.bsdv
|
||||
- echo " ;;" >> dansguardian.bsdv
|
||||
- echo "esac" >> dansguardian.bsdv
|
||||
- echo "exit 0" >> dansguardian.bsdv
|
||||
- chmod u+x dansguardian.bsdv
|
||||
;;
|
||||
NetBSD*)
|
||||
if [ -f dansguardian.bsdv ]; then
|
||||
@@ -3082,7 +3061,7 @@
|
||||
echo "" >>logrotation
|
||||
echo "LOG_DIR=$prefixdir$logdir" >>logrotation
|
||||
echo "NUM_LOGS=4" >>logrotation
|
||||
-echo "LOG=\$LOG_DIR/access.log" >>logrotation
|
||||
+echo "LOG=\$LOG_DIR/dansguardian.log" >>logrotation
|
||||
echo "" >>logrotation
|
||||
|
||||
case `uname -s` in
|
||||
@@ -3176,7 +3155,7 @@
|
||||
fi
|
||||
|
||||
$extendedecho "$prefixdir$logdir\c" >>logrotate.dansguardian
|
||||
-echo "access.log {" >>logrotate.dansguardian
|
||||
+echo "dansguardian.log {" >>logrotate.dansguardian
|
||||
echo " rotate 4" >>logrotate.dansguardian
|
||||
echo " weekly" >>logrotate.dansguardian
|
||||
echo " sharedscripts" >>logrotate.dansguardian
|
||||
|
@ -1,11 +1,11 @@
|
||||
--- dansguardian.8.orig Tue Mar 26 09:03:19 2002
|
||||
+++ dansguardian.8 Tue Mar 26 09:03:25 2002
|
||||
--- dansguardian.8.orig Mon Jul 7 11:37:24 2003
|
||||
+++ dansguardian.8 Mon Jul 7 11:38:15 2003
|
||||
@@ -3,7 +3,7 @@
|
||||
.SH NAME
|
||||
DansGuardian 2
|
||||
.SH SYNOPSIS
|
||||
-/etc/rc.d/init.d/dansguardian [stop|start|status|restart]
|
||||
+/usr/local/etc/rc.d/dansguardian.sh [stop|start|restart]
|
||||
+/usr/local/etc/rc.d/start-dg.sh [stop|start|restart]
|
||||
.SH DESCRIPTION
|
||||
A Introduction
|
||||
|
||||
|
@ -1,20 +1,23 @@
|
||||
DansGuardian is a web content filtering proxy for Linux, FreeBSD, OpenBSD,
|
||||
and Solaris. It relies on a proxy server, such as Squid, for all fetching;
|
||||
however, DansGuardian should work with any proxy server.
|
||||
and Solaris. It relies on a proxy server, for all fetching. The preferred
|
||||
proxy is Squid, however, DansGuardian should work with any proxy server.
|
||||
|
||||
It filters using multiple methods, including:
|
||||
- URL and domain filtering
|
||||
- content phrase filtering
|
||||
- textual content filtering
|
||||
- PICS filtering
|
||||
- MIME filtering
|
||||
- MIME-type filtering
|
||||
- file extension filtering
|
||||
- POST filtering
|
||||
- user filtering
|
||||
- client IP filtering
|
||||
- exception lists for most of the above
|
||||
|
||||
Running make with WITHOUT_PICS=yes will disable the PICS filtering. All
|
||||
other filtering is controlled via the configuration file.
|
||||
|
||||
WWW: http://dansguardian.org
|
||||
WWW: http://backup.dansguardian.org
|
||||
WWW: http://dansguardian.intmain.org
|
||||
|
||||
- Freddie Cash
|
||||
fcash@bigfoot.com
|
||||
fcash@sd73.bc.ca
|
||||
|
@ -1,18 +1,81 @@
|
||||
@exec mkdir -p etc/dansguardian
|
||||
etc/dansguardian/dansguardian.conf
|
||||
etc/dansguardian/bannedphraselist
|
||||
@exec mkdir -p etc/dansguardian/phraselists
|
||||
@exec mkdir -p etc/dansguardian/phraselists/chat
|
||||
@exec mkdir -p etc/dansguardian/phraselists/drugadvocacy
|
||||
@exec mkdir -p etc/dansguardian/phraselists/dutchbadwords
|
||||
@exec mkdir -p etc/dansguardian/phraselists/frenchbadwords
|
||||
@exec mkdir -p etc/dansguardian/phraselists/gambling
|
||||
@exec mkdir -p etc/dansguardian/phraselists/goodphrases
|
||||
@exec mkdir -p etc/dansguardian/phraselists/gore
|
||||
@exec mkdir -p etc/dansguardian/phraselists/illegaldrugs
|
||||
@exec mkdir -p etc/dansguardian/phraselists/intolerance
|
||||
@exec mkdir -p etc/dansguardian/phraselists/italianbadwords
|
||||
@exec mkdir -p etc/dansguardian/phraselists/legaldrugs
|
||||
@exec mkdir -p etc/dansguardian/phraselists/personals
|
||||
@exec mkdir -p etc/dansguardian/phraselists/pornography
|
||||
@exec mkdir -p etc/dansguardian/phraselists/violence
|
||||
@exec mkdir -p etc/dansguardian/phraselists/warezhacking
|
||||
@exec mkdir -p etc/dansguardian/phraselists/weapons
|
||||
etc/dansguardian/bannedextensionlist
|
||||
etc/dansguardian/bannediplist
|
||||
etc/dansguardian/bannedmimetypelist
|
||||
etc/dansguardian/bannedurllist
|
||||
etc/dansguardian/bannedphraselist
|
||||
etc/dansguardian/bannedregexpurllist
|
||||
etc/dansguardian/bannedsitelist
|
||||
etc/dansguardian/exceptionsitelist
|
||||
etc/dansguardian/exceptionuserlist
|
||||
etc/dansguardian/bannedurllist
|
||||
etc/dansguardian/banneduserlist
|
||||
etc/dansguardian/contentregexplist
|
||||
etc/dansguardian/dansguardian.conf
|
||||
etc/dansguardian/exceptioniplist
|
||||
etc/dansguardian/exceptionphraselist
|
||||
etc/dansguardian/exceptionurllist
|
||||
etc/dansguardian/exceptionuserlist
|
||||
etc/dansguardian/exceptionsitelist
|
||||
etc/dansguardian/messages
|
||||
etc/dansguardian/phraselists/chat/weighted
|
||||
etc/dansguardian/phraselists/drugadvocacy/weighted
|
||||
etc/dansguardian/phraselists/dutchbadwords/weighted
|
||||
etc/dansguardian/phraselists/frenchbadwords/weighted
|
||||
etc/dansguardian/phraselists/gambling/banned
|
||||
etc/dansguardian/phraselists/gambling/weighted
|
||||
etc/dansguardian/phraselists/goodphrases/exception
|
||||
etc/dansguardian/phraselists/goodphrases/weighted
|
||||
etc/dansguardian/phraselists/gore/weighted
|
||||
etc/dansguardian/phraselists/illegaldrugs/banned
|
||||
etc/dansguardian/phraselists/illegaldrugs/weighted
|
||||
etc/dansguardian/phraselists/intolerance/banned
|
||||
etc/dansguardian/phraselists/intolerance/weighted
|
||||
etc/dansguardian/phraselists/italianbadwords/weighted
|
||||
etc/dansguardian/phraselists/legaldrugs/weighted
|
||||
etc/dansguardian/phraselists/personals/weighted
|
||||
etc/dansguardian/phraselists/pornography/banned
|
||||
etc/dansguardian/phraselists/pornography/weighted
|
||||
etc/dansguardian/phraselists/violence/weighted
|
||||
etc/dansguardian/phraselists/warezhacking/weighted
|
||||
etc/dansguardian/phraselists/weapons/weighted
|
||||
etc/dansguardian/pics
|
||||
etc/rc.d/dansguardian.sh
|
||||
etc/dansguardian/template.html
|
||||
etc/dansguardian/weightedphraselist
|
||||
etc/rc.d/start-dg.sh
|
||||
sbin/dansguardian
|
||||
www/cgi-bin/dansguardian.pl
|
||||
@dirrm etc/dansguardian/phraselists/chat
|
||||
@dirrm etc/dansguardian/phraselists/drugadvocacy
|
||||
@dirrm etc/dansguardian/phraselists/dutchbadwords
|
||||
@dirrm etc/dansguardian/phraselists/frenchbadwords
|
||||
@dirrm etc/dansguardian/phraselists/gambling
|
||||
@dirrm etc/dansguardian/phraselists/goodphrases
|
||||
@dirrm etc/dansguardian/phraselists/gore
|
||||
@dirrm etc/dansguardian/phraselists/illegaldrugs
|
||||
@dirrm etc/dansguardian/phraselists/intolerance
|
||||
@dirrm etc/dansguardian/phraselists/italianbadwords
|
||||
@dirrm etc/dansguardian/phraselists/legaldrugs
|
||||
@dirrm etc/dansguardian/phraselists/personals
|
||||
@dirrm etc/dansguardian/phraselists/pornography
|
||||
@dirrm etc/dansguardian/phraselists/violence
|
||||
@dirrm etc/dansguardian/phraselists/warezhacking
|
||||
@dirrm etc/dansguardian/phraselists/weapons
|
||||
@dirrm etc/dansguardian/phraselists
|
||||
@dirrm etc/dansguardian
|
||||
@unexec echo If permanently deleting this package, /var/log/dansguardian.log must be removed manually
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user