Updated to version 0.8.6 after I modified several problems
PR: ports/7734 Submitted by: Joel Sutton (maintainer)
This commit is contained in:
parent
35d40460e0
commit
6f79c9c567
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=17454
@ -1,52 +1,54 @@
|
||||
# New ports collection makefile for: Atari800-0.8.0
|
||||
# Version required: 0.8.1
|
||||
# New ports collection makefile for: Atari800-0.8.6
|
||||
# Version required: 0.8.6
|
||||
# Date created: 29th April, 1997
|
||||
# Whom: Joel Sutton <sutton@aardvark.apana.org.au>
|
||||
# Whom: Joel Sutton <jsutton@webnet.com.au>
|
||||
#
|
||||
# $Id: Makefile,v 1.2 1998/08/07 23:56:17 asami Exp $
|
||||
# $Id: Makefile,v 1.3 1998/12/03 06:44:06 obrien Exp $
|
||||
#
|
||||
|
||||
DISTNAME= Atari800-0.8.1
|
||||
PKGNAME= atari800-0.8.1
|
||||
DISTNAME= Atari800-0.8.6
|
||||
PKGNAME= atari800-0.8.6
|
||||
CATEGORIES= emulators
|
||||
MASTER_SITES= http://www.signus.demon.co.uk/Software/Portable/Atari800e/ \
|
||||
http://cas3.zlin.vutbr.cz/~stehlik/a800/
|
||||
DISTFILES= ${DISTNAME}${EXTRACT_SUFX} ${EXTRA_FILES}
|
||||
|
||||
MAINTAINER= sutton@aardvark.apana.org.au
|
||||
MAINTAINER= jsutton@webnet.com.au
|
||||
|
||||
BUILD_DEPENDS= unzip:${PORTSDIR}/archivers/unzip
|
||||
.if defined(ATARI) && (${ATARI} == "freebsd-xview")
|
||||
LIB_DEPENDS= xview:${PORTSDIR}/x11-toolkits/xview-lib
|
||||
|
||||
RESTRICTED= "xf25 contains copyright ROMs and cannot be distributed"
|
||||
NO_PACKAGE= ${RESTRICTED}
|
||||
|
||||
.endif
|
||||
DIST_SUBDIR= atari
|
||||
EXTRA_FILES= xf25.zip
|
||||
EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
|
||||
|
||||
# Source building
|
||||
#
|
||||
ALL_TARGET= freebsd-xview
|
||||
ALL_TARGET= ${ATARI}
|
||||
|
||||
RESTRICTED= "xf25 contains copyright ROMs and cannot be distributed."
|
||||
NO_PACKAGE= ${RESTRICTED}
|
||||
|
||||
# Installation
|
||||
#
|
||||
# Install and mkdir needed for 2.1.5R standard bsd.port.mk file. Other
|
||||
# variables are needed for the post-install target.
|
||||
#
|
||||
ATARI_DOC= ${PREFIX}/share/doc/atari
|
||||
ATARI_ROM= ataribas.rom atariosb.rom atarixl.rom
|
||||
ATARI_XF= ataribas.rom atariosb.rom atarixl.rom demos1.xfd \
|
||||
demos2.xfd dos25.xfd mydos45d.atr
|
||||
ATARI_LIB= ${PREFIX}/lib/atari
|
||||
SED_CONFIG= ${ATARI_LIB:S/\//\\\//g}\/
|
||||
SED_CONFIG= ${ATARI_LIB:S/\//\\\//g}
|
||||
DOC_FILES= BUGS CHANGES COPYING CREDITS INSTALL README TODO USAGE
|
||||
|
||||
MAN1= atari800.1
|
||||
|
||||
# Unpack roms from xf25.zip Atari Emulator for DOS and process the
|
||||
# configuration file to include the right paths for the rom files.
|
||||
#
|
||||
.if !defined(ATARI)
|
||||
pre-extract:
|
||||
@${ECHO_MSG} "Please define the environment variable ATARI to"
|
||||
@${ECHO_MSG} "determine how to build the emulator. Your choices are:"
|
||||
@${ECHO_MSG} " freebsd-ncurses, freebsd-x11, freebsd-xview. "
|
||||
@${ECHO_MSG}
|
||||
@${FALSE}
|
||||
.endif
|
||||
post-extract:
|
||||
@${ECHO_MSG} "===> Unzipping ROM files"
|
||||
unzip -Lo ${DISTDIR}/${DIST_SUBDIR}/${EXTRA_FILES} ${ATARI_ROM} -d ${WRKSRC}/
|
||||
|
||||
unzip -Lo ${DISTDIR}/${DIST_SUBDIR}/${EXTRA_FILES} ${ATARI_XF}\
|
||||
-d ${WRKSRC}/
|
||||
@${ECHO_MSG} "===> Processing configuration file"
|
||||
${SED} "s/GUMBY/${SED_CONFIG}/g" < ${FILESDIR}/atari800.cfg \
|
||||
> ${WRKSRC}/atari800.cfg
|
||||
@ -54,16 +56,29 @@ post-extract:
|
||||
@${ECHO_MSG} "===> Copying config.h to work directory"
|
||||
${CP} ${FILESDIR}/config.h ${WRKSRC}/
|
||||
|
||||
@${ECHO_MSG} "===> Copying UNIX makefile"
|
||||
${CP} ${WRKSRC}/Makefile.unix ${WRKSRC}/Makefile
|
||||
|
||||
post-patch:
|
||||
@${ECHO_MSG} "===> Processing another configuration file"
|
||||
${CP} ${WRKSRC}/rt-config.c ${WRKSRC}/rt-config.c.temp
|
||||
${SED} "s/GUMBY/${SED_CONFIG}/g" <${WRKSRC}/rt-config.c.temp \
|
||||
> ${WRKSRC}/rt-config.c
|
||||
|
||||
# Install roms, extra docs and config file.
|
||||
#
|
||||
post-install:
|
||||
@${ECHO_MSG} "===> Installing ROM files"
|
||||
@${ECHO_MSG} "===> Installing files from xf25.zip"
|
||||
-${MKDIR} ${ATARI_LIB}
|
||||
for file in ${ATARI_ROM} ; do \
|
||||
for file in ${ATARI_XF} ; do \
|
||||
${INSTALL_DATA} ${WRKSRC}/$$file ${ATARI_LIB}/ ;\
|
||||
done
|
||||
|
||||
.if !defined(NOPORTDOCS)
|
||||
@${ECHO_MSG} "===> Installing configuration file"
|
||||
${INSTALL} -c -o root -g wheel -m 664 ${WRKSRC}/atari800.cfg \
|
||||
${ATARI_LIB}/
|
||||
|
||||
.if (!defined(NOPORTDOCS))
|
||||
@${ECHO_MSG} "===> Installing distribution document files"
|
||||
-${MKDIR} ${ATARI_DOC}
|
||||
for file in ${DOC_FILES} ; do \
|
||||
@ -72,8 +87,4 @@ post-install:
|
||||
${INSTALL_DATA} ${PKGDIR}/DESCR ${ATARI_DOC}/README.FreeBSD
|
||||
.endif
|
||||
|
||||
@${ECHO_MSG} "===> Installing configuration file"
|
||||
${INSTALL} -c -o root -g wheel -m 664 ${WRKSRC}/atari800.cfg \
|
||||
${ATARI_LIB}/
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
@ -1,2 +1,2 @@
|
||||
MD5 (Atari800-0.8.1.tar.gz) = 378dda73440159ec0228ef84cb693b17
|
||||
MD5 (xf25.zip) = 4dc3b6b4313e9596c4d474785a37b94d
|
||||
MD5 (atari/Atari800-0.8.6.tar.gz) = 1e84ececd9b68684ebebf236647d6d68
|
||||
MD5 (atari/xf25.zip) = 4dc3b6b4313e9596c4d474785a37b94d
|
||||
|
@ -1,19 +1,5 @@
|
||||
/*
|
||||
FreeBSD ports collection version of config.h
|
||||
by Joel Sutton 22nd April 1997
|
||||
|
||||
This file has been created to simplify installation of the Atari
|
||||
Emulator. Voxware does work and if you wish to install it
|
||||
uncomment the #define line below. Other options are not yet
|
||||
supported.
|
||||
|
||||
*/
|
||||
|
||||
#ifndef __CONFIG__
|
||||
#define __CONFIG__
|
||||
/* #define LINUX_JOYSTICK */
|
||||
/* #define DIRECT_VIDEO */
|
||||
/* #define JOYMOUSE */
|
||||
/* #define VOXWARE */
|
||||
#define VOXWARE
|
||||
#define UNALIGNED_LONG_OK
|
||||
#endif
|
||||
|
@ -1,94 +1,10 @@
|
||||
*** Makefile.orig Sat Apr 19 07:41:29 1997
|
||||
--- Makefile Tue Apr 22 22:02:13 1997
|
||||
***************
|
||||
*** 3,8 ****
|
||||
--- 3,11 ----
|
||||
# -lnsl which is required for the Sun versions. Remove them
|
||||
# if they cause a problem on your system.
|
||||
#
|
||||
+ # Patched by Joel Sutton Tue Apr 22, 1997
|
||||
+ # Fixed install target. Added hooks for config file paths.
|
||||
+ # Disabled configure.
|
||||
|
||||
CC = gcc
|
||||
CPPFLAGS = $(OTHER)
|
||||
***************
|
||||
*** 16,21 ****
|
||||
--- 19,31 ----
|
||||
LIB_PATH = ${PREFIX}/lib
|
||||
MAN_PATH = ${PREFIX}/man
|
||||
|
||||
+ INSTALL = install -c -o bin -g bin
|
||||
+ INSTALL_DATA = ${INSTALL} -m 644
|
||||
+ INSTALL_PROGRAM = ${INSTALL} -m 555
|
||||
+ INSTALL_MAN = ${INSTALL} -m 444
|
||||
+
|
||||
+ CONFIG =${PREFIX}/lib/atari/atari800.cfg
|
||||
+
|
||||
default :
|
||||
@echo "To build the Atari 800 Emulator, type:"
|
||||
@echo "make <version>"
|
||||
***************
|
||||
*** 248,254 ****
|
||||
platform.h
|
||||
|
||||
config config.h : configure
|
||||
! ./configure
|
||||
|
||||
configure : configure.o prompts.o
|
||||
$(LD) $(LDFLAGS) configure.o prompts.o $(LDLIBS) -o configure
|
||||
--- 258,264 ----
|
||||
platform.h
|
||||
|
||||
config config.h : configure
|
||||
! # ./configure
|
||||
|
||||
configure : configure.o prompts.o
|
||||
$(LD) $(LDFLAGS) configure.o prompts.o $(LDLIBS) -o configure
|
||||
***************
|
||||
*** 331,337 ****
|
||||
$(CC) $(CPPFLAGS) $(CFLAGS) prompts.c
|
||||
|
||||
rt-config.o : rt-config.c $(INCLUDES)
|
||||
! $(CC) $(CPPFLAGS) $(CFLAGS) rt-config.c
|
||||
|
||||
sound.o : sound.c $(INCLUDES)
|
||||
$(CC) $(CPPFLAGS) $(CFLAGS) sound.c
|
||||
--- 341,347 ----
|
||||
$(CC) $(CPPFLAGS) $(CFLAGS) prompts.c
|
||||
|
||||
rt-config.o : rt-config.c $(INCLUDES)
|
||||
! $(CC) $(CPPFLAGS) $(CFLAGS) -DATARI_CONFIG=\"${CONFIG}\" rt-config.c
|
||||
|
||||
sound.o : sound.c $(INCLUDES)
|
||||
$(CC) $(CPPFLAGS) $(CFLAGS) sound.c
|
||||
***************
|
||||
*** 341,347 ****
|
||||
|
||||
clean :
|
||||
rm -f configure
|
||||
! rm -f config.h
|
||||
rm -f core
|
||||
rm -f *.o
|
||||
|
||||
--- 351,357 ----
|
||||
|
||||
clean :
|
||||
rm -f configure
|
||||
! # rm -f config.h
|
||||
rm -f core
|
||||
rm -f *.o
|
||||
|
||||
***************
|
||||
*** 350,354 ****
|
||||
chmod 4755 ${BIN_PATH}/atari800
|
||||
|
||||
install :
|
||||
! cp atari800 ${BIN_PATH}/atari800
|
||||
! cp atari800.man ${MAN_PATH}/man1/atari800.1
|
||||
--- 360,364 ----
|
||||
chmod 4755 ${BIN_PATH}/atari800
|
||||
|
||||
install :
|
||||
! ${INSTALL_PROGRAM} atari800 ${BIN_PATH}/atari800
|
||||
! ${INSTALL_MAN} atari800.man ${MAN_PATH}/man1/atari800.1
|
||||
--- Makefile.orig Thu Jun 18 19:49:19 1998
|
||||
+++ Makefile Thu Jun 18 20:00:02 1998
|
||||
@@ -246,7 +246,6 @@
|
||||
platform.h
|
||||
|
||||
config config.h : configure
|
||||
- ./configure
|
||||
|
||||
configure : configure.o prompts.o
|
||||
$(LD) $(LDFLAGS) configure.o prompts.o $(LDLIBS) -o configure
|
||||
|
@ -1,19 +1,29 @@
|
||||
*** sound.c.orig Sun Apr 20 23:19:13 1997
|
||||
--- sound.c Sun Apr 20 23:19:28 1997
|
||||
***************
|
||||
*** 3,9 ****
|
||||
#ifdef VOXWARE
|
||||
#include <fcntl.h>
|
||||
#include <sys/ioctl.h>
|
||||
! #include <sys/soundcard.h>
|
||||
|
||||
#include "pokey11.h"
|
||||
|
||||
--- 3,9 ----
|
||||
#ifdef VOXWARE
|
||||
#include <fcntl.h>
|
||||
#include <sys/ioctl.h>
|
||||
! #include <machine/soundcard.h>
|
||||
|
||||
#include "pokey11.h"
|
||||
|
||||
--- prompts.c.orig Thu Jun 18 20:20:15 1998
|
||||
+++ prompts.c Thu Jun 18 20:22:22 1998
|
||||
@@ -10,7 +10,7 @@
|
||||
char gash[128];
|
||||
|
||||
printf(message, string);
|
||||
- gets(gash);
|
||||
+ fgets(gash,128,stdin);
|
||||
if (strlen(gash) > 0)
|
||||
strcpy(string, gash);
|
||||
}
|
||||
@@ -20,7 +20,7 @@
|
||||
char gash[128];
|
||||
|
||||
printf(message, *num);
|
||||
- gets(gash);
|
||||
+ fgets(gash,128,stdin);
|
||||
if (strlen(gash) > 0)
|
||||
sscanf(gash, "\n%d", num);
|
||||
}
|
||||
@@ -32,7 +32,7 @@
|
||||
|
||||
do {
|
||||
printf(message, *yn);
|
||||
- gets(gash);
|
||||
+ fgets(gash,128,stdin);
|
||||
|
||||
if (strlen(gash) > 0)
|
||||
t_yn = gash[0];
|
||||
|
@ -1,53 +1,26 @@
|
||||
*** prompts.c.orig Sun Apr 20 23:32:27 1997
|
||||
--- prompts.c Sun Apr 20 23:34:30 1997
|
||||
***************
|
||||
*** 10,16 ****
|
||||
char gash[128];
|
||||
|
||||
printf (message, string);
|
||||
! gets (gash);
|
||||
if (strlen(gash) > 0)
|
||||
strcpy (string, gash);
|
||||
}
|
||||
--- 10,16 ----
|
||||
char gash[128];
|
||||
|
||||
printf (message, string);
|
||||
! fgets (gash,128,stdin);
|
||||
if (strlen(gash) > 0)
|
||||
strcpy (string, gash);
|
||||
}
|
||||
***************
|
||||
*** 20,26 ****
|
||||
char gash[128];
|
||||
|
||||
printf (message, *num);
|
||||
! gets (gash);
|
||||
if (strlen(gash) > 0)
|
||||
sscanf (gash,"\n%d", num);
|
||||
}
|
||||
--- 20,26 ----
|
||||
char gash[128];
|
||||
|
||||
printf (message, *num);
|
||||
! fgets (gash,128,stdin);
|
||||
if (strlen(gash) > 0)
|
||||
sscanf (gash,"\n%d", num);
|
||||
}
|
||||
***************
|
||||
*** 33,39 ****
|
||||
do
|
||||
{
|
||||
printf (message, *yn);
|
||||
! gets (gash);
|
||||
|
||||
if (strlen(gash) > 0)
|
||||
t_yn = gash[0];
|
||||
--- 33,39 ----
|
||||
do
|
||||
{
|
||||
printf (message, *yn);
|
||||
! fgets (gash,128,stdin);
|
||||
|
||||
if (strlen(gash) > 0)
|
||||
t_yn = gash[0];
|
||||
--- monitor.c.orig Sun Feb 22 02:19:59 1998
|
||||
+++ monitor.c Thu Jun 18 21:05:50 1998
|
||||
@@ -94,10 +94,13 @@
|
||||
|
||||
printf("> ");
|
||||
fflush(stdout);
|
||||
- if (gets(s) == NULL) {
|
||||
+ if (fgets(s,256,stdin) == NULL) {
|
||||
printf("\n> CONT\n");
|
||||
strcpy(s, "CONT");
|
||||
}
|
||||
+
|
||||
+ s[strlen(s)-1]='\0'; /* fgets provision */
|
||||
+
|
||||
t = get_token(s);
|
||||
if (t == NULL) {
|
||||
continue;
|
||||
@@ -179,7 +182,7 @@
|
||||
char gash[4];
|
||||
|
||||
printf("Press return to continue: ");
|
||||
- gets(gash);
|
||||
+ fgets(gash,4,stdin);
|
||||
nlines = 0;
|
||||
}
|
||||
}
|
||||
|
@ -1,19 +1,19 @@
|
||||
*** rt-config.c.orig Sun Apr 20 23:38:04 1997
|
||||
--- rt-config.c Sun Apr 20 23:39:04 1997
|
||||
*** sound.c.orig Thu Jun 18 21:57:09 1998
|
||||
--- sound.c Thu Jun 18 21:57:30 1998
|
||||
***************
|
||||
*** 32,38 ****
|
||||
int enable_xcolpf1;
|
||||
*** 5,11 ****
|
||||
#ifdef VOXWARE
|
||||
#include <fcntl.h>
|
||||
#include <sys/ioctl.h>
|
||||
! #include <sys/soundcard.h>
|
||||
|
||||
static char *rtconfig_filename1 = "atari800.cfg";
|
||||
! static char *rtconfig_filename2 = "/etc/atari800.cfg";
|
||||
#include "pokey11.h"
|
||||
|
||||
int RtConfigLoad (char *rtconfig_filename)
|
||||
{
|
||||
--- 32,38 ----
|
||||
int enable_xcolpf1;
|
||||
--- 5,11 ----
|
||||
#ifdef VOXWARE
|
||||
#include <fcntl.h>
|
||||
#include <sys/ioctl.h>
|
||||
! #include <machine/soundcard.h>
|
||||
|
||||
static char *rtconfig_filename1 = "atari800.cfg";
|
||||
! static char *rtconfig_filename2 = ATARI_CONFIG ;
|
||||
#include "pokey11.h"
|
||||
|
||||
int RtConfigLoad (char *rtconfig_filename)
|
||||
{
|
||||
|
@ -1,59 +1,19 @@
|
||||
*** monitor.c.orig Tue Apr 22 20:58:59 1997
|
||||
--- monitor.c Tue Apr 22 21:13:57 1997
|
||||
*** rt-config.c.orig Wed Jul 1 19:55:57 1998
|
||||
--- rt-config.c Wed Jul 1 19:56:17 1998
|
||||
***************
|
||||
*** 1,3 ****
|
||||
--- 1,8 ----
|
||||
+ /*
|
||||
+ Patched by Joel Sutton 22nd April, 1997
|
||||
+ Replaced gets with fgets. Added a newline chop feature.
|
||||
+ */
|
||||
+
|
||||
#include <stdio.h>
|
||||
#include <ctype.h>
|
||||
#include <unistd.h>
|
||||
***************
|
||||
*** 95,106 ****
|
||||
*** 32,38 ****
|
||||
int enable_xcolpf1;
|
||||
|
||||
printf ("> ");
|
||||
fflush(stdout);
|
||||
! if (gets (s) == NULL)
|
||||
{
|
||||
printf("\n> CONT\n");
|
||||
strcpy(s, "CONT");
|
||||
}
|
||||
static char *rtconfig_filename1 = "atari800.cfg";
|
||||
! static char *rtconfig_filename2 = "/etc/atari800.cfg";
|
||||
|
||||
for (p=0;s[p]!=0;p++)
|
||||
if (islower(s[p]))
|
||||
s[p] = toupper(s[p]);
|
||||
--- 100,113 ----
|
||||
int RtConfigLoad(char *rtconfig_filename)
|
||||
{
|
||||
--- 32,38 ----
|
||||
int enable_xcolpf1;
|
||||
|
||||
printf ("> ");
|
||||
fflush(stdout);
|
||||
! if (fgets (s,256,stdin) == NULL)
|
||||
{
|
||||
printf("\n> CONT\n");
|
||||
strcpy(s, "CONT");
|
||||
}
|
||||
static char *rtconfig_filename1 = "atari800.cfg";
|
||||
! static char *rtconfig_filename2 = "GUMBY/atari800.cfg";
|
||||
|
||||
+ s[strlen(s)-1]='\0'; /* fgets provision */
|
||||
+
|
||||
for (p=0;s[p]!=0;p++)
|
||||
if (islower(s[p]))
|
||||
s[p] = toupper(s[p]);
|
||||
***************
|
||||
*** 186,192 ****
|
||||
char gash[4];
|
||||
|
||||
printf ("Press return to continue: ");
|
||||
! gets (gash);
|
||||
nlines = 0;
|
||||
}
|
||||
}
|
||||
--- 193,199 ----
|
||||
char gash[4];
|
||||
|
||||
printf ("Press return to continue: ");
|
||||
! fgets (gash,256,stdin);
|
||||
nlines = 0;
|
||||
}
|
||||
}
|
||||
int RtConfigLoad(char *rtconfig_filename)
|
||||
{
|
||||
|
@ -26,15 +26,7 @@ would like to take a further look at XF2.5 you should find it in your
|
||||
distfiles directory (if it successfully down-loaded :->). For more info
|
||||
on this emulator check out "http://www.halcyon.com/brasoft/".
|
||||
|
||||
If you have any general Atari questions then you might get a more
|
||||
fruitful response by posting them to the news group, as the emulation
|
||||
and questions mailing list won't be up-to-date with all things
|
||||
Atari. However the FreeBSD emulation mailing list is dedicated to
|
||||
discussing the emulation of other O/S's so don't be shy. Please check
|
||||
Section 25 of the handbook for information on the mailing lists.
|
||||
|
||||
Share and enjoy,
|
||||
|
||||
Joel...
|
||||
:->
|
||||
suttonj@interconnect.com.au
|
||||
jsutton@webnet.com.au
|
||||
|
@ -1,8 +1,4 @@
|
||||
bin/atari800
|
||||
lib/atari/atari800.cfg
|
||||
lib/atari/ataribas.rom
|
||||
lib/atari/atariosb.rom
|
||||
lib/atari/atarixl.rom
|
||||
share/doc/atari/BUGS
|
||||
share/doc/atari/CHANGES
|
||||
share/doc/atari/COPYING
|
||||
@ -12,5 +8,13 @@ share/doc/atari/README
|
||||
share/doc/atari/TODO
|
||||
share/doc/atari/USAGE
|
||||
share/doc/atari/README.FreeBSD
|
||||
@dirrm lib/atari
|
||||
lib/atari/atari800.cfg
|
||||
lib/atari/ataribas.rom
|
||||
lib/atari/atariosb.rom
|
||||
lib/atari/atarixl.rom
|
||||
lib/atari/demos1.xfd
|
||||
lib/atari/demos2.xfd
|
||||
lib/atari/dos25.xfd
|
||||
lib/atari/mydos45d.atr
|
||||
@dirrm share/doc/atari
|
||||
@dirrm lib/atari
|
||||
|
Loading…
Reference in New Issue
Block a user