- Update to 3.8.1.
- Support staging. PR: ports/184558 Submitted by: Pavel I Volkov <pavelivolkov@gmail.com> (maintainer)
This commit is contained in:
parent
1df9d247be
commit
6f4916f545
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=337465
@ -2,10 +2,10 @@
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= sqlite3
|
||||
PORTVERSION= 3.8.0.2
|
||||
PORTVERSION= 3.8.1
|
||||
CATEGORIES= databases
|
||||
MASTER_SITES= http://www.sqlite.org/2013/ http://www2.sqlite.org/2013/ http://www3.sqlite.org/2013/
|
||||
DISTNAME= sqlite-autoconf-3080002
|
||||
DISTNAME= sqlite-autoconf-3080100
|
||||
|
||||
MAINTAINER= pavelivolkov@gmail.com
|
||||
COMMENT= SQL database engine in a C library
|
||||
@ -24,45 +24,47 @@ GNU_CONFIGURE= yes
|
||||
MAKE_JOBS_UNSAFE= yes
|
||||
|
||||
# Compilation Options For SQLite http://www.sqlite.org/compile.html
|
||||
OPTIONS_DEFINE= FTS3 ICU RTREE RAMTABLE UPD_DEL_LIMIT URI URI_AUTHORITY SOUNDEX METADATA \
|
||||
STAT3 DIRECT_READ MEMMAN SECURE_DELETE UNLOCK_NOTIFY THREADSAFE \
|
||||
EXTENSION
|
||||
OPTIONS_DEFAULT= FTS3 URI METADATA SECURE_DELETE UNLOCK_NOTIFY THREADSAFE EXTENSION
|
||||
FTS3_DESC= Enable FTS3/4 (Full Text Search) module
|
||||
ICU_DESC= Enable built with ICU
|
||||
RTREE_DESC= Enable R*Tree module (${RTREE_INT})
|
||||
RAMTABLE_DESC= Store temporary tables in RAM = ${TEMP_STORE}
|
||||
OPTIONS_DEFINE= FTS4 ICU UPD_DEL_LIMIT URI URI_AUTHORITY SOUNDEX METADATA \
|
||||
DIRECT_READ MEMMAN SECURE_DELETE UNLOCK_NOTIFY THREADS EXTENSION
|
||||
|
||||
FTS4_DESC= Enable FTS3/4 (Full Text Search) module
|
||||
UPD_DEL_LIMIT_DESC= ORDER BY and LIMIT on UPDATE and DELETE
|
||||
URI_DESC= Enable use the URI filename
|
||||
URI_AUTHORITY_DESC= Allow convert URL into a UNC
|
||||
SOUNDEX_DESC= Enables the soundex() SQL function
|
||||
METADATA_DESC= Enable column metadata
|
||||
STAT3_DESC= Help SQLite to chose a better query plan
|
||||
DIRECT_READ_DESC= File is read directly from disk
|
||||
MEMMAN_DESC= Allows it to release unused memory
|
||||
SECURE_DELETE_DESC= Overwrite deleted information with zeros
|
||||
UNLOCK_NOTIFY_DESC= Enable notification on unlocking
|
||||
THREADSAFE_DESC= Build thread-safe library
|
||||
EXTENSION_DESC= Allow loadable extensions
|
||||
|
||||
NO_STAGE= yes
|
||||
.include <bsd.port.options.mk>
|
||||
OPTIONS_SINGLE= RAMT
|
||||
OPTIONS_SINGLE_RAMT= TS0 TS1 TS2 TS3
|
||||
RAMT_DESC= Where to store temporary files
|
||||
TS0_DESC= Always use temporary files
|
||||
TS1_DESC= Files by default, allow changes with PRAGMA
|
||||
TS2_DESC= Memory by default,allow changes with PRAGMA
|
||||
TS3_DESC= Always use memory
|
||||
|
||||
OPTIONS_RADIO= STAT
|
||||
OPTIONS_RADIO_STAT= STAT3 STAT4
|
||||
STAT_DESC= Which query planner to use
|
||||
STAT3_DESC= collect histogram data from leftmost column
|
||||
STAT4_DESC= collect histogram data from all columns
|
||||
|
||||
OPTIONS_GROUP= RTREEG
|
||||
OPTIONS_GROUP_RTREEG= RTREE RTREE_INT
|
||||
RTREEG_DESC= Index type for range queries
|
||||
RTREE_DESC= Enable R*Tree module
|
||||
RTREE_INT_DESC= Store 32-bit sig int (no float) coordinates
|
||||
|
||||
OPTIONS_DEFAULT= FTS4 URI METADATA SECURE_DELETE UNLOCK_NOTIFY THREADS EXTENSION TS1 RTREE
|
||||
|
||||
PLIST_FILES= bin/sqlite3 include/sqlite3.h include/sqlite3ext.h \
|
||||
lib/libsqlite3.a lib/libsqlite3.la lib/libsqlite3.so \
|
||||
lib/libsqlite3.so.8 libdata/pkgconfig/sqlite3.pc
|
||||
|
||||
.if !defined(NO_INSTALL_MANPAGES)
|
||||
MAN1= sqlite3.1
|
||||
.endif
|
||||
|
||||
# NAME83 "Enable use 8.3 filename for temp files" off \
|
||||
# Some devices are compelled to use an older file system with 8+3 filename
|
||||
# restrictions for backwards compatibility, or due to other non-technical factors.
|
||||
# http://www.sqlite.org/shortnames.html
|
||||
.if ${PORT_OPTIONS:MNAME83}
|
||||
CPPFLAGS+= -DSQLITE_ENABLE_8_3_NAMES=1
|
||||
.endif
|
||||
lib/libsqlite3.so.8 libdata/pkgconfig/sqlite3.pc \
|
||||
man/man1/sqlite3.1.gz
|
||||
|
||||
# The default numeric file permissions for newly created database files under unix.
|
||||
# If not specified, the default is 0644 which means that the files is globally
|
||||
@ -77,96 +79,48 @@ CPPFLAGS+= -DSQLITE_DEFAULT_FILE_PERMISSIONS=${DEFAULT_FILE_PERMISSIONS}
|
||||
CPPFLAGS+= -DSQLITE_DEFAULT_TEMP_CACHE_SIZE=${TEMP_CACHE_SIZE}
|
||||
.endif
|
||||
|
||||
.if ${PORT_OPTIONS:MMEMMAN}
|
||||
CPPFLAGS+= -DSQLITE_ENABLE_MEMORY_MANAGEMENT=1
|
||||
.endif
|
||||
|
||||
.if ${PORT_OPTIONS:MUPD_DEL_LIMIT}
|
||||
CPPFLAGS+= -DSQLITE_ENABLE_UPDATE_DELETE_LIMIT=1
|
||||
.endif
|
||||
|
||||
.if ${PORT_OPTIONS:MURI}
|
||||
CPPFLAGS+= -DSQLITE_USE_URI=1
|
||||
.endif
|
||||
|
||||
.if ${PORT_OPTIONS:MURI_AUTHORITY}
|
||||
CPPFLAGS+= -DSQLITE_ALLOW_URI_AUTHORITY=1
|
||||
.endif
|
||||
|
||||
.if ${PORT_OPTIONS:MSOUNDEX}
|
||||
CPPFLAGS+= -DSQLITE_SOUNDEX=1
|
||||
.endif
|
||||
|
||||
.if ${PORT_OPTIONS:MSTAT3}
|
||||
CPPFLAGS+= -DSQLITE_ENABLE_STAT3=1
|
||||
.endif
|
||||
|
||||
.if ${PORT_OPTIONS:MDIRECT_READ}
|
||||
CPPFLAGS+= -DSQLITE_DIRECT_OVERFLOW_READ=1
|
||||
.endif
|
||||
|
||||
.if ${PORT_OPTIONS:MFTS3}
|
||||
CPPFLAGS+= -DSQLITE_ENABLE_FTS3=1 -DSQLITE_ENABLE_FTS3_PARENTHESIS=1 -DSQLITE_ENABLE_FTS4=1
|
||||
.endif
|
||||
|
||||
.if ${PORT_OPTIONS:MRTREE}
|
||||
CPPFLAGS+= -DSQLITE_ENABLE_RTREE=1
|
||||
.ifdef RTREE_INT
|
||||
CPPFLAGS+= -DSQLITE_RTREE_INT_ONLY=1
|
||||
RTREE_INT= "int"
|
||||
.else
|
||||
RTREE_INT= "float"
|
||||
.endif
|
||||
.endif
|
||||
|
||||
.if ${PORT_OPTIONS:MICU}
|
||||
BUILD_DEPENDS+= ${LOCALBASE}/bin/icu-config:${PORTSDIR}/devel/icu
|
||||
LIB_DEPENDS+= libicudata.so:${PORTSDIR}/devel/icu
|
||||
CPPFLAGS+= -DSQLITE_ENABLE_ICU=1
|
||||
CPPFLAGS+= `${LOCALBASE}/bin/icu-config --cppflags`
|
||||
LDFLAGS+= `${LOCALBASE}/bin/icu-config --ldflags`
|
||||
.endif
|
||||
|
||||
# Use an in-ram database for temporary tables (never,no,yes,always),
|
||||
# which is equivalent of TEMP_STORE=[0,1,2,3], default = 1.
|
||||
.if ${PORT_OPTIONS:MRAMTABLE}
|
||||
TEMP_STORE?= 2
|
||||
CPPFLAGS+= -DSQLITE_TEMP_STORE=${TEMP_STORE}
|
||||
.endif
|
||||
TS0_CPPFLAGS= -DSQLITE_TEMP_STORE=0
|
||||
TS1_CPPFLAGS= -DSQLITE_TEMP_STORE=1
|
||||
TS2_CPPFLAGS= -DSQLITE_TEMP_STORE=2
|
||||
TS3_CPPFLAGS= -DSQLITE_TEMP_STORE=3
|
||||
|
||||
.if ${PORT_OPTIONS:MSECURE_DELETE}
|
||||
CPPFLAGS+= -DSQLITE_SECURE_DELETE=1
|
||||
.endif
|
||||
RTREE_CPPFLAGS= -DSQLITE_ENABLE_RTREE=1
|
||||
RTREE_INT_CPPFLAGS= -DSQLITE_RTREE_INT_ONLY=1
|
||||
|
||||
.if ${PORT_OPTIONS:MUNLOCK_NOTIFY}
|
||||
CPPFLAGS+= -DSQLITE_ENABLE_UNLOCK_NOTIFY=1
|
||||
.endif
|
||||
FTS4_CPPFLAGS= -DSQLITE_ENABLE_FTS3=1 -DSQLITE_ENABLE_FTS3_PARENTHESIS=1 -DSQLITE_ENABLE_FTS4=1
|
||||
SOUNDEX_CPPFLAGS= -DSQLITE_SOUNDEX=1
|
||||
MEMMAN_CPPFLAGS= -DSQLITE_ENABLE_MEMORY_MANAGEMENT=1
|
||||
UPD_DEL_LIMIT_CPPFLAGS= -DSQLITE_ENABLE_UPDATE_DELETE_LIMIT=1
|
||||
SECURE_DELETE_CPPFLAGS= -DSQLITE_SECURE_DELETE=1
|
||||
UNLOCK_NOTIFY_CPPFLAGS= -DSQLITE_ENABLE_UNLOCK_NOTIFY=1
|
||||
METADATA_CPPFLAGS= -DSQLITE_ENABLE_COLUMN_METADATA=1
|
||||
STAT3_CPPFLAGS= -DSQLITE_ENABLE_STAT3=1
|
||||
STAT4_CPPFLAGS= -DSQLITE_ENABLE_STAT4=1
|
||||
URI_CPPFLAGS= -DSQLITE_USE_URI=1
|
||||
URI_AUTHORITY_CPPFLAGS= -DSQLITE_ALLOW_URI_AUTHORITY=1
|
||||
DIRECT_READ_CPPFLAGS= -DSQLITE_DIRECT_OVERFLOW_READ=1
|
||||
|
||||
.if ${PORT_OPTIONS:MMETADATA}
|
||||
CPPFLAGS+= -DSQLITE_ENABLE_COLUMN_METADATA=1
|
||||
.endif
|
||||
EXTENSION_CONFIGURE_ENABLE= dynamic-extensions
|
||||
|
||||
.if ${PORT_OPTIONS:MTHREADSAFE}
|
||||
CONFIGURE_ARGS+= --enable-threadsafe
|
||||
LDFLAGS+= ${PTHREAD_LIBS}
|
||||
.else
|
||||
CONFIGURE_ARGS+= --disable-threadsafe
|
||||
.endif
|
||||
THREADS_CONFIGURE_ENABLE= threadsafe
|
||||
THREADS_LDFLAGS= ${PTHREAD_LIBS}
|
||||
|
||||
.if ${PORT_OPTIONS:MEXTENSION}
|
||||
CONFIGURE_ARGS+= --enable-dynamic-extensions
|
||||
.else
|
||||
CONFIGURE_ARGS+= --disable-dynamic-extensions
|
||||
.endif
|
||||
ICU_BUILD_DEPENDS= ${LOCALBASE}/bin/icu-config:${PORTSDIR}/devel/icu
|
||||
ICU_LIB_DEPENDS= icudata:${PORTSDIR}/devel/icu
|
||||
ICU_CPPFLAGS= `${LOCALBASE}/bin/icu-config --cppflags` -DSQLITE_ENABLE_ICU=1
|
||||
ICU_LDFLAGS= `${LOCALBASE}/bin/icu-config --ldflags`
|
||||
|
||||
.include <bsd.port.options.mk>
|
||||
|
||||
post-configure:
|
||||
@${ECHO_MSG} "===> CONFIGURE_ARGS=${CONFIGURE_ARGS}"
|
||||
@${ECHO_MSG} "===> CPPFLAGS=${CPPFLAGS}"
|
||||
@${ECHO_MSG} "===> LDFLAGS=${LDFLAGS}"
|
||||
|
||||
post-build:
|
||||
.if ${ARCH}=="i386"
|
||||
@${ECHO_MSG} "===> WARNING: on ${ARCH} don't pass atof1-* tests"
|
||||
.endif
|
||||
|
||||
post-install:
|
||||
.if !defined(NO_INSTALL_MANPAGES)
|
||||
@${INSTALL_MAN} ${WRKSRC}/sqlite3.1 ${MANPREFIX}/man/man1
|
||||
.endif
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
@ -1,2 +1,2 @@
|
||||
SHA256 (sqlite-autoconf-3080002.tar.gz) = fca3a0a12f94dc92a6d9e700c3f6cab6cd4e79214bd7b6f13717a10f4bcfddb2
|
||||
SIZE (sqlite-autoconf-3080002.tar.gz) = 1878765
|
||||
SHA256 (sqlite-autoconf-3080100.tar.gz) = 176df9a5dfbf4cf8516ef7b91ee187779855f51d4502534a5826034458ba2bb5
|
||||
SIZE (sqlite-autoconf-3080100.tar.gz) = 1896869
|
||||
|
9
databases/sqlite3/files/patch-Makefile.am
Normal file
9
databases/sqlite3/files/patch-Makefile.am
Normal file
@ -0,0 +1,9 @@
|
||||
--- Makefile.am.orig 2013-10-29 19:45:19.000000000 +0400
|
||||
+++ Makefile.am 2013-10-29 19:45:33.000000000 +0400
|
||||
@@ -1,5 +1,5 @@
|
||||
|
||||
-AM_CFLAGS = @THREADSAFE_FLAGS@ @DYNAMIC_EXTENSION_FLAGS@ -DSQLITE_ENABLE_FTS3 -DSQLITE_ENABLE_RTREE
|
||||
+AM_CFLAGS = @THREADSAFE_FLAGS@ @DYNAMIC_EXTENSION_FLAGS@
|
||||
|
||||
lib_LTLIBRARIES = libsqlite3.la
|
||||
libsqlite3_la_SOURCES = sqlite3.c
|
11
databases/sqlite3/files/patch-Makefile.in
Normal file
11
databases/sqlite3/files/patch-Makefile.in
Normal file
@ -0,0 +1,11 @@
|
||||
--- Makefile.in.orig 2013-10-29 19:49:18.000000000 +0400
|
||||
+++ Makefile.in 2013-10-29 19:49:42.000000000 +0400
|
||||
@@ -268,7 +268,7 @@
|
||||
top_build_prefix = @top_build_prefix@
|
||||
top_builddir = @top_builddir@
|
||||
top_srcdir = @top_srcdir@
|
||||
-AM_CFLAGS = @THREADSAFE_FLAGS@ @DYNAMIC_EXTENSION_FLAGS@ -DSQLITE_ENABLE_FTS3 -DSQLITE_ENABLE_RTREE
|
||||
+AM_CFLAGS = @THREADSAFE_FLAGS@ @DYNAMIC_EXTENSION_FLAGS@
|
||||
lib_LTLIBRARIES = libsqlite3.la
|
||||
libsqlite3_la_SOURCES = sqlite3.c
|
||||
libsqlite3_la_LDFLAGS = -no-undefined -version-info 8:6:8
|
Loading…
Reference in New Issue
Block a user