Update to 3.1.2
This commit is contained in:
parent
a9c04bc3c3
commit
6f47048c7c
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=465988
@ -2,7 +2,7 @@
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= electrum
|
||||
PORTVERSION= 3.1.1
|
||||
PORTVERSION= 3.1.2
|
||||
CATEGORIES= finance python
|
||||
MASTER_SITES= https://download.electrum.org/${PORTVERSION}/ \
|
||||
http://download.electrum.org/${PORTVERSION}/
|
||||
|
@ -1,3 +1,3 @@
|
||||
TIMESTAMP = 1520916612
|
||||
SHA256 (Electrum-3.1.1.tar.gz) = 3195679f898bd763c6db32f46bbdf59fa5a211fd3013507f5c7aab25d9b94337
|
||||
SIZE (Electrum-3.1.1.tar.gz) = 2722902
|
||||
TIMESTAMP = 1522432217
|
||||
SHA256 (Electrum-3.1.2.tar.gz) = f5a67c616984e18646a6369e38d203e49e371ad904e6556ff445110f5ab44559
|
||||
SIZE (Electrum-3.1.2.tar.gz) = 2800714
|
||||
|
@ -1,24 +0,0 @@
|
||||
--- setup.py.orig 2018-03-12 17:25:11 UTC
|
||||
+++ setup.py
|
||||
@@ -27,12 +27,6 @@ if platform.system() in ['Linux', 'FreeB
|
||||
parser.add_argument('--root=', dest='root_path', metavar='dir', default='/')
|
||||
opts, _ = parser.parse_known_args(sys.argv[1:])
|
||||
usr_share = os.path.join(sys.prefix, "share")
|
||||
- if not os.access(opts.root_path + usr_share, os.W_OK) and \
|
||||
- not os.access(opts.root_path, os.W_OK):
|
||||
- if 'XDG_DATA_HOME' in os.environ.keys():
|
||||
- usr_share = os.environ['XDG_DATA_HOME']
|
||||
- else:
|
||||
- usr_share = os.path.expanduser('~/.local/share')
|
||||
data_files += [
|
||||
(os.path.join(usr_share, 'applications/'), ['electrum.desktop']),
|
||||
(os.path.join(usr_share, 'pixmaps/'), ['icons/electrum.png'])
|
||||
@@ -86,8 +80,3 @@ setup(
|
||||
url="https://electrum.org",
|
||||
long_description="""Lightweight Bitcoin Wallet"""
|
||||
)
|
||||
-
|
||||
-# Optional modules (not required to run Electrum)
|
||||
-import pip
|
||||
-opt_modules = requirements_hw + ['pycryptodomex']
|
||||
-[ pip.main(['install', m]) for m in opt_modules ]
|
Loading…
Reference in New Issue
Block a user