MFH: r561960

lang/rexx-regina: upgrade to 3.9.3

ChangeLog:
https://sourceforge.net/projects/regina-rexx/files/regina-rexx/3.9.3/

PR:	252726
Submitted by:	bob@eager.cx (maintainer)
This commit is contained in:
Fernando Apesteguía 2021-01-18 19:19:52 +00:00
parent 5979abd789
commit 6f2fb210c0
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/branches/2021Q1/; revision=561961
22 changed files with 242 additions and 93 deletions

View File

@ -2,16 +2,15 @@
# $FreeBSD$
PORTNAME= regina
PORTVERSION= 3.9.1
PORTREVISION= 1
PORTVERSION= 3.9.3
CATEGORIES= lang
MASTER_SITES= SF/${PORTNAME}-rexx/${PORTNAME}-rexx/${PORTVERSION}:source \
SF/${PORTNAME}-rexx/${PORTNAME}-documentation/${PORTVERSION}:docs
SF/${PORTNAME}-rexx/${PORTNAME}-documentation/3.9.1:docs
PKGNAMEPREFIX= rexx-
DISTNAME= Regina-REXX-${PORTVERSION}
DISTNAME= regina-rexx-${PORTVERSION}
DISTFILES= ${DISTNAME}${EXTRACT_SUFX}:source
DIST_SUBDIR= ${PORTNAME}
EXTRACT_ONLY= Regina-REXX-${PORTVERSION}.tar.gz
EXTRACT_ONLY= ${DISTNAME}.tar.gz
MAINTAINER= bob@eager.cx
COMMENT= Rexx interpreter
@ -19,19 +18,19 @@ COMMENT= Rexx interpreter
LICENSE= LGPL21+
USES= gmake iconv ncurses
USE_LDCONFIG= yes
USE_RC_SUBR= rxstack
GNU_CONFIGURE= yes
CONFIGURE_ENV= ac_cv_c_char_unsigned=yes
CONFIGURE_ARGS= --with-addon-dir=${PREFIX}/lib/Regina-REXX/addons
USE_LDCONFIG= yes
CONFIGURE_ENV= ac_cv_c_char_unsigned=yes
MAKE_JOBS_UNSAFE= yes
CONFLICTS= rexx-imc-[0-0]* oorexx-[0-9]*
DATADIR= ${PREFIX}/share/${PKGNAMEPREFIX}${PORTNAME}
DOCSDIR= ${PREFIX}/share/doc/${PKGNAMEPREFIX}${PORTNAME}
EXAMPLESDIR= ${PREFIX}/share/examples/${PKGNAMEPREFIX}${PORTNAME}
CONFLICTS= rexx-imc-[0-0]* oorexx-[0-9]*
OPTIONS_DEFINE= DOCS EXAMPLES
DOCS_DISTFILES= regina.pdf:docs \
regutil.pdf:docs
@ -45,13 +44,13 @@ post-patch:
'/^examplesdir/s|=.*|= $$(datadir)/examples/$$(PACKAGE)| ; \
/$$(sysconfdir)/s|^|#|' ${WRKSRC}/Makefile.in
post-stage:
@${LN} -f ${STAGEDIR}/${PREFIX}/man/man1/regina.1.gz \
${STAGEDIR}/${PREFIX}/man/man1/rexx.1.gz
post-install-DOCS-on:
${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${WRKDIR}/regina.pdf ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${WRKDIR}/regutil.pdf ${STAGEDIR}${DOCSDIR}
post-stage:
@${LN} -f ${STAGEDIR}/${PREFIX}/man/man1/regina.1.gz \
${STAGEDIR}/${PREFIX}/man/man1/rexx.1.gz
.include <bsd.port.mk>

View File

@ -1,6 +1,6 @@
TIMESTAMP = 1472469079
SHA256 (regina/Regina-REXX-3.9.1.tar.gz) = 5d13df26987e27f25e7779a2efa87a5775213beeda449a9efac59b57a5d5f3ee
SIZE (regina/Regina-REXX-3.9.1.tar.gz) = 1358458
TIMESTAMP = 1610659498
SHA256 (regina/regina-rexx-3.9.3.tar.gz) = 1712aabee5978fdf57aeac82cd5a1a112b8980db8c5d7d045523f6a8b74b0531
SIZE (regina/regina-rexx-3.9.3.tar.gz) = 2672320
SHA256 (regina/regina.pdf) = b64693e9629b09eb5ea1e74cb246b11645cbc1f32197dcfbb97f5a5f35786ca4
SIZE (regina/regina.pdf) = 3646139
SHA256 (regina/regutil.pdf) = 7f75ff9cdca0b659695bb33df18aa0d6b4bc20b2817cc5ab401bbdfabf78fa9f

View File

@ -1,11 +0,0 @@
--- Makefile.in.orig 2014-10-19 04:03:24 UTC
+++ Makefile.in
@@ -944,7 +944,7 @@ regtrig.$(OBJ): $(regutildir)/regtrig.c
$(CC) -c $(COPT) $(CC2O) $(DYN_COMP) $(regutildir)/regtrig.c
$(SHLPRE)regutil$(MODPST): $(REGUTILOBJ) $(SHLPRE)$(SHLFILE)$(SHLPST) $(REGUTILEXP)
- $(LD_RXLIB_UTILA) $(REGUTILEXPORTS) $(REGUTILOBJ) $(LD_RXLIB_UTILB) $(BOTHLIBS) #$(REGUTIL_TERM_LIB) $(REGUTIL_MATH_LIB)
+ $(LD_RXLIB_UTILA) $(REGUTILEXPORTS) $(REGUTILOBJ) $(LD_RXLIB_UTILB) $(BOTHLIBS) $(REGUTIL_TERM_LIB) $(REGUTIL_MATH_LIB)
$(RANLIB_DYNAMIC)

View File

@ -1,6 +1,6 @@
--- builtin.c.orig 2015-03-31 04:38:58 UTC
--- builtin.c.orig 2019-10-06 06:19:40 UTC
+++ builtin.c
@@ -1039,7 +1039,7 @@ streng *std_time( tsd_t *TSD, cparamboxp
@@ -1037,7 +1037,7 @@ streng *std_time( tsd_t *TSD, cparamboxptr parms )
break ;
case 'L':
@ -9,7 +9,7 @@
break ;
case 'M':
@@ -1068,7 +1068,7 @@ streng *std_time( tsd_t *TSD, cparamboxp
@@ -1066,7 +1066,7 @@ streng *std_time( tsd_t *TSD, cparamboxptr parms )
case 'T':
rnow = mktime( &tmdata );
@ -18,7 +18,7 @@
break ;
default:
@@ -1308,7 +1308,7 @@ streng *std_date( tsd_t *TSD, cparamboxp
@@ -1302,7 +1302,7 @@ streng *std_date( tsd_t *TSD, cparamboxptr parms )
case 'T':
tmdata.tm_year -= 1900;
rnow = mktime( &tmdata );

View File

@ -1,6 +1,6 @@
--- configure.orig 2015-01-18 20:33:40 UTC
--- configure.orig 2019-10-06 06:19:40 UTC
+++ configure
@@ -3490,13 +3490,22 @@ case "$target" in
@@ -3521,13 +3521,22 @@ case "$target" in
osis64bit=yes
fi
;;
@ -25,7 +25,7 @@
*nto-qnx*)
;;
*qnx*)
@@ -6256,6 +6265,10 @@ rm -f core conftest.err conftest.$ac_objext \
@@ -6286,6 +6295,10 @@ rm -f core conftest.err conftest.$ac_objext \
;;
*linux*)
;;
@ -36,7 +36,7 @@
*freebsd*)
THREADING_COMPILE="-pthread -D_REENTRANT -DPOSIX -DREGINA_REENTRANT"
THREADING_LINK="-pthread"
@@ -8679,7 +8692,14 @@ case "$target" in
@@ -8710,7 +8723,14 @@ case "$target" in
SHLPRE="lib"
SHL_LD="ld -assert pure-text -o ${SHLPRE}${SHLFILE}${SHLPST} "'$('SHOFILES')'
;;
@ -52,7 +52,7 @@
if test "$ac_cv_prog_CC" = "gcc" -o "$ac_cv_prog_CC" = "g++" -o "$ac_cv_prog_CC" = "clang"; then
LD_RXLIB_A1="$ac_cv_prog_CC -shared ${LDFLAGS} -o \$(@)"
LD_RXLIB_A2="$ac_cv_prog_CC -shared ${LDFLAGS} -o \$(@)"
@@ -9429,7 +9449,7 @@ $as_echo_n "checking OS distribution name... " >&6; }
@@ -9460,7 +9480,7 @@ $as_echo_n "checking OS distribution name... " >&6; }
$as_echo "$MYDISTRO" >&6; }
else
case "$target" in

View File

@ -1,6 +1,41 @@
--- files.c.orig 2015-04-04 05:20:44 UTC
--- files.c.orig 2019-10-06 06:09:39 UTC
+++ files.c
@@ -4252,9 +4252,9 @@ static streng *getstatus( tsd_t *TSD, co
@@ -76,6 +76,8 @@
* flag, which all other routines will check for.
*/
+#pragma clang diagnostic ignored "-Wincompatible-pointer-types-discards-qualifiers"
+
/*
* Bug in LCC complier wchar.h that incorrectly says it defines stat struct
* but doesn't
@@ -4139,14 +4141,14 @@ static streng *getstatus( tsd_t *TSD, const streng *fi
#else
if ( sizeof(rx_64) > 4 )
sprintf( result->value,
- "%ld %ld %03o %d %s %s %lld",
+ "%ld %ld %03o %lu %s %s %ld",
(long)(buffer.st_dev), (long)(buffer.st_ino),
buffer.st_mode & ACCESSPERMS, buffer.st_nlink,
ptmppwd, ptmpgrp,
(rx_64)(buffer.st_size) ) ;
else
sprintf( result->value,
- "%ld %ld %03o %d %s %s %ld",
+ "%ld %ld %03o %lu %s %s %ld",
(long)(buffer.st_dev), (long)(buffer.st_ino),
buffer.st_mode & ACCESSPERMS, buffer.st_nlink,
ptmppwd, ptmpgrp,
@@ -4181,7 +4183,7 @@ static streng *getstatus( tsd_t *TSD, const streng *fi
sprintf( result->value, "%I64u", buffer.st_size ) ;
#else
if ( sizeof(rx_64) > 4 )
- sprintf( result->value, "%lld", (rx_64)(buffer.st_size) ) ;
+ sprintf( result->value, "%ld", (rx_64)(buffer.st_size) ) ;
else
sprintf( result->value, "%ld", (long)(buffer.st_size) ) ;
#endif
@@ -4259,9 +4261,9 @@ static streng *getstatus( tsd_t *TSD, const streng *fi
sprintf( result->value, "%I64u", buffer.st_ctime );
#else
if ( sizeof(off_t) > 4 )
@ -12,7 +47,7 @@
#endif
}
break;
@@ -4270,9 +4270,9 @@ static streng *getstatus( tsd_t *TSD, co
@@ -4277,9 +4279,9 @@ static streng *getstatus( tsd_t *TSD, const streng *fi
sprintf( result->value, "%I64u", buffer.st_mtime );
#else
if ( sizeof(off_t) > 4 )
@ -24,7 +59,7 @@
#endif
}
break;
@@ -4288,9 +4288,9 @@ static streng *getstatus( tsd_t *TSD, co
@@ -4295,9 +4297,9 @@ static streng *getstatus( tsd_t *TSD, const streng *fi
sprintf( result->value, "%I64u", buffer.st_atime );
#else
if ( sizeof(off_t) > 4 )
@ -36,7 +71,70 @@
#endif
}
break;
@@ -6061,7 +6061,7 @@ static streng *get_external_routine_file
@@ -4310,7 +4312,7 @@ static streng *getstatus( tsd_t *TSD, const streng *fi
sprintf( result->value, "%I64u", pos_read + 1 );
#else
if ( sizeof(off_t) > 4 )
- sprintf( result->value, "%lld", pos_read + 1 );
+ sprintf( result->value, "%ld", pos_read + 1 );
else
sprintf( result->value, "%ld", (long)(pos_read + 1) );
#endif
@@ -4326,7 +4328,7 @@ static streng *getstatus( tsd_t *TSD, const streng *fi
sprintf( result->value, "%I64u", pos_write + 1 );
#else
if ( sizeof(off_t) > 4 )
- sprintf( result->value, "%lld", pos_write + 1 );
+ sprintf( result->value, "%ld", pos_write + 1 );
else
sprintf( result->value, "%ld", (long)(pos_write + 1) );
#endif
@@ -4342,7 +4344,7 @@ static streng *getstatus( tsd_t *TSD, const streng *fi
sprintf( result->value, "%I64u", line_read );
#else
if ( sizeof(off_t) > 4 )
- sprintf( result->value, "%lld", line_read );
+ sprintf( result->value, "%ld", line_read );
else
sprintf( result->value, "%ld", (long)line_read );
#endif
@@ -4388,7 +4390,7 @@ static streng *getstatus( tsd_t *TSD, const streng *fi
sprintf( result->value, "%I64u", line_write + 1 );
#else
if ( sizeof(off_t) > 4 )
- sprintf( result->value, "%lld", line_write + 1 ) ;
+ sprintf( result->value, "%ld", line_write + 1 ) ;
else
sprintf( result->value, "%ld", (long)(line_write + 1) ) ;
#endif
@@ -4401,7 +4403,7 @@ static streng *getstatus( tsd_t *TSD, const streng *fi
sprintf( result->value, "%I64u", line_write );
#else
if ( sizeof(off_t) > 4 )
- sprintf( result->value, "%lld", line_write ) ;
+ sprintf( result->value, "%ld", line_write ) ;
else
sprintf( result->value, "%ld", (long)line_write ) ;
#endif
@@ -4463,7 +4465,7 @@ static streng *getrexxstatus( const tsd_t *TSD, cfileb
#else
if ( sizeof(rx_64) > 4 )
sprintf( result->value + strlen(result->value),
- " READ: char=%lld line=%lld WRITE: char=%lld line=%lld %s",
+ " READ: char=%ld line=%ld WRITE: char=%ld line=%ld %s",
(ptr->readpos+1), ptr->readline,
(ptr->writepos+1), ptr->writeline,
(ptr->flag & FLAG_PERSIST) ? "PERSISTENT" : "TRANSIENT" ) ;
@@ -4851,7 +4853,7 @@ static streng *getseek( tsd_t *TSD, const streng *file
sprintf(result->value, "%I64u", pos );
#else
if ( sizeof(rx_64) > 4 )
- sprintf(result->value, "%lld", pos );
+ sprintf(result->value, "%ld", pos );
else
sprintf(result->value, "%ld", (long)pos );
#endif
@@ -6079,7 +6081,7 @@ static streng *get_external_routine_file( const tsd_t
if ( *fp == NULL )
return NULL;
@ -45,7 +143,7 @@
return Str_crestrTSD( buf );
}
@@ -6673,7 +6673,7 @@ int my_fullpathstreng( const tsd_t *TSD,
@@ -6717,7 +6719,7 @@ int my_fullpathstreng( const tsd_t *TSD, char *dst, co
int retval;
copy = str_ofTSD( src );

View File

@ -1,6 +1,6 @@
--- options.c.orig 2012-06-11 07:26:33 UTC
--- options.c.orig 2019-10-06 06:09:39 UTC
+++ options.c
@@ -125,7 +125,7 @@ void do_options( const tsd_t *TSD, procl
@@ -125,7 +125,7 @@ void do_options( const tsd_t *TSD, proclevel pl, stren
*/
if ( get_options_flag( pl, EXT_SINGLE_INTERPRETER ) )
{

View File

@ -1,4 +1,4 @@
--- regutil/inifile.c.orig 2014-10-25 01:36:33 UTC
--- regutil/inifile.c.orig 2019-10-06 06:09:42 UTC
+++ regutil/inifile.c
@@ -31,6 +31,7 @@
#include <ctype.h>

View File

@ -1,4 +1,4 @@
--- regutil/regfilesys.c.orig 2015-04-04 08:16:55 UTC
--- regutil/regfilesys.c.orig 2019-10-06 06:19:40 UTC
+++ regutil/regfilesys.c
@@ -27,6 +27,8 @@
#endif

View File

@ -1,4 +1,4 @@
--- regutil/regini.c.orig 2014-10-30 04:54:43 UTC
--- regutil/regini.c.orig 2019-10-06 06:19:40 UTC
+++ regutil/regini.c
@@ -26,6 +26,7 @@
#endif
@ -8,3 +8,16 @@
#ifdef _WIN32
# include <windows.h>
@@ -547,10 +548,10 @@ rxfunc(sysqueryprocess)
result->strlength = 6;
}
else if (!strcmp(arg, "PTIME")) {
- result->strlength = sprintf(result->strptr, "%lu", clock());
+ result->strlength = sprintf(result->strptr, "%u", clock());
}
else if (!strcmp(arg, "TTIME")) {
- result->strlength = sprintf(result->strptr, "%lu", clock());
+ result->strlength = sprintf(result->strptr, "%u", clock());
}
else
return BADARGS;

View File

@ -1,4 +1,4 @@
--- regutil/regmacrospace.c.orig 2009-10-07 07:51:51 UTC
--- regutil/regmacrospace.c.orig 2019-10-06 06:09:42 UTC
+++ regutil/regmacrospace.c
@@ -59,7 +59,7 @@ rxfunc(sysaddrexxmacro)
flags = RXMACRO_SEARCH_AFTER;

View File

@ -1,40 +1,12 @@
--- regutil/regscreenux.c.orig 2012-08-08 01:23:45 UTC
--- regutil/regscreenux.c.orig 2019-10-06 06:19:40 UTC
+++ regutil/regscreenux.c
@@ -21,6 +21,8 @@
* $Header: /opt/cvs/Regina/regutil/regscreenux.c,v 1.9 2012/08/08 01:23:45 mark Exp $
@@ -21,6 +21,9 @@
* $Header: /opt/cvs/Regina/regutil/regscreenux.c,v 1.10 2016/01/20 00:07:46 mark Exp $
*/
#include "regutil.h"
+
+#include </usr/include/strings.h>
+
#ifdef USE_TERMCAP_DB
# ifdef HAVE_NCURSES_H
# include <ncurses.h>
@@ -91,7 +93,7 @@ rxfunc(syscls)
if (!*clr) {
sethandles();
- clr = tgetstr("cl", &clrbuf);
+ clr = tgetstr("cl", (char **) &clrbuf);
}
#else
/* ansi terminal control for clearing the screen should work with any
@@ -128,7 +130,7 @@ rxfunc(syscurpos)
#ifdef USE_TERMCAP_DB
if (!*cpos) {
sethandles();
- cpos = tgetstr("cm", &cposbuf);
+ cpos = tgetstr("cm", (char **) &cposbuf);
}
#endif
@@ -179,8 +181,8 @@ rxfunc(syscurstate)
if (!*css) {
char *pcss = css;
sethandles();
- pcsson = tgetstr("ve", &css);
- pcssoff = tgetstr("vi", &css);
+ pcsson = tgetstr("ve", (char **) &css);
+ pcssoff = tgetstr("vi", (char **) &css);
}
#endif

View File

@ -1,6 +1,6 @@
--- regutil/regtrig.c.orig 2014-06-22 03:53:33 UTC
--- regutil/regtrig.c.orig 2019-10-06 06:09:42 UTC
+++ regutil/regtrig.c
@@ -124,7 +124,7 @@ static void FormatResult(double res, uns
@@ -124,7 +124,7 @@ static void FormatResult(double res, unsigned long pre
}
else
/* format the result */

View File

@ -1,8 +1,8 @@
--- regutil/regunicode.c.orig 2012-08-08 01:26:20 UTC
--- regutil/regunicode.c.orig 2019-10-06 06:19:40 UTC
+++ regutil/regunicode.c
@@ -20,6 +20,7 @@
*
* $Header: /opt/cvs/Regina/regutil/regunicode.c,v 1.3 2012/08/08 01:26:20 mark Exp $
* $Header: /opt/cvs/Regina/regutil/regunicode.c,v 1.5 2019/07/03 22:39:28 mark Exp $
*/
+#include </usr/include/strings.h>
#include "rxproto.h"

View File

@ -1,6 +1,6 @@
--- regutil/regutil.c.orig 2014-10-19 04:07:12 UTC
--- regutil/regutil.c.orig 2019-10-06 06:09:42 UTC
+++ regutil/regutil.c
@@ -183,6 +183,8 @@ extern void *getRexxUtilFunctionAddress(
@@ -183,6 +183,8 @@ extern void *getRexxUtilFunctionAddress( char *name )
}
#endif

View File

@ -1,6 +1,6 @@
--- rxstack.c.orig 2014-06-22 03:45:14 UTC
--- rxstack.c.orig 2019-10-06 06:19:40 UTC
+++ rxstack.c
@@ -1575,7 +1575,7 @@ int rxstack_pull_line_off_queue( Client
@@ -1585,7 +1585,7 @@ int rxstack_pull_line_off_queue( Client *client, stren
if ( q->oldest == NULL )
q->oldest = client;
rc = RXSTACK_WAITING; /* waiting */
@ -9,7 +9,7 @@
}
}
}
@@ -1854,7 +1854,7 @@ int rxstack_process_websockets_headers(
@@ -1914,7 +1914,7 @@ int rxstack_process_websockets_headers( Client *client
key[end-start] = '\0';
start = strstr(ws_headers, "\r\n\r\n");
@ -18,7 +18,30 @@
/*
* Generate our response key
@@ -2958,7 +2958,7 @@ int rxstack_doit( )
@@ -1966,11 +1966,11 @@ int decode_ws_payload( unsigned char *src, size_t srcl
// Find beginning of next frame. First time hdr_length, masked and
// payload_length are zero
frame += hdr_length + 4*masked + payload_length;
- DEBUGDUMP(printf("frame[0..3]: 0x%x 0x%x 0x%x 0x%x (tot: %d)\n",(unsigned char) frame[0],(unsigned char) frame[1],(unsigned char) frame[2],(unsigned char) frame[3], srclength););
+ DEBUGDUMP(printf("frame[0..3]: 0x%x 0x%x 0x%x 0x%x (tot: %d)\n",(unsigned char) frame[0],(unsigned char) frame[1],(unsigned char) frame[2],(unsigned char) frame[3], (int) srclength););
if (frame > src + srclength)
{
- DEBUGDUMP(printf("Truncated frame from client, need %d more bytes\n",frame - (src + srclength)););
+ DEBUGDUMP(printf("Truncated frame from client, need %d more bytes\n", (int) (frame - (src + srclength))););
break;
}
remaining = (src + srclength) - frame;
@@ -2010,7 +2010,7 @@ int decode_ws_payload( unsigned char *src, size_t srcl
{
continue;
}
- DEBUGDUMP(printf(" payload_length: %u, raw remaining: %u, , hdr_length: %d, opcode %d\n",payload_length, remaining,hdr_length, *opcode););
+ DEBUGDUMP(printf(" payload_length: %u, raw remaining: %u, , hdr_length: %d, opcode %d\n",payload_length, (int) remaining,hdr_length, *opcode););
payload = frame + hdr_length + 4*masked;
if (*opcode != 1 && *opcode != 2)
@@ -3041,7 +3041,7 @@ int rxstack_doit( )
rc = 0 ; /* already timed out */
if ( ( rc == -1 ) || ( rc > DEFAULT_WAKEUP ) )
rc = DEFAULT_WAKEUP ;
@ -27,7 +50,7 @@
#if defined(HAVE_POLL) && (defined(HAVE_POLL_H) || defined(HAVE_SYS_POLL_H))
rc = poll( pd, poll_cnt, rc ) ;
#else
@@ -2967,7 +2967,7 @@ int rxstack_doit( )
@@ -3050,7 +3050,7 @@ int rxstack_doit( )
rc = select( max_sock + 1, &ready, (fd_set *)0, (fd_set *)0, &to ) ;
#endif
now = get_now( ) ;

View File

@ -0,0 +1,20 @@
--- stack.c.orig 2021-01-14 22:35:55 UTC
+++ stack.c
@@ -1314,7 +1314,7 @@ int create_queue( tsd_t *TSD, const streng *queue_name
/*
* Create a unique queue name
*/
- sprintf(buf,"S%d-%ld-%d", getpid(), clock(), st->runner++ );
+ sprintf(buf,"S%d-%d-%d", getpid(), clock(), st->runner++ );
new_queue = Str_cre_TSD( TSD, buf ) ;
}
else
@@ -1344,7 +1344,7 @@ int create_queue( tsd_t *TSD, const streng *queue_name
/*
* Create a unique queue name
*/
- sprintf(buf,"S%d-%ld-%d", getpid(), clock(), st->runner++ );
+ sprintf(buf,"S%d-%d-%d", getpid(), clock(), st->runner++ );
new_queue = Str_cre_TSD( TSD, buf ) ;
rc = 1;
}

View File

@ -1,6 +1,6 @@
--- strmath.c.orig 2012-08-09 00:43:53 UTC
--- strmath.c.orig 2019-10-06 06:09:40 UTC
+++ strmath.c
@@ -296,7 +296,7 @@ int descr_to_int( const tsd_t *TSD, cons
@@ -296,7 +296,7 @@ int descr_to_int( const tsd_t *TSD, const num_descr *i
streng *h;
h = name_of_node( TSD, NULL, input );

View File

@ -0,0 +1,12 @@
--- threader.c.orig 2021-01-14 22:06:20 UTC
+++ threader.c
@@ -22,6 +22,9 @@
*
* This example works with Win32 as with OS/2 or Posix threads.
*/
+
+#pragma clang diagnostic ignored "-Wint-to-void-pointer-cast"
+
#include <stdio.h>
#include <string.h>
#include <stdlib.h>

View File

@ -0,0 +1,11 @@
--- yaccsrc.c.orig 2021-01-14 22:34:08 UTC
+++ yaccsrc.c
@@ -96,6 +96,8 @@ static char *RCSid = "$Id: yaccsrc.c,v 1.47 2019/04/06
* Software Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
*/
+#pragma clang diagnostic ignored "-Wint-to-pointer-cast"
+
#include "rexx.h"
#include <time.h>

View File

@ -0,0 +1,11 @@
--- yaccsrc.y.orig 2021-01-14 22:26:31 UTC
+++ yaccsrc.y
@@ -23,6 +23,8 @@ static char *RCSid = "$Id: yaccsrc.y,v 1.44 2019/04/06
* Software Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
*/
+#pragma clang diagnostic ignored "-Wint-to-pointer-cast"
+
#include "rexx.h"
#include <time.h>

View File

@ -9,6 +9,7 @@ lib/Regina-REXX/addons/librxtest1.so
lib/Regina-REXX/addons/librxtest2.so
lib/libregina.a
lib/libregina.so
libdata/pkgconfig/libregina.pc
man/man1/regina.1.gz
man/man1/rexx.1.gz
man/man1/regina-config.1.gz