MFH: r567450
lang/php80: Update from 8.0.2 to 8.0.3 Changelog: Core: Fixed #80706 (mail(): Headers after Bcc headers may be ignored). DOM: Fixed bug #80600 (DOMChildNode::remove() doesn't work on CharacterData nodes). Gettext: Fixed bug #53251 (bindtextdomain with null dir doesn't return old value). MySQLnd: Fixed bug #78680 (mysqlnd's mysql_clear_password does not transmit null-terminated password). Fixed bug #80713 (SegFault when disabling ATTR_EMULATE_PREPARES and MySQL 8.0). MySQLi: Fixed bug #74779 (x() and y() truncating floats to integers). Opcache: Fixed bug #80634 (write_property handler of internal classes is skipped on preloaded JITted code). Fixed bug #80682 (opcache doesn't honour pcre.jit option). Fixed bug #80742 (Opcache JIT makes some boolean logic unexpectedly be true). Fixed bug #80745 (JIT produces Assert failure and UNKNOWN:0 var_dumps in code involving bitshifts). OpenSSL: Fixed bug #80747 (Providing RSA key size < 512 generates key that crash PHP). Phar: Fixed bug #75850 (Unclear error message wrt. __halt_compiler() w/o semicolon) (cmb) Fixed bug #70091 (Phar does not mark UTF-8 filenames in ZIP archives). Fixed bug #53467 (Phar cannot compress large archives). Socket: Fixed bug #80723 (Different sockets compare as equal (regression in 8.0)). SPL: Fixed bug#80719 (Iterating after failed ArrayObject::setIteratorClass() causes Segmentation fault). Standard: Fixed bug #80654 (file_get_contents() maxlen fails above (2**31)-1 bytes). Fixed bug #80718 (ext/standard/dl.c fallback code path with syntax error). Sponsored by: PHP Upgrade Service
This commit is contained in:
parent
807d804249
commit
6eef4e54d9
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/branches/2021Q1/; revision=567453
@ -1,7 +1,7 @@
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= php80
|
||||
DISTVERSION= 8.0.2
|
||||
DISTVERSION= 8.0.3
|
||||
PORTREVISION?= 0
|
||||
CATEGORIES?= lang devel www
|
||||
MASTER_SITES= PHP/distributions
|
||||
|
@ -1,3 +1,3 @@
|
||||
TIMESTAMP = 1612541077
|
||||
SHA256 (php-8.0.2.tar.xz) = 84dd6e36f48c3a71ff5dceba375c1f6b34b71d4fa9e06b720780127176468ccc
|
||||
SIZE (php-8.0.2.tar.xz) = 10650500
|
||||
TIMESTAMP = 1614952496
|
||||
SHA256 (php-8.0.3.tar.xz) = c9816aa9745a9695672951eaff3a35ca5eddcb9cacf87a4f04b9fb1169010251
|
||||
SIZE (php-8.0.3.tar.xz) = 10755796
|
||||
|
@ -1,11 +0,0 @@
|
||||
--- jit/Makefile.frag.orig 2020-11-24 17:04:03 UTC
|
||||
+++ jit/Makefile.frag
|
||||
@@ -5,7 +5,7 @@ $(builddir)/minilua: $(srcdir)/jit/dynasm/minilua.c
|
||||
$(builddir)/jit/zend_jit_x86.c: $(srcdir)/jit/zend_jit_x86.dasc $(srcdir)/jit/dynasm/*.lua $(builddir)/minilua
|
||||
$(builddir)/minilua $(srcdir)/jit/dynasm/dynasm.lua $(DASM_FLAGS) -o $@ $(srcdir)/jit/zend_jit_x86.dasc
|
||||
|
||||
-$(builddir)/jit/zend_jit.lo: \
|
||||
+jit/zend_jit.lo: \
|
||||
$(builddir)/jit/zend_jit_x86.c \
|
||||
$(srcdir)/jit/zend_jit_helpers.c \
|
||||
$(srcdir)/jit/zend_jit_disasm_x86.c \
|
Loading…
Reference in New Issue
Block a user