Add user-selector-applet 0.0.7, fast user switching applet for GNOME.
This commit is contained in:
parent
f28ade93bc
commit
6ee631b326
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=112054
@ -156,6 +156,7 @@
|
||||
SUBDIR += temperature.app
|
||||
SUBDIR += tkgoodstuff
|
||||
SUBDIR += tycoon
|
||||
SUBDIR += user-selector-applet
|
||||
SUBDIR += vdesk
|
||||
SUBDIR += wdm
|
||||
SUBDIR += wmappl
|
||||
|
23
x11/fast-user-switch-applet/Makefile
Normal file
23
x11/fast-user-switch-applet/Makefile
Normal file
@ -0,0 +1,23 @@
|
||||
# New ports collection makefile for: user-selector-applet
|
||||
# Date created: 8 May 2004
|
||||
# Whom: Alexander Nedotsukov <bland@FreeBSD.org>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= user-selector-applet
|
||||
PORTVERSION= 0.0.7
|
||||
CATEGORIES= x11 gnome
|
||||
MASTER_SITES= http://esco.mine.nu/downloads/
|
||||
DIST_SUBDIR= gnome2
|
||||
|
||||
MAINTAINER= bland@FreeBSD.org
|
||||
COMMENT= Fast user switching applet for GNOME
|
||||
|
||||
USE_X_PREFIX= yes
|
||||
USE_GMAKE= yes
|
||||
USE_GNOME= gnomehack gtk20 gnomepanel
|
||||
USE_LIBTOOL_VER= 13
|
||||
INSTALLS_SHLIB= yes
|
||||
|
||||
.include <bsd.port.mk>
|
2
x11/fast-user-switch-applet/distinfo
Normal file
2
x11/fast-user-switch-applet/distinfo
Normal file
@ -0,0 +1,2 @@
|
||||
MD5 (gnome2/user-selector-applet-0.0.7.tar.gz) = 8ee0515a0d3454831d4a1a5562b67415
|
||||
SIZE (gnome2/user-selector-applet-0.0.7.tar.gz) = 413494
|
@ -0,0 +1,11 @@
|
||||
--- src/esco-gdm/esco-user.c.orig Mon Jun 21 00:47:26 2004
|
||||
+++ src/esco-gdm/esco-user.c Mon Jun 21 00:40:35 2004
|
||||
@@ -611,6 +611,8 @@
|
||||
|
||||
mgr = esco_screen_manager_get_default ();
|
||||
|
||||
+ user->screen_changed_id = g_signal_connect (mgr, "new-screen",
|
||||
+ G_CALLBACK (screen_changed_cb), user);
|
||||
user->screen_changed_id = g_signal_connect (mgr, "screen-changed",
|
||||
G_CALLBACK (screen_changed_cb), user);
|
||||
user->screen_closed_id = g_signal_connect (mgr, "screen-closed", G_CALLBACK (screen_closed_cb),
|
@ -0,0 +1,17 @@
|
||||
--- src/esco-gdm/ve-misc.c.orig Sat May 8 23:13:22 2004
|
||||
+++ src/esco-gdm/ve-misc.c Sat May 8 23:23:40 2004
|
||||
@@ -431,13 +431,13 @@
|
||||
* of environment.
|
||||
*
|
||||
**/
|
||||
+extern char **environ;
|
||||
void
|
||||
ve_clearenv (void)
|
||||
{
|
||||
#ifdef HAVE_CLEARENV
|
||||
clearenv ();
|
||||
#else
|
||||
- extern char **environ;
|
||||
environ[0] = NULL;
|
||||
#endif
|
||||
}
|
3
x11/fast-user-switch-applet/pkg-descr
Normal file
3
x11/fast-user-switch-applet/pkg-descr
Normal file
@ -0,0 +1,3 @@
|
||||
The User Selector Applet is an applet for the GNOME 2.6 panel which allows for
|
||||
MacOS X-style fast-user-switching.
|
||||
|
6
x11/fast-user-switch-applet/pkg-plist
Normal file
6
x11/fast-user-switch-applet/pkg-plist
Normal file
@ -0,0 +1,6 @@
|
||||
etc/gconf/schemas/user-selector-applet.schemas
|
||||
libdata/bonobo/servers/GNOME_UserSelectorApplet.server
|
||||
libexec/user-selector-applet
|
||||
share/icons/hicolor/16x16/apps/gdm-xnest.png
|
||||
share/icons/hicolor/32x32/apps/gdm-xnest.png
|
||||
share/icons/hicolor/48x48/apps/gdm-xnest.png
|
23
x11/user-selector-applet/Makefile
Normal file
23
x11/user-selector-applet/Makefile
Normal file
@ -0,0 +1,23 @@
|
||||
# New ports collection makefile for: user-selector-applet
|
||||
# Date created: 8 May 2004
|
||||
# Whom: Alexander Nedotsukov <bland@FreeBSD.org>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= user-selector-applet
|
||||
PORTVERSION= 0.0.7
|
||||
CATEGORIES= x11 gnome
|
||||
MASTER_SITES= http://esco.mine.nu/downloads/
|
||||
DIST_SUBDIR= gnome2
|
||||
|
||||
MAINTAINER= bland@FreeBSD.org
|
||||
COMMENT= Fast user switching applet for GNOME
|
||||
|
||||
USE_X_PREFIX= yes
|
||||
USE_GMAKE= yes
|
||||
USE_GNOME= gnomehack gtk20 gnomepanel
|
||||
USE_LIBTOOL_VER= 13
|
||||
INSTALLS_SHLIB= yes
|
||||
|
||||
.include <bsd.port.mk>
|
2
x11/user-selector-applet/distinfo
Normal file
2
x11/user-selector-applet/distinfo
Normal file
@ -0,0 +1,2 @@
|
||||
MD5 (gnome2/user-selector-applet-0.0.7.tar.gz) = 8ee0515a0d3454831d4a1a5562b67415
|
||||
SIZE (gnome2/user-selector-applet-0.0.7.tar.gz) = 413494
|
@ -0,0 +1,11 @@
|
||||
--- src/esco-gdm/esco-user.c.orig Mon Jun 21 00:47:26 2004
|
||||
+++ src/esco-gdm/esco-user.c Mon Jun 21 00:40:35 2004
|
||||
@@ -611,6 +611,8 @@
|
||||
|
||||
mgr = esco_screen_manager_get_default ();
|
||||
|
||||
+ user->screen_changed_id = g_signal_connect (mgr, "new-screen",
|
||||
+ G_CALLBACK (screen_changed_cb), user);
|
||||
user->screen_changed_id = g_signal_connect (mgr, "screen-changed",
|
||||
G_CALLBACK (screen_changed_cb), user);
|
||||
user->screen_closed_id = g_signal_connect (mgr, "screen-closed", G_CALLBACK (screen_closed_cb),
|
@ -0,0 +1,17 @@
|
||||
--- src/esco-gdm/ve-misc.c.orig Sat May 8 23:13:22 2004
|
||||
+++ src/esco-gdm/ve-misc.c Sat May 8 23:23:40 2004
|
||||
@@ -431,13 +431,13 @@
|
||||
* of environment.
|
||||
*
|
||||
**/
|
||||
+extern char **environ;
|
||||
void
|
||||
ve_clearenv (void)
|
||||
{
|
||||
#ifdef HAVE_CLEARENV
|
||||
clearenv ();
|
||||
#else
|
||||
- extern char **environ;
|
||||
environ[0] = NULL;
|
||||
#endif
|
||||
}
|
3
x11/user-selector-applet/pkg-descr
Normal file
3
x11/user-selector-applet/pkg-descr
Normal file
@ -0,0 +1,3 @@
|
||||
The User Selector Applet is an applet for the GNOME 2.6 panel which allows for
|
||||
MacOS X-style fast-user-switching.
|
||||
|
6
x11/user-selector-applet/pkg-plist
Normal file
6
x11/user-selector-applet/pkg-plist
Normal file
@ -0,0 +1,6 @@
|
||||
etc/gconf/schemas/user-selector-applet.schemas
|
||||
libdata/bonobo/servers/GNOME_UserSelectorApplet.server
|
||||
libexec/user-selector-applet
|
||||
share/icons/hicolor/16x16/apps/gdm-xnest.png
|
||||
share/icons/hicolor/32x32/apps/gdm-xnest.png
|
||||
share/icons/hicolor/48x48/apps/gdm-xnest.png
|
Loading…
Reference in New Issue
Block a user