Add new port games/dustrac:

Dust Racing 2D (Dustrac) is a tile-based, cross-platform 2D racing
game written in Qt.

WWW: http://dustrac.sourceforge.net/
This commit is contained in:
Max Brazhnikov 2014-04-18 09:38:03 +00:00
parent 1d7811daed
commit 6ed528f89a
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=351526
11 changed files with 281 additions and 0 deletions

View File

@ -215,6 +215,7 @@
SUBDIR += duke3d-data
SUBDIR += dungeon
SUBDIR += dungeoncrawl
SUBDIR += dustrac
SUBDIR += eboard
SUBDIR += edge
SUBDIR += editss

46
games/dustrac/Makefile Normal file
View File

@ -0,0 +1,46 @@
# $FreeBSD$
PORTNAME= dustrac
PORTVERSION= 1.7.2
CATEGORIES= games
MASTER_SITES= SF/${PORTNAME}/src
MAINTAINER= makc@FreeBSD.org
COMMENT= 2D top-view racing game
LIB_DEPENDS= libvorbisfile.so:${PORTSDIR}/audio/libvorbis
USES= compiler:c++11-lib cmake openal pkgconfig zip
USE_GL= glu
_USE_QT4= corelib opengl xml linguist_build \
moc_build qmake_build rcc_build uic_build
_USE_QT5= core opengl xml widgets \
buildtools_build linguisttools_build qmake_build
CMAKE_ARGS= -DReleaseBuild=on \
-DDATA_PATH=${DATADIR} \
-DDOC_PATH=${DOCSDIR}
LDFLAGS= -L${LOCALBASE}/lib
OPTIONS_DEFINE= DOCS DEBUG
OPTIONS_SINGLE= TOOLKIT
OPTIONS_SINGLE_TOOLKIT= QT4 QT5
OPTIONS_DEFAULT= QT5
TOOLKIT_DESC= Qt toolkit
DEBUG_CMAKE_ON= -DDebugBuild=on
QT4_USE= ${_USE_QT4:S/^/QT4=/}
QT5_USE= ${_USE_QT5:S/^/QT5=/}
QT5_CMAKE_ON= -DUseQt5=on
QT5_CMAKE_OFF= -DUseQt5=off
STRIP_FILES= bin/dustrac-game \
bin/dustrac-editor
post-patch:
${REINPLACE_CMD} -e '/add_subdirectory(UnitTests)/d' \
${WRKSRC}/src/game/MiniCore/CMakeLists.txt
post-install:
${STRIP_CMD} ${STRIP_FILES:S,^,${STAGEDIR}${PREFIX}/,}
.include <bsd.port.mk>

2
games/dustrac/distinfo Normal file
View File

@ -0,0 +1,2 @@
SHA256 (dustrac-1.7.2.zip) = 2eaa4b98c77936cbbc0c34120b3e1a32a48612886254f8ea85ed042034e4268b
SIZE (dustrac-1.7.2.zip) = 26450932

View File

@ -0,0 +1,18 @@
--- ./CMakeLists.txt.orig 2014-03-09 12:40:35.000000000 +0000
+++ ./CMakeLists.txt 2014-04-05 13:27:16.455482525 +0000
@@ -40,13 +40,12 @@
cmake_policy(VERSION 2.8.7)
endif()
-if(${CMAKE_SYSTEM_NAME} MATCHES "Linux")
+if(UNIX)
include("InstallLinux.cmake")
-elseif(${CMAKE_SYSTEM_NAME} MATCHES "Windows")
+elseif(WIN32)
include("InstallWindows.cmake")
endif()
-set(CMAKE_VERBOSE_MAKEFILE OFF)
set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++0x -W -Wall -O3 -pedantic")
set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -fomit-frame-pointer -finline-functions -ffast-math")

View File

@ -0,0 +1,10 @@
--- ./src/common/route.cpp.orig 2014-03-29 12:42:23.000000000 +0000
+++ ./src/common/route.cpp 2014-04-14 11:24:16.431660171 +0000
@@ -18,6 +18,7 @@
#include <algorithm>
#include <cassert>
+#include <cmath>
static const int CLOSING_TH = 32;

View File

@ -0,0 +1,11 @@
--- ./src/editor/CMakeLists.txt.orig 2014-04-05 14:09:43.520483380 +0000
+++ ./src/editor/CMakeLists.txt 2014-04-05 14:10:03.847483124 +0000
@@ -75,7 +75,7 @@
endif()
# Copy desktop file
-if(ReleaseBuild AND ${CMAKE_SYSTEM_NAME} MATCHES "Linux")
+if(ReleaseBuild AND UNIX)
set(DesktopFileSourcePath)
if(USC)
set(DesktopFileSourcePath ${CMAKE_SOURCE_DIR}/src/dustrac-editor.desktop.opt.in)

View File

@ -0,0 +1,11 @@
--- ./src/editor/editorview.cpp.orig 2014-03-29 12:42:23.000000000 +0000
+++ ./src/editor/editorview.cpp 2014-04-06 15:45:53.624369553 +0000
@@ -240,7 +240,7 @@
if (MainWindow::instance()->randomlyRotateObjects())
{
- object.setRotation(std::rand() % 360);
+ object.setRotation(rand() % 360);
}
scene()->addItem(&object);

View File

@ -0,0 +1,11 @@
--- ./src/game/CMakeLists.txt.orig 2014-04-05 14:09:28.680493168 +0000
+++ ./src/game/CMakeLists.txt 2014-04-05 14:09:35.694483369 +0000
@@ -129,7 +129,7 @@
endif()
# Copy desktop file
-if(ReleaseBuild AND ${CMAKE_SYSTEM_NAME} MATCHES "Linux")
+if(ReleaseBuild AND UNIX)
set(DesktopFileSourcePath)
if(USC)
set(DesktopFileSourcePath ${CMAKE_SOURCE_DIR}/src/dustrac-game.desktop.opt.in)

View File

@ -0,0 +1,20 @@
--- ./src/game/fadeanimation.cpp.orig 2014-03-09 12:40:35.000000000 +0000
+++ ./src/game/fadeanimation.cpp 2014-04-05 13:27:41.052483713 +0000
@@ -81,7 +81,7 @@
#ifdef Q_OS_ANDROID
emit fadeValueChanged(fmin(m_fadeValue, 1.0));
#else
- emit fadeValueChanged(std::fmin(m_fadeValue, 1.0));
+ emit fadeValueChanged(fmin(m_fadeValue, 1.0));
#endif
}
else if (!m_fadeIn && m_fadeValue > 0.0)
@@ -90,7 +90,7 @@
#ifdef Q_OS_ANDROID
emit fadeValueChanged(fmax(m_fadeValue, 0.0));
#else
- emit fadeValueChanged(std::fmax(m_fadeValue, 0.0));
+ emit fadeValueChanged(fmax(m_fadeValue, 0.0));
#endif
}
else if (m_postDelayMSec)

9
games/dustrac/pkg-descr Normal file
View File

@ -0,0 +1,9 @@
Dust Racing 2D (Dustrac) is a tile-based, cross-platform 2D racing
game written in Qt.
Play against challenging computer cars or use the split-screen mode
to play against your friend. A level editor for easy level creation
is included. Dust Racing 2D is inspired by Super Cars and Slicksn
Slide.
WWW: http://dustrac.sourceforge.net/

142
games/dustrac/pkg-plist Normal file
View File

@ -0,0 +1,142 @@
bin/dustrac-editor
bin/dustrac-game
share/applications/dustrac-editor.desktop
share/applications/dustrac-game.desktop
%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
%%PORTDOCS%%%%DOCSDIR%%/CHANGELOG
%%PORTDOCS%%%%DOCSDIR%%/COPYING
%%PORTDOCS%%%%DOCSDIR%%/README
%%DATADIR%%/editorModels.conf
%%DATADIR%%/fonts.conf
%%DATADIR%%/fonts/UbuntuMono-B.ttf
%%DATADIR%%/fonts/UbuntuMono-R.ttf
%%DATADIR%%/images/about.png
%%DATADIR%%/images/asphalt.jpg
%%DATADIR%%/images/brake.png
%%DATADIR%%/images/bridge.png
%%DATADIR%%/images/bridgeEditor.png
%%DATADIR%%/images/bridgeObject.png
%%DATADIR%%/images/bridgePreview.png
%%DATADIR%%/images/bushArea.png
%%DATADIR%%/images/carBlack.png
%%DATADIR%%/images/carBlue.png
%%DATADIR%%/images/carBrown.png
%%DATADIR%%/images/carCyan.png
%%DATADIR%%/images/carDarkGreen.png
%%DATADIR%%/images/carDarkRed.png
%%DATADIR%%/images/carGreen.png
%%DATADIR%%/images/carGrey.png
%%DATADIR%%/images/carNormalMap.png
%%DATADIR%%/images/carOrange.png
%%DATADIR%%/images/carPink.png
%%DATADIR%%/images/carRed.png
%%DATADIR%%/images/carViolet.png
%%DATADIR%%/images/carYellow.png
%%DATADIR%%/images/checkeredFlag.png
%%DATADIR%%/images/clear.png
%%DATADIR%%/images/corner.png
%%DATADIR%%/images/corner45Left.png
%%DATADIR%%/images/corner45LeftPreview.png
%%DATADIR%%/images/corner45Right.png
%%DATADIR%%/images/corner45RightPreview.png
%%DATADIR%%/images/cornerPreview.png
%%DATADIR%%/images/creditsHelpBack.png
%%DATADIR%%/images/cross.png
%%DATADIR%%/images/cursor.png
%%DATADIR%%/images/cursor2.png
%%DATADIR%%/images/dustRacing2DBanner.png
%%DATADIR%%/images/finish.png
%%DATADIR%%/images/finishPreview.png
%%DATADIR%%/images/frontTire.png
%%DATADIR%%/images/grandstand.png
%%DATADIR%%/images/grandstandEditor.png
%%DATADIR%%/images/grass.png
%%DATADIR%%/images/grassEditor.png
%%DATADIR%%/images/grid.png
%%DATADIR%%/images/intro.png
%%DATADIR%%/images/leaf.png
%%DATADIR%%/images/left.png
%%DATADIR%%/images/lock.png
%%DATADIR%%/images/logo.png
%%DATADIR%%/images/mainMenuBack.png
%%DATADIR%%/images/monospace.png
%%DATADIR%%/images/mud.png
%%DATADIR%%/images/pit.png
%%DATADIR%%/images/plant.png
%%DATADIR%%/images/right.png
%%DATADIR%%/images/rock.png
%%DATADIR%%/images/sand.png
%%DATADIR%%/images/sandAreaBig.png
%%DATADIR%%/images/sandAreaCurve.png
%%DATADIR%%/images/sandGrassCorner.png
%%DATADIR%%/images/sandGrassCorner2.png
%%DATADIR%%/images/sandGrassStraight.png
%%DATADIR%%/images/settingsBack.png
%%DATADIR%%/images/skid.png
%%DATADIR%%/images/sky.png
%%DATADIR%%/images/smoke.png
%%DATADIR%%/images/sparkle.png
%%DATADIR%%/images/star.png
%%DATADIR%%/images/starGlow.png
%%DATADIR%%/images/startLightGlow.png
%%DATADIR%%/images/startLightOff.png
%%DATADIR%%/images/startLightOffCorner.png
%%DATADIR%%/images/startLightOn.png
%%DATADIR%%/images/startLightOnCorner.png
%%DATADIR%%/images/steel.jpg
%%DATADIR%%/images/straight.png
%%DATADIR%%/images/straight45Female.png
%%DATADIR%%/images/straight45FemalePreview.png
%%DATADIR%%/images/straight45Male.png
%%DATADIR%%/images/straight45MalePreview.png
%%DATADIR%%/images/straightPreview.png
%%DATADIR%%/images/tire.png
%%DATADIR%%/images/tireStatusIndicatorBody.png
%%DATADIR%%/images/tireStatusIndicatorTires.png
%%DATADIR%%/images/trackSelectionBack.png
%%DATADIR%%/images/tree.png
%%DATADIR%%/images/wood.png
%%DATADIR%%/levels/curvastone.trk
%%DATADIR%%/levels/infinity.trk
%%DATADIR%%/levels/monza.trk
%%DATADIR%%/levels/ring.trk
%%DATADIR%%/levels/straight.trk
%%DATADIR%%/levels/triangle.trk
%%DATADIR%%/levels/twister.trk
%%DATADIR%%/meshes.conf
%%DATADIR%%/models/cube.obj
%%DATADIR%%/sounds/bell.ogg
%%DATADIR%%/sounds/carEngine.ogg
%%DATADIR%%/sounds/carHit.ogg
%%DATADIR%%/sounds/carHit2.ogg
%%DATADIR%%/sounds/carHit3.ogg
%%DATADIR%%/sounds/cheering.ogg
%%DATADIR%%/sounds/menuBoom.ogg
%%DATADIR%%/sounds/menuClick.ogg
%%DATADIR%%/sounds/pit.ogg
%%DATADIR%%/sounds/skid.ogg
%%DATADIR%%/textures.conf
%%DATADIR%%/translations/dustrac-editor_cs.qm
%%DATADIR%%/translations/dustrac-editor_fi.qm
%%DATADIR%%/translations/dustrac-editor_fr.qm
%%DATADIR%%/translations/dustrac-editor_it.qm
%%DATADIR%%/translations/dustrac-game_cs.qm
%%DATADIR%%/translations/dustrac-game_fi.qm
%%DATADIR%%/translations/dustrac-game_fr.qm
%%DATADIR%%/translations/dustrac-game_it.qm
share/icons/hicolor/64x64/apps/dustrac-editor.png
share/icons/hicolor/64x64/apps/dustrac-game.png
share/pixmaps/dustrac-editor.png
share/pixmaps/dustrac-game.png
@dirrmtry share/icons/hicolor/64x64/apps
@dirrmtry share/icons/hicolor/64x64
@dirrmtry share/icons/hicolor
@dirrmtry share/icons
@dirrm %%DATADIR%%/translations
@dirrm %%DATADIR%%/sounds
@dirrm %%DATADIR%%/models
@dirrm %%DATADIR%%/levels
@dirrm %%DATADIR%%/images
@dirrm %%DATADIR%%/fonts
@dirrm %%DATADIR%%
%%PORTDOCS%%@dirrm %%DOCSDIR%%